source: projects/specs/trunk/p/peco/peco-vl.spec @ 10132

Revision 10132, 2.1 KB checked in by ara_t, 8 years ago (diff)

correct Packager

Line 
1%define pkg_name    peco
2%define pkg_version 0.3.5
3%define pkg_release 5%{?_dist_release}
4
5%global gopath %{_datadir}/gocode
6
7Summary:     Simplistic interactive filtering tool
8Summary(ja): シンプルな対話式フィルタリングツール
9Name:        %{pkg_name}
10Version:     %{pkg_version}
11Release:     %{pkg_release}
12
13License: MIT License
14Group:   Applications/Text
15URL:     https://github.com/peco/peco
16Source:  https://github.com/peco/peco/archive/v%{version}.tar.gz#/peco-%{version}.tar.gz
17
18BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
19BuildRequires: golang
20BuildRequires: golang(github.com/google/btree)
21BuildRequires: golang(github.com/mattn/go-runewidth)
22BuildRequires: golang(github.com/jessevdk/go-flags)
23BuildRequires: golang(github.com/nsf/termbox-go)
24
25Vendor: Project Vine
26Distribution: Vine Linux
27Packager: ara_t
28
29
30%description
31peco is a simplistic interactive filtering tool
32based on a python tool, percol, and written in Go.
33
34%description -l ja
35pecoはシンプルな対話式フィルタリングツールであり、
36Pyhon製のpercolをGo言語で実装したプログラムです。
37
38
39%prep
40%{__rm} -rf ${RPM_BUILD_ROOT}
41
42%setup -q
43
44%build
45export BUILD_DIR=$(pwd)/.build
46export GOPATH=$BUILD_DIR:%{gopath}
47
48%{__mkdir_p} $BUILD_DIR/src/github.com/peco/peco
49%{__cp} -r * $BUILD_DIR/src/github.com/peco/peco
50go build cmd/peco/peco.go
51
52%install
53%{__mkdir_p} ${RPM_BUILD_ROOT}%{_bindir}
54%{__install} -m 755 peco ${RPM_BUILD_ROOT}%{_bindir}
55
56%clean
57%{__rm} -rf ${RPM_BUILD_ROOT}
58
59
60%files
61%defattr(-, root, root)
62%doc LICENSE
63%doc README.md Changes
64%{_bindir}/
65
66
67%changelog
68* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-5
69- correct SPEC file
70
71* Fri Jan 29 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-4
72- defile %%{gopath}
73
74* Mon Jan 25 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-3
75- using golang-* RPM packages for BuildRequires
76 - stop 'go get' in build section
77- update build section
78- add LICENSE, README.md and Changes
79
80* Tue Jan 19 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-2
81- build with Go
82- change spec file
83
84* Sun Jan 17 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-1
85- new package
86
Note: See TracBrowser for help on using the repository browser.