source: projects/specs/trunk/p/peco/peco-vl.spec @ 10132

Revision 10132, 2.1 KB checked in by ara_t, 8 years ago (diff)

correct Packager

RevLine 
[10132]1%define pkg_name    peco
[9989]2%define pkg_version 0.3.5
[10132]3%define pkg_release 5%{?_dist_release}
[9983]4
[9998]5%global gopath %{_datadir}/gocode
6
[10132]7Summary:     Simplistic interactive filtering tool
8Summary(ja): シンプルな対話式フィルタリングツール
9Name:        %{pkg_name}
10Version:     %{pkg_version}
11Release:     %{pkg_release}
[9983]12
[10132]13License: MIT License
14Group:   Applications/Text
15URL:     https://github.com/peco/peco
16Source:  https://github.com/peco/peco/archive/v%{version}.tar.gz#/peco-%{version}.tar.gz
[9983]17
[9989]18BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
19BuildRequires: golang
[9990]20BuildRequires: golang(github.com/google/btree)
21BuildRequires: golang(github.com/mattn/go-runewidth)
22BuildRequires: golang(github.com/jessevdk/go-flags)
23BuildRequires: golang(github.com/nsf/termbox-go)
[9989]24
[9983]25Vendor: Project Vine
26Distribution: Vine Linux
[10132]27Packager: ara_t
[9983]28
[10132]29
[9983]30%description
[9989]31peco is a simplistic interactive filtering tool
32based on a python tool, percol, and written in Go.
[9983]33
[9989]34%description -l ja
35pecoはシンプルな対話式フィルタリングツールであり、
36Pyhon製のpercolをGo言語で実装したプログラムです。
37
38
[9983]39%prep
[9989]40%{__rm} -rf ${RPM_BUILD_ROOT}
[9983]41
[9989]42%setup -q
43
[9983]44%build
[9990]45export BUILD_DIR=$(pwd)/.build
46export GOPATH=$BUILD_DIR:%{gopath}
[9983]47
[9990]48%{__mkdir_p} $BUILD_DIR/src/github.com/peco/peco
49%{__cp} -r * $BUILD_DIR/src/github.com/peco/peco
[9989]50go build cmd/peco/peco.go
51
[9983]52%install
[10132]53%{__mkdir_p} ${RPM_BUILD_ROOT}%{_bindir}
[9989]54%{__install} -m 755 peco ${RPM_BUILD_ROOT}%{_bindir}
[9983]55
[9989]56%clean
57%{__rm} -rf ${RPM_BUILD_ROOT}
[9983]58
[9989]59
[9983]60%files
[9989]61%defattr(-, root, root)
[9990]62%doc LICENSE
63%doc README.md Changes
[9989]64%{_bindir}/
[9983]65
[9989]66
[9983]67%changelog
[10132]68* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-5
69- correct SPEC file
70
[9998]71* Fri Jan 29 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-4
72- defile %%{gopath}
73
[9990]74* Mon Jan 25 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 0.3.5-3
75- using golang-* RPM packages for BuildRequires
76 - stop 'go get' in build section
77- update build section
78- add LICENSE, README.md and Changes
79
[9989]80* Tue Jan 19 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-2
81- build with Go
82- change spec file
[9983]83
[9989]84* Sun Jan 17 2016 Toshiaki Ara <ara_t@384.jp> 0.3.5-1
85- new package
86
Note: See TracBrowser for help on using the repository browser.