source: projects/specs/trunk/nonfree/self-build-vlc/self-build-vlc-vl.spec @ 1727

Revision 1727, 10.9 KB checked in by munepi, 14 years ago (diff)

updated self-build-vlc

Line 
1%define pkgname vlc
2%define name    self-build-%{pkgname}
3%define version 1.1.4
4%define release 1%{?_dist_release}
5
6%if %{?_dist_release} == "vl4"
7## dummy echo
8echo This package cannot build on Vine Linux 4.2.
9exit 1
10%endif
11
12%define with_mozilla                    0
13%define with_dc1394                     0
14%define with_directfb                   1
15
16%define with_samba                      0
17
18%define sourceurl0      http://download.videolan.org/pub/videolan/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.bz2
19
20
21Summary:        Package to automatically build %{pkgname} rpm package
22Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
23Name:           %{name}
24Version:        %{version}
25Release:        %{release}
26
27Obsoletes:      vlc < 1.1.0
28Obsoletes:      vlc-devel < 1.1.0
29
30Source0:        %{pkgname}-vl.spec
31
32Source10:       vlc-handlers.schemas
33Source100:      vlc-1.1.0-vlc-cache-gen_noerror.patch
34
35License:        GPLv2+
36Group:          Restricted Software
37
38Requires(post):         self-build-setup >= 0.9.9
39
40Requires(post): desktop-file-utils
41Requires(post): gettext
42Requires(post): gettext-devel
43Requires(post): libtool
44Requires(post): aalib-devel
45Requires(post): alsa-lib-devel
46Requires(post): avahi-devel
47Requires(post):  cdparanoia-devel
48Requires(post):  dbus-devel
49%{?_with_dirac: Requires(post): dirac-devel >= 1.0.0}
50%if %with_directfb
51Requires(post):  libdirectfb-devel
52%endif
53Requires(post): flac-devel
54Requires(post): fribidi-devel
55Requires(post):  gnome-vfs2-devel
56Requires(post): gnutls-devel >= 1.0.17
57Requires(post): gsm-devel
58Requires(post): hal-devel
59Requires(post): jack-audio-connection-kit-devel
60Requires(post):  libavc1394-devel
61Requires(post): libcdio-devel >= 0.77-3
62Requires(post): libdv-devel
63Requires(post): libdvdread-devel
64Requires(post):  libebml-devel
65Requires(post): libid3tag-devel
66%{?_with_kate:  Requires(post): libkate-devel}
67Requires(post): libmatroska-devel >= 0.7.6
68Requires(post): libmpcdec-devel
69Requires(post): libmtp-devel
70Requires(post):  libnotify-devel
71Requires(post): librsvg2-devel >= 2.5.0
72Requires(post):  libshout-devel
73Requires(post):  libsmbclient-devel
74Requires(post): libtheora-devel
75Requires(post):  libtiff-devel
76Requires(post):  libupnp-devel
77Requires(post): libv4l-devel
78Requires(post): libvorbis-devel
79Requires(post):  libxml2-devel
80Requires(post): lirc
81Requires(post):  kernel-headers >= 2.6.20
82Requires(post):  libmusicbrainz-devel
83Requires(post): lua-devel
84Requires(post): ncurses-devel
85Requires(post): openslp-devel
86Requires(post):  qt4-devel
87Requires(post): SDL_image-devel
88Requires(post): speex-devel >= 1.1.5
89%ifarch %{ix86} x86_64
90Requires(post):  svgalib-devel
91%endif
92Requires(post):  taglib-devel
93Requires(post): twolame-devel
94Requires(post): xosd-devel
95Requires(post): zlib-devel
96
97# X-libs
98Requires(post): libXt-devel
99Requires(post): libXv-devel
100Requires(post):  libXxf86vm-devel
101Requires(post):  libX11-devel
102Requires(post):  libXext-devel
103Requires(post):  libXpm-devel
104%ifarch %{ix86} x86_64
105Requires(post):  libXvMC-devel
106%endif
107Requires(post):  xorg-x11-proto-devel
108
109%if %with_samba
110Requires(post):  samba-libsmbclient-devel
111%endif
112
113Requires(post):  pulseaudio-libs-devel >= 0.9.8
114
115%if %with_mozilla
116Requires(post):  gecko-devel
117Requires(post):  nspr-devel
118%endif
119
120Requires(post):  libraw1394-devel
121
122Requires: TrueType-dejavu
123
124## vine
125%if %{?_dist_release} == "vl6"
126Requires(post): libva-devel
127%endif
128Requires(post): libgcrypt-devel
129Requires(post): wx-gtk2-devel
130Requires:       mesa-libGL
131Requires(post): xorg-x11-devel
132Requires(post): mesa-libGL-devel
133Requires(post): self-build-libmpeg2
134Requires(post): self-build-a52dec
135Requires(post): self-build-faac
136Requires(post): self-build-faad2
137Requires(post): self-build-ffmpeg >= 0.4.9
138Requires(post): self-build-libdca
139Requires(post): self-build-libdvbpsi
140Requires(post): self-build-libdvdnav
141Requires(post): self-build-libmad
142Requires(post): self-build-libmp4v2
143Requires(post): self-build-x264 >= 0.0.0-9.20090522
144Requires(post): self-build-xvidcore
145
146BuildRoot:      %{_tmppath}/%{name}-%{version}-root
147
148Packager:       munepi
149
150%description
151VLC (initially VideoLAN Client) is a highly portable multimedia player
152for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
153mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
154It can also be used as a server to stream in unicast or multicast in
155IPv4 or IPv6 on a high-bandwidth network.
156
157
158[Note]
159This package requires many other packages to compile
160targetsoftware. So it consume more disk space than usual.
161Also installation takes logner time because of compilation.
162(This will take a few minutes to quarter or half of an hour,
163depends on building environment)
164
165[About self-build package]
166For some kind of software, distributing of binary package
167may viorate the patent or law. Therefore we chose self-build
168packge, create binary package on your machine, for such kind
169of softwares instead of distributing binary package.
170
171Please obey the national law when you use the created binary
172packages. And if you want to use the softwares using patented
173thechnology, it may be required to get a permission, make an
174agreement or purchas a license. Please consider it with your
175purpose or way of use and take appropriate action.
176
177%description -l ja
178VLC(初期は VideoLAN Client)は高い可搬性のあるマルチメディアプレーヤーで,
179様々なオーディオおよびビデオフォーマット(MPEG-1, MPEG-2, MPEG-4, DivX,
180mp3, ogg など)だけでなく,DVD や VCD,様々なストリーミングプロトコルにも
181対応しています.
182また,高帯域幅上の IPv4 や IPv6 で,
183ユニキャストやマルチキャストのストリームに,
184サーバーとして使用することもできます.
185
186
187このパッケージをインストールすると、自動的にソースコードを
188ダウンロードしてコンパイルし、%{pkgname}-%{version}
189の rpm パッケージを作成します。
190また apt-get コマンドや synaptic パッケージマネージャから実行
191した場合は、作成された rpm パッケージのインストールも自動的に
192行います。
193
194[注意]
195コンパイルに必要な多くの関連パッケージを要求するので通常より
196ディスクの領域を多く消費します。
197またインストール時にコンパイルを行うため、通常より時間がかか
198る場合があります。(環境にもよりますが数分から数十分程度)
199
200[self-build パッケージについて]
201ソフトウェアによってはバイナリパッケージの配布が特許や法律に
202違反する可能性があるものがあります。その為、このような問題が
203懸念されるソフトウェアについてはバイナリパッケージを直接配布
204せずに、ユーザの環境でバイナリを作成する self-build パッケー
205ジという方法を採っています。
206
207作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
208アのライセンス、および利用する国の各種法令に従ってください。
209また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
210センスの購入などが必要となる場合がありますので、利用する目的
211や形態に応じて各自で判断し適切な対応を取ってください。
212
213%prep
214[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
215
216%install
217%{__rm} -rf ${RPM_BUILD_ROOT}
218%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
219%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
220%{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
221
222%{__install} -m 644 \
223    %{SOURCE100} \
224    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
225
226
227%clean
228%{__rm} -rf ${RPM_BUILD_ROOT}
229
230%posttrans
231/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 1195000
232/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
233                                 %{pkgname}-devel-%{version}-%{release}
234
235%files
236%defattr(-,root,root)
237%{_datadir}/%{name}
238
239
240%changelog
241* Mon Aug 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
242- new upstream release
243
244* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.2-1
245- new upstream release
246
247* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-2
248- for only vl6, supported libva
249- set Obsoletes: vlc < 1.1.0 vlc-devel < 1.1.0
250
251* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-1
252- new upstream release
253- added Requires(post): libva-devel
254
255* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
256- renamed %%{Source0} to vlc-vl.spec
257
258* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
259- added Requires(post): libsmbclient-devel
260
261* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
262- new upstream release
263
264* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2
265- built with libdvbpsi-devel
266- dropped 0002-Default-aout-for-pulse.patch
267
268* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1
269- new upstream release
270- updated 0002-Default-aout-for-pulse.patch
271
272* Tue Nov 10 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2
273- added Requires(post): libmtp-devel
274
275* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1
276- new upstream release
277
278* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-2
279- rebuilt to add signature
280
281* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-1
282- new upstream release
283  - applied vlc-1.0.2-compiler.patch from RPM Fusion
284- added Requires(post): lua-devel
285
286* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1
287- new upstream release
288
289* Sat Jul 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-2
290- added Obsoletes: vlc < 1.0.0, vlc-devel < 1.0.0
291
292* Wed Jul 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-1
293- new upstream release
294- clean-up some old patches and merged some patches from RPM Fusion package
295- added vlc-trunk-default_font-vine.patch
296- added vlc-handlers.schemas
297  - Gonf2 url-handler support
298- added shine.c, enc_base.h
299  - missing sources
300- check version between original spec and self-build spec in %%prep
301
302* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.9a-3
303- dropped BuildArch: noarch (with svglib-devel for %%{ix86} x86_64)
304
305* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-2
306- rebuild with x264 >= 0.0.0-9.20090522
307- avoided to execute self-build-rpm.sh on RPM transaction
308  - moved %%post actions to %%posttrans
309
310* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-1
311- new upstream release
312- added BuildArch: noarch
313- s/TrueType-DejaVu/TrueType-dejavu/
314
315* Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.8a-7
316- corrected release number in vlc.spec
317- dropped ExclusiveArch
318
319* Fri Feb 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.8a-6
320- add ppc to ExclusiveArch
321
322* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-5
323- changed to PreReq:  self-build-faad2 from faad2-devel
324- changed to PreReq:  self-build-libmad from libmad-devel
325
326* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-4
327- initial build
328
329### end of file
Note: See TracBrowser for help on using the repository browser.