source: projects/specs/trunk/nonfree/self-build-vlc/self-build-vlc-vl.spec @ 2226

Revision 2226, 11.0 KB checked in by munepi, 14 years ago (diff)

updated self-build-vlc

Line 
1%define pkgname vlc
2%define name    self-build-%{pkgname}
3%define version 1.1.5
4%define release 1%{?_dist_release}
5
6%if %{?_dist_release} == "vl4"
7## dummy echo
8echo This package cannot build on Vine Linux 4.2.
9exit 1
10%endif
11
12%define with_mozilla                    0
13%define with_dc1394                     0
14%define with_directfb                   1
15
16%define with_samba                      0
17
18%define sourceurl0      http://download.videolan.org/pub/videolan/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.bz2
19
20
21Summary:        Package to automatically build %{pkgname} rpm package
22Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
23Name:           %{name}
24Version:        %{version}
25Release:        %{release}
26
27Obsoletes:      vlc < 1.1.0
28Obsoletes:      vlc-devel < 1.1.0
29
30Source0:        %{pkgname}-vl.spec
31
32Source100:      vlc-1.1.0-vlc-cache-gen_noerror.patch
33Source101:      0001-Libnotify-depends-on-a-gtk.patch
34Source103:      vlc-1.1.4-hardode_font_patch.patch
35Source104:      vlc-1.1.4-tls_path.patch
36
37License:        GPLv2+
38Group:          Restricted Software
39
40Requires(post):         self-build-setup >= 0.9.9
41
42Requires(post): desktop-file-utils
43Requires(post): gettext
44Requires(post): gettext-devel
45Requires(post): libtool
46Requires(post): aalib-devel
47Requires(post): alsa-lib-devel
48Requires(post): avahi-devel
49Requires(post):  cdparanoia-devel
50Requires(post):  dbus-devel
51%{?_with_dirac: Requires(post): dirac-devel >= 1.0.0}
52%if %with_directfb
53Requires(post):  libdirectfb-devel
54%endif
55Requires(post): flac-devel
56Requires(post): fribidi-devel
57Requires(post):  gnome-vfs2-devel
58Requires(post): gnutls-devel >= 1.0.17
59Requires(post): gsm-devel
60Requires(post): hal-devel
61Requires(post): jack-audio-connection-kit-devel
62Requires(post):  libavc1394-devel
63Requires(post): libcdio-devel >= 0.77-3
64Requires(post): libdv-devel
65Requires(post): libdvdread-devel
66Requires(post):  libebml-devel
67Requires(post): libid3tag-devel
68%{?_with_kate:  Requires(post): libkate-devel}
69Requires(post): libmatroska-devel >= 0.7.6
70Requires(post): libmpcdec-devel
71Requires(post): libmtp-devel
72Requires(post):  libnotify-devel
73Requires(post): librsvg2-devel >= 2.5.0
74Requires(post):  libshout-devel
75Requires(post):  libsmbclient-devel
76Requires(post): libtheora-devel
77Requires(post):  libtiff-devel
78Requires(post):  libupnp-devel
79Requires(post): libv4l-devel
80Requires(post): libvorbis-devel
81Requires(post):  libxml2-devel
82Requires(post): lirc
83Requires(post):  kernel-headers >= 2.6.20
84Requires(post):  libmusicbrainz-devel
85Requires(post): lua-devel
86Requires(post): ncurses-devel
87Requires(post): openslp-devel
88Requires(post):  qt4-devel
89Requires(post): SDL_image-devel
90Requires(post): speex-devel >= 1.1.5
91%ifarch %{ix86} x86_64
92Requires(post):  svgalib-devel
93%endif
94Requires(post):  taglib-devel
95Requires(post): twolame-devel
96Requires(post): xosd-devel
97Requires(post): zlib-devel
98
99# X-libs
100Requires(post): libXt-devel
101Requires(post): libXv-devel
102Requires(post):  libXxf86vm-devel
103Requires(post):  libX11-devel
104Requires(post):  libXext-devel
105Requires(post):  libXpm-devel
106%ifarch %{ix86} x86_64
107Requires(post):  libXvMC-devel
108%endif
109Requires(post):  xorg-x11-proto-devel
110
111%if %with_samba
112Requires(post):  samba-libsmbclient-devel
113%endif
114
115Requires(post):  pulseaudio-libs-devel >= 0.9.8
116
117%if %with_mozilla
118Requires(post):  gecko-devel
119Requires(post):  nspr-devel
120%endif
121
122Requires(post):  libraw1394-devel
123
124Requires: TrueType-dejavu
125
126## vine
127%if %{?_dist_release} == "vl6"
128Requires(post): libva-devel
129%endif
130Requires(post): libgcrypt-devel
131Requires(post): wx-gtk2-devel
132Requires:       mesa-libGL
133Requires(post): xorg-x11-devel
134Requires(post): mesa-libGL-devel
135Requires(post): self-build-libmpeg2
136Requires(post): self-build-a52dec
137Requires(post): self-build-faac
138Requires(post): self-build-faad2
139Requires(post): self-build-ffmpeg >= 0.4.9
140Requires(post): self-build-libdca
141Requires(post): self-build-libdvbpsi
142Requires(post): self-build-libdvdnav
143Requires(post): self-build-libmad
144Requires(post): self-build-libmp4v2
145Requires(post): self-build-x264 >= 0.0.0-9.20090522
146Requires(post): self-build-xvidcore
147
148BuildRoot:      %{_tmppath}/%{name}-%{version}-root
149
150Packager:       munepi
151
152%description
153VLC (initially VideoLAN Client) is a highly portable multimedia player
154for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
155mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
156It can also be used as a server to stream in unicast or multicast in
157IPv4 or IPv6 on a high-bandwidth network.
158
159
160[Note]
161This package requires many other packages to compile
162targetsoftware. So it consume more disk space than usual.
163Also installation takes logner time because of compilation.
164(This will take a few minutes to quarter or half of an hour,
165depends on building environment)
166
167[About self-build package]
168For some kind of software, distributing of binary package
169may viorate the patent or law. Therefore we chose self-build
170packge, create binary package on your machine, for such kind
171of softwares instead of distributing binary package.
172
173Please obey the national law when you use the created binary
174packages. And if you want to use the softwares using patented
175thechnology, it may be required to get a permission, make an
176agreement or purchas a license. Please consider it with your
177purpose or way of use and take appropriate action.
178
179%description -l ja
180VLC(初期は VideoLAN Client)は高い可搬性のあるマルチメディアプレーヤーで,
181様々なオーディオおよびビデオフォーマット(MPEG-1, MPEG-2, MPEG-4, DivX,
182mp3, ogg など)だけでなく,DVD や VCD,様々なストリーミングプロトコルにも
183対応しています.
184また,高帯域幅上の IPv4 や IPv6 で,
185ユニキャストやマルチキャストのストリームに,
186サーバーとして使用することもできます.
187
188
189このパッケージをインストールすると、自動的にソースコードを
190ダウンロードしてコンパイルし、%{pkgname}-%{version}
191の rpm パッケージを作成します。
192また apt-get コマンドや synaptic パッケージマネージャから実行
193した場合は、作成された rpm パッケージのインストールも自動的に
194行います。
195
196[注意]
197コンパイルに必要な多くの関連パッケージを要求するので通常より
198ディスクの領域を多く消費します。
199またインストール時にコンパイルを行うため、通常より時間がかか
200る場合があります。(環境にもよりますが数分から数十分程度)
201
202[self-build パッケージについて]
203ソフトウェアによってはバイナリパッケージの配布が特許や法律に
204違反する可能性があるものがあります。その為、このような問題が
205懸念されるソフトウェアについてはバイナリパッケージを直接配布
206せずに、ユーザの環境でバイナリを作成する self-build パッケー
207ジという方法を採っています。
208
209作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
210アのライセンス、および利用する国の各種法令に従ってください。
211また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
212センスの購入などが必要となる場合がありますので、利用する目的
213や形態に応じて各自で判断し適切な対応を取ってください。
214
215%prep
216[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
217
218%install
219%{__rm} -rf ${RPM_BUILD_ROOT}
220%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
221%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
222
223%{__install} -m 644 \
224    %{SOURCE100} %{SOURCE101} %{SOURCE103} %{SOURCE104} \
225    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
226
227
228%clean
229%{__rm} -rf ${RPM_BUILD_ROOT}
230
231%posttrans
232/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 1216000
233/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
234                                 %{pkgname}-devel-%{version}-%{release}
235
236%files
237%defattr(-,root,root)
238%{_datadir}/%{name}
239
240
241%changelog
242* Sun Nov 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.5-1
243- new upstream release
244
245* Mon Aug 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
246- new upstream release
247
248* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.2-1
249- new upstream release
250
251* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-2
252- for only vl6, supported libva
253- set Obsoletes: vlc < 1.1.0 vlc-devel < 1.1.0
254
255* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-1
256- new upstream release
257- added Requires(post): libva-devel
258
259* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
260- renamed %%{Source0} to vlc-vl.spec
261
262* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
263- added Requires(post): libsmbclient-devel
264
265* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
266- new upstream release
267
268* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2
269- built with libdvbpsi-devel
270- dropped 0002-Default-aout-for-pulse.patch
271
272* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1
273- new upstream release
274- updated 0002-Default-aout-for-pulse.patch
275
276* Tue Nov 10 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2
277- added Requires(post): libmtp-devel
278
279* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1
280- new upstream release
281
282* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-2
283- rebuilt to add signature
284
285* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-1
286- new upstream release
287  - applied vlc-1.0.2-compiler.patch from RPM Fusion
288- added Requires(post): lua-devel
289
290* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1
291- new upstream release
292
293* Sat Jul 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-2
294- added Obsoletes: vlc < 1.0.0, vlc-devel < 1.0.0
295
296* Wed Jul 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-1
297- new upstream release
298- clean-up some old patches and merged some patches from RPM Fusion package
299- added vlc-trunk-default_font-vine.patch
300- added vlc-handlers.schemas
301  - Gonf2 url-handler support
302- added shine.c, enc_base.h
303  - missing sources
304- check version between original spec and self-build spec in %%prep
305
306* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.9a-3
307- dropped BuildArch: noarch (with svglib-devel for %%{ix86} x86_64)
308
309* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-2
310- rebuild with x264 >= 0.0.0-9.20090522
311- avoided to execute self-build-rpm.sh on RPM transaction
312  - moved %%post actions to %%posttrans
313
314* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-1
315- new upstream release
316- added BuildArch: noarch
317- s/TrueType-DejaVu/TrueType-dejavu/
318
319* Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.8a-7
320- corrected release number in vlc.spec
321- dropped ExclusiveArch
322
323* Fri Feb 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.8a-6
324- add ppc to ExclusiveArch
325
326* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-5
327- changed to PreReq:  self-build-faad2 from faad2-devel
328- changed to PreReq:  self-build-libmad from libmad-devel
329
330* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-4
331- initial build
332
333### end of file
Note: See TracBrowser for help on using the repository browser.