source: projects/specs/trunk/nonfree/self-build-vlc/self-build-vlc-vl.spec @ 12252

Revision 12252, 15.9 KB checked in by ara_t, 2 years ago (diff)

self-build-vlc: change BuildRequires?

Line 
1#% global rcversion 2
2
3%define pkgname vlc
4%define name    self-build-%{pkgname}
5%define version 2.2.2
6%define release 3%{?rcversion:.rc%rcversion}%{?_dist_release}
7
8%define with_mozilla                    0
9
10#% define with_dc1394                   1
11
12%define with_ncurses                    0
13
14%define sourceurl0      http://download.videolan.org/pub/videolan/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.xz
15#% define sourceurl0    http://download.videolan.org/pub/videolan/testing/vlc-2.2.0-rc2/vlc-2.2.0-rc2.tar.xz
16
17Summary:        Package to automatically build %{pkgname} rpm package
18Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
19Name:           %{name}
20Version:        %{version}
21Release:        %{release}
22
23Obsoletes:      vlc < %{version}-%{release}, vlc-devel < %{version}-%{release}
24Obsoletes:      self-build-vlc < %{version}-%{release}
25
26Source0:        %{pkgname}-vl.spec
27
28License:        GPLv2+
29Group:          Restricted Software
30
31Requires(post):         self-build-setup >= 0.9.9
32
33Requires(post): unzip
34Requires(post): desktop-file-utils
35Requires(post): gettext
36Requires(post): gettext-devel
37Requires(post): libtool
38Requires(post): aalib-devel
39Requires(post): alsa-lib-devel
40Requires(post): avahi-devel
41Requires(post):  cdparanoia-devel
42Requires(post):  dbus-devel
43%{?_with_dirac: Requires(post): dirac-devel >= 1.0.0}
44#Requires(post):  directfb-devel
45Requires(post):  libdirectfb-devel
46Requires(post): flac-devel
47##!! Requires(post):  fluidsynth-devel
48Requires(post): fribidi-devel
49Requires(post):  gnome-vfs2-devel
50Requires(post): gnutls-devel >= 1.0.17
51Requires(post): gsm-devel
52%if %{?_dist_release} >= "vl7"
53Requires(post): jack-audio-connection-kit-devel
54%endif
55%{?with_dc1394:Requires(post):  libavc1394-devel}
56Requires(post): libass-devel >= 0.9.7
57##!! Requires(post):    libcaca-devel
58Requires(post): libcddb-devel
59Requires(post): libcdio-devel >= 0.77-3
60%{?with_dc1394:Requires(post):  libavc1394-devel >= 0.5.3}
61%{?with_dc1394:Requires(post):  libdc1394-devel >= 2.1.0}
62%{?with_dc1394:Requires(post):  libdv-devel}
63Requires(post): libdvdnav-devel
64Requires(post): libdvdread-devel
65Requires(post):  libebml-devel
66Requires(post): libid3tag-devel
67%{?_with_kate:  Requires(post): libkate-devel}
68Requires(post): libmatroska-devel >= 0.7.6
69Requires(post): libmodplug-devel
70Requires(post): libmp4v2-devel
71Requires(post): libmpcdec-devel
72Requires(post): libmtp-devel
73Requires(post):  libnotify-devel
74##!! Requires(post):    libprojectM-qt-devel
75Requires(post):  libproxy-devel
76Requires(post): librsvg2-devel >= 2.9.0
77Requires(post):  librtmp-devel
78Requires(post): libssh2-devel
79##!! Requires(post):    libsysfs-devel
80Requires(post):  libshout-devel
81Requires(post):  libsmbclient-devel
82##!! Requires(post):    libtar-devel
83Requires(post): libtheora-devel
84##!! Requires(post):    libtiger-devel
85Requires(post):  libtiff-devel
86Requires(post): libudev-devel >= 142
87Requires(post):  libupnp-devel
88Requires(post): libv4l-devel
89Requires(post): libva-devel
90Requires(post): libvorbis-devel
91Requires(post):  libxml2-devel
92#Requires(post):        lirc-devel
93%{?_with_lirc:Requires(post):   lirc}
94#Requires(post):        live555-devel >= 0-0.19.2008.04.03
95Requires(post):  kernel-headers >= 2.6.20
96# Requires(post):       libGL-devel
97# Requires(post):       libGLU-devel
98Requires(post):  libmusicbrainz-devel
99Requires(post):  lua-devel
100##!! Requires(post):  minizip-devel
101##!! Requires(post):    mpeg2dec-devel >= 0.3.2
102%if %with_ncurses
103Requires(post): ncurses-devel
104%endif
105##!! Requires(post):  opencv-devel
106Requires(post): openslp-devel
107Requires(post):  pcre-devel
108Requires(post):  pulseaudio-libs-devel >= 0.9.8
109##!! Requires(post):  portaudio-devel
110Requires(post):  qt4-devel >= 4.5.2
111##!! Requires(post):  schroedinger-devel
112Requires(post): SDL_image-devel
113Requires(post): speex-devel >= 1.1.5
114Requires(post):  taglib-devel
115Requires(post): twolame-devel
116Requires(post): vcdimager-devel >= 0.7.21
117Requires(post): zlib-devel
118##!! Requires(post):  zvbi-devel
119
120# X-libs
121Requires(post): libXt-devel
122Requires(post): libXv-devel
123Requires(post):  libXxf86vm-devel
124Requires(post):  libX11-devel
125Requires(post):  libXext-devel
126Requires(post):  libXpm-devel
127Requires(post):  libXvMC-devel
128Requires(post):  xcb-util-devel
129Requires(post):  xorg-x11-proto-devel
130
131Requires(post):  pulseaudio-libs-devel >= 0.9.8
132
133%if %with_mozilla
134Requires(post):  gecko-devel
135Requires(post):  nspr-devel
136%endif
137
138Requires: TrueType-dejavu
139
140Requires(post): libmpeg2
141Requires(post): a52dec
142## vine
143Requires(post): libgcrypt-devel
144Requires(post): wxGTK-devel
145Requires(post): mesa-libGL
146Requires(post): xorg-x11-devel
147Requires(post): mesa-libGL-devel
148# Requires(post):       self-build-libmpeg2
149# Requires(post):       self-build-a52dec
150Requires(post): self-build-faac
151Requires(post): self-build-faad2
152Requires(post): self-build-ffmpeg >= 2.4.0
153Requires(post): self-build-libdca
154Requires(post): self-build-libdvbpsi >= 1.0.0
155Requires(post): self-build-libmad
156Requires(post): self-build-x264 >= 0.136
157Requires(post): self-build-xvidcore
158
159BuildArch:      noarch
160BuildRoot:      %{_tmppath}/%{name}-%{version}-root
161
162Packager:       munepi
163
164%description
165VLC (initially VideoLAN Client) is a highly portable multimedia player
166for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
167mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
168It can also be used as a server to stream in unicast or multicast in
169IPv4 or IPv6 on a high-bandwidth network.
170
171
172[Note]
173This package requires many other packages to compile
174targetsoftware. So it consume more disk space than usual.
175Also installation takes logner time because of compilation.
176(This will take a few minutes to quarter or half of an hour,
177depends on building environment)
178
179[About self-build package]
180For some kind of software, distributing of binary package
181may viorate the patent or law. Therefore we chose self-build
182packge, create binary package on your machine, for such kind
183of softwares instead of distributing binary package.
184
185Please obey the national law when you use the created binary
186packages. And if you want to use the softwares using patented
187thechnology, it may be required to get a permission, make an
188agreement or purchas a license. Please consider it with your
189purpose or way of use and take appropriate action.
190
191%description -l ja
192VLC(初期は VideoLAN Client)は高い可搬性のあるマルチメディアプレーヤーで,
193様々なオーディオおよびビデオフォーマット(MPEG-1, MPEG-2, MPEG-4, DivX,
194mp3, ogg など)だけでなく,DVD や VCD,様々なストリーミングプロトコルにも
195対応しています.
196また,高帯域幅上の IPv4 や IPv6 で,
197ユニキャストやマルチキャストのストリームに,
198サーバーとして使用することもできます.
199
200
201このパッケージをインストールすると、自動的にソースコードを
202ダウンロードしてコンパイルし、%{pkgname}-%{version}
203の rpm パッケージを作成します。
204また apt-get コマンドや synaptic パッケージマネージャから実行
205した場合は、作成された rpm パッケージのインストールも自動的に
206行います。
207
208[注意]
209コンパイルに必要な多くの関連パッケージを要求するので通常より
210ディスクの領域を多く消費します。
211またインストール時にコンパイルを行うため、通常より時間がかか
212る場合があります。(環境にもよりますが数分から数十分程度)
213
214[self-build パッケージについて]
215ソフトウェアによってはバイナリパッケージの配布が特許や法律に
216違反する可能性があるものがあります。その為、このような問題が
217懸念されるソフトウェアについてはバイナリパッケージを直接配布
218せずに、ユーザの環境でバイナリを作成する self-build パッケー
219ジという方法を採っています。
220
221作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
222アのライセンス、および利用する国の各種法令に従ってください。
223また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
224センスの購入などが必要となる場合がありますので、利用する目的
225や形態に応じて各自で判断し適切な対応を取ってください。
226
227%prep
228[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
229
230%install
231%{__rm} -rf ${RPM_BUILD_ROOT}
232%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
233%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
234
235%clean
236%{__rm} -rf ${RPM_BUILD_ROOT}
237
238%posttrans
239/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl0} 794000
240
241/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
242                                 %{pkgname}-devel-%{version}-%{release}
243
244%files
245%defattr(-,root,root)
246%{_datadir}/%{name}
247
248
249%changelog
250* Wed Oct 09 2019 Toshiaki Ara <ara_t@384.jp> 2.2.2-3
251- change BR: self-build-{libmpeg2,a52dec} to {libmpeg2,a52dec}-devel
252
253* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.2-2
254- rebuild with libcdio-0.93
255
256* Mon Feb  8 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.2-1
257- new upstream release
258
259* Sat Jan 23 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.1-4
260- rebuilt
261
262* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.1-3
263- rebuild with gnutls-3.4.7
264
265* Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.1-2
266- rebuilt
267
268* Sun Apr 19 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.1-1
269- new upstream release
270
271* Sun Apr 12 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.0-4
272- new upstream release
273
274* Mon Mar  9 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.0-3.rc2
275- rebuild
276
277* Sat Feb 21 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.0-2.rc2
278- rebuild
279
280* Fri Jan  2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2.2.0-1.rc2
281- updated to 2.2.0-rc2
282
283* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.2-2
284- remove Requires(post): xosd-devel
285
286* Sat Dec 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.2-1
287- new upstream release
288
289* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.0-2
290- added Obsoletes: vlc < %{version}-%{release}, vlc-devel < %{version}-%{release}
291
292* Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.1.0-1
293- new upstream release
294- built with new x264 (ABI 0.136) and ffmpeg (1.2.x)
295
296* Wed Jul  3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.7-1
297- new upstream release
298
299* Tue Apr 30 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.6-1
300- new upstream release
301
302* Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.5-2
303- rebuilt with new x264 (ABI 0.129) and ffmpeg (1.1.x)
304
305* Mon Jan 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.5-1
306- new upstream release
307
308* Wed Nov  7 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.4-1
309- new upstream release
310
311* Fri Aug 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.3-1
312- new upstream release
313- s/wx-gtk2/wxGTK/g
314
315* Sat Jun 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-1
316- new upstream release
317
318* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-1
319- new upstream release
320- dropped DC1394 and DV
321
322* Tue Jan  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.13-1
323- new upstream release
324
325* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-3
326- rebuilt with new x264 and ffmpeg
327
328* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-2
329- s/self-build-libmp4v2/libmp4v2/
330- s/self-build-libdvdnav/libdvdnav/
331
332* Sat Oct 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.12-1
333- new upstream release
334
335* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.11-2
336- dropped Requires(post): svga-devel
337- added BuildArch: noarch
338
339* Thu Jul 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.11-1
340- new upstream release
341
342* Fri Jun 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.10-1
343- new upstream release
344- backport from 1.1-bugfix from RPM Fusion development
345
346* Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.9-2
347- added Requires(post): unzip
348
349* Sun Apr 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.9-1
350- new upstream release
351- applied vlc_patch_0.02/vlc118.diff in up0617.zip on 2sen.dip.jp/dtv
352
353* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.8-1
354- new upstream release
355- added Requires(post):
356  - libcddb-devel
357  - libdc1394-devel >= 2.1.0
358  - libmodplug-devel
359  - libproxy-devel
360  - librtmp-devel
361  - libssh2-devel
362  - libudev-devel >= 142
363  - pcre-devel
364  - vcdimager-devel >= 0.7.21
365  - xcb-util-devel
366
367* Sat Feb 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.7-1
368- new upstream release
369- dropped upstreamed patches
370- applied a reverted patch to pulse.c for vl5
371
372* Sat Feb 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.6-2
373- backport lirc and signal fixes
374
375* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.6-1
376- new upstream release
377- dropped temporarily BuildRequires: lirc
378- added BuildRequires: libass-devel as the tag Requires(post)
379
380* Sun Nov 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.5-1
381- new upstream release
382
383* Mon Aug 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
384- new upstream release
385
386* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.2-1
387- new upstream release
388
389* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-2
390- for only vl6, supported libva
391- set Obsoletes: vlc < 1.1.0 vlc-devel < 1.1.0
392
393* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-1
394- new upstream release
395- added Requires(post): libva-devel
396
397* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
398- renamed %%{Source0} to vlc-vl.spec
399
400* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
401- added Requires(post): libsmbclient-devel
402
403* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
404- new upstream release
405
406* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2
407- built with libdvbpsi-devel
408- dropped 0002-Default-aout-for-pulse.patch
409
410* Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1
411- new upstream release
412- updated 0002-Default-aout-for-pulse.patch
413
414* Tue Nov 10 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2
415- added Requires(post): libmtp-devel
416
417* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1
418- new upstream release
419
420* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-2
421- rebuilt to add signature
422
423* Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-1
424- new upstream release
425  - applied vlc-1.0.2-compiler.patch from RPM Fusion
426- added Requires(post): lua-devel
427
428* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1
429- new upstream release
430
431* Sat Jul 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-2
432- added Obsoletes: vlc < 1.0.0, vlc-devel < 1.0.0
433
434* Wed Jul 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-1
435- new upstream release
436- clean-up some old patches and merged some patches from RPM Fusion package
437- added vlc-trunk-default_font-vine.patch
438- added vlc-handlers.schemas
439  - Gonf2 url-handler support
440- added shine.c, enc_base.h
441  - missing sources
442- check version between original spec and self-build spec in %%prep
443
444* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.9a-3
445- dropped BuildArch: noarch (with svglib-devel for %%{ix86} x86_64)
446
447* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-2
448- rebuild with x264 >= 0.0.0-9.20090522
449- avoided to execute self-build-rpm.sh on RPM transaction
450  - moved %%post actions to %%posttrans
451
452* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-1
453- new upstream release
454- added BuildArch: noarch
455- s/TrueType-DejaVu/TrueType-dejavu/
456
457* Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.8a-7
458- corrected release number in vlc.spec
459- dropped ExclusiveArch
460
461* Fri Feb 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.8a-6
462- add ppc to ExclusiveArch
463
464* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-5
465- changed to PreReq:  self-build-faad2 from faad2-devel
466- changed to PreReq:  self-build-libmad from libmad-devel
467
468* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-4
469- initial build
470
471### end of file
Note: See TracBrowser for help on using the repository browser.