source: projects/specs/trunk/nonfree/self-build-kino/self-build-kino-vl.spec @ 615

Revision 615, 5.7 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define pkgname kino
2%define name    self-build-%{pkgname}
3%define version 1.3.4
4%define release 2%{?_dist_release}
5
6%define sourceurl0      http://prdownloads.sourceforge.net/kino/%{pkgname}-%{version}.tar.gz
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14Source100:      kino-udev.patch
15
16License:        GPL
17Group:          Restricted Software
18
19Obsoletes:      kino < 1.3.3-2
20
21Requires(post):         self-build-setup >= 0.9.9
22
23Requires(post):         desktop-file-utils
24Requires(post):         gettext
25Requires(post):         intltool
26Requires(post):         libsamplerate-devel
27Requires(post):         libdv-devel
28Requires(post):         libavc1394-devel
29Requires(post):         libraw1394-devel
30Requires(post):         libiec61883-devel
31Requires(post):         libogg-devel
32Requires(post):         libvorbis-devel
33Requires(post):         gtk2-devel >= 2.6.0
34Requires(post):         XOrg-devel
35Requires(post):         imlib-devel
36Requires(post):         libxml2-devel
37Requires(post):         perl
38
39Requires:               libdv
40Requires:               libavc1394
41Requires:               libraw1394
42Requires:               libogg
43Requires:               libvorbis
44Requires:               gtk2
45Requires:               imlib
46Requires:               libxml2
47Requires(post):         shared-mime-info
48
49Requires(post):         self-build-libquicktime
50Requires(post):         self-build-ffmpeg
51Requires(post):         self-build-ffmpeg2theora
52
53BuildArch:      noarch
54BuildRoot:      %{_tmppath}/%{name}-%{version}-root
55
56Packager:       munepi
57
58%description
59The new generation of digital camcorders use the Digital Video (DV) data
60format. Kino allows you to record, create, edit, and play movies recorded
61with DV camcorders. Unlike other editors, this program uses many keyboard
62commands for fast navigating and editing inside the movie.
63
64
65If you install this package, it automaticaly downloads source
66code ,compile it, and create rpm packages of %{pkgname}-%{version}.
67And the created rpm packages are automatically installed
68if installation is executed by apt-get command or synaptic
69package manager.
70
71[Note]
72This package requires many other packages to compile
73targetsoftware. So it consume more disk space than usual.
74Also installation takes logner time because of compilation.
75(This will take a few minutes to quarter or half of an hour,
76depends on building environment)
77
78[About self-build package]
79For some kind of software, distributing of binary package
80may viorate the patent or law. Therefore we chose self-build
81packge, create binary package on your machine, for such kind
82of softwares instead of distributing binary package.
83
84Please obey the national law when you use the created binary
85packages. And if you want to use the softwares using patented
86thechnology, it may be required to get a permission, make an
87agreement or purchas a license. Please consider it with your
88purpose or way of use and take appropriate action.
89
90%description -l ja
91デジタルビデオカメラの新世代は
92Digital Video (DV) データフォーマットを使います。
93Kino は DV デジタルビデオカメラで録画された動画を
94録画、作成、編集、再生できます。
95他の編集ソフトとは異なり、
96動画の中へ素早く移動や編集するために
97多くのキーボードコマンドを使えます。
98
99
100このパッケージをインストールすると、自動的にソースコードを
101ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
102パッケージを作成します。
103また apt-get コマンドや synaptic パッケージマネージャから実行
104した場合は、作成された rpm パッケージのインストールも自動的に
105行います。
106
107[注意]
108コンパイルに必要な多くの関連パッケージを要求するので通常より
109ディスクの領域を多く消費します。
110またインストール時にコンパイルを行うため、通常より時間がかか
111る場合があります。(環境にもよりますが数分から数十分程度)
112
113[self-build パッケージについて]
114ソフトウェアによってはバイナリパッケージの配布が特許や法律に
115違反する可能性があるものがあります。その為、このような問題が
116懸念されるソフトウェアについてはバイナリパッケージを直接配布
117せずに、ユーザの環境でバイナリを作成する self-build パッケー
118ジという方法を採っています。
119
120作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
121アのライセンス、および利用する国の各種法令に従ってください。
122また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
123センスの購入などが必要となる場合がありますので、利用する目的
124や形態に応じて各自で判断し適切な対応を取ってください。
125
126%prep
127[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
128
129%install
130%{__rm} -rf ${RPM_BUILD_ROOT}
131%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
132%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
133%{__install} -m 644 %{SOURCE100} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
134
135%clean
136%{__rm} -rf ${RPM_BUILD_ROOT}
137
138%posttrans
139/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 105000
140/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
141                                 %{pkgname}-devel-%{version}-%{release}
142
143%files
144%defattr(-,root,root)
145%{_datadir}/%{name}
146
147%changelog
148* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-2
149- renamed %%{Source0} to kino-vl.spec
150
151* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-1
152- new upstream release
153  - with recent ffmpeg
154
155* Sun Jun 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-2
156- initial bulid
Note: See TracBrowser for help on using the repository browser.