source: projects/specs/trunk/nonfree/self-build-kino/self-build-kino-vl.spec @ 3143

Revision 3143, 6.3 KB checked in by munepi, 13 years ago (diff)

updated self-build-gstreamer-plugins-ffmpeg self-build-kino self-build-gstreamer-plugins-bad self-build-gstreamer-plugins-ugly self-build-ffmpeg2theora

Line 
1%define pkgname kino
2%define name    self-build-%{pkgname}
3%define version 1.3.4
4%define release 4%{?_dist_release}
5
6%define sourceurl0      http://prdownloads.sourceforge.net/kino/%{pkgname}-%{version}.tar.gz
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14#Source100:     kino-udev.patch
15Source101:      kino-1.3.4-dso.patch
16
17License:        GPLv2+
18Group:          Restricted Software
19
20Obsoletes:      kino < 1.3.3-2
21
22Requires(post):         self-build-setup >= 0.9.9
23
24Requires(post): gtk2-devel >= 2.6.0
25Requires(post): glib2-devel
26Requires(post): libxml2-devel
27Requires(post): libraw1394-devel
28Requires(post): libavc1394-devel
29Requires(post): libiec61883-devel
30Requires(post): libdv-devel
31Requires(post): libXv-devel
32Requires(post): libbonoboui-devel
33Requires(post): libogg-devel
34Requires(post): libvorbis-devel
35Requires(post): imlib-devel
36Requires(post): desktop-file-utils
37Requires(post): libsamplerate-devel
38Requires(post): zlib-devel
39Requires(post): gettext
40Requires(post): intltool
41Requires(post): perl(XML::Parser)
42Requires(post): libICE-devel
43Requires(post): libSM-devel
44Requires(post): alsa-lib-devel
45Requires(post): XOrg-devel
46
47Requires:               libdv
48Requires:               libavc1394
49Requires:               libraw1394
50Requires:               libogg
51Requires:               libvorbis
52Requires:               gtk2
53Requires:               imlib
54Requires:               libxml2
55Requires(post):         shared-mime-info
56
57Requires(post):         self-build-libquicktime
58Requires(post):         self-build-mjpegtools
59Requires(post):         self-build-mplayer
60Requires(post):         self-build-ffmpeg
61Requires(post):         self-build-ffmpeg2theora
62
63BuildArch:      noarch
64BuildRoot:      %{_tmppath}/%{name}-%{version}-root
65
66Packager:       munepi
67
68%description
69The new generation of digital camcorders use the Digital Video (DV) data
70format. Kino allows you to record, create, edit, and play movies recorded
71with DV camcorders. Unlike other editors, this program uses many keyboard
72commands for fast navigating and editing inside the movie.
73
74
75If you install this package, it automaticaly downloads source
76code ,compile it, and create rpm packages of %{pkgname}-%{version}.
77And the created rpm packages are automatically installed
78if installation is executed by apt-get command or synaptic
79package manager.
80
81[Note]
82This package requires many other packages to compile
83targetsoftware. So it consume more disk space than usual.
84Also installation takes logner time because of compilation.
85(This will take a few minutes to quarter or half of an hour,
86depends on building environment)
87
88[About self-build package]
89For some kind of software, distributing of binary package
90may viorate the patent or law. Therefore we chose self-build
91packge, create binary package on your machine, for such kind
92of softwares instead of distributing binary package.
93
94Please obey the national law when you use the created binary
95packages. And if you want to use the softwares using patented
96thechnology, it may be required to get a permission, make an
97agreement or purchas a license. Please consider it with your
98purpose or way of use and take appropriate action.
99
100%description -l ja
101デジタルビデオカメラの新世代は
102Digital Video (DV) データフォーマットを使います。
103Kino は DV デジタルビデオカメラで録画された動画を
104録画、作成、編集、再生できます。
105他の編集ソフトとは異なり、
106動画の中へ素早く移動や編集するために
107多くのキーボードコマンドを使えます。
108
109
110このパッケージをインストールすると、自動的にソースコードを
111ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
112パッケージを作成します。
113また apt-get コマンドや synaptic パッケージマネージャから実行
114した場合は、作成された rpm パッケージのインストールも自動的に
115行います。
116
117[注意]
118コンパイルに必要な多くの関連パッケージを要求するので通常より
119ディスクの領域を多く消費します。
120またインストール時にコンパイルを行うため、通常より時間がかか
121る場合があります。(環境にもよりますが数分から数十分程度)
122
123[self-build パッケージについて]
124ソフトウェアによってはバイナリパッケージの配布が特許や法律に
125違反する可能性があるものがあります。その為、このような問題が
126懸念されるソフトウェアについてはバイナリパッケージを直接配布
127せずに、ユーザの環境でバイナリを作成する self-build パッケー
128ジという方法を採っています。
129
130作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
131アのライセンス、および利用する国の各種法令に従ってください。
132また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
133センスの購入などが必要となる場合がありますので、利用する目的
134や形態に応じて各自で判断し適切な対応を取ってください。
135
136%prep
137[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
138
139%install
140%{__rm} -rf ${RPM_BUILD_ROOT}
141%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
142%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
143%{__install} -m 644 %{SOURCE101} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
144
145%clean
146%{__rm} -rf ${RPM_BUILD_ROOT}
147
148%posttrans
149/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 111000
150/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
151                                 %{pkgname}-devel-%{version}-%{release}
152
153%files
154%defattr(-,root,root)
155%{_datadir}/%{name}
156
157%changelog
158* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-4
159- applied kino-1.3.4-dso.patch from RPM Fusion development
160  - rebuilt for gcc bug
161- drop the udev rules patch
162
163* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-3
164- added Requires(post): self-build-mjpegtools, self-build-mplayer
165
166* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-2
167- renamed %%{Source0} to kino-vl.spec
168
169* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-1
170- new upstream release
171  - with recent ffmpeg
172
173* Sun Jun 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-2
174- initial bulid
Note: See TracBrowser for help on using the repository browser.