source: projects/specs/trunk/nonfree/self-build-kino/self-build-kino-vl.spec @ 1816

Revision 1816, 5.9 KB checked in by munepi, 14 years ago (diff)

added self-build-mjpegtools

Line 
1%define pkgname kino
2%define name    self-build-%{pkgname}
3%define version 1.3.4
4%define release 3%{?_dist_release}
5
6%define sourceurl0      http://prdownloads.sourceforge.net/kino/%{pkgname}-%{version}.tar.gz
7
8Summary:        Package to automatically build %{pkgname} rpm package
9Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
10Name:           %{name}
11Version:        %{version}
12Release:        %{release}
13Source0:        %{pkgname}-vl.spec
14Source100:      kino-udev.patch
15
16License:        GPL
17Group:          Restricted Software
18
19Obsoletes:      kino < 1.3.3-2
20
21Requires(post):         self-build-setup >= 0.9.9
22
23Requires(post):         desktop-file-utils
24Requires(post):         gettext
25Requires(post):         intltool
26Requires(post):         libsamplerate-devel
27Requires(post):         libdv-devel
28Requires(post):         libavc1394-devel
29Requires(post):         libraw1394-devel
30Requires(post):         libiec61883-devel
31Requires(post):         libogg-devel
32Requires(post):         libvorbis-devel
33Requires(post):         gtk2-devel >= 2.6.0
34Requires(post):         XOrg-devel
35Requires(post):         imlib-devel
36Requires(post):         libxml2-devel
37Requires(post):         perl
38
39Requires:               libdv
40Requires:               libavc1394
41Requires:               libraw1394
42Requires:               libogg
43Requires:               libvorbis
44Requires:               gtk2
45Requires:               imlib
46Requires:               libxml2
47Requires(post):         shared-mime-info
48
49Requires(post):         self-build-libquicktime
50Requires(post):         self-build-mjpegtools
51Requires(post):         self-build-mplayer
52Requires(post):         self-build-ffmpeg
53Requires(post):         self-build-ffmpeg2theora
54
55BuildArch:      noarch
56BuildRoot:      %{_tmppath}/%{name}-%{version}-root
57
58Packager:       munepi
59
60%description
61The new generation of digital camcorders use the Digital Video (DV) data
62format. Kino allows you to record, create, edit, and play movies recorded
63with DV camcorders. Unlike other editors, this program uses many keyboard
64commands for fast navigating and editing inside the movie.
65
66
67If you install this package, it automaticaly downloads source
68code ,compile it, and create rpm packages of %{pkgname}-%{version}.
69And the created rpm packages are automatically installed
70if installation is executed by apt-get command or synaptic
71package manager.
72
73[Note]
74This package requires many other packages to compile
75targetsoftware. So it consume more disk space than usual.
76Also installation takes logner time because of compilation.
77(This will take a few minutes to quarter or half of an hour,
78depends on building environment)
79
80[About self-build package]
81For some kind of software, distributing of binary package
82may viorate the patent or law. Therefore we chose self-build
83packge, create binary package on your machine, for such kind
84of softwares instead of distributing binary package.
85
86Please obey the national law when you use the created binary
87packages. And if you want to use the softwares using patented
88thechnology, it may be required to get a permission, make an
89agreement or purchas a license. Please consider it with your
90purpose or way of use and take appropriate action.
91
92%description -l ja
93デジタルビデオカメラの新世代は
94Digital Video (DV) データフォーマットを使います。
95Kino は DV デジタルビデオカメラで録画された動画を
96録画、作成、編集、再生できます。
97他の編集ソフトとは異なり、
98動画の中へ素早く移動や編集するために
99多くのキーボードコマンドを使えます。
100
101
102このパッケージをインストールすると、自動的にソースコードを
103ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
104パッケージを作成します。
105また apt-get コマンドや synaptic パッケージマネージャから実行
106した場合は、作成された rpm パッケージのインストールも自動的に
107行います。
108
109[注意]
110コンパイルに必要な多くの関連パッケージを要求するので通常より
111ディスクの領域を多く消費します。
112またインストール時にコンパイルを行うため、通常より時間がかか
113る場合があります。(環境にもよりますが数分から数十分程度)
114
115[self-build パッケージについて]
116ソフトウェアによってはバイナリパッケージの配布が特許や法律に
117違反する可能性があるものがあります。その為、このような問題が
118懸念されるソフトウェアについてはバイナリパッケージを直接配布
119せずに、ユーザの環境でバイナリを作成する self-build パッケー
120ジという方法を採っています。
121
122作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
123アのライセンス、および利用する国の各種法令に従ってください。
124また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
125センスの購入などが必要となる場合がありますので、利用する目的
126や形態に応じて各自で判断し適切な対応を取ってください。
127
128%prep
129[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
130
131%install
132%{__rm} -rf ${RPM_BUILD_ROOT}
133%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
134%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
135%{__install} -m 644 %{SOURCE100} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
136
137%clean
138%{__rm} -rf ${RPM_BUILD_ROOT}
139
140%posttrans
141/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 105000
142/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
143                                 %{pkgname}-devel-%{version}-%{release}
144
145%files
146%defattr(-,root,root)
147%{_datadir}/%{name}
148
149%changelog
150* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-3
151- added Requires(post): self-build-mjpegtools, self-build-mplayer
152
153* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-2
154- renamed %%{Source0} to kino-vl.spec
155
156* Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.4-1
157- new upstream release
158  - with recent ffmpeg
159
160* Sun Jun 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-2
161- initial bulid
Note: See TracBrowser for help on using the repository browser.