source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 5396

Revision 5396, 10.4 KB checked in by munepi, 12 years ago (diff)

updated self-build-ffmpeg: updated source to v0.9.1

Line 
1#TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
2#TODO: add make test to %%check section
3
4#% define svndate       20100625
5%define with_faac 1
6%define with_vaapi 1
7%define with_libvpx 1
8
9#% define enable_avconv 1
10
11%define use_prebuilt_man 1
12
13Summary:        Digital VCR and streaming server
14Name:           ffmpeg
15Version:        0.9.1
16Release:        1%{?svndate:.%svndate}%{?_dist_release}
17Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
18Source1:        %{name}-snapshot.sh
19
20# pre-built man files
21%if %{use_prebuilt_man}
22#$ tar Jcvf ~/rpm/SOURCES/ffmpeg/ffmpeg-0.9-doc.tar.xz ffmpeg-0.9/doc/*.html ffmpeg-0.9/doc/*.pod ffmpeg-0.9/doc/*.1
23Source90:       ffmpeg-%{version}-doc.tar.xz
24%endif
25
26%if 0%{?_with_amr:1}
27License:        GPLv3+
28%else
29License:        GPLv2+
30%endif
31Group:          Applications/Multimedia
32URL:            http://ffmpeg.org/
33
34BuildRequires:  bzip2-devel
35BuildRequires:  celt-devel
36##BuildRequires:  dirac-devel
37BuildRequires:  freetype2-devel
38BuildRequires:  gsm-devel
39BuildRequires:  imlib2-devel
40BuildRequires:  libdc1394-devel
41BuildRequires:  libogg-devel
42BuildRequires:  libraw1394-devel
43BuildRequires:  librtmp-devel >= 2.3
44BuildRequires:  libtheora-devel
45%{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
46BuildRequires:  libvdpau-devel
47BuildRequires:  libvorbis-devel
48%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.6}
49%{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
50##BuildRequires:  openjpeg-devel
51##BuildRequires:  schroedinger-devel
52BuildRequires:  SDL-devel
53BuildRequires:  speex-devel
54%{!?use_prebuilt_man:BuildRequires:     texi2html}
55BuildRequires:  zlib-devel
56BuildRequires:  yasm
57# *-devel packages provided by other self-build-* should only be listed
58# in self-build-%{name}.spec as PreReq.
59#BuildRequires: a52dec-devel
60#BuildRequires: faac-devel
61#BuildRequires: lame-devel
62#BuildRequires: libdca-devel
63#BuildRequires: x264-devel >= 0.0.0-18.20111216
64#BuildRequires: xvidcore-devel
65
66Requires:       %{name}-libs = %{version}-%{release}
67
68BuildRoot:      %{_tmppath}/%{name}-%{version}-root
69
70%description
71FFMpeg is a complete and free Internet live audio and video
72broadcasting solution for Linux/Unix. It also includes a digital
73VCR. It can encode in real time in many formats including MPEG1 audio
74and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
75
76%package libs
77Summary: Libraries for %{name}
78Group: System Environment/Libraries
79
80%description libs
81FFMpeg is a complete and free Internet live audio and video
82broadcasting solution for Linux/Unix. It also includes a digital
83VCR. It can encode in real time in many formats including MPEG1 audio
84and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
85
86This package contains the libraries for %{name}.
87
88%package devel
89Summary: Development package for %{name}
90Group: Development/Libraries
91Requires: %{name}-libs = %{version}-%{release}
92Requires: pkgconfig
93
94%description devel
95FFMpeg is a complete and free Internet live audio and video
96broadcasting solution for Linux/Unix. It also includes a digital
97VCR. It can encode in real time in many formats including MPEG1 audio
98and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
99
100This package contains development files for %{name}.
101
102
103%prep
104%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
105%if %{use_prebuilt_man}
106tar -C .. -xf %{SOURCE90}
107%endif
108
109%build
110%ifarch ppc
111# compile with -mlongcall on ppc/ppc64 (rf804)
112export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
113%endif
114
115./configure \
116    --prefix=%{_prefix} \
117    --incdir=%{_includedir}/%{name} \
118    --shlibdir=%{_libdir} \
119    --libdir=%{_libdir} \
120    --mandir=%{_mandir} \
121    --arch=%{_target_cpu} \
122%ifarch %{ix86}
123    --cpu=%{_target_cpu} \
124%endif
125%ifarch ppc
126    --cpu=g3 \
127    --enable-pic \
128%endif
129    --enable-runtime-cpudetect \
130    --extra-cflags="$RPM_OPT_FLAGS" \
131    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
132    --enable-bzlib \
133    --enable-zlib \
134    --enable-libcelt \
135    --enable-libdc1394 \
136    %{?_with_libdirac:--enable-libdirac} \
137    %{?with_faac:--enable-libfaac --enable-nonfree} \
138    --enable-libfreetype \
139    --enable-libgsm \
140    --enable-libmp3lame \
141    %{?_with_openjpeg:--enable-libopenjpeg} \
142    --enable-librtmp \
143    --enable-libspeex \
144    --enable-libtheora \
145    --enable-libvorbis \
146    %{?with_libvpx:--enable-libvpx} \
147    --enable-libx264 \
148    --enable-libxvid \
149    \
150    --enable-x11grab \
151    --enable-avfilter \
152    --enable-postproc \
153    --enable-pthreads \
154    --disable-static \
155    --enable-shared \
156    --enable-gpl \
157    %{?use_prebuilt_man:--disable-doc} \
158    --disable-debug \
159    --disable-stripping \
160    \
161    %{?enable_avconv:--enable-avconv} \
162    ;
163
164%__make %{?_smp_mflags}
165
166%__make alltools
167
168
169%install
170%__make install DESTDIR=$RPM_BUILD_ROOT
171
172## install tool/qt-faststart
173%__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
174
175## install man
176%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
177%__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
178
179
180%clean
181%{__rm} -rf $RPM_BUILD_ROOT
182
183%post libs -p /sbin/ldconfig
184
185%postun libs -p /sbin/ldconfig
186
187%files
188%defattr(-,root,root,-)
189%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
190%{?enable_avconv:%{_bindir}/avconv}
191%{_bindir}/ffmpeg
192%{_bindir}/ffplay
193%{_bindir}/ffprobe
194%{_bindir}/ffserver
195%{_bindir}/qt-faststart
196%{?enable_avconv:%{_mandir}/man1/avconv.1*}
197%{_mandir}/man1/ffmpeg.1*
198%{_mandir}/man1/ffplay.1*
199%{_mandir}/man1/ffprobe.1*
200%{_mandir}/man1/ffserver.1*
201%{_datadir}/ffmpeg
202
203
204%files libs
205%defattr(-,root,root,-)
206%{_libdir}/lib*.so.*
207
208%files devel
209%defattr(-,root,root,-)
210%doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
211%{_includedir}/ffmpeg
212%{_libdir}/pkgconfig/lib*.pc
213%{_libdir}/lib*.so
214
215
216%changelog
217* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
218- new upstream release
219
220* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
221- new upstream release
222- enable CELT decoding via libcelt
223- enable FreeType support
224- drop faad2 support (dropped upstream)
225
226* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
227- change release to sync with self-build-ffmpeg-vl.spec
228
229* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
230- new upstream release
231
232* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
233- new upstream release
234
235* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
236- required latest x264 build
237- added BuildRequires: librtmp-devel >= 2.3
238- build PIC objects on PPC
239#- add qt-faststart tool
240
241* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
242- new upstream release
243
244* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
245- change release to sync with self-build-ffmpeg-vl.spec
246
247* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
248- added BuildRequires: libvpx-devel >= 0.9.1
249
250* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
251- new upstream release
252
253* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
254- bumped version to pre-0.6
255
256* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
257- updated source snapshot 20100410
258
259* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
260- change release to sync with self-build-ffmpeg-vl.spec
261
262* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
263- change release to sync with self-build-ffmpeg-vl.spec
264
265* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
266- updated source snapshot 20100401
267
268* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
269- updated source snapshot 20100326
270
271* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
272- change release to sync with self-build-ffmpeg
273
274* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
275- updated source snapshot 20100216
276  - rebuild with recent x264-devel
277- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
278- added BuildRequires:  libvdpau-devel
279
280* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
281- change release to sync with self-build-ffmpeg
282
283* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
284- change release to sync with self-build-ffmpeg
285
286* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
287- applied ffmpeg-0.5-disable-texi2html.patch
288  - dropped BuildRequires: texi2html
289
290* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
291- change release to sync with self-build-ffmpeg
292
293* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
294- corrected release number
295
296* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
297- new upstream release
298- added BuildRequires:
299  - speex-devel
300  - bzip2-devel
301
302* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
303- 20090227 snapshot
304
305* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
306- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
307
308* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
309- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
310- dropped Requires: a52dec, faad2 in ffmpeg-libs
311
312* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
313- 20090202 snapshot
314
315* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
316- 20090110 snapshot
317- dropped some patches
318
319* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
320- source updated (r15488)
321- fixed License: GPLv2+
322- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
323- added BuildRequires: yasm (only %%ix86)
324- applied ffmpeg-cpu.patch (merged from RPM Fusion)
325
326* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
327- spec in utf8
328
329* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
330- change release to sync with self-build-ffmpeg
331
332* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
333- drop "Patch100: ffmpeg-vine.patch".
334
335* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
336- build with new versioning policy
337- change to use svn export from svn checkout on post install
338- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
339
340* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
341- [self-build-ffmpeg.spec]
342  For all pre-required package that is provied by self-build, 
343  changed to its self-build package
344
345* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
346- initial build for Vine Linux 4.2
347- snapshot 2008/01/28 + some Rev.11662 2008/01/29
348
349### end of file
Note: See TracBrowser for help on using the repository browser.