source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 6241

Revision 6241, 11.2 KB checked in by munepi, 12 years ago (diff)

upgrade some self-build packages; remove obsolete self-build packages

Line 
1#TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
2#TODO: add make test to %%check section
3
4#% define svndate       20100625
5%define with_faac 1
6%define with_vaapi 1
7%define with_libvpx 1
8
9#% define enable_avconv 1
10
11%define use_prebuilt_man 1
12
13Summary:        Digital VCR and streaming server
14Name:           ffmpeg
15Version:        0.11
16Release:        1%{?svndate:.%svndate}%{?_dist_release}
17Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
18
19# pre-built man files
20#$ tar Jcvf ~/rpm/SOURCES/ffmpeg/ffmpeg-0.10-doc.tar.xz ffmpeg-0.10/doc/*.html ffmpeg-0.10/doc/*.pod ffmpeg-0.10/doc/*.1
21%{?use_prebuilt_man:Source90:       ffmpeg-%{version}-doc.tar.xz}
22
23%if 0%{?_with_amr:1}
24License:        GPLv3+
25%else
26License:        GPLv2+
27%endif
28Group:          Applications/Multimedia
29URL:            http://ffmpeg.org/
30
31BuildRequires:  bzip2-devel
32BuildRequires:  celt-devel
33##BuildRequires:  dirac-devel
34BuildRequires:  freetype2-devel
35BuildRequires:  gsm-devel
36BuildRequires:  imlib2-devel
37BuildRequires:  libdc1394-devel
38BuildRequires:  libogg-devel
39BuildRequires:  libass-devel
40%{!?_without_cdio:BuildRequires: libcdio-devel}
41#libcrystalhd is currently broken
42%{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
43BuildRequires:  libraw1394-devel
44BuildRequires:  librtmp-devel >= 2.3
45BuildRequires:  libtheora-devel
46%{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
47BuildRequires:  libvdpau-devel
48BuildRequires:  libvorbis-devel
49%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.6}
50BuildRequires:  libXvMC-devel
51%{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
52%{!?_without_openal:BuildRequires: openal-soft-devel}
53%{?_with_opencv:BuildRequires: opencv-devel}
54%{?_with_openjpeg:BuildRequires:  openjpeg-devel}
55##BuildRequires:  schroedinger-devel
56BuildRequires:  SDL-devel
57BuildRequires:  speex-devel
58%{!?use_prebuilt_man:BuildRequires:     texi2html}
59BuildRequires:  zlib-devel
60BuildRequires:  yasm
61# *-devel packages provided by other self-build-* should only be listed
62# in self-build-%{name}.spec as PreReq.
63#BuildRequires: a52dec-devel
64#BuildRequires: faac-devel
65#BuildRequires: lame-devel
66#BuildRequires: libdca-devel
67#BuildRequires: x264-devel >= 0.0.0-18.20111216
68#BuildRequires: xvidcore-devel
69
70Requires:       %{name}-libs = %{version}-%{release}
71
72BuildRoot:      %{_tmppath}/%{name}-%{version}-root
73
74Obsoletes:      ffmpeg < %{version}, ffmpeg-libs < %{version}, ffmpeg-devel < %{version}
75
76%description
77FFMpeg is a complete and free Internet live audio and video
78broadcasting solution for Linux/Unix. It also includes a digital
79VCR. It can encode in real time in many formats including MPEG1 audio
80and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
81
82%package libs
83Summary: Libraries for %{name}
84Group: System Environment/Libraries
85
86%description libs
87FFMpeg is a complete and free Internet live audio and video
88broadcasting solution for Linux/Unix. It also includes a digital
89VCR. It can encode in real time in many formats including MPEG1 audio
90and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
91
92This package contains the libraries for %{name}.
93
94%package devel
95Summary: Development package for %{name}
96Group: Development/Libraries
97Requires: %{name}-libs = %{version}-%{release}
98Requires: pkgconfig
99
100%description devel
101FFMpeg is a complete and free Internet live audio and video
102broadcasting solution for Linux/Unix. It also includes a digital
103VCR. It can encode in real time in many formats including MPEG1 audio
104and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
105
106This package contains development files for %{name}.
107
108
109%prep
110%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
111%{?use_prebuilt_man:tar -C .. -xf %{SOURCE90}}
112
113%build
114%ifarch ppc
115# compile with -mlongcall on ppc/ppc64 (rf804)
116export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
117%endif
118
119./configure \
120    --prefix=%{_prefix} \
121    --incdir=%{_includedir}/%{name} \
122    --shlibdir=%{_libdir} \
123    --libdir=%{_libdir} \
124    --mandir=%{_mandir} \
125    --arch=%{_target_cpu} \
126%ifarch %{ix86}
127    --cpu=%{_target_cpu} \
128%endif
129%ifarch ppc
130    --cpu=g3 \
131    --enable-pic \
132%endif
133    --enable-runtime-cpudetect \
134    --extra-cflags="$RPM_OPT_FLAGS" \
135    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
136    --enable-bzlib \
137    %{!?_with_crystalhd:--disable-crystalhd} \
138    --enable-zlib \
139    %{?_with_frei0r:--enable-frei0r} \
140    --enable-gnutls \
141    --enable-libass \
142    %{!?_without_cdio:--enable-libcdio} \
143    --enable-libcelt \
144    --enable-libdc1394 \
145    %{?_with_libdirac:--enable-libdirac} \
146    %{?with_faac:--enable-libfaac --enable-nonfree} \
147    --enable-libfreetype \
148    --enable-libgsm \
149    --enable-libmp3lame \
150    %{!?_without_openal:--enable-openal} \
151    %{?_with_opencv:--enable-libopencv} \
152    %{?_with_openjpeg:--enable-libopenjpeg} \
153    --enable-librtmp \
154    --enable-libspeex \
155    --enable-libtheora \
156    --enable-libvorbis \
157    %{?with_libvpx:--enable-libvpx} \
158    --enable-libx264 \
159    --enable-libxvid \
160    \
161    --enable-x11grab \
162    --enable-avfilter \
163    --enable-postproc \
164    --enable-pthreads \
165    --disable-static \
166    --enable-shared \
167    --enable-gpl \
168    %{?use_prebuilt_man:--disable-doc} \
169    --disable-debug \
170    --disable-stripping \
171    \
172    %{?enable_avconv:--enable-avconv} \
173    ;
174
175%__make %{?_smp_mflags}
176
177%__make alltools
178
179
180%install
181%__make install DESTDIR=$RPM_BUILD_ROOT
182
183## install tool/qt-faststart
184%__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
185
186## install man
187%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
188%__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
189
190
191%clean
192%{__rm} -rf $RPM_BUILD_ROOT
193
194%post libs -p /sbin/ldconfig
195
196%postun libs -p /sbin/ldconfig
197
198%files
199%defattr(-,root,root,-)
200%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
201%{?enable_avconv:%{_bindir}/avconv}
202%{_bindir}/ffmpeg
203%{_bindir}/ffplay
204%{_bindir}/ffprobe
205%{_bindir}/ffserver
206%{_bindir}/qt-faststart
207%{?enable_avconv:%{_mandir}/man1/avconv.1*}
208%{_mandir}/man1/ffmpeg.1*
209%{_mandir}/man1/ffplay.1*
210%{_mandir}/man1/ffprobe.1*
211%{_mandir}/man1/ffserver.1*
212%{_datadir}/ffmpeg
213
214
215%files libs
216%defattr(-,root,root,-)
217%{_libdir}/lib*.so.*
218
219%files devel
220%defattr(-,root,root,-)
221%doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
222%{_includedir}/ffmpeg
223%{_libdir}/pkgconfig/lib*.pc
224%{_libdir}/lib*.so
225
226
227%changelog
228* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
229- new upstream release
230
231* Sat Feb 18 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10-1
232- new upstream release
233
234* Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
235- new upstream release
236
237* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
238- new upstream release
239- enable CELT decoding via libcelt
240- enable FreeType support
241- drop faad2 support (dropped upstream)
242
243* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
244- change release to sync with self-build-ffmpeg-vl.spec
245
246* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
247- new upstream release
248
249* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
250- new upstream release
251
252* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
253- required latest x264 build
254- added BuildRequires: librtmp-devel >= 2.3
255- build PIC objects on PPC
256#- add qt-faststart tool
257
258* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
259- new upstream release
260
261* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
262- change release to sync with self-build-ffmpeg-vl.spec
263
264* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
265- added BuildRequires: libvpx-devel >= 0.9.1
266
267* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
268- new upstream release
269
270* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
271- bumped version to pre-0.6
272
273* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
274- updated source snapshot 20100410
275
276* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
277- change release to sync with self-build-ffmpeg-vl.spec
278
279* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
280- change release to sync with self-build-ffmpeg-vl.spec
281
282* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
283- updated source snapshot 20100401
284
285* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
286- updated source snapshot 20100326
287
288* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
289- change release to sync with self-build-ffmpeg
290
291* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
292- updated source snapshot 20100216
293  - rebuild with recent x264-devel
294- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
295- added BuildRequires:  libvdpau-devel
296
297* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
298- change release to sync with self-build-ffmpeg
299
300* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
301- change release to sync with self-build-ffmpeg
302
303* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
304- applied ffmpeg-0.5-disable-texi2html.patch
305  - dropped BuildRequires: texi2html
306
307* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
308- change release to sync with self-build-ffmpeg
309
310* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
311- corrected release number
312
313* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
314- new upstream release
315- added BuildRequires:
316  - speex-devel
317  - bzip2-devel
318
319* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
320- 20090227 snapshot
321
322* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
323- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
324
325* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
326- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
327- dropped Requires: a52dec, faad2 in ffmpeg-libs
328
329* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
330- 20090202 snapshot
331
332* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
333- 20090110 snapshot
334- dropped some patches
335
336* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
337- source updated (r15488)
338- fixed License: GPLv2+
339- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
340- added BuildRequires: yasm (only %%ix86)
341- applied ffmpeg-cpu.patch (merged from RPM Fusion)
342
343* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
344- spec in utf8
345
346* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
347- change release to sync with self-build-ffmpeg
348
349* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
350- drop "Patch100: ffmpeg-vine.patch".
351
352* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
353- build with new versioning policy
354- change to use svn export from svn checkout on post install
355- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
356
357* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
358- [self-build-ffmpeg.spec]
359  For all pre-required package that is provied by self-build, 
360  changed to its self-build package
361
362* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
363- initial build for Vine Linux 4.2
364- snapshot 2008/01/28 + some Rev.11662 2008/01/29
365
366### end of file
Note: See TracBrowser for help on using the repository browser.