source: projects/specs/trunk/nonfree/self-build-ffmpeg/ffmpeg-vl.spec @ 5297

Revision 5297, 10.3 KB checked in by munepi, 12 years ago (diff)

updated self-build-* packages: new x264 ABI and ffmpeg 0.9

Line 
1#TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
2#TODO: add make test to %%check section
3
4#% define svndate       20100625
5%define with_faac 1
6%define with_vaapi 1
7%define with_libvpx 1
8
9%define use_prebuilt_man 1
10
11Summary:        Digital VCR and streaming server
12Name:           ffmpeg
13Version:        0.9
14Release:        1%{?svndate:.%svndate}%{?_dist_release}
15Source:         http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
16Source1:        %{name}-snapshot.sh
17
18# pre-built man files
19%if %{use_prebuilt_man}
20#$ tar Jcvf ~/rpm/SOURCES/ffmpeg/ffmpeg-0.9-doc.tar.xz ffmpeg-0.9/doc/*.html ffmpeg-0.9/doc/*.pod ffmpeg-0.9/doc/*.1
21Source90:       ffmpeg-%{version}-doc.tar.xz
22%endif
23
24%if 0%{?_with_amr:1}
25License:        GPLv3+
26%else
27License:        GPLv2+
28%endif
29Group:          Applications/Multimedia
30URL:            http://ffmpeg.org/
31
32BuildRequires:  bzip2-devel
33BuildRequires:  celt-devel
34##BuildRequires:  dirac-devel
35BuildRequires:  freetype2-devel
36BuildRequires:  gsm-devel
37BuildRequires:  imlib2-devel
38BuildRequires:  libdc1394-devel
39BuildRequires:  libogg-devel
40BuildRequires:  libraw1394-devel
41BuildRequires:  librtmp-devel >= 2.3
42BuildRequires:  libtheora-devel
43%{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
44BuildRequires:  libvdpau-devel
45BuildRequires:  libvorbis-devel
46%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.6}
47%{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
48##BuildRequires:  openjpeg-devel
49##BuildRequires:  schroedinger-devel
50BuildRequires:  SDL-devel
51BuildRequires:  speex-devel
52%{!?use_prebuilt_man:BuildRequires:     texi2html}
53BuildRequires:  zlib-devel
54BuildRequires:  yasm
55# *-devel packages provided by other self-build-* should only be listed
56# in self-build-%{name}.spec as PreReq.
57#BuildRequires: a52dec-devel
58#BuildRequires: faac-devel
59#BuildRequires: lame-devel
60#BuildRequires: libdca-devel
61#BuildRequires: x264-devel >= 0.0.0-15.20110322
62#BuildRequires: xvidcore-devel
63
64Requires:       %{name}-libs = %{version}-%{release}
65
66BuildRoot:      %{_tmppath}/%{name}-%{version}-root
67
68%description
69FFMpeg is a complete and free Internet live audio and video
70broadcasting solution for Linux/Unix. It also includes a digital
71VCR. It can encode in real time in many formats including MPEG1 audio
72and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
73
74%package libs
75Summary: Libraries for %{name}
76Group: System Environment/Libraries
77
78%description libs
79FFMpeg is a complete and free Internet live audio and video
80broadcasting solution for Linux/Unix. It also includes a digital
81VCR. It can encode in real time in many formats including MPEG1 audio
82and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
83
84This package contains the libraries for %{name}.
85
86%package devel
87Summary: Development package for %{name}
88Group: Development/Libraries
89Requires: %{name}-libs = %{version}-%{release}
90Requires: pkgconfig
91
92%description devel
93FFMpeg is a complete and free Internet live audio and video
94broadcasting solution for Linux/Unix. It also includes a digital
95VCR. It can encode in real time in many formats including MPEG1 audio
96and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
97
98This package contains development files for %{name}.
99
100
101%prep
102%setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
103%if %{use_prebuilt_man}
104tar -C .. -xf %{SOURCE90}
105%endif
106
107%build
108%ifarch ppc
109# compile with -mlongcall on ppc/ppc64 (rf804)
110export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
111%endif
112
113./configure \
114    --prefix=%{_prefix} \
115    --incdir=%{_includedir}/%{name} \
116    --shlibdir=%{_libdir} \
117    --libdir=%{_libdir} \
118    --mandir=%{_mandir} \
119    --arch=%{_target_cpu} \
120%ifarch %{ix86}
121    --cpu=%{_target_cpu} \
122%endif
123%ifarch ppc
124    --cpu=g3 \
125    --enable-pic \
126%endif
127    --enable-runtime-cpudetect \
128    --extra-cflags="$RPM_OPT_FLAGS" \
129    %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
130    --enable-bzlib \
131    --enable-zlib \
132    --enable-libcelt \
133    --enable-libdc1394 \
134    %{?_with_libdirac:--enable-libdirac} \
135    %{?with_faac:--enable-libfaac --enable-nonfree} \
136    --enable-libfreetype \
137    --enable-libgsm \
138    --enable-libmp3lame \
139    %{?_with_openjpeg:--enable-libopenjpeg} \
140    --enable-librtmp \
141    --enable-libspeex \
142    --enable-libtheora \
143    --enable-libvorbis \
144    %{?with_libvpx:--enable-libvpx} \
145    --enable-libx264 \
146    --enable-libxvid \
147    \
148    --enable-x11grab \
149    --enable-avfilter \
150    --enable-postproc \
151    --enable-pthreads \
152    --disable-static \
153    --enable-shared \
154    --enable-gpl \
155    %{?use_prebuilt_man:--disable-doc} \
156    --disable-debug \
157    --disable-stripping \
158    ;
159
160%__make %{?_smp_mflags}
161
162%if %{!use_prebuilt_man}
163%__make documentation
164%endif
165
166%__make alltools
167
168
169%install
170%__make install DESTDIR=$RPM_BUILD_ROOT
171
172## install tool/qt-faststart
173%__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
174
175# ## install man
176%if %{!use_prebuilt_man}
177%__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
178%__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
179%endif
180
181
182%clean
183%{__rm} -rf $RPM_BUILD_ROOT
184
185%post libs -p /sbin/ldconfig
186
187%postun libs -p /sbin/ldconfig
188
189%files
190%defattr(-,root,root,-)
191%doc COPYING.* CREDITS Changelog README doc/ffserver.conf
192%{_bindir}/avconv
193%{_bindir}/ffmpeg
194%{_bindir}/ffplay
195%{_bindir}/ffprobe
196%{_bindir}/ffserver
197%{_bindir}/qt-faststart
198%{_mandir}/man1/avconv.1*
199%{_mandir}/man1/ffmpeg.1*
200%{_mandir}/man1/ffplay.1*
201%{_mandir}/man1/ffprobe.1*
202%{_mandir}/man1/ffserver.1*
203%{_datadir}/ffmpeg
204
205
206%files libs
207%defattr(-,root,root,-)
208%{_libdir}/lib*.so.*
209
210%files devel
211%defattr(-,root,root,-)
212%doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
213%{_includedir}/ffmpeg
214%{_libdir}/pkgconfig/lib*.pc
215%{_libdir}/lib*.so
216
217
218%changelog
219* Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
220- new upstream release
221- enable CELT decoding via libcelt
222- enable FreeType support
223- drop faad2 support (dropped upstream)
224
225* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
226- change release to sync with self-build-ffmpeg-vl.spec
227
228* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
229- new upstream release
230
231* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
232- new upstream release
233
234* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
235- required latest x264 build
236- added BuildRequires: librtmp-devel >= 2.3
237- build PIC objects on PPC
238#- add qt-faststart tool
239
240* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
241- new upstream release
242
243* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
244- change release to sync with self-build-ffmpeg-vl.spec
245
246* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
247- added BuildRequires: libvpx-devel >= 0.9.1
248
249* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
250- new upstream release
251
252* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
253- bumped version to pre-0.6
254
255* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
256- updated source snapshot 20100410
257
258* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
259- change release to sync with self-build-ffmpeg-vl.spec
260
261* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
262- change release to sync with self-build-ffmpeg-vl.spec
263
264* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
265- updated source snapshot 20100401
266
267* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
268- updated source snapshot 20100326
269
270* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
271- change release to sync with self-build-ffmpeg
272
273* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
274- updated source snapshot 20100216
275  - rebuild with recent x264-devel
276- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
277- added BuildRequires:  libvdpau-devel
278
279* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
280- change release to sync with self-build-ffmpeg
281
282* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
283- change release to sync with self-build-ffmpeg
284
285* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
286- applied ffmpeg-0.5-disable-texi2html.patch
287  - dropped BuildRequires: texi2html
288
289* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
290- change release to sync with self-build-ffmpeg
291
292* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
293- corrected release number
294
295* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
296- new upstream release
297- added BuildRequires:
298  - speex-devel
299  - bzip2-devel
300
301* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
302- 20090227 snapshot
303
304* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
305- added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
306
307* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
308- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
309- dropped Requires: a52dec, faad2 in ffmpeg-libs
310
311* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
312- 20090202 snapshot
313
314* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
315- 20090110 snapshot
316- dropped some patches
317
318* Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
319- source updated (r15488)
320- fixed License: GPLv2+
321- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
322- added BuildRequires: yasm (only %%ix86)
323- applied ffmpeg-cpu.patch (merged from RPM Fusion)
324
325* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
326- spec in utf8
327
328* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
329- change release to sync with self-build-ffmpeg
330
331* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
332- drop "Patch100: ffmpeg-vine.patch".
333
334* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
335- build with new versioning policy
336- change to use svn export from svn checkout on post install
337- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
338
339* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
340- [self-build-ffmpeg.spec]
341  For all pre-required package that is provied by self-build, 
342  changed to its self-build package
343
344* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
345- initial build for Vine Linux 4.2
346- snapshot 2008/01/28 + some Rev.11662 2008/01/29
347
348### end of file
Note: See TracBrowser for help on using the repository browser.