source: projects/specs/trunk/nonfree/self-build-avidemux/avidemux-vl.spec @ 1258

Revision 1258, 13.4 KB checked in by munepi, 14 years ago (diff)

updated some self-build packages

Line 
1%define _pkgbuilddir %{_builddir}/%{name}_%{version}
2
3Name:           avidemux
4Version:        2.5.2
5Release:        3%{?_dist_release}
6Summary:        Graphical video editing and transcoding tool
7
8Group:          Applications/Multimedia
9License:        GPLv2+
10URL:            http://www.avidemux.org/
11Source0:        http://download.berlios.de/avidemux/avidemux_%{version}.tar.gz
12Source1:        %{name}-gtk.desktop
13Source2:        %{name}-qt.desktop
14# Patch0 obtained from avidemux-2.5.0-patches-1.tar.bz2:
15# http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/distfiles/avidemux-2.5.0-patches-1.tar.bz2
16Patch0:         2.5.0-coreImage-parallel-build.patch
17Patch1:         avidemux-2.5-pulseaudio-default.patch
18Patch2:         avidemux-2.4-qt4.patch
19Patch3:         avidemux-2.5-i18n.patch
20Patch4:         avidemux-2.5-libmpeg2enc-altivec.patch
21Patch5:         avidemux-2.5-checkfunction-includes.patch
22Patch6:         avidemux-2.5.1-tmplinktarget.patch
23
24## Vine customization patches
25Patch10:         avidemux-2.4.3-alsa-device-default.patch
26Patch11:         avidemux-2.5.2-no-qt4-ui.patch
27
28BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
29
30Requires:       %{name}-cli  = %{version}
31Requires:       %{name}-gui = %{version}
32Obsoletes:      %{name}-qt < 2.5.0
33
34# *-devel pacages provided by other self-build-* should only be listed
35# in self-build-%{name}.spec as PreReq.
36
37# Compiling
38BuildRequires:  cmake
39#BuildRequires:  gettext-devel
40BuildRequires:  gettext
41
42# Libraries
43BuildRequires:  nasm >= 0.98.38
44BuildRequires:  libxml2-devel >= 2.6.8
45BuildRequires:  fontconfig-devel
46#BuildRequires:  freetype-devel
47BuildRequires:  freetype2-devel
48BuildRequires:  js-devel
49BuildRequires:  libXv-devel
50BuildRequires:  libXmu-devel
51# Required by gtk: libXi-devel, libXext-devel, libX11-devel
52# Required by qt: libXt-devel, libXext-devel, libX11-devel
53BuildRequires:  libsamplerate-devel
54BuildRequires:  jack-audio-connection-kit-devel
55
56# Sound out
57BuildRequires:  alsa-lib-devel >= 1.0.3
58BuildRequires:  esound-devel >= 0.2.0
59BuildRequires:  pulseaudio-libs-devel
60
61# Video out
62BuildRequires:  SDL-devel >= 1.2.7
63
64# Audio Codecs
65#BuildRequires:  a52dec-devel >= 0.7.4
66#BuildRequires:  faac-devel >= 1.24
67#BuildRequires:  faad2-devel >= 2.0
68#BuildRequires:  lame-devel >= 3.96.1
69#BuildRequires:  libmad-devel >= 0.15.1
70BuildRequires:  libogg-devel >= 1.1
71BuildRequires:  libvorbis-devel >= 1.0.1
72# BuildRequires:  self-build-a52dec >= 0.7.4
73# BuildRequires:  self-build-faac >= 1.24
74# BuildRequires:  self-build-faad2 >= 2.0
75# BuildRequires:  self-build-lame >= 3.96.1
76# BuildRequires:  self-build-libmad >= 0.15.1
77#BuildRequires:  libdca-devel
78# BuildRequires:  self-build-libdca
79
80# Video Codecs
81#BuildRequires:  xvidcore-devel >= 1.0.2
82#BuildRequires:  x264-devel
83#BuildRequires:  ffmpeg-devel
84# BuildRequires:  self-build-xvidcore >= 1.0.2
85# BuildRequires:  self-build-x264
86# BuildRequires:  self-build-ffmpeg
87
88# FIXME: aften not packaged, add BR when it is
89
90# Finally...
91BuildRequires:  desktop-file-utils
92
93%description
94Avidemux is a free video editor designed for simple cutting, filtering and
95encoding tasks. It supports many file types, including AVI, DVD compatible
96MPEG files, MP4 and ASF, using a variety of codecs. Tasks can be automated
97using projects, job queue and powerful scripting capabilities.
98
99For compatability reasons, avidemux is a meta-package which installs the
100graphical, command line and plugin packages. If you want a smaller setup,
101you may selectively install one or more of the avidemux-* subpackages.
102
103%package cli
104Summary:        CLI for %{name}
105Group:          Applications/Multimedia
106Requires:       %{name} = %{version}-%{release}
107
108%description cli
109This package provides a command-line interface to editing videos with %{name}.
110
111%package gtk
112Summary:        GTK interface for %{name}
113Group:          Applications/Multimedia
114BuildRequires:  gtk2-devel >= 2.8.0
115BuildRequires:  cairo-devel
116# Slightly higher so it is default, but it can be avoided by installing
117# avidemux-qt directly or it can be removed later once avidemux-qt is installed
118Provides:       %{name}-gui = %{version}-%{release}.1
119Requires:       %{name} = %{version}-%{release}
120
121%description gtk
122This package provides the GTK graphical interface for %{name}.
123
124%if %{?with_qt_ui:1} %{!?with_qt_ui:0}
125%package qt
126Summary:        Qt interface for %{name}
127Group:          Applications/Multimedia
128# 4.5.0-9 fixes a failure when there are duplicate translated strings
129# https://bugzilla.redhat.com/show_bug.cgi?id=491514
130BuildRequires:  qt4-devel >= 4.5.0-9
131BuildRequires:  qt4-designer
132Provides:       %{name}-gui = %{version}-%{release}
133Requires:       %{name} = %{version}-%{release}
134
135%description qt
136This package contains the Qt graphical interface for %{name}.
137%endif
138
139%package devel
140Summary:        Development files for %{name}
141Group:          Development/Libraries
142Requires:       %{name} = %{version}-%{release}
143
144%description devel
145This package contains files required to develop with or extend %{name}.
146
147%prep
148%__rm -rf $RPM_BUILD_ROOT
149
150%setup -q -n avidemux_%{version}
151
152# change hardcoded libdir paths
153%ifarch x86_64 ppc64
154%__sed -i.bak 's/startDir="lib";/startDir="lib64";/' avidemux/ADM_core/src/ADM_fileio.cpp
155%__sed -i.bak 's/startDir="lib";/startDir="lib64";/' avidemux/main.cpp
156%endif
157
158%patch0 -p1 -b .parallel
159%patch1 -p1 -b .pulse
160#%patch2 -p1 -b .qt4
161%patch3 -p1 -b .i18n
162%patch4 -p1 -b .altivec
163%patch5 -p1 -b .cfincludes
164#%patch6 -p1 -b .tmplinktarget
165
166#%patch10 -p1 -b .alsa
167%{!?with_qt_ui:%patch11 -p1 -b .qt4}
168
169%build
170# Out of source build
171%__mkdir_p build && cd build
172%cmake -DAVIDEMUX_INSTALL_PREFIX=%{_prefix} \
173       -DAVIDEMUX_SOURCE_DIR="%{_pkgbuilddir}" \
174       -DAVIDEMUX_CORECONFIG_DIR="%{_pkgbuilddir}/build/config" \
175       ..
176%__make %{?_smp_mflags}
177# Create the temp link directory manuall since otherwise it happens too early
178%__mkdir_p %{_pkgbuilddir}/build/%{_lib}
179find %{_pkgbuilddir}/build/avidemux -name '*.so*' | \
180     xargs ln -sft %{_pkgbuilddir}/build/%{_lib}
181
182%__mkdir_p ../build_plugins && cd ../build_plugins
183%cmake -DAVIDEMUX_INSTALL_PREFIX="%{_pkgbuilddir}/build/" \
184       -DAVIDEMUX_SOURCE_DIR="%{_pkgbuilddir}" \
185       -DAVIDEMUX_CORECONFIG_DIR="%{_pkgbuilddir}/build/config" \
186       ../plugins
187%__make %{?_smp_mflags}
188
189
190%install
191%__rm -rf $RPM_BUILD_ROOT
192# Temporary workaround since the i18n files aren't being built
193%__mkdir_p $RPM_BUILD_ROOT/%{_datadir}/%{name}
194
195%__make -C build install DESTDIR=$RPM_BUILD_ROOT
196%__make -C build_plugins install DESTDIR=$RPM_BUILD_ROOT
197# Install the build configuration for devel package
198%__install -d -m755 $RPM_BUILD_ROOT%{_includedir}
199%__install -m644 build/config/ADM_coreConfig.h $RPM_BUILD_ROOT%{_includedir}/ADM_coreConfig.h
200
201# Find and remove all la files
202find $RPM_BUILD_ROOT -type f -name "*.la" -exec %__rm -f {} ';'
203
204# Install .desktop shortcuts
205desktop-file-install --vendor vine \
206    --dir $RPM_BUILD_ROOT%{_datadir}/applications \
207    %{SOURCE1}
208
209%if %{?with_qt_ui:1} %{!?with_qt_ui:0}
210desktop-file-install --vendor vine \
211    --dir $RPM_BUILD_ROOT%{_datadir}/applications \
212    %{SOURCE2}
213%endif
214
215find $RPM_BUILD_ROOT -type f -name "*.la" -exec %__rm -f {} ';'
216%find_lang %{name}
217
218%clean
219%__rm -rf $RPM_BUILD_ROOT
220
221%post -p /sbin/ldconfig
222%postun -p /sbin/ldconfig
223
224%files -f %{name}.lang
225%defattr(-,root,root,-)
226%doc AUTHORS COPYING README TODO
227%{_datadir}/%{name}/
228%{_datadir}/ADM_scripts/
229%{_libdir}/libADM*
230%{_libdir}/ADM_plugins/
231
232%files cli
233%defattr(-,root,root,-)
234%{_bindir}/avidemux2_cli
235
236%files gtk
237%defattr(-,root,root,-)
238%{_bindir}/avidemux2_gtk
239%{_datadir}/applications/*gtk*.desktop
240
241%if %{?with_qt_ui:1} %{!?with_qt_ui:0}
242%files qt
243%defattr(-,root,root,-)
244#{_datadir}/%{name}/i18n/
245%{_bindir}/avidemux2_qt4
246%{_datadir}/applications/*qt*.desktop
247%endif
248
249%files devel
250%defattr(-,root,root,-)
251%{_includedir}/ADM_coreConfig.h
252
253
254%changelog
255* Sat Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-3
256- unapply avidemux-2.4-qt4.patch
257
258* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-2
259- change release to sync with self-build-avidemux
260
261* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-1
262- new upstream release
263
264* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.4-1
265- new upstream release
266  - update patches accordingly
267  - build with x264 >= 0.0.0-9.20090522
268- dropped avidemux-2.4.3-ppc.patch, avidemux-x264.patch
269
270* Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 2.4.3-7
271- corrected release number
272
273* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-5
274- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
275- changed to PreReq:  self-build-libmad >= 0.15.1 from libmad-devel
276
277* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-4
278- change release to sync with self-build-avidemux
279
280* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-3
281- added avidemux-x264.patch from Gentoo
282
283* Mon Dec 08 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-2
284- applied avidemux-2.4.3-alsa-device-default.patch
285
286* Mon Nov 24 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-1
287- initial build based on RPM Fusion of Fedora package
288  - changed to BuildRequires: gettext from gettext-devel
289  - added BuildRequires: qt4-designer for gtk subpackage
290  - dropped avidemux-2.4.3-qt4.patch
291 
292* Thu Sep 18 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-5
293- Add CMake patch for PPC64
294- Update patches for 2.4.3
295- Remove outdated libmad patch (Nov. 2007)
296
297* Thu Sep 18 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-4
298- Add another patch to fix ppc64 build (pointer type), first
299  patch was for libmad
300
301* Fri Aug 22 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-3
302- Add patch to fix ppc64 build
303
304* Sat Aug 16 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-2
305- retag
306
307* Sat Aug 16 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-1
308- Update to 2.4.3
309
310* Tue Aug 12 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.2-3
311- ppc64 uint_32 fun
312
313* Sun Aug 03 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 2.4.2-2
314- rebuild
315
316* Sat Jul 19 2008 Thorsten Leemhuis <s.adam at diffingo.com> - 2.4.2-1
317- Update to 2.4.2
318
319* Wed May 21 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-3.20080521svn
320- Disable --new-faad
321- 20080521 subversion snapshot
322
323* Sat Mar 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-2
324- Disable %%{?_smp_mflags}
325
326* Sat Mar 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-1
327- Update to 2.4.1
328- Don't list the bin files twice, revisited
329- Default to GTK frontend
330
331* Wed Feb 20 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-6.20080126svn
332- Make pulseaudio default for sound out
333- Don't list the bin files twice
334- Don't build with arts support
335
336* Fri Feb 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-5.20080126svn
337- Don't list the .desktop files twice (bz#1870)
338- Oops, we should have %%{svndate}svn in release tag!
339
340* Sat Feb 2 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-4
341- F-8/F-7 x86_64 does seem to need --with-newfaad
342
343* Fri Feb 1 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-3
344- Update to version 2.4 (20080126svn) and include fixes from devel branch
345
346* Mon Jan 14 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-2
347- Fix many copy/paste errors and desktop file's Exec field
348
349* Sun Jan 13 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-1
350- Update to 2.4 final
351- Split up desktop files and make them pass desktop-file-validate
352- Add structure to split into gtk and qt pacakges
353- Disable qt4 for now, doesn't compile
354
355* Sun Oct 7 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>3- 2.3.0-4.3
356- move js-include to a place where it is honored
357
358* Sun Oct 7 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4.2
359- Fix macro problem
360- Fix changelog date
361- Rebuild with faad, but don't pass --newfaad
362
363* Sun Oct 7 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4.1
364- Rebuild with no faad
365
366* Sat Oct 6 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4
367- Rebuild for ffmpeg dependency problems
368- Update License: tag per Fedora guidelines
369
370* Sat Jan 13 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.3.0-3
371- more features with new BR's: x264-devel libXv-devel
372- make a note regarding the libdca-devel problem
373- remove the "0:" from the versioned BR's
374
375* Thu Jan 04 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.3.0-2
376- don't use smp_mflags during make for now
377
378* Sat Dec 23 2006 kwizart < kwizart at gmail.com > - 2.3.0-1
379- Update to 2.3.0 Final
380- Use find_lang
381
382* Mon Apr 03 2006 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.1.2-1
383- Update to 2.1.2
384
385* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
386- switch to new release field
387
388* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
389- add dist
390
391* Wed Jan 04 2006 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.1.0-0.lvn.1
392- Update to 2.1.0
393- Drop epoch
394- gtk 2.6 now, so drop FC3 support
395
396* Sat Aug 27 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.3
397- Remove bogus BR ffmpeg-devel (#555)
398
399* Thu Jul 09 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.2
400- Add missing BR desktop-file-utils (thanks to ixs)
401
402* Thu Jul 07 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.1
403- Update to 2.0.42
404
405* Sat Jan 22 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.36-0.lvn.1
406- Update to 2.0.34
407- Rename package to avidemux -- no need for avidemux2 afaics
408
409* Sun Nov 21 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.34-0.lvn.1.test1
410- Update to 2.0.34-test1
411- BR gettext, libtool
412
413* Tue Oct 18 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.30-0.lvn.1
414- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.