source: projects/specs/trunk/nonfree/self-build-avidemux/avidemux-vl.spec @ 615

Revision 615, 13.3 KB checked in by munepi, 14 years ago (diff)

added many self-build-* specs

Line 
1%define _pkgbuilddir %{_builddir}/%{name}_%{version}
2
3Name:           avidemux
4Version:        2.5.2
5Release:        2%{?_dist_release}
6Summary:        Graphical video editing and transcoding tool
7
8Group:          Applications/Multimedia
9License:        GPLv2+
10URL:            http://www.avidemux.org/
11Source0:        http://download.berlios.de/avidemux/avidemux_%{version}.tar.gz
12Source1:        %{name}-gtk.desktop
13Source2:        %{name}-qt.desktop
14# Patch0 obtained from avidemux-2.5.0-patches-1.tar.bz2:
15# http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/distfiles/avidemux-2.5.0-patches-1.tar.bz2
16Patch0:         2.5.0-coreImage-parallel-build.patch
17Patch1:         avidemux-2.5-pulseaudio-default.patch
18Patch2:         avidemux-2.4-qt4.patch
19Patch3:         avidemux-2.5-i18n.patch
20Patch4:         avidemux-2.5-libmpeg2enc-altivec.patch
21Patch5:         avidemux-2.5-checkfunction-includes.patch
22Patch6:         avidemux-2.5.1-tmplinktarget.patch
23
24## Vine customization patches
25Patch10:         avidemux-2.4.3-alsa-device-default.patch
26Patch11:         avidemux-2.5.2-no-qt4-ui.patch
27
28BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
29
30Requires:       %{name}-cli  = %{version}
31Requires:       %{name}-gui = %{version}
32Obsoletes:      %{name}-qt < 2.5.0
33
34# *-devel pacages provided by other self-build-* should only be listed
35# in self-build-%{name}.spec as PreReq.
36
37# Compiling
38BuildRequires:  cmake
39#BuildRequires:  gettext-devel
40BuildRequires:  gettext
41
42# Libraries
43BuildRequires:  nasm >= 0.98.38
44BuildRequires:  libxml2-devel >= 2.6.8
45BuildRequires:  fontconfig-devel
46#BuildRequires:  freetype-devel
47BuildRequires:  freetype2-devel
48BuildRequires:  js-devel
49BuildRequires:  libXv-devel
50BuildRequires:  libXmu-devel
51# Required by gtk: libXi-devel, libXext-devel, libX11-devel
52# Required by qt: libXt-devel, libXext-devel, libX11-devel
53BuildRequires:  libsamplerate-devel
54BuildRequires:  jack-audio-connection-kit-devel
55
56# Sound out
57BuildRequires:  alsa-lib-devel >= 1.0.3
58BuildRequires:  esound-devel >= 0.2.0
59BuildRequires:  pulseaudio-libs-devel
60
61# Video out
62BuildRequires:  SDL-devel >= 1.2.7
63
64# Audio Codecs
65#BuildRequires:  a52dec-devel >= 0.7.4
66#BuildRequires:  faac-devel >= 1.24
67#BuildRequires:  faad2-devel >= 2.0
68#BuildRequires:  lame-devel >= 3.96.1
69#BuildRequires:  libmad-devel >= 0.15.1
70BuildRequires:  libogg-devel >= 1.1
71BuildRequires:  libvorbis-devel >= 1.0.1
72# BuildRequires:  self-build-a52dec >= 0.7.4
73# BuildRequires:  self-build-faac >= 1.24
74# BuildRequires:  self-build-faad2 >= 2.0
75# BuildRequires:  self-build-lame >= 3.96.1
76# BuildRequires:  self-build-libmad >= 0.15.1
77#BuildRequires:  libdca-devel
78# BuildRequires:  self-build-libdca
79
80# Video Codecs
81#BuildRequires:  xvidcore-devel >= 1.0.2
82#BuildRequires:  x264-devel
83#BuildRequires:  ffmpeg-devel
84# BuildRequires:  self-build-xvidcore >= 1.0.2
85# BuildRequires:  self-build-x264
86# BuildRequires:  self-build-ffmpeg
87
88# FIXME: aften not packaged, add BR when it is
89
90# Finally...
91BuildRequires:  desktop-file-utils
92
93%description
94Avidemux is a free video editor designed for simple cutting, filtering and
95encoding tasks. It supports many file types, including AVI, DVD compatible
96MPEG files, MP4 and ASF, using a variety of codecs. Tasks can be automated
97using projects, job queue and powerful scripting capabilities.
98
99For compatability reasons, avidemux is a meta-package which installs the
100graphical, command line and plugin packages. If you want a smaller setup,
101you may selectively install one or more of the avidemux-* subpackages.
102
103%package cli
104Summary:        CLI for %{name}
105Group:          Applications/Multimedia
106Requires:       %{name} = %{version}-%{release}
107
108%description cli
109This package provides a command-line interface to editing videos with %{name}.
110
111%package gtk
112Summary:        GTK interface for %{name}
113Group:          Applications/Multimedia
114BuildRequires:  gtk2-devel >= 2.8.0
115BuildRequires:  cairo-devel
116# Slightly higher so it is default, but it can be avoided by installing
117# avidemux-qt directly or it can be removed later once avidemux-qt is installed
118Provides:       %{name}-gui = %{version}-%{release}.1
119Requires:       %{name} = %{version}-%{release}
120
121%description gtk
122This package provides the GTK graphical interface for %{name}.
123
124%if %{?with_qt_ui:1} %{!?with_qt_ui:0}
125%package qt
126Summary:        Qt interface for %{name}
127Group:          Applications/Multimedia
128# 4.5.0-9 fixes a failure when there are duplicate translated strings
129# https://bugzilla.redhat.com/show_bug.cgi?id=491514
130BuildRequires:  qt4-devel >= 4.5.0-9
131BuildRequires:  qt4-designer
132Provides:       %{name}-gui = %{version}-%{release}
133Requires:       %{name} = %{version}-%{release}
134
135%description qt
136This package contains the Qt graphical interface for %{name}.
137%endif
138
139%package devel
140Summary:        Development files for %{name}
141Group:          Development/Libraries
142Requires:       %{name} = %{version}-%{release}
143
144%description devel
145This package contains files required to develop with or extend %{name}.
146
147%prep
148%__rm -rf $RPM_BUILD_ROOT
149
150%setup -q -n avidemux_%{version}
151
152# change hardcoded libdir paths
153%ifarch x86_64 ppc64
154sed -i.bak 's/startDir="lib";/startDir="lib64";/' avidemux/ADM_core/src/ADM_fileio.cpp
155sed -i.bak 's/startDir="lib";/startDir="lib64";/' avidemux/main.cpp
156%endif
157
158%patch0 -p1 -b .parallel
159%patch1 -p1 -b .pulse
160%patch2 -p1 -b .qt4
161%patch3 -p1 -b .i18n
162%patch4 -p1 -b .altivec
163%patch5 -p1 -b .cfincludes
164#%patch6 -p1 -b .tmplinktarget
165
166#%patch10 -p1 -b .alsa
167%{!?with_qt_ui:%patch11 -p1 -b .qt4}
168
169%build
170# Out of source build
171%__mkdir_p build && cd build
172%cmake -DAVIDEMUX_INSTALL_PREFIX=%{_prefix} \
173       -DAVIDEMUX_SOURCE_DIR="%{_pkgbuilddir}" \
174       -DAVIDEMUX_CORECONFIG_DIR="%{_pkgbuilddir}/build/config" \
175       ..
176%__make %{?_smp_mflags}
177# Create the temp link directory manuall since otherwise it happens too early
178%__mkdir_p %{_pkgbuilddir}/build/%{_lib}
179find %{_pkgbuilddir}/build/avidemux -name '*.so*' | \
180     xargs ln -sft %{_pkgbuilddir}/build/%{_lib}
181
182%__mkdir_p ../build_plugins && cd ../build_plugins
183%cmake -DAVIDEMUX_INSTALL_PREFIX="%{_pkgbuilddir}/build/" \
184       -DAVIDEMUX_SOURCE_DIR="%{_pkgbuilddir}" \
185       -DAVIDEMUX_CORECONFIG_DIR="%{_pkgbuilddir}/build/config" \
186       ../plugins
187%__make %{?_smp_mflags}
188
189
190%install
191rm -rf $RPM_BUILD_ROOT
192# Temporary workaround since the i18n files aren't being built
193mkdir -p $RPM_BUILD_ROOT/%{_datadir}/%{name}
194
195make -C build install DESTDIR=$RPM_BUILD_ROOT
196make -C build_plugins install DESTDIR=$RPM_BUILD_ROOT
197# Install the build configuration for devel package
198install -d -m755 $RPM_BUILD_ROOT%{_includedir}
199install -m644 build/config/ADM_coreConfig.h $RPM_BUILD_ROOT%{_includedir}/ADM_coreConfig.h
200
201# Find and remove all la files
202find $RPM_BUILD_ROOT -type f -name "*.la" -exec %__rm -f {} ';'
203
204# Install .desktop shortcuts
205desktop-file-install --vendor vine \
206    --dir $RPM_BUILD_ROOT%{_datadir}/applications \
207    %{SOURCE1}
208
209desktop-file-install --vendor vine \
210    --dir $RPM_BUILD_ROOT%{_datadir}/applications \
211    %{SOURCE2}
212
213find $RPM_BUILD_ROOT -type f -name "*.la" -exec %__rm -f {} ';'
214%find_lang %{name}
215
216%clean
217%__rm -rf $RPM_BUILD_ROOT
218
219%post -p /sbin/ldconfig
220%postun -p /sbin/ldconfig
221
222%files -f %{name}.lang
223%defattr(-,root,root,-)
224%doc AUTHORS COPYING ChangeLog History README TODO
225%{_datadir}/%{name}/
226%{_datadir}/ADM_scripts/
227%{_libdir}/libADM*
228%{_libdir}/ADM_plugins/
229
230%files cli
231%defattr(-,root,root,-)
232%{_bindir}/avidemux2_cli
233
234%files gtk
235%defattr(-,root,root,-)
236%{_bindir}/avidemux2_gtk
237%{_datadir}/applications/*gtk*.desktop
238
239%if %{?with_qt_ui:1} %{!?with_qt_ui:0}
240%files qt
241%defattr(-,root,root,-)
242#{_datadir}/%{name}/i18n/
243%{_bindir}/avidemux2_qt4
244%{_datadir}/applications/*qt*.desktop
245%endif
246
247%files devel
248%defattr(-,root,root,-)
249%{_includedir}/ADM_coreConfig.h
250
251
252%changelog
253* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-2
254- change release to sync with self-build-avidemux
255
256* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-1
257- new upstream release
258
259* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.4-1
260- new upstream release
261  - update patches accordingly
262  - build with x264 >= 0.0.0-9.20090522
263- dropped avidemux-2.4.3-ppc.patch, avidemux-x264.patch
264
265* Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 2.4.3-7
266- corrected release number
267
268* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-5
269- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
270- changed to PreReq:  self-build-libmad >= 0.15.1 from libmad-devel
271
272* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-4
273- change release to sync with self-build-avidemux
274
275* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-3
276- added avidemux-x264.patch from Gentoo
277
278* Mon Dec 08 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-2
279- applied avidemux-2.4.3-alsa-device-default.patch
280
281* Mon Nov 24 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-1
282- initial build based on RPM Fusion of Fedora package
283  - changed to BuildRequires: gettext from gettext-devel
284  - added BuildRequires: qt4-designer for gtk subpackage
285  - dropped avidemux-2.4.3-qt4.patch
286 
287* Thu Sep 18 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-5
288- Add CMake patch for PPC64
289- Update patches for 2.4.3
290- Remove outdated libmad patch (Nov. 2007)
291
292* Thu Sep 18 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-4
293- Add another patch to fix ppc64 build (pointer type), first
294  patch was for libmad
295
296* Fri Aug 22 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-3
297- Add patch to fix ppc64 build
298
299* Sat Aug 16 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-2
300- retag
301
302* Sat Aug 16 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-1
303- Update to 2.4.3
304
305* Tue Aug 12 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.2-3
306- ppc64 uint_32 fun
307
308* Sun Aug 03 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 2.4.2-2
309- rebuild
310
311* Sat Jul 19 2008 Thorsten Leemhuis <s.adam at diffingo.com> - 2.4.2-1
312- Update to 2.4.2
313
314* Wed May 21 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-3.20080521svn
315- Disable --new-faad
316- 20080521 subversion snapshot
317
318* Sat Mar 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-2
319- Disable %%{?_smp_mflags}
320
321* Sat Mar 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-1
322- Update to 2.4.1
323- Don't list the bin files twice, revisited
324- Default to GTK frontend
325
326* Wed Feb 20 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-6.20080126svn
327- Make pulseaudio default for sound out
328- Don't list the bin files twice
329- Don't build with arts support
330
331* Fri Feb 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-5.20080126svn
332- Don't list the .desktop files twice (bz#1870)
333- Oops, we should have %%{svndate}svn in release tag!
334
335* Sat Feb 2 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-4
336- F-8/F-7 x86_64 does seem to need --with-newfaad
337
338* Fri Feb 1 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-3
339- Update to version 2.4 (20080126svn) and include fixes from devel branch
340
341* Mon Jan 14 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-2
342- Fix many copy/paste errors and desktop file's Exec field
343
344* Sun Jan 13 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-1
345- Update to 2.4 final
346- Split up desktop files and make them pass desktop-file-validate
347- Add structure to split into gtk and qt pacakges
348- Disable qt4 for now, doesn't compile
349
350* Sun Oct 7 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>3- 2.3.0-4.3
351- move js-include to a place where it is honored
352
353* Sun Oct 7 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4.2
354- Fix macro problem
355- Fix changelog date
356- Rebuild with faad, but don't pass --newfaad
357
358* Sun Oct 7 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4.1
359- Rebuild with no faad
360
361* Sat Oct 6 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4
362- Rebuild for ffmpeg dependency problems
363- Update License: tag per Fedora guidelines
364
365* Sat Jan 13 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.3.0-3
366- more features with new BR's: x264-devel libXv-devel
367- make a note regarding the libdca-devel problem
368- remove the "0:" from the versioned BR's
369
370* Thu Jan 04 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.3.0-2
371- don't use smp_mflags during make for now
372
373* Sat Dec 23 2006 kwizart < kwizart at gmail.com > - 2.3.0-1
374- Update to 2.3.0 Final
375- Use find_lang
376
377* Mon Apr 03 2006 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.1.2-1
378- Update to 2.1.2
379
380* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
381- switch to new release field
382
383* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
384- add dist
385
386* Wed Jan 04 2006 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.1.0-0.lvn.1
387- Update to 2.1.0
388- Drop epoch
389- gtk 2.6 now, so drop FC3 support
390
391* Sat Aug 27 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.3
392- Remove bogus BR ffmpeg-devel (#555)
393
394* Thu Jul 09 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.2
395- Add missing BR desktop-file-utils (thanks to ixs)
396
397* Thu Jul 07 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.1
398- Update to 2.0.42
399
400* Sat Jan 22 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.36-0.lvn.1
401- Update to 2.0.34
402- Rename package to avidemux -- no need for avidemux2 afaics
403
404* Sun Nov 21 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.34-0.lvn.1.test1
405- Update to 2.0.34-test1
406- BR gettext, libtool
407
408* Tue Oct 18 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.30-0.lvn.1
409- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.