source: projects/specs/trunk/nonfree/self-build-avidemux/avidemux-vl.spec @ 3882

Revision 3882, 13.6 KB checked in by Takemikaduchi, 13 years ago (diff)

add Patch7(SOURCE107)

Line 
1%define _pkgbuilddir %{_builddir}/%{name}_%{version}
2
3Name:           avidemux
4Version:        2.5.2
5Release:        4%{?_dist_release}
6Summary:        Graphical video editing and transcoding tool
7
8Group:          Applications/Multimedia
9License:        GPLv2+
10URL:            http://www.avidemux.org/
11Source0:        http://download.berlios.de/avidemux/avidemux_%{version}.tar.gz
12Source1:        %{name}-gtk.desktop
13Source2:        %{name}-qt.desktop
14# Patch0 obtained from avidemux-2.5.0-patches-1.tar.bz2:
15# http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/distfiles/avidemux-2.5.0-patches-1.tar.bz2
16Patch0:         2.5.0-coreImage-parallel-build.patch
17Patch1:         avidemux-2.5-pulseaudio-default.patch
18Patch2:         avidemux-2.4-qt4.patch
19Patch3:         avidemux-2.5-i18n.patch
20Patch4:         avidemux-2.5-libmpeg2enc-altivec.patch
21Patch5:         avidemux-2.5-checkfunction-includes.patch
22Patch6:         avidemux-2.5.1-tmplinktarget.patch
23Patch7:         avidemux-2.5.4-x264-X264_WEIGHTP_BLIND-fix.patch
24
25## Vine customization patches
26Patch10:         avidemux-2.4.3-alsa-device-default.patch
27Patch11:         avidemux-2.5.2-no-qt4-ui.patch
28
29BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
30
31Requires:       %{name}-cli  = %{version}
32Requires:       %{name}-gui = %{version}
33Obsoletes:      %{name}-qt < 2.5.0
34
35# *-devel pacages provided by other self-build-* should only be listed
36# in self-build-%{name}.spec as PreReq.
37
38# Compiling
39BuildRequires:  cmake
40#BuildRequires:  gettext-devel
41BuildRequires:  gettext
42
43# Libraries
44BuildRequires:  nasm >= 0.98.38
45BuildRequires:  libxml2-devel >= 2.6.8
46BuildRequires:  fontconfig-devel
47#BuildRequires:  freetype-devel
48BuildRequires:  freetype2-devel
49BuildRequires:  js-devel
50BuildRequires:  libXv-devel
51BuildRequires:  libXmu-devel
52# Required by gtk: libXi-devel, libXext-devel, libX11-devel
53# Required by qt: libXt-devel, libXext-devel, libX11-devel
54BuildRequires:  libsamplerate-devel
55BuildRequires:  jack-audio-connection-kit-devel
56
57# Sound out
58BuildRequires:  alsa-lib-devel >= 1.0.3
59BuildRequires:  esound-devel >= 0.2.0
60BuildRequires:  pulseaudio-libs-devel
61
62# Video out
63BuildRequires:  SDL-devel >= 1.2.7
64
65# Audio Codecs
66#BuildRequires:  a52dec-devel >= 0.7.4
67#BuildRequires:  faac-devel >= 1.24
68#BuildRequires:  faad2-devel >= 2.0
69#BuildRequires:  lame-devel >= 3.96.1
70#BuildRequires:  libmad-devel >= 0.15.1
71BuildRequires:  libogg-devel >= 1.1
72BuildRequires:  libvorbis-devel >= 1.0.1
73# BuildRequires:  self-build-a52dec >= 0.7.4
74# BuildRequires:  self-build-faac >= 1.24
75# BuildRequires:  self-build-faad2 >= 2.0
76# BuildRequires:  self-build-lame >= 3.96.1
77# BuildRequires:  self-build-libmad >= 0.15.1
78#BuildRequires:  libdca-devel
79# BuildRequires:  self-build-libdca
80
81# Video Codecs
82#BuildRequires:  xvidcore-devel >= 1.0.2
83#BuildRequires:  x264-devel
84#BuildRequires:  ffmpeg-devel
85# BuildRequires:  self-build-xvidcore >= 1.0.2
86# BuildRequires:  self-build-x264
87# BuildRequires:  self-build-ffmpeg
88
89# FIXME: aften not packaged, add BR when it is
90
91# Finally...
92BuildRequires:  desktop-file-utils
93
94%description
95Avidemux is a free video editor designed for simple cutting, filtering and
96encoding tasks. It supports many file types, including AVI, DVD compatible
97MPEG files, MP4 and ASF, using a variety of codecs. Tasks can be automated
98using projects, job queue and powerful scripting capabilities.
99
100For compatability reasons, avidemux is a meta-package which installs the
101graphical, command line and plugin packages. If you want a smaller setup,
102you may selectively install one or more of the avidemux-* subpackages.
103
104%package cli
105Summary:        CLI for %{name}
106Group:          Applications/Multimedia
107Requires:       %{name} = %{version}-%{release}
108
109%description cli
110This package provides a command-line interface to editing videos with %{name}.
111
112%package gtk
113Summary:        GTK interface for %{name}
114Group:          Applications/Multimedia
115BuildRequires:  gtk2-devel >= 2.8.0
116BuildRequires:  cairo-devel
117# Slightly higher so it is default, but it can be avoided by installing
118# avidemux-qt directly or it can be removed later once avidemux-qt is installed
119Provides:       %{name}-gui = %{version}-%{release}.1
120Requires:       %{name} = %{version}-%{release}
121
122%description gtk
123This package provides the GTK graphical interface for %{name}.
124
125%if %{?with_qt_ui:1} %{!?with_qt_ui:0}
126%package qt
127Summary:        Qt interface for %{name}
128Group:          Applications/Multimedia
129# 4.5.0-9 fixes a failure when there are duplicate translated strings
130# https://bugzilla.redhat.com/show_bug.cgi?id=491514
131BuildRequires:  qt4-devel >= 4.5.0-9
132BuildRequires:  qt4-designer
133Provides:       %{name}-gui = %{version}-%{release}
134Requires:       %{name} = %{version}-%{release}
135
136%description qt
137This package contains the Qt graphical interface for %{name}.
138%endif
139
140%package devel
141Summary:        Development files for %{name}
142Group:          Development/Libraries
143Requires:       %{name} = %{version}-%{release}
144
145%description devel
146This package contains files required to develop with or extend %{name}.
147
148%prep
149%__rm -rf $RPM_BUILD_ROOT
150
151%setup -q -n avidemux_%{version}
152
153# change hardcoded libdir paths
154%ifarch x86_64 ppc64
155%__sed -i.bak 's/startDir="lib";/startDir="lib64";/' avidemux/ADM_core/src/ADM_fileio.cpp
156%__sed -i.bak 's/startDir="lib";/startDir="lib64";/' avidemux/main.cpp
157%endif
158
159%patch0 -p1 -b .parallel
160%patch1 -p1 -b .pulse
161#%patch2 -p1 -b .qt4
162%patch3 -p1 -b .i18n
163%patch4 -p1 -b .altivec
164%patch5 -p1 -b .cfincludes
165#%patch6 -p1 -b .tmplinktarget
166%patch7 -p1 -b .blind
167
168#%patch10 -p1 -b .alsa
169%{!?with_qt_ui:%patch11 -p1 -b .qt4}
170
171%build
172# Out of source build
173%__mkdir_p build && cd build
174%cmake -DAVIDEMUX_INSTALL_PREFIX=%{_prefix} \
175       -DAVIDEMUX_SOURCE_DIR="%{_pkgbuilddir}" \
176       -DAVIDEMUX_CORECONFIG_DIR="%{_pkgbuilddir}/build/config" \
177       ..
178%__make %{?_smp_mflags}
179# Create the temp link directory manuall since otherwise it happens too early
180%__mkdir_p %{_pkgbuilddir}/build/%{_lib}
181find %{_pkgbuilddir}/build/avidemux -name '*.so*' | \
182     xargs ln -sft %{_pkgbuilddir}/build/%{_lib}
183
184%__mkdir_p ../build_plugins && cd ../build_plugins
185%cmake -DAVIDEMUX_INSTALL_PREFIX="%{_pkgbuilddir}/build/" \
186       -DAVIDEMUX_SOURCE_DIR="%{_pkgbuilddir}" \
187       -DAVIDEMUX_CORECONFIG_DIR="%{_pkgbuilddir}/build/config" \
188       ../plugins
189%__make %{?_smp_mflags}
190
191
192%install
193%__rm -rf $RPM_BUILD_ROOT
194# Temporary workaround since the i18n files aren't being built
195%__mkdir_p $RPM_BUILD_ROOT/%{_datadir}/%{name}
196
197%__make -C build install DESTDIR=$RPM_BUILD_ROOT
198%__make -C build_plugins install DESTDIR=$RPM_BUILD_ROOT
199# Install the build configuration for devel package
200%__install -d -m755 $RPM_BUILD_ROOT%{_includedir}
201%__install -m644 build/config/ADM_coreConfig.h $RPM_BUILD_ROOT%{_includedir}/ADM_coreConfig.h
202
203# Find and remove all la files
204find $RPM_BUILD_ROOT -type f -name "*.la" -exec %__rm -f {} ';'
205
206# Install .desktop shortcuts
207desktop-file-install --vendor vine \
208    --dir $RPM_BUILD_ROOT%{_datadir}/applications \
209    %{SOURCE1}
210
211%if %{?with_qt_ui:1} %{!?with_qt_ui:0}
212desktop-file-install --vendor vine \
213    --dir $RPM_BUILD_ROOT%{_datadir}/applications \
214    %{SOURCE2}
215%endif
216
217find $RPM_BUILD_ROOT -type f -name "*.la" -exec %__rm -f {} ';'
218%find_lang %{name}
219
220%clean
221%__rm -rf $RPM_BUILD_ROOT
222
223%post -p /sbin/ldconfig
224%postun -p /sbin/ldconfig
225
226%files -f %{name}.lang
227%defattr(-,root,root,-)
228%doc AUTHORS COPYING README TODO
229%{_datadir}/%{name}/
230%{_datadir}/ADM_scripts/
231%{_libdir}/libADM*
232%{_libdir}/ADM_plugins/
233
234%files cli
235%defattr(-,root,root,-)
236%{_bindir}/avidemux2_cli
237
238%files gtk
239%defattr(-,root,root,-)
240%{_bindir}/avidemux2_gtk
241%{_datadir}/applications/*gtk*.desktop
242
243%if %{?with_qt_ui:1} %{!?with_qt_ui:0}
244%files qt
245%defattr(-,root,root,-)
246#{_datadir}/%{name}/i18n/
247%{_bindir}/avidemux2_qt4
248%{_datadir}/applications/*qt*.desktop
249%endif
250
251%files devel
252%defattr(-,root,root,-)
253%{_includedir}/ADM_coreConfig.h
254
255
256%changelog
257* Sun May 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.2-4
258- add Patch7 (avidemux-2.5.4-x264-X264_WEIGHTP_BLIND-fix.patch)
259
260* Sat Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-3
261- unapply avidemux-2.4-qt4.patch
262
263* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-2
264- change release to sync with self-build-avidemux
265
266* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-1
267- new upstream release
268
269* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.4-1
270- new upstream release
271  - update patches accordingly
272  - build with x264 >= 0.0.0-9.20090522
273- dropped avidemux-2.4.3-ppc.patch, avidemux-x264.patch
274
275* Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 2.4.3-7
276- corrected release number
277
278* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-5
279- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
280- changed to PreReq:  self-build-libmad >= 0.15.1 from libmad-devel
281
282* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-4
283- change release to sync with self-build-avidemux
284
285* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-3
286- added avidemux-x264.patch from Gentoo
287
288* Mon Dec 08 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-2
289- applied avidemux-2.4.3-alsa-device-default.patch
290
291* Mon Nov 24 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-1
292- initial build based on RPM Fusion of Fedora package
293  - changed to BuildRequires: gettext from gettext-devel
294  - added BuildRequires: qt4-designer for gtk subpackage
295  - dropped avidemux-2.4.3-qt4.patch
296 
297* Thu Sep 18 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-5
298- Add CMake patch for PPC64
299- Update patches for 2.4.3
300- Remove outdated libmad patch (Nov. 2007)
301
302* Thu Sep 18 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-4
303- Add another patch to fix ppc64 build (pointer type), first
304  patch was for libmad
305
306* Fri Aug 22 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-3
307- Add patch to fix ppc64 build
308
309* Sat Aug 16 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-2
310- retag
311
312* Sat Aug 16 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-1
313- Update to 2.4.3
314
315* Tue Aug 12 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.2-3
316- ppc64 uint_32 fun
317
318* Sun Aug 03 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 2.4.2-2
319- rebuild
320
321* Sat Jul 19 2008 Thorsten Leemhuis <s.adam at diffingo.com> - 2.4.2-1
322- Update to 2.4.2
323
324* Wed May 21 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-3.20080521svn
325- Disable --new-faad
326- 20080521 subversion snapshot
327
328* Sat Mar 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-2
329- Disable %%{?_smp_mflags}
330
331* Sat Mar 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-1
332- Update to 2.4.1
333- Don't list the bin files twice, revisited
334- Default to GTK frontend
335
336* Wed Feb 20 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-6.20080126svn
337- Make pulseaudio default for sound out
338- Don't list the bin files twice
339- Don't build with arts support
340
341* Fri Feb 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-5.20080126svn
342- Don't list the .desktop files twice (bz#1870)
343- Oops, we should have %%{svndate}svn in release tag!
344
345* Sat Feb 2 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-4
346- F-8/F-7 x86_64 does seem to need --with-newfaad
347
348* Fri Feb 1 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-3
349- Update to version 2.4 (20080126svn) and include fixes from devel branch
350
351* Mon Jan 14 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-2
352- Fix many copy/paste errors and desktop file's Exec field
353
354* Sun Jan 13 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-1
355- Update to 2.4 final
356- Split up desktop files and make them pass desktop-file-validate
357- Add structure to split into gtk and qt pacakges
358- Disable qt4 for now, doesn't compile
359
360* Sun Oct 7 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>3- 2.3.0-4.3
361- move js-include to a place where it is honored
362
363* Sun Oct 7 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4.2
364- Fix macro problem
365- Fix changelog date
366- Rebuild with faad, but don't pass --newfaad
367
368* Sun Oct 7 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4.1
369- Rebuild with no faad
370
371* Sat Oct 6 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4
372- Rebuild for ffmpeg dependency problems
373- Update License: tag per Fedora guidelines
374
375* Sat Jan 13 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.3.0-3
376- more features with new BR's: x264-devel libXv-devel
377- make a note regarding the libdca-devel problem
378- remove the "0:" from the versioned BR's
379
380* Thu Jan 04 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.3.0-2
381- don't use smp_mflags during make for now
382
383* Sat Dec 23 2006 kwizart < kwizart at gmail.com > - 2.3.0-1
384- Update to 2.3.0 Final
385- Use find_lang
386
387* Mon Apr 03 2006 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.1.2-1
388- Update to 2.1.2
389
390* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
391- switch to new release field
392
393* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
394- add dist
395
396* Wed Jan 04 2006 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.1.0-0.lvn.1
397- Update to 2.1.0
398- Drop epoch
399- gtk 2.6 now, so drop FC3 support
400
401* Sat Aug 27 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.3
402- Remove bogus BR ffmpeg-devel (#555)
403
404* Thu Jul 09 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.2
405- Add missing BR desktop-file-utils (thanks to ixs)
406
407* Thu Jul 07 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.1
408- Update to 2.0.42
409
410* Sat Jan 22 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.36-0.lvn.1
411- Update to 2.0.34
412- Rename package to avidemux -- no need for avidemux2 afaics
413
414* Sun Nov 21 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.34-0.lvn.1.test1
415- Update to 2.0.34-test1
416- BR gettext, libtool
417
418* Tue Oct 18 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.30-0.lvn.1
419- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.