source: projects/specs/trunk/n/nspluginwrapper/nspluginwrapper-vl.spec @ 2286

Revision 2286, 17.7 KB checked in by munepi, 13 years ago (diff)

updated nspluginwrapper-vl.spec

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3# Compile as a debug package
4%define make_debug_package      0
5
6# What gecko we use
7%define gecko_flavour           "mozilla"
8
9%define plugin_config_version 1.9
10%define plugin_config_name plugin-config-%{plugin_config_version}
11%define plugin_config_binary plugin-config
12
13# Excluded plugins (separated by ':')
14%define exclude_list            "libtotem*:libjavaplugin*:gecko-mediaplayer*:mplayerplug-in*:librhythmbox*:packagekit*"
15
16# Target defines
17%if "%{_target_cpu}" == "i386"
18%define target_bits     32
19%endif
20
21%if "%{_target_cpu}" == "i586"
22%define target_bits     32
23%endif
24
25%if "%{_target_cpu}" == "i686"
26%define target_bits     32
27%endif
28
29%if "%{_target_cpu}" == "ppc"
30%define target_bits     32
31%endif
32
33%if "%{_target_cpu}" == "x86_64"
34%define target_bits     64
35%endif
36
37%if "%{_target_cpu}" == "ppc64"
38%define target_bits     64
39%endif
40
41# Define libraries for 32/64 arches
42%define lib32                   lib
43%define lib64                   lib64
44%define libdir32                /usr/lib
45%define libdir64                /usr/lib64
46
47# define nspluginswrapper libdir (invariant, including libdir)
48%define pkgdir32                %{libdir32}/%{name}
49%define pkgdir64                %{libdir64}/%{name}
50
51# define mozilla plugin dir and back up dir for 32-bit browsers
52%define pluginsourcedir32       %{libdir32}/mozilla/plugins
53%define plugindir32             %{libdir32}/mozilla/plugins-wrapped
54
55# define mozilla plugin dir and back up dir for 64-bit browsers
56%define pluginsourcedir64       %{libdir64}/mozilla/plugins
57%define plugindir64             %{libdir64}/mozilla/plugins-wrapped
58
59%define build_dir               objs-%{target_bits}
60
61%if "%{target_bits}" == "32"
62%define lib             %{lib32}
63%define libdir          %{libdir32}
64%define pkgdir          %{pkgdir32}
65%define plugindir       %{plugindir32}
66%define pluginsourcedir %{pluginsourcedir32}
67%else
68%define lib             %{lib64}
69%define libdir          %{libdir64}
70%define pkgdir          %{pkgdir64}
71%define plugindir       %{plugindir64}
72%define pluginsourcedir %{pluginsourcedir64}
73%endif
74
75Summary:        A compatibility layer for Netscape 4 plugins
76Name:           nspluginwrapper
77Version:        1.3.0
78Release:        3%{?_dist_release}
79Source0:        %{name}-%{version}%{?svndate:-%{svndate}}.tar.bz2
80Source1:        %{plugin_config_name}.tar.gz
81Source2:        plugin-config.sh.in
82Source3:        %{name}.sh.in
83Patch1:         nspluginwrapper-1.3.0-make.patch
84Patch2:         nspluginwrapper-1.3.0-configure.patch
85Patch3:         nspluginwrapper-1.3.0-directory.patch
86Patch4:         nspluginwrapper-20090625-fix-npident-array-sending.patch
87Patch5:         nspluginwrapper-1.3.0-inst.patch
88Patch6:         nspluginwrapper-1.3.0-compiz.patch
89Patch7:         nspluginwrapper-1.3.0-comp.patch
90Patch8:         nspluginwrapper-1.3.0-silent.patch
91Patch9:         nspluginwrapper-1.3.0-timeout.patch
92Patch100:       plugin-config-setuid.patch
93Patch101:       plugin-config-umask.patch
94Patch102:       plugin-config-print.patch
95Patch103:       plugin-config-native.patch
96Patch104:       plugin-config-time-check.patch
97
98License:        GPLv2+
99Group:          Applications/Internet
100URL:            http://gwenole.beauchesne.info/projects/nspluginwrapper/
101
102BuildRoot:      %{_tmppath}/%{name}-%{version}-root
103Provides:       %{name} = %{version}-%{release}
104#Requires:      mozilla-filesystem
105%ifarch x86_64
106Requires:       compat32-%{name} = %{version}-%{release}
107%endif
108BuildRequires:  pkgconfig gtk2-devel glib2-devel nspr-devel
109BuildRequires:  libX11-devel libXt-devel cairo-devel pango-devel curl-devel
110BuildRequires:  gecko-devel
111ExclusiveArch:  %{ix86} x86_64 ppc
112
113%description
114nspluginwrapper makes it possible to use Netscape 4 compatible plugins
115compiled for %{_arch} into Mozilla for another architecture, e.g. x86_64.
116
117This package consists in:
118  * npviewer: the plugin viewer
119  * npwrapper.so: the browser-side plugin
120  * nspluginplayer: stand-alone NPAPI plugin player
121  * mozilla-plugin-config: a tool to manage plugins installation and update
122
123## to build compat32 for x86_64 architecture support
124%package -n compat32-%{name}
125Summary:        A compatibility layer for Netscape 4 plugins
126Group: System Environment/Libraries
127
128%description -n compat32-%{name}
129nspluginwrapper makes it possible to use Netscape 4 compatible plugins
130compiled for %{_arch} into Mozilla for another architecture, e.g. x86_64.
131
132This package consists in:
133  * npviewer: the plugin viewer
134  * npwrapper.so: the browser-side plugin
135  * nspluginplayer: stand-alone NPAPI plugin player
136  * mozilla-plugin-config: a tool to manage plugins installation and update
137
138
139%prep
140%setup  -q -a 1
141
142# Installation & build patches
143%patch1 -p1 -b .make
144%patch2 -p1 -b .conf
145%patch3 -p1 -b .dir
146%patch4 -p0 -b .array
147%patch5 -p1 -b .inst
148%patch6 -p1 -b .compiz
149%patch7 -p1 -b .comp
150%patch8 -p1 -b .silent
151%patch9 -p1 -b .timeout
152
153# Plugin-config patches
154pushd %plugin_config_name
155%patch100 -p2
156%patch101 -p2 -b .umask
157%patch102 -p2 -b .print
158%patch103 -p2 -b .native
159%patch104 -p2 -b .time
160popd
161
162%build
163# Build wrapper
164
165# set the propper built options
166%if %{make_debug_package}
167    %if "%{target_bits}" == "64"
168        export CFLAGS="-g -m64 -DDEBUG"
169    %else
170        export CFLAGS="-g -m32 -DDEBUG"
171    %endif
172%else
173    export CFLAGS="$RPM_OPT_FLAGS"
174%endif
175
176# set the propper built options
177%if "%{target_bits}" == "64"
178    export LDFLAGS="-m64 -L%{libdir64}"
179%else
180    export LDFLAGS="-m32 -L%{libdir32}"
181%endif
182
183mkdir %{build_dir}
184pushd %{build_dir}
185../configure                                    \
186            --prefix=%{_prefix}                 \
187            --target-cpu=%{_target_cpu}         \
188            --pkgdir=%{name}                    \
189            --pkglibdir=%{pkgdir}               \
190            --with-lib32=%{lib32}               \
191            --with-lib64=%{lib64}               \
192            --with-base-lib=%{lib}              \
193            --with-base-libdir=%{libdir}        \
194            --viewer-paths=%{pkgdir}            \
195            --with-x11-prefix=/usr              \
196            --with-gecko=%{gecko_flavour}       \
197            --enable-viewer                     \
198            --viewer-paths="%{pkgdir32}:%{pkgdir64}"\
199            --disable-biarch
200       
201%__make
202popd
203
204#Build plugin configuration utility
205pushd %{plugin_config_name}
206./configure --prefix=%{_prefix} CFLAGS="$RPM_OPT_FLAGS"
207%__make
208popd
209
210%install
211%__rm -rf $RPM_BUILD_ROOT
212
213%__mkdir_p $RPM_BUILD_ROOT%{_bindir}
214%__mkdir_p $RPM_BUILD_ROOT%{plugindir}
215%__mkdir_p $RPM_BUILD_ROOT%{pluginsourcedir}
216%__mkdir_p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
217
218%__make -C %{build_dir} install DESTDIR=$RPM_BUILD_ROOT
219
220ln -s %{pkgdir}/npwrapper.so $RPM_BUILD_ROOT/%{plugindir}/npwrapper.so
221
222# Install plugin-config utility
223pushd %{plugin_config_name}
224DESTDIR=$RPM_BUILD_ROOT %__make install
225popd
226
227cd $RPM_BUILD_ROOT%{_bindir}
228%__mv %{plugin_config_binary} $RPM_BUILD_ROOT/%{pkgdir}
229cd -
230
231%__rm -rf $RPM_BUILD_ROOT/usr/doc/plugin-config
232
233cat %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-plugin-config
234chmod 755 $RPM_BUILD_ROOT%{_bindir}/mozilla-plugin-config
235
236cat %{SOURCE3} | %{__sed} -e "s|EXCLUDE_LIST|%{exclude_list}|g" \
237    > $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
238chmod 644 $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
239
240# set up nsplugin player starting script
241%{__cat} > $RPM_BUILD_ROOT%{pkgdir}/nspluginplayer << EOF
242export MOZ_PLUGIN_PATH=%{pluginsourcedir}
243%{pkgdir}/npplayer "$@"
244EOF
245chmod 755 $RPM_BUILD_ROOT%{pkgdir}/nspluginplayer
246
247# Remove conflicting files
248%__rm -rf $RPM_BUILD_ROOT%{_bindir}/nspluginplayer
249%__rm -rf $RPM_BUILD_ROOT%{_bindir}/nspluginwrapper
250
251## <mozilla-filesystem>
252%__mkdir_p $RPM_BUILD_ROOT/usr/{lib,%{_lib}}/mozilla/{plugins,extensions}
253%__mkdir_p $RPM_BUILD_ROOT/%{_datadir}/mozilla/extensions
254%__mkdir_p $RPM_BUILD_ROOT/etc/skel/.mozilla/{plugins,extensions}
255## </mozilla-filesystem>
256
257%clean
258%__rm -rf $RPM_BUILD_ROOT
259
260%post
261/usr/bin/mozilla-plugin-config -i -f > /dev/null 2>&1 || :
262
263%preun
264if [ "$1" == "0" ]; then
265    /usr/bin/mozilla-plugin-config -r > /dev/null 2>&1 || :
266fi;
267
268%files
269%defattr(-,root,root)
270%doc README COPYING NEWS
271%dir %{pkgdir}
272%dir %{plugindir}
273
274%{pkgdir}/%{plugin_config_binary}
275%{pkgdir}/npconfig
276%{pkgdir}/npwrapper.so
277%{pkgdir}/npviewer.bin
278%{pkgdir}/npviewer.sh
279%{pkgdir}/npviewer
280%{pkgdir}/npplayer
281%{pkgdir}/libxpcom.so
282%{pkgdir}/libnoxshm.so
283%{pkgdir}/nspluginplayer
284%{plugindir}/npwrapper.so
285%{_bindir}/mozilla-plugin-config
286%config %{_sysconfdir}/sysconfig/%{name}
287
288## <mozilla-filesystem>
289/usr/lib*/mozilla
290%{_datadir}/mozilla
291/etc/skel/.mozilla
292## </mozilla-filesystem>
293
294
295## to build compat32 for x86_64 architecture support
296%if %{build_compat32}
297%files -n compat32-%{name}
298%defattr(-,root,root)
299%dir %{pkgdir}
300%dir %{plugindir}
301
302%{pkgdir}/%{plugin_config_binary}
303%{pkgdir}/npconfig
304%{pkgdir}/npwrapper.so
305%{pkgdir}/npviewer.bin
306%{pkgdir}/npviewer.sh
307%{pkgdir}/npviewer
308%{pkgdir}/npplayer
309%{pkgdir}/libxpcom.so
310%{pkgdir}/libnoxshm.so
311%{pkgdir}/nspluginplayer
312%{plugindir}/npwrapper.so
313%endif
314
315
316%changelog
317* Mon Nov 15 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.0-3
318- applied some improvement patches from Fedora rawhide
319  * Wed Jun 30 2010 Martin Stransky <stransky@redhat.com> 1.3.0-14
320  - fixed patch for rhbz#523273
321  * Tue Jun 29 2010 Martin Stransky <stransky@redhat.com> 1.3.0-13
322  - Changed RPM timeout to 10 second, should prevent
323    long browser hangs.
324  - Disabled debug outputs in normal build.
325  * Mon Jun 28 2010 Martin Stransky <stransky@redhat.com> 1.3.0-12
326  - Fixed rhbz#523273 - wrapped plugins not getting updated
327  * Fri Dec 4 2009 Martin Stransky <stransky@redhat.com> 1.3.0-10
328  - added Compiz workaround (#542424)
329  * Tue Nov 10 2009 Martin Stransky <stransky@redhat.com> 1.3.0-9
330  - added NULL check (#531669)
331  * Wed Jul 15 2009 Martin Stransky <stransky@redhat.com> 1.3.0-7
332  - NPIdentifiers fix by Tristan Schmelcher (Google)
333  * Wed Jul 15 2009 Martin Stransky <stransky@redhat.com> 1.3.0-6
334  - Package kit plugin is ignored now (#511385)
335
336* Sat Aug 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-2
337- changed Group to System Environment/Libraries
338
339* Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.0-1
340- initial release
341  - ported from Fedora development package
342
343* Tue Mar 03 2009 Warren Togami <wtogami@redhat.com> - 1.3.0-5
344- Really Fix x86 32bit build (#488308)
345
346* Sun Mar 01 2009 Warren Togami <wtogami@redhat.com> - 1.3.0-4
347- Fix x86 32bit build
348
349* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
350- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
351
352* Thu Jan 9 2009 Martin Stransky <stransky@redhat.com> 1.3.0-2
353- Fixed multilib conflicts
354
355* Thu Jan 8 2009 Martin Stransky <stransky@redhat.com> 1.3.0-1
356- Updated to 1.3.0 and removed some fedora build patches
357
358* Tue Dec 02 2008 Warren Togami <wtogami@redhat.com> 1.1.8-2
359- fix-invalid-RPC-after-NPP_Destroy fixes a crasher
360
361* Mon Dec 1 2008 Martin Stransky <stransky@redhat.com> 1.1.8-1
362- Updated to 1.1.8
363- Removed already upstreamed patches
364
365* Wed Nov 12 2008 Martin Stransky <stransky@redhat.com> 1.1.4-1
366- Updated to 1.1.4
367- Consolidated build patches
368
369* Wed Oct 22 2008 Martin Stransky <stransky@redhat.com> 1.1.2-4
370- Fixed #449338 - mozilla-plugin-config segfaults with -v argument
371
372* Tue Oct 21 2008 Martin Stransky <stransky@redhat.com> 1.1.2-3
373- Removed event patch, it blocks X events and breaks Adobe pdf plugin
374- Removed event limit in xt_event_polling_timer_callback
375
376* Fri Oct 17 2008 Martin Stransky <stransky@redhat.com> 1.1.2-2
377- added umask to plugin config (#463736)
378
379* Thu Oct 16 2008 Martin Stransky <stransky@redhat.com> 1.1.2-1
380- updated to 1.1.12
381- added librhythmbox* to ignored plugins (#467187)
382- removed debug prints (#467090)
383
384* Mon Oct 06 2008 Warren Togami <wtogami@redhat.com> 1.1.0-11
385- Unrevert patch from -7 because Warren was wrong
386- Concurrent rpc_method_invoke() patch
387
388* Fri Oct 03 2008 Warren Togami <wtogami@redhat.com> 1.1.0-10
389- Revert libcurl requires because it was done in an incorrect way
390- Revert patch from -7 because it made things worse
391
392* Tue Sep 30 2008 Martin Stransky <stransky@redhat.com> 1.1.0-7
393- Updated fix for #456432 -(Windowless Crash) Flash 10 w/ Firefox 3
394
395* Wed Sep 17 2008 Martin Stransky <stransky@redhat.com> 1.1.0-6
396- Added libcurl to requires (#460988)
397
398* Mon Aug 04 2008 Martin Stransky <stransky@redhat.com> 1.1.0-5
399- Added fix for #456432 -(Windowless Crash) Flash 10 w/ Firefox 3
400
401* Mon Jul 21 2008 Martin Stransky <stransky@redhat.com> 1.1.0-4
402- Removed gecko-libs from requieres (it's not needed now)
403
404* Tue Jul 18 2008 Martin Stransky <stransky@redhat.com> 1.1.0-3
405- Enabled experimental stand-alone plugin player
406
407* Tue Jul 15 2008 Martin Stransky <stransky@redhat.com> 1.1.0-2
408- Fixed build warnings in our patches
409
410* Tue Jul 8 2008 Martin Stransky <stransky@redhat.com> 1.1.0-1
411- update to latest upstream version (1.1.0)
412
413* Mon May 5 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-28
414- link pluginwrapper with stdc++ lib
415
416* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 0.9.91.5-27
417- mozilla-filesystem now owns the plugin source dir
418
419* Tue Mar 11 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-26
420- /etc/sysconfig/nspluginwrapper marked as config file
421- exclude some player plugins
422
423* Mon Mar 10 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-25
424- updated the sleep patch
425
426* Thu Mar 06 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-24
427- added experimental patch for #426968 - nspluginwrapper wakes up too much
428
429* Tue Feb 26 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-23
430- merged exclude patch with main tarball
431- fixed #431095 - Typo in mozilla-plugin-config verbose output
432
433* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.91.5-22
434- Autorebuild for GCC 4.3
435
436* Mon Jan 21 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-21
437- fixed #426618 - gcjwebplugin error: Failed to run
438  (added to ignored plugins)
439
440* Mon Jan 14 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-20
441- fixed #426176 - Orphaned npviewer.bin processes
442
443* Thu Jan 10 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-19
444- xulrunner rebuild
445- fixed build script, added gthread-2.0
446
447* Mon Dec 24 2007 Warren Togami <wtogami@redhat.com> 0.9.91.5-18
448- Make nsviewer.bin initialized for multithreading, fixes #360891
449
450* Tue Dec 20 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-17
451- disabled xpcom support - it causes more troubles than advantages
452
453* Tue Dec 13 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-16
454- spec fixes
455- fixed xulrunner support
456
457* Mon Dec 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-15
458- updated configure script - gecko selection
459
460* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-14
461- enabled xpcom support
462- added fix for #393541 - scripts will never fail
463
464* Fri Nov 23 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-13
465- rebuilt against xulrunner
466
467* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-12
468- more fixes from review by security standards team
469
470* Wed Oct 31 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-11
471- added fixes from review by security standards team
472
473* Fri Oct 26 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-10
474- mozilla-plugin-config can be run by normal user now
475
476* Wed Oct 24 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-9
477- Updated config utility - removes dangling symlinks and
478  wrapped plugins
479 
480* Tue Oct 23 2007 Jeremy Katz <katzj@redhat.com> 0.9.91.5-8
481- Rebuild against new firefox
482
483* Mon Oct 15 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-7
484- added a fix for #281061 - gnash fails when wrapped, works when native
485
486* Wed Oct 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-6
487- removed possibble deadlock during plugin restart
488
489* Tue Oct 9 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-5
490- fixed browser crashes (#290901)
491
492* Mon Oct 1 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-4
493- quit the plugin when browser crashes (#290901)
494
495* Fri Sep 21 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-3
496- added original plugin dir to the package
497
498* Mon Sep 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-2
499- added upstream patches - RPC error handling and plugin restart
500
501* Mon Aug 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-1
502- update to the latest upstream
503
504* Mon Aug 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-19
505- converted rpc error handling code to a thread-safe variant
506- added a time limit to plugin restart
507
508* Tue Aug 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-18
509- implemented plugin restart (#251530)
510
511* Tue Aug 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-17
512- fixed an installation script (#251698)
513
514* Mon Aug 13 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-16
515- fixed plugins check
516- minor spec fixes
517
518* Fri Aug 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-15
519- removed mozembeded dependency
520- excluded totem plugins from wrapping
521- xpcom support is optional now
522
523* Thu Aug 9 2007 Christopher Aillon <caillon@redhat.com> 0.9.91.4-14
524- Rebuild against newer gecko
525
526* Wed Aug 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-13
527- removed unsafe plugins probe
528- added agruments to mozilla-plugin-config
529
530* Tue Aug 7 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-12
531- removed fake libxpcom
532
533* Mon Aug 6 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-11
534- added gecko dependency
535- added plugin configuration utility
536
537* Fri Aug 3 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-10
538- fixed totem-complex plugin wrapping
539
540* Mon Jul 30 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-9
541- added plugin dirs
542
543* Fri Jul 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-8
544- added switch for creating debug packages
545
546* Thu Jul 19 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-7
547- integrated with firefox / seamonkey
548
549* Tue Jul 11 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-6
550- added new options to the configuration utility
551- modified along new plug-ins concept
552
553* Thu Jun 19 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-5
554- updated nspluginsetup script
555- added support for x86_64 plug-ins
556
557* Thu Jun 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-4
558- added ppc arch
559- silenced installation scripts
560- moved configuration to /etc/sysconfig
561
562* Thu Jun 12 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-3
563- updated nspluginsetup script and package install/uninstall scripts
564- added cross-compilation support
565- removed binaries stripping
566
567* Fri Jun 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-2
568- added BuildRequires - pkgconfig, gtk2-devel, glib, libXt-devel
569
570* Fri Jun 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-1
571- initial build
Note: See TracBrowser for help on using the repository browser.