source: projects/specs/trunk/n/nspluginwrapper/nspluginwrapper-vl.spec @ 3643

Revision 3643, 18.2 KB checked in by munepi, 13 years ago (diff)

updated nspluginwrapper-vl.spec

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3# Compile as a debug package
4%define make_debug_package      0
5
6# What gecko we use
7%define gecko_flavour           "mozilla"
8
9%define plugin_config_version 1.9
10%define plugin_config_name plugin-config-%{plugin_config_version}
11%define plugin_config_binary plugin-config
12
13# Excluded plugins (separated by ':')
14%define exclude_list    "libtotem*:libjavaplugin*:gecko-mediaplayer*:mplayerplug-in*:librhythmbox*:packagekit*:libnsISpicec*"
15
16# Target defines
17%if "%{_target_cpu}" == "i386"
18%define target_bits     32
19%endif
20
21%if "%{_target_cpu}" == "i586"
22%define target_bits     32
23%endif
24
25%if "%{_target_cpu}" == "i686"
26%define target_bits     32
27%endif
28
29%if "%{_target_cpu}" == "ppc"
30%define target_bits     32
31%endif
32
33%if "%{_target_cpu}" == "x86_64"
34%define target_bits     64
35%endif
36
37%if "%{_target_cpu}" == "ppc64"
38%define target_bits     64
39%endif
40
41# Define libraries for 32/64 arches
42%define lib32                   lib
43%define lib64                   lib64
44%define libdir32                /usr/lib
45%define libdir64                /usr/lib64
46
47# define nspluginswrapper libdir (invariant, including libdir)
48%define pkgdir32                %{libdir32}/%{name}
49%define pkgdir64                %{libdir64}/%{name}
50
51# define mozilla plugin dir and back up dir for 32-bit browsers
52%define pluginsourcedir32       %{libdir32}/mozilla/plugins
53%define plugindir32             %{libdir32}/mozilla/plugins-wrapped
54
55# define mozilla plugin dir and back up dir for 64-bit browsers
56%define pluginsourcedir64       %{libdir64}/mozilla/plugins
57%define plugindir64             %{libdir64}/mozilla/plugins-wrapped
58
59%define build_dir               objs-%{target_bits}
60
61%if "%{target_bits}" == "32"
62%define lib             %{lib32}
63%define libdir          %{libdir32}
64%define pkgdir          %{pkgdir32}
65%define plugindir       %{plugindir32}
66%define pluginsourcedir %{pluginsourcedir32}
67%else
68%define lib             %{lib64}
69%define libdir          %{libdir64}
70%define pkgdir          %{pkgdir64}
71%define plugindir       %{plugindir64}
72%define pluginsourcedir %{pluginsourcedir64}
73%endif
74
75Summary:        A compatibility layer for Netscape 4 plugins
76Name:           nspluginwrapper
77Version:        1.3.0
78Release:        4%{?_dist_release}
79Source0:        http://gwenole.beauchesne.info/projects/nspluginwrapper/files/%{name}-%{version}%{?svndate:-%{svndate}}.tar.bz2
80Source1:        %{plugin_config_name}.tar.gz
81Source2:        plugin-config.sh.in
82Source3:        %{name}.sh.in
83Patch1:         nspluginwrapper-1.3.0-make.patch
84Patch2:         nspluginwrapper-1.3.0-configure.patch
85Patch3:         nspluginwrapper-1.3.0-directory.patch
86Patch4:         nspluginwrapper-20090625-fix-npident-array-sending.patch
87Patch5:         nspluginwrapper-1.3.0-inst.patch
88Patch6:         nspluginwrapper-1.3.0-compiz.patch
89Patch7:         nspluginwrapper-1.3.0-comp.patch
90Patch8:         nspluginwrapper-1.3.0-silent.patch
91Patch9:         nspluginwrapper-1.3.0-timeout.patch
92Patch10:        npplayer-xid.patch
93Patch11:        nspluginwrapper-1.3.0-racecond.patch
94Patch100:       plugin-config-setuid.patch
95Patch101:       plugin-config-umask.patch
96Patch102:       plugin-config-print.patch
97Patch103:       plugin-config-native.patch
98Patch104:       plugin-config-time-check.patch
99
100License:        GPLv2+
101Group:          Applications/Internet
102URL:            http://gwenole.beauchesne.info/projects/nspluginwrapper/
103
104BuildRoot:      %{_tmppath}/%{name}-%{version}-root
105Provides:       %{name} = %{version}-%{release}
106#Requires:      mozilla-filesystem
107%ifarch x86_64
108Requires:       compat32-%{name} = %{version}-%{release}
109%endif
110BuildRequires:  pkgconfig gtk2-devel glib2-devel nspr-devel
111BuildRequires:  libX11-devel libXt-devel cairo-devel pango-devel curl-devel
112BuildRequires:  gecko-devel
113ExclusiveArch:  %{ix86} x86_64 ppc
114
115%description
116nspluginwrapper makes it possible to use Netscape 4 compatible plugins
117compiled for %{_arch} into Mozilla for another architecture, e.g. x86_64.
118
119This package consists in:
120  * npviewer: the plugin viewer
121  * npwrapper.so: the browser-side plugin
122  * nspluginplayer: stand-alone NPAPI plugin player
123  * mozilla-plugin-config: a tool to manage plugins installation and update
124
125## to build compat32 for x86_64 architecture support
126%package -n compat32-%{name}
127Summary:        A compatibility layer for Netscape 4 plugins
128Group: System Environment/Libraries
129
130%description -n compat32-%{name}
131nspluginwrapper makes it possible to use Netscape 4 compatible plugins
132compiled for %{_arch} into Mozilla for another architecture, e.g. x86_64.
133
134This package consists in:
135  * npviewer: the plugin viewer
136  * npwrapper.so: the browser-side plugin
137  * nspluginplayer: stand-alone NPAPI plugin player
138  * mozilla-plugin-config: a tool to manage plugins installation and update
139
140
141%prep
142%setup  -q -a 1
143
144# Installation & build patches
145%patch1 -p1 -b .make
146%patch2 -p1 -b .conf
147%patch3 -p1 -b .dir
148%patch4 -p0 -b .array
149%patch5 -p1 -b .inst
150%patch6 -p1 -b .compiz
151%patch7 -p1 -b .comp
152%patch8 -p1 -b .silent
153%patch9 -p1 -b .timeout
154%patch10 -p1 -b .xid
155%patch11 -p1 -b .racecond
156
157# Plugin-config patches
158pushd %plugin_config_name
159%patch100 -p2
160%patch101 -p2 -b .umask
161%patch102 -p2 -b .print
162%patch103 -p2 -b .native
163%patch104 -p2 -b .time
164popd
165
166%build
167# Build wrapper
168
169# set the propper built options
170%if %{make_debug_package}
171    %if "%{target_bits}" == "64"
172        export CFLAGS="-g -m64 -DDEBUG"
173    %else
174        export CFLAGS="-g -m32 -DDEBUG"
175    %endif
176%else
177    export CFLAGS="$RPM_OPT_FLAGS"
178%endif
179
180# set the propper built options
181%if "%{target_bits}" == "64"
182    export LDFLAGS="-m64 -L%{libdir64}"
183%else
184    export LDFLAGS="-m32 -L%{libdir32}"
185%endif
186
187mkdir %{build_dir}
188pushd %{build_dir}
189../configure                                    \
190            --prefix=%{_prefix}                 \
191            --target-cpu=%{_target_cpu}         \
192            --pkgdir=%{name}                    \
193            --pkglibdir=%{pkgdir}               \
194            --with-lib32=%{lib32}               \
195            --with-lib64=%{lib64}               \
196            --with-base-lib=%{lib}              \
197            --with-base-libdir=%{libdir}        \
198            --viewer-paths=%{pkgdir}            \
199            --with-x11-prefix=/usr              \
200            --with-gecko=%{gecko_flavour}       \
201            --enable-viewer                     \
202            --viewer-paths="%{pkgdir32}:%{pkgdir64}"\
203            --disable-biarch
204       
205%__make
206popd
207
208#Build plugin configuration utility
209pushd %{plugin_config_name}
210./configure --prefix=%{_prefix} --libdir=%{_libdir} CFLAGS="$RPM_OPT_FLAGS"
211%__make
212popd
213
214%install
215%__rm -rf $RPM_BUILD_ROOT
216
217%__mkdir_p $RPM_BUILD_ROOT%{_bindir}
218%__mkdir_p $RPM_BUILD_ROOT%{plugindir}
219%__mkdir_p $RPM_BUILD_ROOT%{pluginsourcedir}
220%__mkdir_p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
221
222%__make -C %{build_dir} install DESTDIR=$RPM_BUILD_ROOT
223
224ln -s %{pkgdir}/npwrapper.so $RPM_BUILD_ROOT/%{plugindir}/npwrapper.so
225
226# Install plugin-config utility
227pushd %{plugin_config_name}
228DESTDIR=$RPM_BUILD_ROOT %__make install
229popd
230
231cd $RPM_BUILD_ROOT%{_bindir}
232%__mv %{plugin_config_binary} $RPM_BUILD_ROOT/%{pkgdir}
233cd -
234
235%__rm -rf $RPM_BUILD_ROOT/usr/doc/plugin-config
236
237cat %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-plugin-config
238chmod 755 $RPM_BUILD_ROOT%{_bindir}/mozilla-plugin-config
239
240cat %{SOURCE3} | %{__sed} -e "s|EXCLUDE_LIST|%{exclude_list}|g" \
241    > $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
242chmod 644 $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
243
244# set up nsplugin player starting script
245%{__cat} > $RPM_BUILD_ROOT%{pkgdir}/nspluginplayer << EOF
246export MOZ_PLUGIN_PATH=%{pluginsourcedir}
247%{pkgdir}/npplayer "$@"
248EOF
249chmod 755 $RPM_BUILD_ROOT%{pkgdir}/nspluginplayer
250
251# Remove conflicting files
252%__rm -rf $RPM_BUILD_ROOT%{_bindir}/nspluginplayer
253%__rm -rf $RPM_BUILD_ROOT%{_bindir}/nspluginwrapper
254
255## <mozilla-filesystem>
256%__mkdir_p $RPM_BUILD_ROOT/usr/{lib,%{_lib}}/mozilla/{plugins,extensions}
257%__mkdir_p $RPM_BUILD_ROOT/%{_datadir}/mozilla/extensions
258%__mkdir_p $RPM_BUILD_ROOT/etc/skel/.mozilla/{plugins,extensions}
259## </mozilla-filesystem>
260
261%clean
262%__rm -rf $RPM_BUILD_ROOT
263
264%post
265/usr/bin/mozilla-plugin-config -i -f > /dev/null 2>&1 || :
266
267%preun
268if [ "$1" == "0" ]; then
269    /usr/bin/mozilla-plugin-config -r > /dev/null 2>&1 || :
270fi;
271
272%files
273%defattr(-,root,root)
274%doc README COPYING NEWS
275%dir %{pkgdir}
276%dir %{plugindir}
277
278%{pkgdir}/%{plugin_config_binary}
279%{pkgdir}/npconfig
280%{pkgdir}/npwrapper.so
281%{pkgdir}/npviewer.bin
282%{pkgdir}/npviewer.sh
283%{pkgdir}/npviewer
284%{pkgdir}/npplayer
285%{pkgdir}/libxpcom.so
286%{pkgdir}/libnoxshm.so
287%{pkgdir}/nspluginplayer
288%{plugindir}/npwrapper.so
289%{_bindir}/mozilla-plugin-config
290%config %{_sysconfdir}/sysconfig/%{name}
291
292## <mozilla-filesystem>
293/usr/lib*/mozilla
294%{_datadir}/mozilla
295/etc/skel/.mozilla
296## </mozilla-filesystem>
297
298
299## to build compat32 for x86_64 architecture support
300%if %{build_compat32}
301%files -n compat32-%{name}
302%defattr(-,root,root)
303%dir %{pkgdir}
304%dir %{plugindir}
305
306%{pkgdir}/%{plugin_config_binary}
307%{pkgdir}/npconfig
308%{pkgdir}/npwrapper.so
309%{pkgdir}/npviewer.bin
310%{pkgdir}/npviewer.sh
311%{pkgdir}/npviewer
312%{pkgdir}/npplayer
313%{pkgdir}/libxpcom.so
314%{pkgdir}/libnoxshm.so
315%{pkgdir}/nspluginplayer
316%{plugindir}/npwrapper.so
317%endif
318
319
320%changelog
321* Fri Apr 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.0-4
322- added spice-xpi to ignored plugins
323- applied some improvement patches from Fedora rawhide
324  * Wed Mar 09 2011 Peter Hatina <phatina@redhat.coom> 1.3.0-18
325  - Race condition patch
326  * Wed Jun 30 2010 Martin Stransky <stransky@redhat.com> 1.3.0-14
327  - fixed patch for rhbz#523273
328
329* Mon Nov 15 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.0-3
330- applied some improvement patches from Fedora rawhide
331  * Wed Jun 30 2010 Martin Stransky <stransky@redhat.com> 1.3.0-14
332  - fixed patch for rhbz#523273
333  * Tue Jun 29 2010 Martin Stransky <stransky@redhat.com> 1.3.0-13
334  - Changed RPM timeout to 10 second, should prevent
335    long browser hangs.
336  - Disabled debug outputs in normal build.
337  * Mon Jun 28 2010 Martin Stransky <stransky@redhat.com> 1.3.0-12
338  - Fixed rhbz#523273 - wrapped plugins not getting updated
339  * Fri Dec 4 2009 Martin Stransky <stransky@redhat.com> 1.3.0-10
340  - added Compiz workaround (#542424)
341  * Tue Nov 10 2009 Martin Stransky <stransky@redhat.com> 1.3.0-9
342  - added NULL check (#531669)
343  * Wed Jul 15 2009 Martin Stransky <stransky@redhat.com> 1.3.0-7
344  - NPIdentifiers fix by Tristan Schmelcher (Google)
345  * Wed Jul 15 2009 Martin Stransky <stransky@redhat.com> 1.3.0-6
346  - Package kit plugin is ignored now (#511385)
347
348* Sat Aug 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-2
349- changed Group to System Environment/Libraries
350
351* Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.0-1
352- initial release
353  - ported from Fedora development package
354
355* Tue Mar 03 2009 Warren Togami <wtogami@redhat.com> - 1.3.0-5
356- Really Fix x86 32bit build (#488308)
357
358* Sun Mar 01 2009 Warren Togami <wtogami@redhat.com> - 1.3.0-4
359- Fix x86 32bit build
360
361* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
362- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
363
364* Thu Jan 9 2009 Martin Stransky <stransky@redhat.com> 1.3.0-2
365- Fixed multilib conflicts
366
367* Thu Jan 8 2009 Martin Stransky <stransky@redhat.com> 1.3.0-1
368- Updated to 1.3.0 and removed some fedora build patches
369
370* Tue Dec 02 2008 Warren Togami <wtogami@redhat.com> 1.1.8-2
371- fix-invalid-RPC-after-NPP_Destroy fixes a crasher
372
373* Mon Dec 1 2008 Martin Stransky <stransky@redhat.com> 1.1.8-1
374- Updated to 1.1.8
375- Removed already upstreamed patches
376
377* Wed Nov 12 2008 Martin Stransky <stransky@redhat.com> 1.1.4-1
378- Updated to 1.1.4
379- Consolidated build patches
380
381* Wed Oct 22 2008 Martin Stransky <stransky@redhat.com> 1.1.2-4
382- Fixed #449338 - mozilla-plugin-config segfaults with -v argument
383
384* Tue Oct 21 2008 Martin Stransky <stransky@redhat.com> 1.1.2-3
385- Removed event patch, it blocks X events and breaks Adobe pdf plugin
386- Removed event limit in xt_event_polling_timer_callback
387
388* Fri Oct 17 2008 Martin Stransky <stransky@redhat.com> 1.1.2-2
389- added umask to plugin config (#463736)
390
391* Thu Oct 16 2008 Martin Stransky <stransky@redhat.com> 1.1.2-1
392- updated to 1.1.12
393- added librhythmbox* to ignored plugins (#467187)
394- removed debug prints (#467090)
395
396* Mon Oct 06 2008 Warren Togami <wtogami@redhat.com> 1.1.0-11
397- Unrevert patch from -7 because Warren was wrong
398- Concurrent rpc_method_invoke() patch
399
400* Fri Oct 03 2008 Warren Togami <wtogami@redhat.com> 1.1.0-10
401- Revert libcurl requires because it was done in an incorrect way
402- Revert patch from -7 because it made things worse
403
404* Tue Sep 30 2008 Martin Stransky <stransky@redhat.com> 1.1.0-7
405- Updated fix for #456432 -(Windowless Crash) Flash 10 w/ Firefox 3
406
407* Wed Sep 17 2008 Martin Stransky <stransky@redhat.com> 1.1.0-6
408- Added libcurl to requires (#460988)
409
410* Mon Aug 04 2008 Martin Stransky <stransky@redhat.com> 1.1.0-5
411- Added fix for #456432 -(Windowless Crash) Flash 10 w/ Firefox 3
412
413* Mon Jul 21 2008 Martin Stransky <stransky@redhat.com> 1.1.0-4
414- Removed gecko-libs from requieres (it's not needed now)
415
416* Tue Jul 18 2008 Martin Stransky <stransky@redhat.com> 1.1.0-3
417- Enabled experimental stand-alone plugin player
418
419* Tue Jul 15 2008 Martin Stransky <stransky@redhat.com> 1.1.0-2
420- Fixed build warnings in our patches
421
422* Tue Jul 8 2008 Martin Stransky <stransky@redhat.com> 1.1.0-1
423- update to latest upstream version (1.1.0)
424
425* Mon May 5 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-28
426- link pluginwrapper with stdc++ lib
427
428* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 0.9.91.5-27
429- mozilla-filesystem now owns the plugin source dir
430
431* Tue Mar 11 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-26
432- /etc/sysconfig/nspluginwrapper marked as config file
433- exclude some player plugins
434
435* Mon Mar 10 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-25
436- updated the sleep patch
437
438* Thu Mar 06 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-24
439- added experimental patch for #426968 - nspluginwrapper wakes up too much
440
441* Tue Feb 26 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-23
442- merged exclude patch with main tarball
443- fixed #431095 - Typo in mozilla-plugin-config verbose output
444
445* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.91.5-22
446- Autorebuild for GCC 4.3
447
448* Mon Jan 21 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-21
449- fixed #426618 - gcjwebplugin error: Failed to run
450  (added to ignored plugins)
451
452* Mon Jan 14 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-20
453- fixed #426176 - Orphaned npviewer.bin processes
454
455* Thu Jan 10 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-19
456- xulrunner rebuild
457- fixed build script, added gthread-2.0
458
459* Mon Dec 24 2007 Warren Togami <wtogami@redhat.com> 0.9.91.5-18
460- Make nsviewer.bin initialized for multithreading, fixes #360891
461
462* Tue Dec 20 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-17
463- disabled xpcom support - it causes more troubles than advantages
464
465* Tue Dec 13 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-16
466- spec fixes
467- fixed xulrunner support
468
469* Mon Dec 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-15
470- updated configure script - gecko selection
471
472* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-14
473- enabled xpcom support
474- added fix for #393541 - scripts will never fail
475
476* Fri Nov 23 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-13
477- rebuilt against xulrunner
478
479* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-12
480- more fixes from review by security standards team
481
482* Wed Oct 31 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-11
483- added fixes from review by security standards team
484
485* Fri Oct 26 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-10
486- mozilla-plugin-config can be run by normal user now
487
488* Wed Oct 24 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-9
489- Updated config utility - removes dangling symlinks and
490  wrapped plugins
491 
492* Tue Oct 23 2007 Jeremy Katz <katzj@redhat.com> 0.9.91.5-8
493- Rebuild against new firefox
494
495* Mon Oct 15 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-7
496- added a fix for #281061 - gnash fails when wrapped, works when native
497
498* Wed Oct 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-6
499- removed possibble deadlock during plugin restart
500
501* Tue Oct 9 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-5
502- fixed browser crashes (#290901)
503
504* Mon Oct 1 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-4
505- quit the plugin when browser crashes (#290901)
506
507* Fri Sep 21 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-3
508- added original plugin dir to the package
509
510* Mon Sep 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-2
511- added upstream patches - RPC error handling and plugin restart
512
513* Mon Aug 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-1
514- update to the latest upstream
515
516* Mon Aug 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-19
517- converted rpc error handling code to a thread-safe variant
518- added a time limit to plugin restart
519
520* Tue Aug 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-18
521- implemented plugin restart (#251530)
522
523* Tue Aug 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-17
524- fixed an installation script (#251698)
525
526* Mon Aug 13 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-16
527- fixed plugins check
528- minor spec fixes
529
530* Fri Aug 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-15
531- removed mozembeded dependency
532- excluded totem plugins from wrapping
533- xpcom support is optional now
534
535* Thu Aug 9 2007 Christopher Aillon <caillon@redhat.com> 0.9.91.4-14
536- Rebuild against newer gecko
537
538* Wed Aug 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-13
539- removed unsafe plugins probe
540- added agruments to mozilla-plugin-config
541
542* Tue Aug 7 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-12
543- removed fake libxpcom
544
545* Mon Aug 6 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-11
546- added gecko dependency
547- added plugin configuration utility
548
549* Fri Aug 3 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-10
550- fixed totem-complex plugin wrapping
551
552* Mon Jul 30 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-9
553- added plugin dirs
554
555* Fri Jul 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-8
556- added switch for creating debug packages
557
558* Thu Jul 19 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-7
559- integrated with firefox / seamonkey
560
561* Tue Jul 11 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-6
562- added new options to the configuration utility
563- modified along new plug-ins concept
564
565* Thu Jun 19 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-5
566- updated nspluginsetup script
567- added support for x86_64 plug-ins
568
569* Thu Jun 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-4
570- added ppc arch
571- silenced installation scripts
572- moved configuration to /etc/sysconfig
573
574* Thu Jun 12 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-3
575- updated nspluginsetup script and package install/uninstall scripts
576- added cross-compilation support
577- removed binaries stripping
578
579* Fri Jun 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-2
580- added BuildRequires - pkgconfig, gtk2-devel, glib, libXt-devel
581
582* Fri Jun 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-1
583- initial build
Note: See TracBrowser for help on using the repository browser.