source: projects/specs/trunk/n/nspluginwrapper/nspluginwrapper-vl.spec @ 4870

Revision 4870, 17.8 KB checked in by munepi, 13 years ago (diff)

updated nspluginwrapper and install-assist-flash-plugin: supported native linux x86_64 flash-plugin

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3# Compile as a debug package
4%define make_debug_package      0
5
6# What gecko we use
7%define gecko_flavour           "mozilla"
8
9%define plugin_config_version 1.9
10%define plugin_config_name plugin-config-%{plugin_config_version}
11%define plugin_config_binary plugin-config
12
13# Excluded plugins (separated by ':')
14%define exclude_list    "libtotem*:libjavaplugin*:gecko-mediaplayer*:mplayerplug-in*:librhythmbox*:packagekit*:libnsISpicec*:libgnashplugin*:liblightsparkplugin*:libflashplayer*"
15
16# Target defines
17%if "%{_target_cpu}" == "i386"
18%define target_bits     32
19%endif
20
21%if "%{_target_cpu}" == "i586"
22%define target_bits     32
23%endif
24
25%if "%{_target_cpu}" == "i686"
26%define target_bits     32
27%endif
28
29%if "%{_target_cpu}" == "ppc"
30%define target_bits     32
31%endif
32
33%if "%{_target_cpu}" == "x86_64"
34%define target_bits     64
35%endif
36
37%if "%{_target_cpu}" == "ppc64"
38%define target_bits     64
39%endif
40
41# Define libraries for 32/64 arches
42%define lib32                   lib
43%define lib64                   lib64
44%define libdir32                /usr/lib
45%define libdir64                /usr/lib64
46
47# define nspluginswrapper libdir (invariant, including libdir)
48%define pkgdir32                %{libdir32}/%{name}
49%define pkgdir64                %{libdir64}/%{name}
50
51# define mozilla plugin dir and back up dir for 32-bit browsers
52%define pluginsourcedir32       %{libdir32}/mozilla/plugins
53%define plugindir32             %{libdir32}/mozilla/plugins-wrapped
54
55# define mozilla plugin dir and back up dir for 64-bit browsers
56%define pluginsourcedir64       %{libdir64}/mozilla/plugins
57%define plugindir64             %{libdir64}/mozilla/plugins-wrapped
58
59%define build_dir               objs-%{target_bits}
60
61%if "%{target_bits}" == "32"
62%define lib             %{lib32}
63%define libdir          %{libdir32}
64%define pkgdir          %{pkgdir32}
65%define plugindir       %{plugindir32}
66%define pluginsourcedir %{pluginsourcedir32}
67%else
68%define lib             %{lib64}
69%define libdir          %{libdir64}
70%define pkgdir          %{pkgdir64}
71%define plugindir       %{plugindir64}
72%define pluginsourcedir %{pluginsourcedir64}
73%endif
74
75Summary:        A compatibility layer for Netscape 4 plugins
76Name:           nspluginwrapper
77Version:        1.4.4
78Release:        1%{?_dist_release}
79Source0:        http://nspluginwrapper.org/download/%{name}-%{version}%{?svndate:-%{svndate}}.tar.gz
80Source1:        %{plugin_config_name}.tar.gz
81Source2:        plugin-config.sh.in
82Source3:        %{name}.sh.in
83Patch1:         nspluginwrapper-1.3.0-make.patch
84Patch3:         nspluginwrapper-1.3.0-directory.patch
85Patch6:         nspluginwrapper-1.3.0-compiz.patch
86Patch7:         nspluginwrapper-1.3.0-comp.patch
87Patch9:         nspluginwrapper-1.3.0-timeout.patch
88Patch100:       plugin-config-setuid.patch
89Patch101:       plugin-config-umask.patch
90Patch102:       plugin-config-print.patch
91Patch103:       plugin-config-native.patch
92Patch104:       plugin-config-time-check.patch
93
94License:        GPLv2+
95Group:          Applications/Internet
96URL:            http://nspluginwrapper.org/
97
98BuildRoot:      %{_tmppath}/%{name}-%{version}-root
99Provides:       %{name} = %{version}-%{release}
100#Requires:      mozilla-filesystem
101%ifarch x86_64
102Requires:       compat32-%{name} = %{version}-%{release}
103%endif
104BuildRequires:  pkgconfig gtk2-devel glib2-devel nspr-devel
105BuildRequires:  libX11-devel libXt-devel cairo-devel pango-devel curl-devel
106BuildRequires:  gecko-devel
107ExclusiveArch:  %{ix86} x86_64 ppc
108
109%description
110nspluginwrapper makes it possible to use Netscape 4 compatible plugins
111compiled for %{_arch} into Mozilla for another architecture, e.g. x86_64.
112
113This package consists in:
114  * npviewer: the plugin viewer
115  * npwrapper.so: the browser-side plugin
116  * nspluginplayer: stand-alone NPAPI plugin player
117  * mozilla-plugin-config: a tool to manage plugins installation and update
118
119## to build compat32 for x86_64 architecture support
120%package -n compat32-%{name}
121Summary:        A compatibility layer for Netscape 4 plugins
122Group: System Environment/Libraries
123
124%description -n compat32-%{name}
125nspluginwrapper makes it possible to use Netscape 4 compatible plugins
126compiled for %{_arch} into Mozilla for another architecture, e.g. x86_64.
127
128This package consists in:
129  * npviewer: the plugin viewer
130  * npwrapper.so: the browser-side plugin
131  * nspluginplayer: stand-alone NPAPI plugin player
132  * mozilla-plugin-config: a tool to manage plugins installation and update
133
134
135%prep
136%setup  -q -a 1
137
138# Installation & build patches
139%patch1 -p1 -b .make
140%patch3 -p1 -b .dir
141%patch6 -p1 -b .compiz
142%patch7 -p1 -b .comp
143%patch9 -p1 -b .timeout
144
145# Plugin-config patches
146pushd %plugin_config_name
147%patch100 -p2
148%patch101 -p2 -b .umask
149%patch102 -p2 -b .print
150%patch103 -p2 -b .native
151%patch104 -p2 -b .time
152popd
153
154%build
155# Build wrapper
156
157# set the propper built options
158%if %{make_debug_package}
159    %if "%{target_bits}" == "64"
160        export CFLAGS="-g -m64 -DDEBUG"
161    %else
162        export CFLAGS="-g -m32 -DDEBUG"
163    %endif
164%else
165    export CFLAGS="$RPM_OPT_FLAGS"
166%endif
167
168# set the propper built options
169%if "%{target_bits}" == "64"
170    export LDFLAGS="-m64 -L%{libdir64} -ldl"
171%else
172    export LDFLAGS="-m32 -L%{libdir32} -ldl"
173%endif
174
175%__mkdir_p %{build_dir}
176pushd %{build_dir}
177../configure                                    \
178            --prefix=%{_prefix}                 \
179            --target-cpu=%{_target_cpu}         \
180            --pkglibdir=%{pkgdir}               \
181            --with-lib32=%{lib32}               \
182            --with-lib64=%{lib64}               \
183            --viewer-paths=%{pkgdir}            \
184            --enable-viewer                     \
185            --viewer-paths="%{pkgdir32}:%{pkgdir64}"\
186            --disable-biarch
187
188%__make
189popd
190
191#Build plugin configuration utility
192pushd %{plugin_config_name}
193./configure --prefix=%{_prefix} --libdir=%{_libdir} CFLAGS="$RPM_OPT_FLAGS"
194%__make
195popd
196
197%install
198%__rm -rf $RPM_BUILD_ROOT
199
200%__mkdir_p $RPM_BUILD_ROOT%{_bindir}
201%__mkdir_p $RPM_BUILD_ROOT%{plugindir}
202%__mkdir_p $RPM_BUILD_ROOT%{pluginsourcedir}
203%__mkdir_p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
204
205%__make -C %{build_dir} install DESTDIR=$RPM_BUILD_ROOT
206
207%__ln_s %{pkgdir}/npwrapper.so $RPM_BUILD_ROOT/%{plugindir}/npwrapper.so
208
209# Install plugin-config utility
210pushd %{plugin_config_name}
211DESTDIR=$RPM_BUILD_ROOT %__make install
212popd
213
214cd $RPM_BUILD_ROOT%{_bindir}
215%__mv %{plugin_config_binary} $RPM_BUILD_ROOT/%{pkgdir}
216cd -
217
218%__rm -rf $RPM_BUILD_ROOT/usr/doc/plugin-config
219
220cat %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-plugin-config
221chmod 755 $RPM_BUILD_ROOT%{_bindir}/mozilla-plugin-config
222
223cat %{SOURCE3} | %{__sed} -e "s|EXCLUDE_LIST|%{exclude_list}|g" \
224    > $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
225chmod 644 $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
226
227# set up nsplugin player starting script
228%{__cat} > $RPM_BUILD_ROOT%{pkgdir}/nspluginplayer << EOF
229export MOZ_PLUGIN_PATH=%{pluginsourcedir}
230%{pkgdir}/npplayer "$@"
231EOF
232chmod 755 $RPM_BUILD_ROOT%{pkgdir}/nspluginplayer
233
234# Remove conflicting files
235%__rm -rf $RPM_BUILD_ROOT%{_bindir}/nspluginplayer
236%__rm -rf $RPM_BUILD_ROOT%{_bindir}/nspluginwrapper
237
238## <mozilla-filesystem>
239%__mkdir_p $RPM_BUILD_ROOT/usr/{lib,%{_lib}}/mozilla/{plugins,extensions}
240%__mkdir_p $RPM_BUILD_ROOT/%{_datadir}/mozilla/extensions
241%__mkdir_p $RPM_BUILD_ROOT/etc/skel/.mozilla/{plugins,extensions}
242## </mozilla-filesystem>
243
244%clean
245%__rm -rf $RPM_BUILD_ROOT
246
247%post
248/usr/bin/mozilla-plugin-config -i -f > /dev/null 2>&1 || :
249
250%preun
251if [ "$1" == "0" ]; then
252    /usr/bin/mozilla-plugin-config -r > /dev/null 2>&1 || :
253fi;
254
255%files
256%defattr(-,root,root)
257%doc README COPYING NEWS
258%dir %{pkgdir}
259%dir %{plugindir}
260
261%{pkgdir}/%{plugin_config_binary}
262%{pkgdir}/npconfig
263%{pkgdir}/npwrapper.so
264%{pkgdir}/npviewer.bin
265%{pkgdir}/npviewer.sh
266%{pkgdir}/npviewer
267%{pkgdir}/npplayer
268%{pkgdir}/libnoxshm.so
269%{pkgdir}/nspluginplayer
270%{plugindir}/npwrapper.so
271%{_bindir}/mozilla-plugin-config
272%config %{_sysconfdir}/sysconfig/%{name}
273## <mozilla-filesystem>
274/usr/lib*/mozilla
275%{_datadir}/mozilla
276/etc/skel/.mozilla
277## </mozilla-filesystem>
278
279
280## to build compat32 for x86_64 architecture support
281%if %{build_compat32}
282%files -n compat32-%{name}
283%defattr(-,root,root)
284%dir %{pkgdir}
285%dir %{plugindir}
286
287%{pkgdir}/%{plugin_config_binary}
288%{pkgdir}/npconfig
289%{pkgdir}/npwrapper.so
290%{pkgdir}/npviewer.bin
291%{pkgdir}/npviewer.sh
292%{pkgdir}/npviewer
293%{pkgdir}/npplayer
294%{pkgdir}/libnoxshm.so
295%{pkgdir}/nspluginplayer
296%{plugindir}/npwrapper.so
297%endif
298
299
300%changelog
301* Thu Oct  6 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.4-1
302- new upstream release based on Fedora rawhide
303- supported native Linux x86_64 flash-plugin
304  - added libflashplayer to ignored plugins (exclude_list)
305
306* Fri Apr 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.0-4
307- added spice-xpi to ignored plugins
308- applied some improvement patches from Fedora rawhide
309  * Wed Mar 09 2011 Peter Hatina <phatina@redhat.coom> 1.3.0-18
310  - Race condition patch
311  * Wed Jun 30 2010 Martin Stransky <stransky@redhat.com> 1.3.0-14
312  - fixed patch for rhbz#523273
313
314* Mon Nov 15 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.0-3
315- applied some improvement patches from Fedora rawhide
316  * Wed Jun 30 2010 Martin Stransky <stransky@redhat.com> 1.3.0-14
317  - fixed patch for rhbz#523273
318  * Tue Jun 29 2010 Martin Stransky <stransky@redhat.com> 1.3.0-13
319  - Changed RPM timeout to 10 second, should prevent
320    long browser hangs.
321  - Disabled debug outputs in normal build.
322  * Mon Jun 28 2010 Martin Stransky <stransky@redhat.com> 1.3.0-12
323  - Fixed rhbz#523273 - wrapped plugins not getting updated
324  * Fri Dec 4 2009 Martin Stransky <stransky@redhat.com> 1.3.0-10
325  - added Compiz workaround (#542424)
326  * Tue Nov 10 2009 Martin Stransky <stransky@redhat.com> 1.3.0-9
327  - added NULL check (#531669)
328  * Wed Jul 15 2009 Martin Stransky <stransky@redhat.com> 1.3.0-7
329  - NPIdentifiers fix by Tristan Schmelcher (Google)
330  * Wed Jul 15 2009 Martin Stransky <stransky@redhat.com> 1.3.0-6
331  - Package kit plugin is ignored now (#511385)
332
333* Sat Aug 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-2
334- changed Group to System Environment/Libraries
335
336* Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.0-1
337- initial release
338  - ported from Fedora development package
339
340* Tue Mar 03 2009 Warren Togami <wtogami@redhat.com> - 1.3.0-5
341- Really Fix x86 32bit build (#488308)
342
343* Sun Mar 01 2009 Warren Togami <wtogami@redhat.com> - 1.3.0-4
344- Fix x86 32bit build
345
346* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
347- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
348
349* Thu Jan 9 2009 Martin Stransky <stransky@redhat.com> 1.3.0-2
350- Fixed multilib conflicts
351
352* Thu Jan 8 2009 Martin Stransky <stransky@redhat.com> 1.3.0-1
353- Updated to 1.3.0 and removed some fedora build patches
354
355* Tue Dec 02 2008 Warren Togami <wtogami@redhat.com> 1.1.8-2
356- fix-invalid-RPC-after-NPP_Destroy fixes a crasher
357
358* Mon Dec 1 2008 Martin Stransky <stransky@redhat.com> 1.1.8-1
359- Updated to 1.1.8
360- Removed already upstreamed patches
361
362* Wed Nov 12 2008 Martin Stransky <stransky@redhat.com> 1.1.4-1
363- Updated to 1.1.4
364- Consolidated build patches
365
366* Wed Oct 22 2008 Martin Stransky <stransky@redhat.com> 1.1.2-4
367- Fixed #449338 - mozilla-plugin-config segfaults with -v argument
368
369* Tue Oct 21 2008 Martin Stransky <stransky@redhat.com> 1.1.2-3
370- Removed event patch, it blocks X events and breaks Adobe pdf plugin
371- Removed event limit in xt_event_polling_timer_callback
372
373* Fri Oct 17 2008 Martin Stransky <stransky@redhat.com> 1.1.2-2
374- added umask to plugin config (#463736)
375
376* Thu Oct 16 2008 Martin Stransky <stransky@redhat.com> 1.1.2-1
377- updated to 1.1.12
378- added librhythmbox* to ignored plugins (#467187)
379- removed debug prints (#467090)
380
381* Mon Oct 06 2008 Warren Togami <wtogami@redhat.com> 1.1.0-11
382- Unrevert patch from -7 because Warren was wrong
383- Concurrent rpc_method_invoke() patch
384
385* Fri Oct 03 2008 Warren Togami <wtogami@redhat.com> 1.1.0-10
386- Revert libcurl requires because it was done in an incorrect way
387- Revert patch from -7 because it made things worse
388
389* Tue Sep 30 2008 Martin Stransky <stransky@redhat.com> 1.1.0-7
390- Updated fix for #456432 -(Windowless Crash) Flash 10 w/ Firefox 3
391
392* Wed Sep 17 2008 Martin Stransky <stransky@redhat.com> 1.1.0-6
393- Added libcurl to requires (#460988)
394
395* Mon Aug 04 2008 Martin Stransky <stransky@redhat.com> 1.1.0-5
396- Added fix for #456432 -(Windowless Crash) Flash 10 w/ Firefox 3
397
398* Mon Jul 21 2008 Martin Stransky <stransky@redhat.com> 1.1.0-4
399- Removed gecko-libs from requieres (it's not needed now)
400
401* Tue Jul 18 2008 Martin Stransky <stransky@redhat.com> 1.1.0-3
402- Enabled experimental stand-alone plugin player
403
404* Tue Jul 15 2008 Martin Stransky <stransky@redhat.com> 1.1.0-2
405- Fixed build warnings in our patches
406
407* Tue Jul 8 2008 Martin Stransky <stransky@redhat.com> 1.1.0-1
408- update to latest upstream version (1.1.0)
409
410* Mon May 5 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-28
411- link pluginwrapper with stdc++ lib
412
413* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 0.9.91.5-27
414- mozilla-filesystem now owns the plugin source dir
415
416* Tue Mar 11 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-26
417- /etc/sysconfig/nspluginwrapper marked as config file
418- exclude some player plugins
419
420* Mon Mar 10 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-25
421- updated the sleep patch
422
423* Thu Mar 06 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-24
424- added experimental patch for #426968 - nspluginwrapper wakes up too much
425
426* Tue Feb 26 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-23
427- merged exclude patch with main tarball
428- fixed #431095 - Typo in mozilla-plugin-config verbose output
429
430* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.91.5-22
431- Autorebuild for GCC 4.3
432
433* Mon Jan 21 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-21
434- fixed #426618 - gcjwebplugin error: Failed to run
435  (added to ignored plugins)
436
437* Mon Jan 14 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-20
438- fixed #426176 - Orphaned npviewer.bin processes
439
440* Thu Jan 10 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-19
441- xulrunner rebuild
442- fixed build script, added gthread-2.0
443
444* Mon Dec 24 2007 Warren Togami <wtogami@redhat.com> 0.9.91.5-18
445- Make nsviewer.bin initialized for multithreading, fixes #360891
446
447* Tue Dec 20 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-17
448- disabled xpcom support - it causes more troubles than advantages
449
450* Tue Dec 13 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-16
451- spec fixes
452- fixed xulrunner support
453
454* Mon Dec 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-15
455- updated configure script - gecko selection
456
457* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-14
458- enabled xpcom support
459- added fix for #393541 - scripts will never fail
460
461* Fri Nov 23 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-13
462- rebuilt against xulrunner
463
464* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-12
465- more fixes from review by security standards team
466
467* Wed Oct 31 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-11
468- added fixes from review by security standards team
469
470* Fri Oct 26 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-10
471- mozilla-plugin-config can be run by normal user now
472
473* Wed Oct 24 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-9
474- Updated config utility - removes dangling symlinks and
475  wrapped plugins
476 
477* Tue Oct 23 2007 Jeremy Katz <katzj@redhat.com> 0.9.91.5-8
478- Rebuild against new firefox
479
480* Mon Oct 15 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-7
481- added a fix for #281061 - gnash fails when wrapped, works when native
482
483* Wed Oct 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-6
484- removed possibble deadlock during plugin restart
485
486* Tue Oct 9 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-5
487- fixed browser crashes (#290901)
488
489* Mon Oct 1 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-4
490- quit the plugin when browser crashes (#290901)
491
492* Fri Sep 21 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-3
493- added original plugin dir to the package
494
495* Mon Sep 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-2
496- added upstream patches - RPC error handling and plugin restart
497
498* Mon Aug 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-1
499- update to the latest upstream
500
501* Mon Aug 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-19
502- converted rpc error handling code to a thread-safe variant
503- added a time limit to plugin restart
504
505* Tue Aug 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-18
506- implemented plugin restart (#251530)
507
508* Tue Aug 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-17
509- fixed an installation script (#251698)
510
511* Mon Aug 13 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-16
512- fixed plugins check
513- minor spec fixes
514
515* Fri Aug 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-15
516- removed mozembeded dependency
517- excluded totem plugins from wrapping
518- xpcom support is optional now
519
520* Thu Aug 9 2007 Christopher Aillon <caillon@redhat.com> 0.9.91.4-14
521- Rebuild against newer gecko
522
523* Wed Aug 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-13
524- removed unsafe plugins probe
525- added agruments to mozilla-plugin-config
526
527* Tue Aug 7 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-12
528- removed fake libxpcom
529
530* Mon Aug 6 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-11
531- added gecko dependency
532- added plugin configuration utility
533
534* Fri Aug 3 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-10
535- fixed totem-complex plugin wrapping
536
537* Mon Jul 30 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-9
538- added plugin dirs
539
540* Fri Jul 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-8
541- added switch for creating debug packages
542
543* Thu Jul 19 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-7
544- integrated with firefox / seamonkey
545
546* Tue Jul 11 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-6
547- added new options to the configuration utility
548- modified along new plug-ins concept
549
550* Thu Jun 19 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-5
551- updated nspluginsetup script
552- added support for x86_64 plug-ins
553
554* Thu Jun 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-4
555- added ppc arch
556- silenced installation scripts
557- moved configuration to /etc/sysconfig
558
559* Thu Jun 12 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-3
560- updated nspluginsetup script and package install/uninstall scripts
561- added cross-compilation support
562- removed binaries stripping
563
564* Fri Jun 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-2
565- added BuildRequires - pkgconfig, gtk2-devel, glib, libXt-devel
566
567* Fri Jun 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-1
568- initial build
Note: See TracBrowser for help on using the repository browser.