source: projects/specs/trunk/n/nspluginwrapper/nspluginwrapper-vl.spec @ 1713

Revision 1713, 16.3 KB checked in by inagaki, 14 years ago (diff)

update: libflashsupport, libmediainfo, libzen, nspluginswrapper, xlockmore

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3# Compile as a debug package
4%define make_debug_package      0
5
6# What gecko we use
7%define gecko_flavour           "mozilla"
8
9%define plugin_config_version 1.9
10%define plugin_config_name plugin-config-%{plugin_config_version}
11%define plugin_config_binary plugin-config
12
13# Excluded plugins (separated by ':')
14%define exclude_list            "libtotem*:libjavaplugin*:gecko-mediaplayer*:mplayerplug-in*:librhythmbox*"
15
16# Target defines
17%if "%{_target_cpu}" == "i386"
18%define target_bits     32
19%endif
20
21%if "%{_target_cpu}" == "i586"
22%define target_bits     32
23%endif
24
25%if "%{_target_cpu}" == "i686"
26%define target_bits     32
27%endif
28
29%if "%{_target_cpu}" == "ppc"
30%define target_bits     32
31%endif
32
33%if "%{_target_cpu}" == "x86_64"
34%define target_bits     64
35%endif
36
37%if "%{_target_cpu}" == "ppc64"
38%define target_bits     64
39%endif
40
41# Define libraries for 32/64 arches
42%define lib32                   lib
43%define lib64                   lib64
44%define libdir32                /usr/lib
45%define libdir64                /usr/lib64
46
47# define nspluginswrapper libdir (invariant, including libdir)
48%define pkgdir32                %{libdir32}/%{name}
49%define pkgdir64                %{libdir64}/%{name}
50
51# define mozilla plugin dir and back up dir for 32-bit browsers
52%define pluginsourcedir32       %{libdir32}/mozilla/plugins
53%define plugindir32             %{libdir32}/mozilla/plugins-wrapped
54
55# define mozilla plugin dir and back up dir for 64-bit browsers
56%define pluginsourcedir64       %{libdir64}/mozilla/plugins
57%define plugindir64             %{libdir64}/mozilla/plugins-wrapped
58
59%define build_dir               objs-%{target_bits}
60
61%if "%{target_bits}" == "32"
62%define lib             %{lib32}
63%define libdir          %{libdir32}
64%define pkgdir          %{pkgdir32}
65%define plugindir       %{plugindir32}
66%define pluginsourcedir %{pluginsourcedir32}
67%else
68%define lib             %{lib64}
69%define libdir          %{libdir64}
70%define pkgdir          %{pkgdir64}
71%define plugindir       %{plugindir64}
72%define pluginsourcedir %{pluginsourcedir64}
73%endif
74
75Summary:        A compatibility layer for Netscape 4 plugins
76Name:           nspluginwrapper
77Version:        1.3.0
78Release:        2%{?_dist_release}
79Source0:        %{name}-%{version}%{?svndate:-%{svndate}}.tar.bz2
80Source1:        %{plugin_config_name}.tar.gz
81Source2:        plugin-config.sh.in
82Source3:        %{name}.sh.in
83Patch1:         nspluginwrapper-1.3.0-make.patch
84Patch2:         nspluginwrapper-1.3.0-configure.patch
85Patch3:         nspluginwrapper-1.3.0-directory.patch
86Patch100:       plugin-config-setuid.patch
87Patch101:       plugin-config-umask.patch
88Patch102:       plugin-config-print.patch
89Patch103:       plugin-config-native.patch
90
91License:        GPLv2+
92Group:          Applications/Internet
93URL:            http://gwenole.beauchesne.info/projects/nspluginwrapper/
94
95BuildRoot:      %{_tmppath}/%{name}-%{version}-root
96Provides:       %{name} = %{version}-%{release}
97#Requires:      mozilla-filesystem
98%ifarch x86_64
99Requires:       compat32-%{name} = %{version}-%{release}
100%endif
101BuildRequires:  pkgconfig gtk2-devel glib2-devel nspr-devel
102BuildRequires:  libX11-devel libXt-devel cairo-devel pango-devel curl-devel
103BuildRequires:  gecko-devel
104ExclusiveArch:  %{ix86} x86_64 ppc
105
106%description
107nspluginwrapper makes it possible to use Netscape 4 compatible plugins
108compiled for %{_arch} into Mozilla for another architecture, e.g. x86_64.
109
110This package consists in:
111  * npviewer: the plugin viewer
112  * npwrapper.so: the browser-side plugin
113  * nspluginplayer: stand-alone NPAPI plugin player
114  * mozilla-plugin-config: a tool to manage plugins installation and update
115
116## to build compat32 for x86_64 architecture support
117%package -n compat32-%{name}
118Summary:        A compatibility layer for Netscape 4 plugins
119Group: System Environment/Libraries
120
121%description -n compat32-%{name}
122nspluginwrapper makes it possible to use Netscape 4 compatible plugins
123compiled for %{_arch} into Mozilla for another architecture, e.g. x86_64.
124
125This package consists in:
126  * npviewer: the plugin viewer
127  * npwrapper.so: the browser-side plugin
128  * nspluginplayer: stand-alone NPAPI plugin player
129  * mozilla-plugin-config: a tool to manage plugins installation and update
130
131
132%prep
133%setup  -q -a 1
134
135# Installation & build patches
136%patch1 -p1 -b .make
137%patch2 -p1 -b .conf
138%patch3 -p1 -b .dir
139
140# Plugin-config patches
141pushd %plugin_config_name
142%patch100 -p2
143%patch101 -p2 -b .umask
144%patch102 -p2 -b .print
145%patch103 -p2 -b .native
146popd
147
148%build
149# Build wrapper
150
151# set the propper built options
152%if %{make_debug_package}
153    %if "%{target_bits}" == "64"
154        export CFLAGS="-g -m64 -DDEBUG"
155    %else
156        export CFLAGS="-g -m32 -DDEBUG"
157    %endif
158%else
159    export CFLAGS="$RPM_OPT_FLAGS"
160%endif
161
162# set the propper built options
163%if "%{target_bits}" == "64"
164    export LDFLAGS="-m64 -L%{libdir64}"
165%else
166    export LDFLAGS="-m32 -L%{libdir32}"
167%endif
168
169mkdir %{build_dir}
170pushd %{build_dir}
171../configure                                    \
172            --prefix=%{_prefix}                 \
173            --target-cpu=%{_target_cpu}         \
174            --pkgdir=%{name}                    \
175            --pkglibdir=%{pkgdir}               \
176            --with-lib32=%{lib32}               \
177            --with-lib64=%{lib64}               \
178            --with-base-lib=%{lib}              \
179            --with-base-libdir=%{libdir}        \
180            --viewer-paths=%{pkgdir}            \
181            --with-x11-prefix=/usr              \
182            --with-gecko=%{gecko_flavour}       \
183            --enable-viewer                     \
184            --viewer-paths="%{pkgdir32}:%{pkgdir64}"\
185            --disable-biarch
186       
187make
188popd
189
190#Build plugin configuration utility
191pushd %{plugin_config_name}
192./configure --prefix=/usr CFLAGS="$RPM_OPT_FLAGS"
193make
194popd
195
196%install
197rm -rf $RPM_BUILD_ROOT
198
199mkdir -p $RPM_BUILD_ROOT%{_bindir}
200mkdir -p $RPM_BUILD_ROOT%{plugindir}
201mkdir -p $RPM_BUILD_ROOT%{pluginsourcedir}
202mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
203
204make -C %{build_dir} install DESTDIR=$RPM_BUILD_ROOT
205
206ln -s %{pkgdir}/npwrapper.so $RPM_BUILD_ROOT/%{plugindir}/npwrapper.so
207
208# Install plugin-config utility
209pushd %{plugin_config_name}
210DESTDIR=$RPM_BUILD_ROOT make install
211popd
212
213cd $RPM_BUILD_ROOT/usr/bin
214mv %{plugin_config_binary} $RPM_BUILD_ROOT/%{pkgdir}
215cd -
216
217rm -rf $RPM_BUILD_ROOT/usr/doc/plugin-config
218
219cat %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-plugin-config
220chmod 755 $RPM_BUILD_ROOT%{_bindir}/mozilla-plugin-config
221
222cat %{SOURCE3} | %{__sed} -e "s|EXCLUDE_LIST|%{exclude_list}|g" \
223    > $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
224chmod 644 $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
225
226# set up nsplugin player starting script
227%{__cat} > $RPM_BUILD_ROOT%{pkgdir}/nspluginplayer << EOF
228export MOZ_PLUGIN_PATH=%{pluginsourcedir}
229%{pkgdir}/npplayer "$@"
230EOF
231chmod 755 $RPM_BUILD_ROOT%{pkgdir}/nspluginplayer
232
233# Remove conflicting files
234rm -rf $RPM_BUILD_ROOT%{_bindir}/nspluginplayer
235rm -rf $RPM_BUILD_ROOT%{_bindir}/nspluginwrapper
236
237## <mozilla-filesystem>
238mkdir -p $RPM_BUILD_ROOT/usr/{lib,%{_lib}}/mozilla/{plugins,extensions}
239mkdir -p $RPM_BUILD_ROOT/%{_datadir}/mozilla/extensions
240mkdir -p $RPM_BUILD_ROOT/etc/skel/.mozilla/{plugins,extensions}
241## </mozilla-filesystem>
242
243%clean
244rm -rf $RPM_BUILD_ROOT
245
246%post
247/usr/bin/mozilla-plugin-config -i -f > /dev/null 2>&1 || :
248
249%preun
250if [ "$1" == "0" ]; then
251    /usr/bin/mozilla-plugin-config -r > /dev/null 2>&1 || :
252fi;
253
254%files
255%defattr(-,root,root)
256%doc README COPYING NEWS
257%dir %{pkgdir}
258%dir %{plugindir}
259
260%{pkgdir}/%{plugin_config_binary}
261%{pkgdir}/npconfig
262%{pkgdir}/npwrapper.so
263%{pkgdir}/npviewer.bin
264%{pkgdir}/npviewer.sh
265%{pkgdir}/npviewer
266%{pkgdir}/npplayer
267%{pkgdir}/libxpcom.so
268%{pkgdir}/libnoxshm.so
269%{pkgdir}/nspluginplayer
270%{plugindir}/npwrapper.so
271%{_bindir}/mozilla-plugin-config
272%config %{_sysconfdir}/sysconfig/%{name}
273
274## <mozilla-filesystem>
275/usr/lib*/mozilla
276%{_datadir}/mozilla
277/etc/skel/.mozilla
278## </mozilla-filesystem>
279
280
281## to build compat32 for x86_64 architecture support
282%if %{build_compat32}
283%files -n compat32-%{name}
284%defattr(-,root,root)
285%dir %{pkgdir}
286%dir %{plugindir}
287
288%{pkgdir}/%{plugin_config_binary}
289%{pkgdir}/npconfig
290%{pkgdir}/npwrapper.so
291%{pkgdir}/npviewer.bin
292%{pkgdir}/npviewer.sh
293%{pkgdir}/npviewer
294%{pkgdir}/npplayer
295%{pkgdir}/libxpcom.so
296%{pkgdir}/libnoxshm.so
297%{pkgdir}/nspluginplayer
298%{plugindir}/npwrapper.so
299%endif
300
301
302%changelog
303* Sat Aug 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-2
304- changed Group to System Environment/Libraries
305
306* Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.0-1
307- initial release
308  - ported from Fedora development package
309
310* Tue Mar 03 2009 Warren Togami <wtogami@redhat.com> - 1.3.0-5
311- Really Fix x86 32bit build (#488308)
312
313* Sun Mar 01 2009 Warren Togami <wtogami@redhat.com> - 1.3.0-4
314- Fix x86 32bit build
315
316* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
317- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
318
319* Thu Jan 9 2009 Martin Stransky <stransky@redhat.com> 1.3.0-2
320- Fixed multilib conflicts
321
322* Thu Jan 8 2009 Martin Stransky <stransky@redhat.com> 1.3.0-1
323- Updated to 1.3.0 and removed some fedora build patches
324
325* Tue Dec 02 2008 Warren Togami <wtogami@redhat.com> 1.1.8-2
326- fix-invalid-RPC-after-NPP_Destroy fixes a crasher
327
328* Mon Dec 1 2008 Martin Stransky <stransky@redhat.com> 1.1.8-1
329- Updated to 1.1.8
330- Removed already upstreamed patches
331
332* Wed Nov 12 2008 Martin Stransky <stransky@redhat.com> 1.1.4-1
333- Updated to 1.1.4
334- Consolidated build patches
335
336* Wed Oct 22 2008 Martin Stransky <stransky@redhat.com> 1.1.2-4
337- Fixed #449338 - mozilla-plugin-config segfaults with -v argument
338
339* Tue Oct 21 2008 Martin Stransky <stransky@redhat.com> 1.1.2-3
340- Removed event patch, it blocks X events and breaks Adobe pdf plugin
341- Removed event limit in xt_event_polling_timer_callback
342
343* Fri Oct 17 2008 Martin Stransky <stransky@redhat.com> 1.1.2-2
344- added umask to plugin config (#463736)
345
346* Thu Oct 16 2008 Martin Stransky <stransky@redhat.com> 1.1.2-1
347- updated to 1.1.12
348- added librhythmbox* to ignored plugins (#467187)
349- removed debug prints (#467090)
350
351* Mon Oct 06 2008 Warren Togami <wtogami@redhat.com> 1.1.0-11
352- Unrevert patch from -7 because Warren was wrong
353- Concurrent rpc_method_invoke() patch
354
355* Fri Oct 03 2008 Warren Togami <wtogami@redhat.com> 1.1.0-10
356- Revert libcurl requires because it was done in an incorrect way
357- Revert patch from -7 because it made things worse
358
359* Tue Sep 30 2008 Martin Stransky <stransky@redhat.com> 1.1.0-7
360- Updated fix for #456432 -(Windowless Crash) Flash 10 w/ Firefox 3
361
362* Wed Sep 17 2008 Martin Stransky <stransky@redhat.com> 1.1.0-6
363- Added libcurl to requires (#460988)
364
365* Mon Aug 04 2008 Martin Stransky <stransky@redhat.com> 1.1.0-5
366- Added fix for #456432 -(Windowless Crash) Flash 10 w/ Firefox 3
367
368* Mon Jul 21 2008 Martin Stransky <stransky@redhat.com> 1.1.0-4
369- Removed gecko-libs from requieres (it's not needed now)
370
371* Tue Jul 18 2008 Martin Stransky <stransky@redhat.com> 1.1.0-3
372- Enabled experimental stand-alone plugin player
373
374* Tue Jul 15 2008 Martin Stransky <stransky@redhat.com> 1.1.0-2
375- Fixed build warnings in our patches
376
377* Tue Jul 8 2008 Martin Stransky <stransky@redhat.com> 1.1.0-1
378- update to latest upstream version (1.1.0)
379
380* Mon May 5 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-28
381- link pluginwrapper with stdc++ lib
382
383* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 0.9.91.5-27
384- mozilla-filesystem now owns the plugin source dir
385
386* Tue Mar 11 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-26
387- /etc/sysconfig/nspluginwrapper marked as config file
388- exclude some player plugins
389
390* Mon Mar 10 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-25
391- updated the sleep patch
392
393* Thu Mar 06 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-24
394- added experimental patch for #426968 - nspluginwrapper wakes up too much
395
396* Tue Feb 26 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-23
397- merged exclude patch with main tarball
398- fixed #431095 - Typo in mozilla-plugin-config verbose output
399
400* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.91.5-22
401- Autorebuild for GCC 4.3
402
403* Mon Jan 21 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-21
404- fixed #426618 - gcjwebplugin error: Failed to run
405  (added to ignored plugins)
406
407* Mon Jan 14 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-20
408- fixed #426176 - Orphaned npviewer.bin processes
409
410* Thu Jan 10 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-19
411- xulrunner rebuild
412- fixed build script, added gthread-2.0
413
414* Mon Dec 24 2007 Warren Togami <wtogami@redhat.com> 0.9.91.5-18
415- Make nsviewer.bin initialized for multithreading, fixes #360891
416
417* Tue Dec 20 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-17
418- disabled xpcom support - it causes more troubles than advantages
419
420* Tue Dec 13 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-16
421- spec fixes
422- fixed xulrunner support
423
424* Mon Dec 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-15
425- updated configure script - gecko selection
426
427* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-14
428- enabled xpcom support
429- added fix for #393541 - scripts will never fail
430
431* Fri Nov 23 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-13
432- rebuilt against xulrunner
433
434* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-12
435- more fixes from review by security standards team
436
437* Wed Oct 31 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-11
438- added fixes from review by security standards team
439
440* Fri Oct 26 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-10
441- mozilla-plugin-config can be run by normal user now
442
443* Wed Oct 24 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-9
444- Updated config utility - removes dangling symlinks and
445  wrapped plugins
446 
447* Tue Oct 23 2007 Jeremy Katz <katzj@redhat.com> 0.9.91.5-8
448- Rebuild against new firefox
449
450* Mon Oct 15 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-7
451- added a fix for #281061 - gnash fails when wrapped, works when native
452
453* Wed Oct 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-6
454- removed possibble deadlock during plugin restart
455
456* Tue Oct 9 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-5
457- fixed browser crashes (#290901)
458
459* Mon Oct 1 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-4
460- quit the plugin when browser crashes (#290901)
461
462* Fri Sep 21 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-3
463- added original plugin dir to the package
464
465* Mon Sep 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-2
466- added upstream patches - RPC error handling and plugin restart
467
468* Mon Aug 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-1
469- update to the latest upstream
470
471* Mon Aug 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-19
472- converted rpc error handling code to a thread-safe variant
473- added a time limit to plugin restart
474
475* Tue Aug 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-18
476- implemented plugin restart (#251530)
477
478* Tue Aug 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-17
479- fixed an installation script (#251698)
480
481* Mon Aug 13 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-16
482- fixed plugins check
483- minor spec fixes
484
485* Fri Aug 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-15
486- removed mozembeded dependency
487- excluded totem plugins from wrapping
488- xpcom support is optional now
489
490* Thu Aug 9 2007 Christopher Aillon <caillon@redhat.com> 0.9.91.4-14
491- Rebuild against newer gecko
492
493* Wed Aug 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-13
494- removed unsafe plugins probe
495- added agruments to mozilla-plugin-config
496
497* Tue Aug 7 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-12
498- removed fake libxpcom
499
500* Mon Aug 6 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-11
501- added gecko dependency
502- added plugin configuration utility
503
504* Fri Aug 3 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-10
505- fixed totem-complex plugin wrapping
506
507* Mon Jul 30 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-9
508- added plugin dirs
509
510* Fri Jul 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-8
511- added switch for creating debug packages
512
513* Thu Jul 19 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-7
514- integrated with firefox / seamonkey
515
516* Tue Jul 11 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-6
517- added new options to the configuration utility
518- modified along new plug-ins concept
519
520* Thu Jun 19 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-5
521- updated nspluginsetup script
522- added support for x86_64 plug-ins
523
524* Thu Jun 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-4
525- added ppc arch
526- silenced installation scripts
527- moved configuration to /etc/sysconfig
528
529* Thu Jun 12 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-3
530- updated nspluginsetup script and package install/uninstall scripts
531- added cross-compilation support
532- removed binaries stripping
533
534* Fri Jun 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-2
535- added BuildRequires - pkgconfig, gtk2-devel, glib, libXt-devel
536
537* Fri Jun 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-1
538- initial build
Note: See TracBrowser for help on using the repository browser.