source: projects/specs/trunk/n/ninja/ninja-vl.spec @ 11190

Revision 11190, 4.8 KB checked in by tomop, 7 years ago (diff)

ninja-1.7.2-1

Line 
1Name:           ninja
2Version:        1.7.2
3Release:        1%{?_dist_release}
4Summary:        A small build system with a focus on speed
5Summary(ja):    スピードを重視した小さなビルドシステム
6Group:          Development/Tools
7License:        ASL 2.0
8URL:            http://martine.github.com/ninja/
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12Source0:        https://github.com/martine/ninja/archive/v%{version}.tar.gz#/ninja-%{version}.tar.gz
13Source1:        macros.ninja
14Source2:        ninja.vim
15BuildRequires:  asciidoc
16BuildRequires:  gtest-devel
17BuildRequires:  python-devel
18BuildRequires:  re2c >= 0.11.3
19
20%description
21Ninja is a small build system with a focus on speed. It differs from other
22build systems in two major respects: it is designed to have its input files
23generated by a higher-level build system, and it is designed to run builds as
24fast as possible.
25
26%package vim
27Summary:     macros and syntax files of ninja for vim
28Summary(ja): VIM用のninjaマクロ・文法ファイル
29Group:       Development/Tools
30Requires:    vim-common
31
32%description vim
33 This package contains macros and syntax files of ninja for vim.
34
35%prep
36%setup -qn ninja-%{version}
37
38%build
39CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" \
40%{__python} configure.py --bootstrap --verbose
41./ninja -v manual
42./ninja -v ninja_test
43
44%install
45# TODO: Install ninja_syntax.py?
46mkdir -p %{buildroot}/{%{_bindir},%{_datadir}/bash-completion/completions,%{_datadir}/emacs/site-lisp,%{_datadir}/vim/vimfiles/syntax,%{_datadir}/vim/vimfiles/ftdetect,%{_datadir}/zsh/site-functions}
47
48install -pm755 ninja %{buildroot}%{_bindir}/ninja
49ln -sf ninja %{buildroot}%{_bindir}/ninja-build
50install -pm644 misc/bash-completion %{buildroot}%{_datadir}/bash-completion/completions/ninja-bash-completion
51install -pm644 misc/ninja-mode.el %{buildroot}%{_datadir}/emacs/site-lisp/ninja-mode.el
52install -pm644 misc/ninja.vim %{buildroot}%{_datadir}/vim/vimfiles/syntax/ninja.vim
53install -pm644 %{SOURCE2} %{buildroot}%{_datadir}/vim/vimfiles/ftdetect/ninja.vim
54install -pm644 misc/zsh-completion %{buildroot}%{_datadir}/zsh/site-functions/_ninja
55
56mkdir -p %{buildroot}%{_sysconfdir}/rpm
57install -pm644 %{SOURCE1} %{buildroot}%{_sysconfdir}/rpm/macros.ninja
58
59%check
60# workaround possible too low default limits
61ulimit -n 4096 && ulimit -u 4096
62./ninja_test
63
64%files
65%doc COPYING HACKING.md README doc/manual.html
66%{_sysconfdir}/rpm/macros.ninja
67%{_bindir}/ninja
68%{_bindir}/ninja-build
69%{_datadir}/bash-completion/completions/ninja-bash-completion
70%{_datadir}/emacs/site-lisp/ninja-mode.el
71# zsh does not have a -filesystem package
72%{_datadir}/zsh/
73
74
75%files vim
76%{_datadir}/vim/vimfiles/syntax/ninja.vim
77%{_datadir}/vim/vimfiles/ftdetect/ninja.vim
78
79
80%changelog
81* Mon Sep 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-1
82- updated to 1.7.2.
83- added rpmmacros.
84- added a subpackage ninja-vim.
85
86* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
87- updated to 1.7.1.
88
89* Mon Jan 18 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-1
90- update to 1.6.0
91- remove R: vim, emacsen
92  (TODO: vim or el should be splitted to subpackage)
93- add ninja-build symlink to compatible with other rpm distros.
94
95* Thu Jun 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.0-1
96- initial build for Vine Linux
97
98* Wed Nov 20 2013 Ben Boeckel <mathstuf@gmail.com> - 1.4.0-1
99- Update to 1.4.0
100
101* Sun Nov  3 2013 Ville Skyttä <ville.skytta@iki.fi> - 1.3.4-4
102- Use special %%doc to install all docs (#994005).
103
104* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-3
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
106
107* Fri Jun 21 2013 Dan Horák <dan[at]danny.cz> - 1.3.4-2
108- workaround possible too low limits for number of processes and open files,
109  fixes build on ppc/ppc64 and s390(x)
110
111* Sun Jun 09 2013 Ben Boeckel <mathstuf@gmail.com> - 1.3.4-1
112- Update to 1.3.4
113- Run test suite
114
115* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
116- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
117
118* Sun Nov 04 2012 Ben Boeckel <mathstuf@gmail.com> - 1.0.0-1
119- Update to 1.0.0
120
121* Thu Jul 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.6.20120719git5dc55a3
122- Update to new snapshot
123
124* Mon Jul 09 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.5.20120709gitb90d038
125- Preserve timestamps on install
126- Install as ninja-build to avoid conflicts with the ninja IRC package
127- Update snapshot
128
129* Tue Jun 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.4.20120605git54553d3
130- Add an ftdetect file for ninja
131- Fix zsh-stuff directory ownership
132
133* Thu Jun 07 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.3.20120605git54553d3
134- Add a Group tag
135
136* Tue Jun 05 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.2.20120605git54553d3
137- Update to new snapshot
138
139* Fri Mar 30 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.1.20120330gitabd33d5
140- Initial package
Note: See TracBrowser for help on using the repository browser.