source: projects/specs/trunk/n/ninja/ninja-vl.spec @ 11189

Revision 11189, 4.2 KB checked in by tomop, 7 years ago (diff)

ninja-1.7.1-1

Line 
1Name:           ninja
2Version:        1.7.1
3Release:        1%{?_dist_release}
4Summary:        A small build system with a focus on speed
5Summary(ja):    スピードを重視した小さなビルドシステム
6License:        ASL 2.0
7URL:            http://martine.github.com/ninja/
8Vendor:         Project Vine
9Distribution:   Vine Linux
10
11Source0:        https://github.com/martine/ninja/archive/v%{version}.tar.gz#/ninja-%{version}.tar.gz
12Source1:        ninja.vim
13BuildRequires:  asciidoc
14BuildRequires:  gtest-devel
15BuildRequires:  python-devel
16BuildRequires:  re2c >= 0.11.3
17
18%description
19Ninja is a small build system with a focus on speed. It differs from other
20build systems in two major respects: it is designed to have its input files
21generated by a higher-level build system, and it is designed to run builds as
22fast as possible.
23
24%prep
25%setup -qn ninja-%{version}
26
27%build
28CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" \
29%{__python} configure.py --bootstrap --verbose
30./ninja -v manual
31./ninja -v ninja_test
32
33%install
34# TODO: Install ninja_syntax.py?
35mkdir -p %{buildroot}/{%{_bindir},%{_datadir}/bash-completion/completions,%{_datadir}/emacs/site-lisp,%{_datadir}/vim/vimfiles/syntax,%{_datadir}/vim/vimfiles/ftdetect,%{_datadir}/zsh/site-functions}
36
37install -pm755 ninja %{buildroot}%{_bindir}/ninja
38ln -sf ninja %{buildroot}%{_bindir}/ninja-build
39install -pm644 misc/bash-completion %{buildroot}%{_datadir}/bash-completion/completions/ninja-bash-completion
40install -pm644 misc/ninja-mode.el %{buildroot}%{_datadir}/emacs/site-lisp/ninja-mode.el
41install -pm644 misc/ninja.vim %{buildroot}%{_datadir}/vim/vimfiles/syntax/ninja.vim
42install -pm644 %{SOURCE1} %{buildroot}%{_datadir}/vim/vimfiles/ftdetect/ninja.vim
43install -pm644 misc/zsh-completion %{buildroot}%{_datadir}/zsh/site-functions/_ninja
44
45%check
46# workaround possible too low default limits
47ulimit -n 4096 && ulimit -u 4096
48./ninja_test
49
50%files
51%doc COPYING HACKING.md README doc/manual.html
52%{_bindir}/ninja
53%{_bindir}/ninja-build
54%{_datadir}/bash-completion/completions/ninja-bash-completion
55%{_datadir}/emacs/site-lisp/ninja-mode.el
56%{_datadir}/vim/vimfiles/syntax/ninja.vim
57%{_datadir}/vim/vimfiles/ftdetect/ninja.vim
58# zsh does not have a -filesystem package
59%{_datadir}/zsh/
60
61%changelog
62* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
63- updated to 1.7.1.
64
65* Mon Jan 18 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-1
66- update to 1.6.0
67- remove R: vim, emacsen
68  (TODO: vim or el should be splitted to subpackage)
69- add ninja-build symlink to compatible with other rpm distros.
70
71* Thu Jun 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.0-1
72- initial build for Vine Linux
73
74* Wed Nov 20 2013 Ben Boeckel <mathstuf@gmail.com> - 1.4.0-1
75- Update to 1.4.0
76
77* Sun Nov  3 2013 Ville Skyttä <ville.skytta@iki.fi> - 1.3.4-4
78- Use special %%doc to install all docs (#994005).
79
80* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-3
81- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
82
83* Fri Jun 21 2013 Dan Horák <dan[at]danny.cz> - 1.3.4-2
84- workaround possible too low limits for number of processes and open files,
85  fixes build on ppc/ppc64 and s390(x)
86
87* Sun Jun 09 2013 Ben Boeckel <mathstuf@gmail.com> - 1.3.4-1
88- Update to 1.3.4
89- Run test suite
90
91* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
92- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
93
94* Sun Nov 04 2012 Ben Boeckel <mathstuf@gmail.com> - 1.0.0-1
95- Update to 1.0.0
96
97* Thu Jul 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.6.20120719git5dc55a3
98- Update to new snapshot
99
100* Mon Jul 09 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.5.20120709gitb90d038
101- Preserve timestamps on install
102- Install as ninja-build to avoid conflicts with the ninja IRC package
103- Update snapshot
104
105* Tue Jun 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.4.20120605git54553d3
106- Add an ftdetect file for ninja
107- Fix zsh-stuff directory ownership
108
109* Thu Jun 07 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.3.20120605git54553d3
110- Add a Group tag
111
112* Tue Jun 05 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.2.20120605git54553d3
113- Update to new snapshot
114
115* Fri Mar 30 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.1.20120330gitabd33d5
116- Initial package
Note: See TracBrowser for help on using the repository browser.