source: projects/specs/trunk/n/ninja/ninja-vl.spec @ 12383

Revision 12383, 4.9 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

OpenEXR-2.4.1-1

ipset-7.6-1

meson-0.54.0-1

ninja-1.10.0-1

postsrsd-1.6-2

stunnel-5.56-1

ulogd-2.0.7-2

Line 
1Name:           ninja
2Version:        1.10.0
3Release:        1%{?_dist_release}
4Summary:        A small build system with a focus on speed
5Summary(ja):    スピードを重視した小さなビルドシステム
6Group:          Development/Tools
7Vendor:         Project Vine
8Distribution:   Vine Linux
9
10License:        ASL 2.0
11URL:            https://ninja-build.org/
12Source0:        https://github.com/martine/ninja/archive/v%{version}.tar.gz#/ninja-%{version}.tar.gz
13Source1:        macros.ninja
14Source2:        ninja.vim
15
16BuildRequires:  asciidoc
17BuildRequires:  gtest-devel
18BuildRequires:  python-devel
19BuildRequires:  re2c >= 0.11.3
20
21%description
22Ninja is a small build system with a focus on speed. It differs from other
23build systems in two major respects: it is designed to have its input files
24generated by a higher-level build system, and it is designed to run builds as
25fast as possible.
26
27%package vim
28Summary:     macros and syntax files of ninja for vim
29Summary(ja): VIM用のninjaマクロ・文法ファイル
30Group:       Development/Tools
31Requires:    vim-common
32
33%description vim
34 This package contains macros and syntax files of ninja for vim.
35
36%prep
37%setup -qn ninja-%{version}
38
39%build
40CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" \
41%{__python} configure.py --bootstrap --verbose
42./ninja -v manual
43./ninja -v ninja_test
44
45%install
46# TODO: Install ninja_syntax.py?
47mkdir -p %{buildroot}/{%{_bindir},%{_datadir}/bash-completion/completions,%{_datadir}/emacs/site-lisp,%{_datadir}/vim/vimfiles/syntax,%{_datadir}/vim/vimfiles/ftdetect,%{_datadir}/zsh/site-functions}
48
49install -pm755 ninja %{buildroot}%{_bindir}/ninja
50ln -sf ninja %{buildroot}%{_bindir}/ninja-build
51install -pm644 misc/bash-completion %{buildroot}%{_datadir}/bash-completion/completions/ninja-bash-completion
52install -pm644 misc/ninja-mode.el %{buildroot}%{_datadir}/emacs/site-lisp/ninja-mode.el
53install -pm644 misc/ninja.vim %{buildroot}%{_datadir}/vim/vimfiles/syntax/ninja.vim
54install -pm644 %{SOURCE2} %{buildroot}%{_datadir}/vim/vimfiles/ftdetect/ninja.vim
55install -pm644 misc/zsh-completion %{buildroot}%{_datadir}/zsh/site-functions/_ninja
56
57mkdir -p %{buildroot}%{_sysconfdir}/rpm
58install -pm644 %{SOURCE1} %{buildroot}%{_sysconfdir}/rpm/macros.ninja
59
60%check
61# workaround possible too low default limits
62ulimit -n 4096 && ulimit -u 4096
63./ninja_test
64
65%files
66%license
67%doc HACKING.md README doc/manual.html
68%{_sysconfdir}/rpm/macros.ninja
69%{_bindir}/ninja
70%{_bindir}/ninja-build
71%{_datadir}/bash-completion/completions/ninja-bash-completion
72%{_datadir}/emacs/site-lisp/ninja-mode.el
73# zsh does not have a -filesystem package
74%{_datadir}/zsh/
75
76
77%files vim
78%{_datadir}/vim/vimfiles/syntax/ninja.vim
79%{_datadir}/vim/vimfiles/ftdetect/ninja.vim
80
81
82%changelog
83* Sun Apr 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-1
84- new upstream release.
85
86* Mon Sep 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-1
87- updated to 1.7.2.
88- added rpmmacros.
89- added a subpackage ninja-vim.
90
91* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
92- updated to 1.7.1.
93
94* Mon Jan 18 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-1
95- update to 1.6.0
96- remove R: vim, emacsen
97  (TODO: vim or el should be splitted to subpackage)
98- add ninja-build symlink to compatible with other rpm distros.
99
100* Thu Jun 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.0-1
101- initial build for Vine Linux
102
103* Wed Nov 20 2013 Ben Boeckel <mathstuf@gmail.com> - 1.4.0-1
104- Update to 1.4.0
105
106* Sun Nov  3 2013 Ville Skyttä <ville.skytta@iki.fi> - 1.3.4-4
107- Use special %%doc to install all docs (#994005).
108
109* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-3
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
111
112* Fri Jun 21 2013 Dan Horák <dan[at]danny.cz> - 1.3.4-2
113- workaround possible too low limits for number of processes and open files,
114  fixes build on ppc/ppc64 and s390(x)
115
116* Sun Jun 09 2013 Ben Boeckel <mathstuf@gmail.com> - 1.3.4-1
117- Update to 1.3.4
118- Run test suite
119
120* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
121- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
122
123* Sun Nov 04 2012 Ben Boeckel <mathstuf@gmail.com> - 1.0.0-1
124- Update to 1.0.0
125
126* Thu Jul 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.6.20120719git5dc55a3
127- Update to new snapshot
128
129* Mon Jul 09 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.5.20120709gitb90d038
130- Preserve timestamps on install
131- Install as ninja-build to avoid conflicts with the ninja IRC package
132- Update snapshot
133
134* Tue Jun 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.4.20120605git54553d3
135- Add an ftdetect file for ninja
136- Fix zsh-stuff directory ownership
137
138* Thu Jun 07 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.3.20120605git54553d3
139- Add a Group tag
140
141* Tue Jun 05 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.2.20120605git54553d3
142- Update to new snapshot
143
144* Fri Mar 30 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.1.20120330gitabd33d5
145- Initial package
Note: See TracBrowser for help on using the repository browser.