source: projects/specs/trunk/n/ninja/ninja-vl.spec @ 9964

Revision 9964, 4.1 KB checked in by daisuke, 8 years ago (diff)

ninja: update to 1.6.0

Line 
1Name:           ninja
2Version:        1.6.0
3Release:        1%{?_dist_release}
4Summary:        A small build system with a focus on speed
5Summary(ja):    スピードを重視した小さなビルドシステム
6License:        ASL 2.0
7URL:            http://martine.github.com/ninja/
8Source0:        https://github.com/martine/ninja/archive/v%{version}.tar.gz#/ninja-%{version}.tar.gz
9Source1:        ninja.vim
10BuildRequires:  asciidoc
11BuildRequires:  gtest-devel
12BuildRequires:  python-devel
13BuildRequires:  re2c >= 0.11.3
14
15%description
16Ninja is a small build system with a focus on speed. It differs from other
17build systems in two major respects: it is designed to have its input files
18generated by a higher-level build system, and it is designed to run builds as
19fast as possible.
20
21%prep
22%setup -qn ninja-%{version}
23
24%build
25CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" \
26%{__python} configure.py --bootstrap --verbose
27./ninja -v manual
28./ninja -v ninja_test
29
30%install
31# TODO: Install ninja_syntax.py?
32mkdir -p %{buildroot}/{%{_bindir},%{_datadir}/bash-completion/completions,%{_datadir}/emacs/site-lisp,%{_datadir}/vim/vimfiles/syntax,%{_datadir}/vim/vimfiles/ftdetect,%{_datadir}/zsh/site-functions}
33
34install -pm755 ninja %{buildroot}%{_bindir}/ninja
35ln -sf ninja %{buildroot}%{_bindir}/ninja-build
36install -pm644 misc/bash-completion %{buildroot}%{_datadir}/bash-completion/completions/ninja-bash-completion
37install -pm644 misc/ninja-mode.el %{buildroot}%{_datadir}/emacs/site-lisp/ninja-mode.el
38install -pm644 misc/ninja.vim %{buildroot}%{_datadir}/vim/vimfiles/syntax/ninja.vim
39install -pm644 %{SOURCE1} %{buildroot}%{_datadir}/vim/vimfiles/ftdetect/ninja.vim
40install -pm644 misc/zsh-completion %{buildroot}%{_datadir}/zsh/site-functions/_ninja
41
42%check
43# workaround possible too low default limits
44ulimit -n 4096 && ulimit -u 4096
45./ninja_test
46
47%files
48%doc COPYING HACKING.md README doc/manual.html
49%{_bindir}/ninja
50%{_bindir}/ninja-build
51%{_datadir}/bash-completion/completions/ninja-bash-completion
52%{_datadir}/emacs/site-lisp/ninja-mode.el
53%{_datadir}/vim/vimfiles/syntax/ninja.vim
54%{_datadir}/vim/vimfiles/ftdetect/ninja.vim
55# zsh does not have a -filesystem package
56%{_datadir}/zsh/
57
58%changelog
59* Mon Jan 18 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-1
60- update to 1.6.0
61- remove R: vim, emacsen
62  (TODO: vim or el should be splitted to subpackage)
63- add ninja-build symlink to compatible with other rpm distros.
64
65* Thu Jun 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.0-1
66- initial build for Vine Linux
67
68* Wed Nov 20 2013 Ben Boeckel <mathstuf@gmail.com> - 1.4.0-1
69- Update to 1.4.0
70
71* Sun Nov  3 2013 Ville Skyttä <ville.skytta@iki.fi> - 1.3.4-4
72- Use special %%doc to install all docs (#994005).
73
74* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-3
75- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
76
77* Fri Jun 21 2013 Dan Horák <dan[at]danny.cz> - 1.3.4-2
78- workaround possible too low limits for number of processes and open files,
79  fixes build on ppc/ppc64 and s390(x)
80
81* Sun Jun 09 2013 Ben Boeckel <mathstuf@gmail.com> - 1.3.4-1
82- Update to 1.3.4
83- Run test suite
84
85* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
86- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
87
88* Sun Nov 04 2012 Ben Boeckel <mathstuf@gmail.com> - 1.0.0-1
89- Update to 1.0.0
90
91* Thu Jul 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.6.20120719git5dc55a3
92- Update to new snapshot
93
94* Mon Jul 09 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.5.20120709gitb90d038
95- Preserve timestamps on install
96- Install as ninja-build to avoid conflicts with the ninja IRC package
97- Update snapshot
98
99* Tue Jun 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.4.20120605git54553d3
100- Add an ftdetect file for ninja
101- Fix zsh-stuff directory ownership
102
103* Thu Jun 07 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.3.20120605git54553d3
104- Add a Group tag
105
106* Tue Jun 05 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.2.20120605git54553d3
107- Update to new snapshot
108
109* Fri Mar 30 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.1.20120330gitabd33d5
110- Initial package
Note: See TracBrowser for help on using the repository browser.