source: projects/specs/trunk/n/nghttp2/nghttp2-vl.spec @ 10559

Revision 10559, 6.3 KB checked in by tomop, 8 years ago (diff)

nghttp2-1.12.0-1

Line 
1%bcond_with test
2
3Summary: Experimental HTTP/2 client, server and proxy
4Summary(ja): HTTP/2クライアント・サーバ・プロキシの実験的実装
5Name: nghttp2
6Version: 1.12.0
7Release: 1%{?_dist_release}
8License: MIT
9Group: Applications/Internet
10URL: https://nghttp2.org/
11
12Vendor: Project Vine
13Distribution: Vine Linux
14
15Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/nghttp2-%{version}.tar.xz
16
17%if %{with test}
18BuildRequires: CUnit-devel
19%endif
20BuildRequires: jemalloc-devel
21BuildRequires: libboost-devel
22BuildRequires: libboost-thread
23BuildRequires: libev-devel
24BuildRequires: openssl-devel
25BuildRequires: zlib-devel
26
27Requires: libnghttp2 = %{version}-%{release}
28
29%description
30This package contains the HTTP/2 client, server and proxy programs.
31
32%description -l ja
33This package contains the HTTP/2 client, server and proxy programs.
34 このパッケージにはHTTP/2クライアント・サーバ。プロキシのプログラム
35が含まれています。
36
37
38%package -n libnghttp2
39Summary: A library implementing the HTTP/2 protocol
40Summary(ja): HTTP/2ライブラリ
41Group: Development/Libraries
42
43%description -n libnghttp2
44libnghttp2 is a library implementing the Hypertext Transfer Protocol
45version 2 (HTTP/2) protocol in C.
46
47%description -l ja -n libnghttp2
48 libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
49実装したライブラリです。
50
51
52%package -n libnghttp2-devel
53Summary: Files needed for building applications with libnghttp2
54Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
55Group: Development/Libraries
56Requires: libnghttp2%{?_isa} = %{version}-%{release}
57Requires: pkgconfig
58
59%description -n libnghttp2-devel
60The libnghttp2-devel package includes libraries and header files needed
61for building applications with libnghttp2.
62
63%description -l ja -n libnghttp2-devel
64 libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
65をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
66す。
67
68
69%prep
70%setup -q
71
72
73%build
74LIBEV_CFLAGS=`pkg-config --cflags libev`
75CFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS"    \
76CXXFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS"  \
77%configure                                  \
78    --enable-app                            \
79    --enable-asio-lib                       \
80    --with-pic                              \
81    --with-boost                            \
82    --with-boost-asio                       \
83    --with-boost-system                     \
84    --with-boost-thread                     \
85    --disable-python-bindings               \
86    --disable-static                        \
87    --without-libxml2                       \
88    --without-spdylay
89
90# avoid using rpath
91sed -i libtool                              \
92    -e 's/^runpath_var=.*/runpath_var=/'    \
93    -e 's/^hardcode_libdir_flag_spec=".*"$/hardcode_libdir_flag_spec=""/'
94
95make %{?_smp_mflags} V=1
96
97
98%install
99%make_install
100
101# not needed on Fedora/RHEL
102rm -f $RPM_BUILD_ROOT%{_libdir}/libnghttp2*.la
103
104# will be installed via %%doc
105rm -f "$RPM_BUILD_ROOT%{_datadir}/doc/nghttp2/README.rst"
106
107%post -n libnghttp2 -p /sbin/ldconfig
108
109%postun -n libnghttp2 -p /sbin/ldconfig
110
111
112%check
113%if %{with test}
114# test the just built library instead of the system one, without using rpath
115export "LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir}:$LD_LIBRARY_PATH"
116make %{?_smp_mflags} check
117%endif
118
119%files
120%{_bindir}/h2load
121%{_bindir}/nghttp
122%{_bindir}/nghttpd
123%{_bindir}/nghttpx
124%{_datadir}/nghttp2
125%{_mandir}/man1/h2load.1*
126%{_mandir}/man1/nghttp.1*
127%{_mandir}/man1/nghttpd.1*
128%{_mandir}/man1/nghttpx.1*
129
130%files -n libnghttp2
131%{_libdir}/libnghttp2*.so.*
132%{!?_licensedir:%global license %%doc}
133%license COPYING
134
135%files -n libnghttp2-devel
136%{_includedir}/nghttp2
137%{_libdir}/pkgconfig/libnghttp2*.pc
138%{_libdir}/libnghttp2*.so
139%doc README.rst
140
141
142%changelog
143* Thu Jul  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
144- new upstream release.
145
146* Tue Jun  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.1-2
147- initial build for Vne Linux.
148
149* Sun May 29 2016 Kamil Dudka <kdudka@redhat.com> 1.11.1-1
150- update to the latest upstream release
151
152* Thu May 26 2016 Kamil Dudka <kdudka@redhat.com> 1.11.0-1
153- update to the latest upstream release
154
155* Mon Apr 25 2016 Kamil Dudka <kdudka@redhat.com> 1.10.0-1
156- update to the latest upstream release
157
158* Sun Apr 03 2016 Kamil Dudka <kdudka@redhat.com> 1.9.2-1
159- update to the latest upstream release
160
161* Tue Mar 29 2016 Kamil Dudka <kdudka@redhat.com> 1.9.1-1
162- update to the latest upstream release
163
164* Thu Feb 25 2016 Kamil Dudka <kdudka@redhat.com> 1.8.0-1
165- update to the latest upstream release
166
167* Thu Feb 11 2016 Kamil Dudka <kdudka@redhat.com> 1.7.1-1
168- update to the latest upstream release (fixes CVE-2016-1544)
169
170* Fri Feb 05 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-3
171- make the package compile with gcc-6
172
173* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-2
174- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
175
176* Mon Jan 25 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-1
177- update to the latest upstream release
178
179* Fri Dec 25 2015 Kamil Dudka <kdudka@redhat.com> 1.6.0-1
180- update to the latest upstream release (fixes CVE-2015-8659)
181
182* Thu Nov 26 2015 Kamil Dudka <kdudka@redhat.com> 1.5.0-1
183- update to the latest upstream release
184
185* Mon Oct 26 2015 Kamil Dudka <kdudka@redhat.com> 1.4.0-1
186- update to the latest upstream release
187
188* Thu Sep 24 2015 Kamil Dudka <kdudka@redhat.com> 1.3.4-1
189- update to the latest upstream release
190
191* Wed Sep 23 2015 Kamil Dudka <kdudka@redhat.com> 1.3.3-1
192- update to the latest upstream release
193
194* Wed Sep 16 2015 Kamil Dudka <kdudka@redhat.com> 1.3.2-1
195- update to the latest upstream release
196
197* Mon Sep 14 2015 Kamil Dudka <kdudka@redhat.com> 1.3.1-1
198- update to the latest upstream release
199
200* Mon Aug 31 2015 Kamil Dudka <kdudka@redhat.com> 1.3.0-1
201- update to the latest upstream release
202
203* Mon Aug 17 2015 Kamil Dudka <kdudka@redhat.com> 1.2.1-1
204- update to the latest upstream release
205
206* Sun Aug 09 2015 Kamil Dudka <kdudka@redhat.com> 1.2.0-1
207- update to the latest upstream release
208
209* Wed Jul 15 2015 Kamil Dudka <kdudka@redhat.com> 1.1.1-1
210- update to the latest upstream release
211
212* Tue Jun 30 2015 Kamil Dudka <kdudka@redhat.com> 1.0.5-1
213- packaged for Fedora (#1237247)
Note: See TracBrowser for help on using the repository browser.