source: projects/specs/trunk/n/nghttp2/nghttp2-vl.spec @ 12537

Revision 12537, 9.5 KB checked in by tomop, 3 years ago (diff)

updated 8 packages

Field3D-1.7.3-3

OpenImageIO-2.2.11.1-1

c-ares-1.17.1-1

curl-7.75.0-1

galera-26.4.6-1

libboost-1.75.0-1

nghttp2-1.43.0-1

source-highlight-3.1.8-3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%bcond_with test
4%bcond_without app
5
6%define _unpackaged_files_terminate_build 1
7
8Summary: Experimental HTTP/2 client, server and proxy
9Summary(ja): HTTP/2クライアント・サーバ・プロキシの実験的実装
10Name: nghttp2
11Version: 1.43.0
12Release: 1%{?_dist_release}
13Group: internet
14Vendor: Project Vine
15Distribution: Vine Linux
16
17License: MIT
18URL: https://nghttp2.org/
19Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/nghttp2-%{version}.tar.xz
20
21%if %{with test}
22BuildRequires: CUnit-devel
23%endif
24BuildRequires: jemalloc-devel
25BuildRequires: libboost-devel
26BuildRequires: libboost-thread
27BuildRequires: libev-devel
28BuildRequires: openssl-devel
29BuildRequires: zlib-devel
30
31%if %{with app}
32Requires: libnghttp2 = %{version}-%{release}
33BuildRequires: c-ares-devel
34BuildRequires: jansson-devel
35BuildRequires: libxml2-devel
36%endif
37
38%description
39This package contains the HTTP/2 client, server and proxy programs.
40
41%description -l ja
42This package contains the HTTP/2 client, server and proxy programs.
43 このパッケージにはHTTP/2クライアント・サーバ。プロキシのプログラム
44が含まれています。
45
46
47%package -n libnghttp2
48Summary: A library implementing the HTTP/2 protocol
49Summary(ja): HTTP/2ライブラリ
50Group: system
51
52%description -n libnghttp2
53libnghttp2 is a library implementing the Hypertext Transfer Protocol
54version 2 (HTTP/2) protocol in C.
55
56%description -l ja -n libnghttp2
57 libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
58実装したライブラリです。
59
60
61%package -n libnghttp2-devel
62Summary: Files needed for building applications with libnghttp2
63Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
64Group: programming
65Requires: libnghttp2%{?_isa} = %{version}-%{release}
66Requires: pkgconfig
67
68%description -n libnghttp2-devel
69The libnghttp2-devel package includes libraries and header files needed
70for building applications with libnghttp2.
71
72%description -l ja -n libnghttp2-devel
73 libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
74をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
75す。
76
77
78%package -n compat32-libnghttp2
79Summary: A library implementing the HTTP/2 protocol
80Summary(ja): HTTP/2ライブラリ
81Group: system
82
83%description -n compat32-libnghttp2
84libnghttp2 is a library implementing the Hypertext Transfer Protocol
85version 2 (HTTP/2) protocol in C.
86
87%description -l ja -n compat32-libnghttp2
88 libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
89実装したライブラリです。
90
91
92%package -n compat32-libnghttp2-devel
93Summary: Files needed for building applications with libnghttp2
94Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
95Group: programming
96Requires: compat32-libnghttp2%{?_isa} = %{version}-%{release}
97Requires: pkgconfig
98
99%description -n compat32-libnghttp2-devel
100The libnghttp2-devel package includes libraries and header files needed
101for building applications with libnghttp2.
102
103%description -l ja -n compat32-libnghttp2-devel
104 libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
105をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
106す。
107
108
109%debug_package
110
111
112%prep
113%setup -q
114
115
116%build
117CFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS"    \
118CXXFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS"  \
119%configure                                  \
120%if %{with app}
121    --enable-app                            \
122%endif
123        --enable-asio-lib                       \
124    --with-pic                              \
125    --with-boost                            \
126    --with-boost-asio                       \
127    --with-boost-system                     \
128    --with-boost-thread                     \
129    --disable-python-bindings               \
130    --disable-static                        \
131    --without-libxml2                       \
132    --without-spdylay
133
134# avoid using rpath
135sed -i libtool                              \
136    -e 's/^runpath_var=.*/runpath_var=/'    \
137    -e 's/^hardcode_libdir_flag_spec=".*"$/hardcode_libdir_flag_spec=""/'
138
139make %{?_smp_mflags} V=1
140
141
142%install
143%make_install
144
145# not needed on Fedora/RHEL
146rm -f %{buildroot}%{_libdir}/libnghttp2*.la
147
148# will be installed via %%doc
149rm -f "%{buildroot}%{_datadir}/doc/nghttp2/README.rst"
150
151%if ! %{with app}
152rm -f %{buildroot}%{_mandir}/man1/*
153%endif
154
155
156%post -n libnghttp2
157/sbin/ldconfig
158
159%postun -n libnghttp2
160/sbin/ldconfig
161
162%post -n compat32-libnghttp2
163/sbin/ldconfig
164
165%postun -n compat32-libnghttp2
166/sbin/ldconfig
167
168
169%check
170%if %{with test}
171# test the just built library instead of the system one, without using rpath
172export "LD_LIBRARY_PATH=%{buildroot}%{_libdir}:$LD_LIBRARY_PATH"
173make %{?_smp_mflags} check
174%endif
175
176%if %{with app}
177%files
178%{_bindir}/h2load
179%{_bindir}/nghttp
180%{_bindir}/nghttpd
181%{_bindir}/nghttpx
182%{_bindir}/deflatehd
183%{_bindir}/inflatehd
184%{_datadir}/nghttp2
185%{_mandir}/man1/h2load.1*
186%{_mandir}/man1/nghttp.1*
187%{_mandir}/man1/nghttpd.1*
188%{_mandir}/man1/nghttpx.1*
189%endif
190
191%files -n libnghttp2
192%{_libdir}/libnghttp2*.so.*
193%{_datadir}/%{name}/fetch-ocsp-response
194%{!?_licensedir:%global license %%doc}
195%license COPYING
196
197%files -n libnghttp2-devel
198%{_includedir}/nghttp2
199%{_libdir}/pkgconfig/libnghttp2*.pc
200%{_libdir}/libnghttp2*.so
201%doc README.rst
202
203%if %{build_compat32}
204%files -n compat32-libnghttp2
205%{_libdir}/libnghttp2*.so.*
206%{!?_licensedir:%global license %%doc}
207%license COPYING
208
209%files -n compat32-libnghttp2-devel
210%{_includedir}/nghttp2
211%{_libdir}/pkgconfig/libnghttp2*.pc
212%{_libdir}/libnghttp2*.so
213%doc README.rst
214%endif
215
216%changelog
217* Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.43.0-1
218- new upstream release.
219
220* Wed Dec 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.42.0-1
221- new upstream release.
222
223* Tue Jun 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.41.0-1
224- new upstream release.
225
226* Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.40.0-2
227- rebuilt with boost-1.72.0.
228
229* Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.40.0-1
230- new upstream release.
231
232* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.39.2-1
233- new upstream release.
234
235* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.34.0-1
236- new upstream release.
237
238* Fri Mar 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.31.0-1
239- new upstream release.
240
241* Sun Jan 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.0-2
242- rebuilt with libboost-1.66.0.
243
244* Sun Dec 24 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.0-1
245- new upstream release.
246- enabled to build apps as default.
247
248* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.22.0-1
249- new upstream release.
250
251* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.20.0-1
252- new upstream release.
253- disabled to build apps as default.
254
255* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.17.0-1
256- new upstream release.
257
258* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-2
259- added compat32-* packages.
260
261* Thu Jul  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
262- new upstream release.
263
264* Tue Jun  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.1-2
265- initial build for Vne Linux.
266
267* Sun May 29 2016 Kamil Dudka <kdudka@redhat.com> 1.11.1-1
268- update to the latest upstream release
269
270* Thu May 26 2016 Kamil Dudka <kdudka@redhat.com> 1.11.0-1
271- update to the latest upstream release
272
273* Mon Apr 25 2016 Kamil Dudka <kdudka@redhat.com> 1.10.0-1
274- update to the latest upstream release
275
276* Sun Apr 03 2016 Kamil Dudka <kdudka@redhat.com> 1.9.2-1
277- update to the latest upstream release
278
279* Tue Mar 29 2016 Kamil Dudka <kdudka@redhat.com> 1.9.1-1
280- update to the latest upstream release
281
282* Thu Feb 25 2016 Kamil Dudka <kdudka@redhat.com> 1.8.0-1
283- update to the latest upstream release
284
285* Thu Feb 11 2016 Kamil Dudka <kdudka@redhat.com> 1.7.1-1
286- update to the latest upstream release (fixes CVE-2016-1544)
287
288* Fri Feb 05 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-3
289- make the package compile with gcc-6
290
291* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-2
292- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
293
294* Mon Jan 25 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-1
295- update to the latest upstream release
296
297* Fri Dec 25 2015 Kamil Dudka <kdudka@redhat.com> 1.6.0-1
298- update to the latest upstream release (fixes CVE-2015-8659)
299
300* Thu Nov 26 2015 Kamil Dudka <kdudka@redhat.com> 1.5.0-1
301- update to the latest upstream release
302
303* Mon Oct 26 2015 Kamil Dudka <kdudka@redhat.com> 1.4.0-1
304- update to the latest upstream release
305
306* Thu Sep 24 2015 Kamil Dudka <kdudka@redhat.com> 1.3.4-1
307- update to the latest upstream release
308
309* Wed Sep 23 2015 Kamil Dudka <kdudka@redhat.com> 1.3.3-1
310- update to the latest upstream release
311
312* Wed Sep 16 2015 Kamil Dudka <kdudka@redhat.com> 1.3.2-1
313- update to the latest upstream release
314
315* Mon Sep 14 2015 Kamil Dudka <kdudka@redhat.com> 1.3.1-1
316- update to the latest upstream release
317
318* Mon Aug 31 2015 Kamil Dudka <kdudka@redhat.com> 1.3.0-1
319- update to the latest upstream release
320
321* Mon Aug 17 2015 Kamil Dudka <kdudka@redhat.com> 1.2.1-1
322- update to the latest upstream release
323
324* Sun Aug 09 2015 Kamil Dudka <kdudka@redhat.com> 1.2.0-1
325- update to the latest upstream release
326
327* Wed Jul 15 2015 Kamil Dudka <kdudka@redhat.com> 1.1.1-1
328- update to the latest upstream release
329
330* Tue Jun 30 2015 Kamil Dudka <kdudka@redhat.com> 1.0.5-1
331- packaged for Fedora (#1237247)
Note: See TracBrowser for help on using the repository browser.