source: projects/specs/trunk/n/nghttp2/nghttp2-vl.spec @ 10631

Revision 10631, 7.9 KB checked in by tomop, 8 years ago (diff)

nghttp2-1.12.0-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%bcond_with test
4
5Summary: Experimental HTTP/2 client, server and proxy
6Summary(ja): HTTP/2クライアント・サーバ・プロキシの実験的実装
7Name: nghttp2
8Version: 1.12.0
9Release: 2%{?_dist_release}
10License: MIT
11Group: Applications/Internet
12URL: https://nghttp2.org/
13
14Vendor: Project Vine
15Distribution: Vine Linux
16
17Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/nghttp2-%{version}.tar.xz
18
19%if %{with test}
20BuildRequires: CUnit-devel
21%endif
22BuildRequires: jemalloc-devel
23BuildRequires: libboost-devel
24BuildRequires: libboost-thread
25BuildRequires: libev-devel
26BuildRequires: openssl-devel
27BuildRequires: zlib-devel
28
29Requires: libnghttp2 = %{version}-%{release}
30
31%description
32This package contains the HTTP/2 client, server and proxy programs.
33
34%description -l ja
35This package contains the HTTP/2 client, server and proxy programs.
36 このパッケージにはHTTP/2クライアント・サーバ。プロキシのプログラム
37が含まれています。
38
39
40%package -n libnghttp2
41Summary: A library implementing the HTTP/2 protocol
42Summary(ja): HTTP/2ライブラリ
43Group: Development/Libraries
44
45%description -n libnghttp2
46libnghttp2 is a library implementing the Hypertext Transfer Protocol
47version 2 (HTTP/2) protocol in C.
48
49%description -l ja -n libnghttp2
50 libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
51実装したライブラリです。
52
53
54%package -n libnghttp2-devel
55Summary: Files needed for building applications with libnghttp2
56Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
57Group: Development/Libraries
58Requires: libnghttp2%{?_isa} = %{version}-%{release}
59Requires: pkgconfig
60
61%description -n libnghttp2-devel
62The libnghttp2-devel package includes libraries and header files needed
63for building applications with libnghttp2.
64
65%description -l ja -n libnghttp2-devel
66 libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
67をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
68す。
69
70
71%package -n compat32-libnghttp2
72Summary: A library implementing the HTTP/2 protocol
73Summary(ja): HTTP/2ライブラリ
74Group: Development/Libraries
75
76%description -n compat32-libnghttp2
77libnghttp2 is a library implementing the Hypertext Transfer Protocol
78version 2 (HTTP/2) protocol in C.
79
80%description -l ja -n compat32-libnghttp2
81 libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
82実装したライブラリです。
83
84
85%package -n compat32-libnghttp2-devel
86Summary: Files needed for building applications with libnghttp2
87Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
88Group: Development/Libraries
89Requires: compat32-libnghttp2%{?_isa} = %{version}-%{release}
90Requires: pkgconfig
91
92%description -n compat32-libnghttp2-devel
93The libnghttp2-devel package includes libraries and header files needed
94for building applications with libnghttp2.
95
96%description -l ja -n compat32-libnghttp2-devel
97 libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
98をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
99す。
100
101
102%prep
103%setup -q
104
105
106%build
107LIBEV_CFLAGS=`pkg-config --cflags libev`
108CFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS"    \
109CXXFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS"  \
110%configure                                  \
111    --enable-app                            \
112    --enable-asio-lib                       \
113    --with-pic                              \
114    --with-boost                            \
115    --with-boost-asio                       \
116    --with-boost-system                     \
117    --with-boost-thread                     \
118    --disable-python-bindings               \
119    --disable-static                        \
120    --without-libxml2                       \
121    --without-spdylay
122
123# avoid using rpath
124sed -i libtool                              \
125    -e 's/^runpath_var=.*/runpath_var=/'    \
126    -e 's/^hardcode_libdir_flag_spec=".*"$/hardcode_libdir_flag_spec=""/'
127
128make %{?_smp_mflags} V=1
129
130
131%install
132%make_install
133
134# not needed on Fedora/RHEL
135rm -f $RPM_BUILD_ROOT%{_libdir}/libnghttp2*.la
136
137# will be installed via %%doc
138rm -f "$RPM_BUILD_ROOT%{_datadir}/doc/nghttp2/README.rst"
139
140%post -n libnghttp2
141/sbin/ldconfig
142
143%postun -n libnghttp2
144/sbin/ldconfig
145
146%post -n compat32-libnghttp2
147/sbin/ldconfig
148
149%postun -n compat32-libnghttp2
150/sbin/ldconfig
151
152
153%check
154%if %{with test}
155# test the just built library instead of the system one, without using rpath
156export "LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir}:$LD_LIBRARY_PATH"
157make %{?_smp_mflags} check
158%endif
159
160%files
161%{_bindir}/h2load
162%{_bindir}/nghttp
163%{_bindir}/nghttpd
164%{_bindir}/nghttpx
165%{_datadir}/nghttp2
166%{_mandir}/man1/h2load.1*
167%{_mandir}/man1/nghttp.1*
168%{_mandir}/man1/nghttpd.1*
169%{_mandir}/man1/nghttpx.1*
170
171%files -n libnghttp2
172%{_libdir}/libnghttp2*.so.*
173%{!?_licensedir:%global license %%doc}
174%license COPYING
175
176%files -n libnghttp2-devel
177%{_includedir}/nghttp2
178%{_libdir}/pkgconfig/libnghttp2*.pc
179%{_libdir}/libnghttp2*.so
180%doc README.rst
181
182%if %{build_compat32}
183%files -n compat32-libnghttp2
184%{_libdir}/libnghttp2*.so.*
185%{!?_licensedir:%global license %%doc}
186%license COPYING
187
188%files -n compat32-libnghttp2-devel
189%{_includedir}/nghttp2
190%{_libdir}/pkgconfig/libnghttp2*.pc
191%{_libdir}/libnghttp2*.so
192%doc README.rst
193%endif
194
195%changelog
196* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-2
197- added compat32-* packages.
198
199* Thu Jul  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
200- new upstream release.
201
202* Tue Jun  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.1-2
203- initial build for Vne Linux.
204
205* Sun May 29 2016 Kamil Dudka <kdudka@redhat.com> 1.11.1-1
206- update to the latest upstream release
207
208* Thu May 26 2016 Kamil Dudka <kdudka@redhat.com> 1.11.0-1
209- update to the latest upstream release
210
211* Mon Apr 25 2016 Kamil Dudka <kdudka@redhat.com> 1.10.0-1
212- update to the latest upstream release
213
214* Sun Apr 03 2016 Kamil Dudka <kdudka@redhat.com> 1.9.2-1
215- update to the latest upstream release
216
217* Tue Mar 29 2016 Kamil Dudka <kdudka@redhat.com> 1.9.1-1
218- update to the latest upstream release
219
220* Thu Feb 25 2016 Kamil Dudka <kdudka@redhat.com> 1.8.0-1
221- update to the latest upstream release
222
223* Thu Feb 11 2016 Kamil Dudka <kdudka@redhat.com> 1.7.1-1
224- update to the latest upstream release (fixes CVE-2016-1544)
225
226* Fri Feb 05 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-3
227- make the package compile with gcc-6
228
229* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-2
230- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
231
232* Mon Jan 25 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-1
233- update to the latest upstream release
234
235* Fri Dec 25 2015 Kamil Dudka <kdudka@redhat.com> 1.6.0-1
236- update to the latest upstream release (fixes CVE-2015-8659)
237
238* Thu Nov 26 2015 Kamil Dudka <kdudka@redhat.com> 1.5.0-1
239- update to the latest upstream release
240
241* Mon Oct 26 2015 Kamil Dudka <kdudka@redhat.com> 1.4.0-1
242- update to the latest upstream release
243
244* Thu Sep 24 2015 Kamil Dudka <kdudka@redhat.com> 1.3.4-1
245- update to the latest upstream release
246
247* Wed Sep 23 2015 Kamil Dudka <kdudka@redhat.com> 1.3.3-1
248- update to the latest upstream release
249
250* Wed Sep 16 2015 Kamil Dudka <kdudka@redhat.com> 1.3.2-1
251- update to the latest upstream release
252
253* Mon Sep 14 2015 Kamil Dudka <kdudka@redhat.com> 1.3.1-1
254- update to the latest upstream release
255
256* Mon Aug 31 2015 Kamil Dudka <kdudka@redhat.com> 1.3.0-1
257- update to the latest upstream release
258
259* Mon Aug 17 2015 Kamil Dudka <kdudka@redhat.com> 1.2.1-1
260- update to the latest upstream release
261
262* Sun Aug 09 2015 Kamil Dudka <kdudka@redhat.com> 1.2.0-1
263- update to the latest upstream release
264
265* Wed Jul 15 2015 Kamil Dudka <kdudka@redhat.com> 1.1.1-1
266- update to the latest upstream release
267
268* Tue Jun 30 2015 Kamil Dudka <kdudka@redhat.com> 1.0.5-1
269- packaged for Fedora (#1237247)
Note: See TracBrowser for help on using the repository browser.