source: projects/specs/trunk/n/netatalk/netatalk-vl.spec @ 3787

Revision 3787, 10.0 KB checked in by shaolin, 13 years ago (diff)
  • netatalk: updated to 2.1.5
Line 
1%define _sysconfdir     /etc
2
3################################################# BASIC PACKAGE INFORMATION
4Summary:       AppleTalk and AppleShare/IP services for Linux
5Summary(ja):   Linux 用 AppleTalk, AppleShare/IP サービス
6Name:          netatalk
7Version:       2.1.5
8Release:       1%{_dist_release}
9License:       GPLv2+
10Group:         System Environment/Daemons
11Source0:       %{name}-%{version}.tar.bz2
12URL:           http://netatalk.sourceforge.net/
13Obsoletes:     netatalk-1.4b2+asun
14
15# patch for default config file
16Patch10:       netatalk-2.1.3-config-utf8.patch
17
18# other patches
19#Patch13:       netatalk-2.0.3-db43.patch
20#Patch14:       netatalk-2.0.3-newerdb.patch
21
22Source10:      afpd.service
23
24
25############################################################## REQUIREMENTS
26Requires(pre): chkconfig, /sbin/ldconfig, grep, textutils
27Requires:      cracklib, openssl, tcp_wrappers, pam, perl
28BuildRequires: openssl-devel, pam-devel, cups-devel, db4-devel, quota
29
30BuildRoot:     %{_tmppath}/%{name}-%{version}-root
31
32Vendor:        Project Vine
33Distribution:  Vine Linux
34Packager:      shaolin
35
36
37%description
38Netatalk is a freely-available Open Source AFP fileserver. It also provides a
39kernel level implementation of the AppleTalk Protocol Suite. A *NIX/*BSD system
40running Netatalk is capable of serving many Macintosh clients simultaneously
41as an AppleShare file server (AFP), AppleTalk router, *NIX/*BSD print server,
42and for accessing AppleTalk printers via Printer Access Protocol (PAP).
43Included are a number of minor printing and debugging utilities.
44
45%description -l ja
46このパッケージを使うことで, Linux 上で AppleTalk プロトコルを
47扱うことができ, Macintosh と通信が可能になります.
48Linux 上で AppleTalk や AFP over TCP の Mac 向けファイルサーバを
49稼働させることができるデーモンプログラムが収められています.
50
51
52%package devel
53Group:         Development/Libraries
54Summary:       Headers for AppleTalk development
55Summary(ja):   AppleTalk 開発用ヘッダファイル
56
57%description devel
58This package contains the header files for building AppleTalk networking
59programs.
60
61
62%prep
63%setup -q
64
65%patch10 -p1 -b .cjk-config
66
67#%patch13 -p1 -b .db43
68#%patch14 -p1 -b .newerdb
69
70
71%build
72touch AUTHORS
73ln -s NEWS ChangeLog
74rm -f README.cjk4.cjk
75
76libtoolize --force
77aclocal -I macros
78automake --add-missing
79autoconf
80autoheader
81CFLAGS="${RPM_OPT_FLAGS} -fomit-frame-pointer -fsigned-char" \
82./configure \
83        --prefix=%{_prefix} \
84        --libdir=%{_libdir} \
85        --libexecdir=%{_libdir}/netatalk \
86        --sysconfdir=%{_sysconfdir} \
87        --mandir=%{_mandir} \
88        --localstatedir=%{_var} \
89        --enable-shared \
90        --enable-afp3 \
91        --with-cnid-dbd-backend \
92        --with-cnid-cdb-backend \
93        --with-cnid-default-backend=dbd \
94        --enable-cups \
95        --with-message-dir=%{_sysconfdir}/netatalk/msg \
96        --with-uams-path=%{_libdir}/netatalk \
97        --with-spooldir=%{_var}/spool/netatalk \
98        --enable-redhat \
99        --with-cracklib \
100        --with-pam \
101        --with-shadow \
102        --with-tcp-wrappers \
103        --with-ssl \
104        --enable-pgp-uam
105
106make all
107
108
109%install
110### INSTALL (USING "make install") ###
111rm -rf ${RPM_BUILD_ROOT}
112mkdir -p ${RPM_BUILD_ROOT}{%{_prefix},%{_sysconfdir}/netatalk/msg}
113make DESTDIR=$RPM_BUILD_ROOT install
114
115## netatalk/at.h is now provided by glibc
116rm -f $RPM_BUILD_ROOT%{_prefix}/include/netatalk/at.h
117
118## for Bonjour (requires nss-mdns)
119install -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services
120install -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services/
121
122
123%pre
124### COPY OLD PREFERENCE FILES ###
125
126if [ -d /etc/atalk ] ; then
127    mkdir -p /etc/netatalk/
128    cp -a /etc/atalk /etc/netatalk/00_OLD_VERSION_PREFS
129fi
130exit 0
131
132
133%post
134
135### RUN CHKCONFIG ###
136/sbin/chkconfig --add netatalk
137
138/sbin/ldconfig
139
140if test -r /var/lock/atalkd ; then
141        /etc/rc.d/init.d/netatalk restart >&2
142fi
143
144
145%preun
146
147### RUN CHKCONFIG ###
148/sbin/chkconfig --del netatalk
149
150
151%triggerpostun -- netatalk <= 1.4b2+asun2.1.3-7vl6
152/sbin/chkconfig --add netatalk
153
154
155%clean
156rm -rf ${RPM_BUILD_ROOT}
157
158
159%files
160%defattr(-,root,root)
161%doc CONTRIBUTORS COPYING COPYRIGHT
162%doc NEWS README* TODO
163%doc doc/[A-L,N-Z]*
164%config(noreplace) /etc/netatalk/Apple*
165%config(noreplace) /etc/netatalk/*.conf
166%config /etc/pam.d/netatalk
167%config /etc/rc.d/init.d/netatalk
168%dir %{_sysconfdir}/netatalk
169%dir %{_sysconfdir}/netatalk/msg
170%{_sysconfdir}/avahi/services/afpd.service
171%dir %{_var}/spool/netatalk
172%{_bindir}/*
173%{_sbindir}/*
174%{_libdir}/netatalk/*
175%exclude %{_libdir}/netatalk/*.a
176%exclude %{_libdir}/netatalk/*.la
177%{_mandir}/*/*
178%{_datadir}/netatalk/pagecount.ps
179
180
181%files devel
182%defattr(-,root,root)
183%{_libdir}/*.a
184%{_libdir}/*.la
185%{_libdir}/netatalk/*.a
186%{_libdir}/netatalk/*.la
187%dir %{_includedir}/atalk
188%{_includedir}/atalk/*.h
189%dir %{_includedir}/netatalk
190%{_includedir}/netatalk/*.h
191%{_datadir}/aclocal/netatalk.m4
192
193
194%changelog
195* Wed May 04 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.5-1
196- new upstream release
197
198* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
199- rebuild with openssl-1.0.0c
200
201* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
202- fix Patch10 & update description - upon HAT-san's suggestions
203
204* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
205- new upstream release
206- update Vine patch
207
208* Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
209- new upstream release
210
211* Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
212- new upstream release
213
214* Sun Mar  8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
215- rebuilt both for VineSeed / VinePlus-4.0
216
217* Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
218- updated to the cjk-6 patch
219- Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
220- Patch14 updated for db46
221
222* Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
223- remove openslp dependency
224
225* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
226- add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
227- TODO: remember to revise this fix after VineSeed changes default locale
228        from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
229
230* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
231- revise description (thanks HAT-san for pointing this out)
232- run libtoolize/aclocal/auto{make,conf,header} before doing configure
233  (without this, uams_* modules won't get .so suffix)
234
235* Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
236- Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
237  (Patch10 now includes all the modifications and more fixes)
238
239* Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
240- add patch13 and patch14 for db-4.3.
241- move files in %%_libexecdir to %%libdir.
242
243* Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
244- updated to 2.0.3 release w/ cjk patches (see the above Patch section)
245
246* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
247- security fix: added Patch10 (CAN-2004-0974)
248
249* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
250- configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
251
252* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
253- updated to 2.0 with cjk patch
254  (see the above Patch section for details)
255
256* Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
257- merge the patch repairing bug for System 7.5.5
258- (patch6 netatalk-1.5.3.oldsys.patch)
259- made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
260- patch6 addupted no matter noeuc is, license GPL, URL in comment
261
262* Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
263- euc and kana patch originally by
264- Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
265- applied to netatalk-1.5.2 by me
266- README.vine
267- omit VERSION from doc, omit perl from require
268
269* Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
270- this package is removed because the release number duplicated
271
272* Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
273- move acleandir.rc to the doc directory, remove executable flag.
274
275* Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
276- updated to new upstream release
277
278* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
279- added Japanese Summary for devel and corrected Group
280
281* Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
282- Oops, check /var/lock/atalkd instead of /var/run/atd.pid
283  (say atd.pid doesn't have anything to do with netatalk!!)
284
285* Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
286- updated to new upstream release
287
288* Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
289- install man pages into %%{_mandir}
290- PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
291- let pre script exit 0
292
293* Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
294- spec cleanup
295- backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
296- restart atalk daemons in the %%post section
297
298* Sun Feb 3 2002  k hanai <hanai@koto.kpu-m.ac.jp>
299 - v1.5.1.1-0vl1
300
301* Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
302  - v1.5.0-0vl1
303  - release 1.5.0 for sourceforge
304
305* Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
306  - v1.5pre6-1rh7
307  - pre-release 6 for sourceforge
308
309* Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
310  - v1.5pre5-1
311  - pre-release 5 for sourceforge
312
313* Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
314  - v1.5pre5-0
315  - pre-release 5 for sourceforge (prebuild)
316
317* Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
318  - v1.5pre4-1
319  - pre-release 4 for sourceforge
320  - modified/split mandrake spec for redhat 7 build
321
322* Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
323  - v1.5pre3-1mdk
324  - pre-release 3 for sourceforge
325  - moved away from 1.4.99 ...
326
327* Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
328  - v1.4.99-0.20001108mdk
329  - pre-release 2 for sourceforge
330
331* Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
332  - v1.4.99-0.20000927mdk
333  - pre-release 1 for sourceforge
Note: See TracBrowser for help on using the repository browser.