source: projects/specs/trunk/n/netatalk/netatalk-vl.spec @ 2653

Revision 2653, 9.8 KB checked in by Takemikaduchi, 13 years ago (diff)

eog-plugins,perl-Net_SSLeay,hdf5: new upstream release, others: rebuild with openssl-1.0.0c

Line 
1%define _sysconfdir     /etc
2
3################################################# BASIC PACKAGE INFORMATION
4Summary:       AppleTalk and AppleShare/IP services for Linux
5Summary(ja):   Linux 用 AppleTalk, AppleShare/IP サービス
6Name:          netatalk
7Version:       2.1.3
8Release:       3%{_dist_release}
9License:       GPLv2+
10Group:         System Environment/Daemons
11Source0:       %{name}-%{version}.tar.bz2
12URL:           http://netatalk.sourceforge.net/
13Obsoletes:     netatalk-1.4b2+asun
14
15# patch for default config file
16Patch10:       netatalk-2.1.3-config-utf8.patch
17
18# other patches
19#Patch13:       netatalk-2.0.3-db43.patch
20#Patch14:       netatalk-2.0.3-newerdb.patch
21
22Source10:      afpd.service
23
24
25############################################################## REQUIREMENTS
26Requires(pre): chkconfig, /sbin/ldconfig, grep, textutils
27Requires:      cracklib, openssl, tcp_wrappers, pam, perl
28BuildRequires: openssl-devel, pam-devel, cups-devel, db4-devel, quota
29
30BuildRoot:     %{_tmppath}/%{name}-%{version}-root
31
32
33%description
34Netatalk is a freely-available Open Source AFP fileserver. It also provides a
35kernel level implementation of the AppleTalk Protocol Suite. A *NIX/*BSD system
36running Netatalk is capable of serving many Macintosh clients simultaneously
37as an AppleShare file server (AFP), AppleTalk router, *NIX/*BSD print server,
38and for accessing AppleTalk printers via Printer Access Protocol (PAP).
39Included are a number of minor printing and debugging utilities.
40
41%description -l ja
42このパッケージを使うことで, Linux 上で AppleTalk プロトコルを
43扱うことができ, Macintosh と通信が可能になります.
44Linux 上で AppleTalk や AFP over TCP の Mac 向けファイルサーバを
45稼働させることができるデーモンプログラムが収められています.
46
47
48%package devel
49Group:         Development/Libraries
50Summary:       Headers for AppleTalk development
51Summary(ja):   AppleTalk 開発用ヘッダファイル
52
53%description devel
54This package contains the header files for building AppleTalk networking
55programs.
56
57
58%prep
59%setup -q
60
61%patch10 -p1 -b .cjk-config
62
63#%patch13 -p1 -b .db43
64#%patch14 -p1 -b .newerdb
65
66
67%build
68touch AUTHORS
69ln -s NEWS ChangeLog
70rm -f README.cjk4.cjk
71
72libtoolize --force
73aclocal -I macros
74automake --add-missing
75autoconf
76autoheader
77CFLAGS="${RPM_OPT_FLAGS} -fomit-frame-pointer -fsigned-char" \
78./configure \
79        --prefix=%{_prefix} \
80        --libdir=%{_libdir} \
81        --libexecdir=%{_libdir}/netatalk \
82        --sysconfdir=%{_sysconfdir} \
83        --mandir=%{_mandir} \
84        --localstatedir=%{_var} \
85        --enable-shared \
86        --enable-afp3 \
87        --with-cnid-dbd-backend \
88        --with-cnid-cdb-backend \
89        --with-cnid-default-backend=dbd \
90        --enable-cups \
91        --with-message-dir=%{_sysconfdir}/netatalk/msg \
92        --with-uams-path=%{_libdir}/netatalk \
93        --with-spooldir=%{_var}/spool/netatalk \
94        --enable-redhat \
95        --with-cracklib \
96        --with-pam \
97        --with-shadow \
98        --with-tcp-wrappers \
99        --with-ssl \
100        --enable-pgp-uam
101
102make all
103
104
105%install
106### INSTALL (USING "make install") ###
107rm -rf ${RPM_BUILD_ROOT}
108mkdir -p ${RPM_BUILD_ROOT}{%{_prefix},%{_sysconfdir}/netatalk/msg}
109make DESTDIR=$RPM_BUILD_ROOT install
110
111## netatalk/at.h is now provided by glibc
112rm -f $RPM_BUILD_ROOT%{_prefix}/include/netatalk/at.h
113
114## for Bonjour (requires nss-mdns)
115install -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services
116install -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services/
117
118
119%pre
120### COPY OLD PREFERENCE FILES ###
121
122if [ -d /etc/atalk ] ; then
123    mkdir -p /etc/netatalk/
124    cp -a /etc/atalk /etc/netatalk/00_OLD_VERSION_PREFS
125fi
126exit 0
127
128
129%post
130
131### RUN CHKCONFIG ###
132/sbin/chkconfig --add netatalk
133
134/sbin/ldconfig
135
136if test -r /var/lock/atalkd ; then
137        /etc/rc.d/init.d/netatalk restart >&2
138fi
139
140
141%preun
142
143### RUN CHKCONFIG ###
144/sbin/chkconfig --del netatalk
145
146
147%triggerpostun -- netatalk <= 1.4b2+asun2.1.3-7vl6
148/sbin/chkconfig --add netatalk
149
150
151%clean
152rm -rf ${RPM_BUILD_ROOT}
153
154
155%files
156%defattr(-,root,root)
157%doc CONTRIBUTORS COPYING COPYRIGHT
158%doc NEWS README* TODO
159%doc doc/[A-L,N-Z]*
160%config(noreplace) /etc/netatalk/Apple*
161%config(noreplace) /etc/netatalk/*.conf
162%config /etc/pam.d/netatalk
163%config /etc/rc.d/init.d/netatalk
164%dir %{_sysconfdir}/netatalk
165%dir %{_sysconfdir}/netatalk/msg
166%{_sysconfdir}/avahi/services/afpd.service
167%dir %{_var}/spool/netatalk
168%{_bindir}/*
169%{_sbindir}/*
170%{_libdir}/netatalk/*
171%exclude %{_libdir}/netatalk/*.a
172%exclude %{_libdir}/netatalk/*.la
173%{_mandir}/*/*
174%{_datadir}/netatalk/pagecount.ps
175
176
177%files devel
178%defattr(-,root,root)
179%{_libdir}/*.a
180%{_libdir}/*.la
181%{_libdir}/netatalk/*.a
182%{_libdir}/netatalk/*.la
183%dir %{_includedir}/atalk
184%{_includedir}/atalk/*.h
185%dir %{_includedir}/netatalk
186%{_includedir}/netatalk/*.h
187%{_datadir}/aclocal/netatalk.m4
188
189
190%changelog
191* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
192- rebuild with openssl-1.0.0c
193
194* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
195- fix Patch10 & update description - upon HAT-san's suggestions
196
197* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
198- new upstream release
199- update Vine patch
200
201* Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
202- new upstream release
203
204* Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
205- new upstream release
206
207* Sun Mar  8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
208- rebuilt both for VineSeed / VinePlus-4.0
209
210* Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
211- updated to the cjk-6 patch
212- Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
213- Patch14 updated for db46
214
215* Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
216- remove openslp dependency
217
218* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
219- add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
220- TODO: remember to revise this fix after VineSeed changes default locale
221        from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
222
223* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
224- revise description (thanks HAT-san for pointing this out)
225- run libtoolize/aclocal/auto{make,conf,header} before doing configure
226  (without this, uams_* modules won't get .so suffix)
227
228* Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
229- Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
230  (Patch10 now includes all the modifications and more fixes)
231
232* Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
233- add patch13 and patch14 for db-4.3.
234- move files in %%_libexecdir to %%libdir.
235
236* Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
237- updated to 2.0.3 release w/ cjk patches (see the above Patch section)
238
239* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
240- security fix: added Patch10 (CAN-2004-0974)
241
242* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
243- configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
244
245* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
246- updated to 2.0 with cjk patch
247  (see the above Patch section for details)
248
249* Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
250- merge the patch repairing bug for System 7.5.5
251- (patch6 netatalk-1.5.3.oldsys.patch)
252- made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
253- patch6 addupted no matter noeuc is, license GPL, URL in comment
254
255* Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
256- euc and kana patch originally by
257- Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
258- applied to netatalk-1.5.2 by me
259- README.vine
260- omit VERSION from doc, omit perl from require
261
262* Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
263- this package is removed because the release number duplicated
264
265* Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
266- move acleandir.rc to the doc directory, remove executable flag.
267
268* Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
269- updated to new upstream release
270
271* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
272- added Japanese Summary for devel and corrected Group
273
274* Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
275- Oops, check /var/lock/atalkd instead of /var/run/atd.pid
276  (say atd.pid doesn't have anything to do with netatalk!!)
277
278* Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
279- updated to new upstream release
280
281* Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
282- install man pages into %%{_mandir}
283- PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
284- let pre script exit 0
285
286* Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
287- spec cleanup
288- backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
289- restart atalk daemons in the %%post section
290
291* Sun Feb 3 2002  k hanai <hanai@koto.kpu-m.ac.jp>
292 - v1.5.1.1-0vl1
293
294* Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
295  - v1.5.0-0vl1
296  - release 1.5.0 for sourceforge
297
298* Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
299  - v1.5pre6-1rh7
300  - pre-release 6 for sourceforge
301
302* Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
303  - v1.5pre5-1
304  - pre-release 5 for sourceforge
305
306* Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
307  - v1.5pre5-0
308  - pre-release 5 for sourceforge (prebuild)
309
310* Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
311  - v1.5pre4-1
312  - pre-release 4 for sourceforge
313  - modified/split mandrake spec for redhat 7 build
314
315* Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
316  - v1.5pre3-1mdk
317  - pre-release 3 for sourceforge
318  - moved away from 1.4.99 ...
319
320* Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
321  - v1.4.99-0.20001108mdk
322  - pre-release 2 for sourceforge
323
324* Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
325  - v1.4.99-0.20000927mdk
326  - pre-release 1 for sourceforge
Note: See TracBrowser for help on using the repository browser.