source: projects/specs/trunk/n/netatalk/netatalk-vl.spec @ 12374

Revision 12374, 14.3 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

libevent-2.1.11-1

memcached-1.6.5-1

netatalk-3.1.12-2

nfs-utils-2.4.3-1

nsd-4.3.0-3

perl-Event-Lib-1.03-5

tmux-3.0a-1

unbound-1.10.0-2

zabbix-4.0.19-2

Line 
1%bcond_with systemd
2%global tracker_api 2.0
3
4################################################# BASIC PACKAGE INFORMATION
5Summary:        AFP fileserver for Macintosh clients
6Summary(ja):    Macintoshクライアント向けのAFPファイルサーバー
7Name:           netatalk
8Version:        3.1.12
9Release:        2%{_dist_release}%{?with_systemd:.systemd}
10Group:          System Environment/Daemons
11Vendor:         Project Vine
12Distribution:   Vine Linux
13Packager:       shaolin, tomop
14
15License:        GPLv2+
16URL:            http://netatalk.sourceforge.net/
17Source0:        %{name}-%{version}.tar.bz2
18Source1:        netatalk.pam-system-auth
19Source2:        netatalk.conf
20Patch0:         netatalk-3.0.1-basedir.patch
21Patch1:         netatalk-systemd-execstartpre.patch
22# https://github.com/Netatalk/Netatalk/pull/110
23Patch2:         netatalk-fix-incorrect-fsf-address.patch
24# https://github.com/Netatalk/Netatalk/pull/113
25Patch3:         netatalk-afpstats-python3-compat.patch
26# https://github.com/Netatalk/Netatalk/pull/125
27Patch4:         netatalk-invalid_dircache_entries.patch
28
29############################################################## REQUIREMENTS
30BuildRequires:  cracklib openssl-devel pam quota libtool automake
31BuildRequires:  autoconf libdb-devel pam-devel tcp_wrappers libgcrypt-devel
32BuildRequires:  avahi-devel libacl-devel openldap-devel
33BuildRequires:  dbus-devel dbus-glib-devel glib2-devel systemtap-sdt-devel
34BuildRequires:  libevent-devel libtdb-devel libmysqlclient-devel
35BuildRequires:  python3-rpm-macros
36BuildRequires:  tracker-devel
37
38Requires:       dbus-python3
39Requires:       dconf
40Requires(post): /sbin/ldconfig
41Requires(postun): /sbin/ldconfig
42%if %{with systemd}
43BuildRequires:  systemd
44%{?systemd_requires}
45%else
46Requires(post): /sbin/chkconfig
47Requires(preun): /sbin/chkconfig
48Requires(preun): /sbin/service
49Requires(postun): /sbin/service
50%endif
51
52BuildRoot:     %{_tmppath}/%{name}-%{version}-root
53
54%description
55Netatalk is a freely-available Open Source AFP fileserver. A *NIX/*BSD
56system running Netatalk is capable of serving many Macintosh clients
57simultaneously as an AppleShare file server (AFP).
58
59%description -l ja
60 Netatalkは自由に利用可能なオープンソースAFPファイルサーバーです。
61Netatalkを実行している*NIX/*BSDシステムでは、多くのMacintoshクライ
62アントに対してAppleShareファイルサーバー(AFP)としてサービスを提供
63可能です。
64
65%package devel
66Group:         Development/Libraries
67Summary:       Headers for Netatalk development
68Summary(ja):   Netatalk開発用ヘッダファイル
69
70%description devel
71This package contains the header files for Netatalk.
72
73
74%prep
75%setup -q
76%autopatch -p1
77
78rm -frv libevent/
79
80ln -s ./NEWS ChangeLog
81
82# Avoid re-running the autotools
83touch -r aclocal.m4 configure configure.ac macros/gssapi-check.m4
84
85# fix permissions
86find include \( -name '*.h' -a -executable \) -exec chmod -x {} \;
87
88# Don't call systemctl daemon-reload during the build
89sed -i 's\-systemctl daemon-reload\\g' distrib/initscripts/Makefile.in
90
91%build
92
93%ifnarch x86_64
94export CFLAGS=$(echo '%{optflags}' -fPIE | sed -e 's|-O2|-O0|')
95%else
96export CFLAGS="%{optflags} -fPIE"
97%endif
98export LDFLAGS="-pie -Wl,-z,relro,-z,now,-z,noexecstack"
99
100%configure \
101        --disable-silent-rules \
102        --disable-static \
103        --enable-shared \
104        --localstatedir=%{_localstatedir}/lib \
105        --with-pkgconfdir=%{_sysconfdir}/netatalk \
106        --with-cracklib \
107        --with-pam \
108        --with-shadow \
109        --with-uams-path=%{_libdir}/netatalk \
110        --enable-shared \
111        --enable-krbV-uam \
112        --enable-overwrite \
113        --with-gnu-ld \
114%if %{with systemd}
115        --with-lockfile=/run/lock/netatalk/netatalk \
116        --with-init-style=redhat-systemd \
117        --with-init-dir=%{_unitdir} \
118%else
119        --with-init-style=redhat-sysv \
120%endif
121        --with-libgcrypt \
122        --without-libevent \
123        --without-tdb \
124        --with-pam-confdir=%{_sysconfdir}/pam.d \
125        --with-dbus-sysconf-dir=%{_sysconfdir}/dbus-1/system.d \
126        -with-spotlight \
127        --with-tracker-pkgconfig-version=%{tracker_api}
128
129make %{?_smp_mflags} all
130
131%install
132### INSTALL (USING "make install") ###
133rm -rf ${RPM_BUILD_ROOT}
134
135make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
136
137# install our tmpfiles config
138install -Dpm644 %{SOURCE2} %{buildroot}%{_tmpfilesdir}/netatalk.conf
139
140# install example config files in doc
141mkdir config.example
142cp -fp config/afp.conf config.example
143cp -fp config/extmap.conf config.example
144mkdir -p $RPM_BUILD_ROOT/usr/share/netatalk
145
146cp -fp %{SOURCE1} config.example
147# XXX bad hack until this file is updated in glibc-headers:
148rm -f $RPM_BUILD_ROOT/usr/include/netatalk/at.h
149
150# Clean up .a and .la files
151find $RPM_BUILD_ROOT -name \*.a -exec rm {} \;
152find $RPM_BUILD_ROOT -name \*.la -exec rm {} \;
153
154# Fix python shebang
155sed -i 's\^#!/usr/bin/env python$\#!%{__python3}\' %{buildroot}/usr/bin/afpstats
156
157
158%clean
159rm -rf ${RPM_BUILD_ROOT}
160
161
162%post
163if [ -e /var/netatalk/afp_signature.conf -a ! -e /var/lib/netatalk/afp_signature.conf ]; then
164    mv -f /var/netatalk/afp_signature.conf /var/lib/netatalk/
165fi
166if [ -e /etc/netatalk/afp_signature.conf -a ! -e /var/lib/netatalk/afp_signature.conf ]; then
167    mv -f /etc/netatalk/afp_signature.conf /var/lib/netatalk/
168fi
169if [ -e /var/netatalk/afp_voluuid.conf -a ! -e /var/lib/netatalk/afp_voluuid.conf ]; then
170    mv -f /var/netatalk/afp_voluuid.conf /var/lib/netatalk/
171fi
172if [ -e /etc/netatalk/afp_voluuid.conf -a ! -e /var/lib/netatalk/afp_voluuid.conf ]; then
173    mv -f /etc/netatalk/afp_voluuid.conf /var/lib/netatalk/
174fi
175
176%if %{with systemd}
177%systemd_post %{name}.service
178%else
179/sbin/chkconfig --add netatalk
180%endif
181/sbin/ldconfig
182
183%preun
184%if %{with systemd}
185%systemd_preun %{name}.service
186%else
187if [ "$1" = "0" -o -x /bin/systemctl ] ; then
188    # check for existence due to renaming initscript
189    if [ -x  %{_initrddir}/netatalk ] ; then
190        /sbin/service netatalk stop > /dev/null 2>&1
191        /sbin/chkconfig --del netatalk
192    fi
193fi
194%endif
195
196%postun
197%if %{with systemd}
198%systemd_postun_with_restart %{name}.service
199%else
200if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
201    /sbin/service netatalk condrestart > /dev/null 2>&1 || :
202fi
203%endif
204/sbin/ldconfig
205
206
207%files
208%defattr(-,root,root)
209%license COPYING COPYRIGHT
210%doc NEWS
211%doc config.example
212%if %{with systemd}
213%{_unitdir}/netatalk.service
214%{_tmpfilesdir}/netatalk.conf
215%else
216%attr(755,root,root) %{_initrddir}/netatalk
217%endif
218%dir %{_sysconfdir}/netatalk
219%config(noreplace) %{_sysconfdir}/netatalk/afp.conf
220%config(noreplace) %{_sysconfdir}/netatalk/extmap.conf
221%config(noreplace) %{_sysconfdir}/netatalk/dbus-session.conf
222%config(noreplace) %{_sysconfdir}/pam.d/netatalk
223%config(noreplace) %{_sysconfdir}/dbus-1/system.d/netatalk-dbus.conf
224%{_sbindir}/*
225%{_bindir}/*
226%exclude %{_bindir}/netatalk-config
227%{_mandir}/man*/*
228%exclude %{_mandir}/man*/netatalk-config*
229%{_datadir}/netatalk
230%{_libdir}/*.so
231%{_libdir}/*.so.*
232%dir %{_libdir}/netatalk
233%{_libdir}/netatalk/*.so
234%{_localstatedir}/lib/netatalk
235
236%files devel
237%defattr(-,root,root)
238%license COPYING COPYRIGHT
239%dir %{_includedir}/atalk
240%attr(0644,root,root) %{_includedir}/atalk/*
241%{_datadir}/aclocal/netatalk.m4
242%{_bindir}/netatalk-config
243%{_mandir}/man*/netatalk-config.1*
244
245%changelog
246* Tue Apr 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.12-2
247- rebuilt with libevent-2.1.11.
248- added systemd support (disabled as default).
249
250* Mon Jan 07 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.12-1
251- new upstream release.
252
253* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.11-2
254- rebuilt with openssl-1.1.1 and libevent-2.1.8.
255
256* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.11-1
257- new upstream release.
258
259* Wed Jul 20 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.9-1
260- new upstream release.
261- dropped Patch1: fixed in upstream.
262
263* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.8-2
264- added Patch1.
265
266* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.8-1
267- new upstream release.
268
269* Tue Jun 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.7-1
270- new upstream release.
271
272* Mon Dec  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.2.2-2
273- rebuilt with libgcrypt 1.6.0 and libdb 5.3.28
274
275* Thu Apr 26 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.2.2-1
276- new upstream release.
277- added build option 'force_uidgid'.
278
279* Sun Sep 18 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.1-1
280- new upstream release
281- fix configure options; add missing BRs
282
283* Thu Jul 28 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-3
284- now back from the upstream confusion (and one more or two...)
285  new upstream release 2.2.0 at the official site
286
287* Mon Jul 25 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-2
288- fix Patch10 to follow HAT-san's strong and confident objection
289  (no need to set ATALK_NAME explicitly in netatalk.conf)
290
291* Sat Jul 23 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-1
292- new upstream release (at http://www003.upp.so-net.ne.jp/hat/netatalk/)
293- add Source100 to add one missing header file in the tarball
294- revise Patch10
295- explicitly specify --disable-ddp for the first time
296
297* Wed May 04 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.5-1
298- new upstream release
299
300* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
301- rebuild with openssl-1.0.0c
302
303* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
304- fix Patch10 & update description - upon HAT-san's suggestions
305
306* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
307- new upstream release
308- update Vine patch
309
310* Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
311- new upstream release
312
313* Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
314- new upstream release
315
316* Sun Mar  8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
317- rebuilt both for VineSeed / VinePlus-4.0
318
319* Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
320- updated to the cjk-6 patch
321- Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
322- Patch14 updated for db46
323
324* Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
325- remove openslp dependency
326
327* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
328- add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
329- TODO: remember to revise this fix after VineSeed changes default locale
330        from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
331
332* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
333- revise description (thanks HAT-san for pointing this out)
334- run libtoolize/aclocal/auto{make,conf,header} before doing configure
335  (without this, uams_* modules won't get .so suffix)
336
337* Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
338- Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
339  (Patch10 now includes all the modifications and more fixes)
340
341* Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
342- add patch13 and patch14 for db-4.3.
343- move files in %%_libexecdir to %%libdir.
344
345* Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
346- updated to 2.0.3 release w/ cjk patches (see the above Patch section)
347
348* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
349- security fix: added Patch10 (CAN-2004-0974)
350
351* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
352- configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
353
354* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
355- updated to 2.0 with cjk patch
356  (see the above Patch section for details)
357
358* Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
359- merge the patch repairing bug for System 7.5.5
360- (patch6 netatalk-1.5.3.oldsys.patch)
361- made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
362- patch6 addupted no matter noeuc is, license GPL, URL in comment
363
364* Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
365- euc and kana patch originally by
366- Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
367- applied to netatalk-1.5.2 by me
368- README.vine
369- omit VERSION from doc, omit perl from require
370
371* Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
372- this package is removed because the release number duplicated
373
374* Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
375- move acleandir.rc to the doc directory, remove executable flag.
376
377* Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
378- updated to new upstream release
379
380* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
381- added Japanese Summary for devel and corrected Group
382
383* Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
384- Oops, check /var/lock/atalkd instead of /var/run/atd.pid
385  (say atd.pid doesn't have anything to do with netatalk!!)
386
387* Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
388- updated to new upstream release
389
390* Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
391- install man pages into %%{_mandir}
392- PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
393- let pre script exit 0
394
395* Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
396- spec cleanup
397- backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
398- restart atalk daemons in the %%post section
399
400* Sun Feb 3 2002  k hanai <hanai@koto.kpu-m.ac.jp>
401 - v1.5.1.1-0vl1
402
403* Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
404  - v1.5.0-0vl1
405  - release 1.5.0 for sourceforge
406
407* Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
408  - v1.5pre6-1rh7
409  - pre-release 6 for sourceforge
410
411* Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
412  - v1.5pre5-1
413  - pre-release 5 for sourceforge
414
415* Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
416  - v1.5pre5-0
417  - pre-release 5 for sourceforge (prebuild)
418
419* Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
420  - v1.5pre4-1
421  - pre-release 4 for sourceforge
422  - modified/split mandrake spec for redhat 7 build
423
424* Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
425  - v1.5pre3-1mdk
426  - pre-release 3 for sourceforge
427  - moved away from 1.4.99 ...
428
429* Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
430  - v1.4.99-0.20001108mdk
431  - pre-release 2 for sourceforge
432
433* Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
434  - v1.4.99-0.20000927mdk
435  - pre-release 1 for sourceforge
Note: See TracBrowser for help on using the repository browser.