source: projects/specs/trunk/n/netatalk/netatalk-vl.spec @ 521

Revision 521, 10.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _sysconfdir     /etc
2
3################################################# BASIC PACKAGE INFORMATION
4Summary:       AppleTalk and AppleShare/IP services for Linux
5Summary(ja):   Linux 用 AppleTalk, AppleShare/IP サービス
6Name:          netatalk
7Version:       2.0.5
8Release:       1%{_dist_release}
9License:       GPL
10Group:         System Environment/Daemons
11Source0:       %{name}-%{version}.tar.bz2
12URL:           http://netatalk.sourceforge.net/
13Obsoletes:     netatalk-1.4b2+asun
14
15# taken from http://www003.upp.so-net.ne.jp/hat/netatalk/cjk.html
16#Patch10:       netatalk-2.0.3-cjk-6.patch.gz
17
18# patch for default config file
19Patch11:       netatalk-2.0.4-config-eucjp.patch
20Patch12:       netatalk-2.0.4-config-utf8.patch
21
22# other patches
23#Patch13:       netatalk-2.0.3-db43.patch
24#Patch14:       netatalk-2.0.3-newerdb.patch
25
26Source10:      afpd.service
27
28
29############################################################## REQUIREMENTS
30PreReq:        chkconfig, /sbin/ldconfig, grep, textutils
31Requires:      cracklib, openssl, tcp_wrappers, pam, perl
32BuildRequires: openssl-devel, pam-devel, cups-devel, db4-devel, quota
33
34BuildRoot:     %{_tmppath}/%{name}-%{version}-root
35
36
37%description
38Netatalk is a freely-available, kernel level implementation of the
39AppleTalk Protocol Suite, originally for BSD-derived systems.
40A *NIX/*BSD system running netatalk is capable of serving many macintosh
41clients simultaneously as an AppleTalk router, AppleShare file server (AFP),
42*NIX/*BSD print server, and for accessing AppleTalk printers via Printer
43Access Protocol (PAP).
44
45%description -l ja
46このパッケージを使うことで, Linux 上で AppleTalk プロトコルを
47扱うことができ, Macintosh と通信が可能になります.
48Linux 上で EtherTalk や AppleTalk over IP の Mac 向けファイルサーバを
49稼働させることができるデーモンプログラムが収められています.
50
51
52%package devel
53Group:         Development/Libraries
54Summary:       Appletalk and Appleshare/IP services for Linux development files
55Summary(ja):   Linux 用 AppleTalk と Appleshare/IP サービスの開発用ファイル
56
57%description devel
58Netatalk is a freely-available, kernel level implementation of the
59AppleTalk Protocol Suite, originally for BSD-derived systems.
60A *NIX/*BSD system running netatalk is capable of serving many macintosh
61clients simultaneously as an AppleTalk router, AppleShare file server (AFP),
62*NIX/*BSD print server, and for accessing AppleTalk printers via Printer
63Access Protocol (PAP).
64
65This package is required for developing appletalk-based applications.
66
67
68%prep
69%setup -q
70
71#%patch10 -p1 -b .cjk
72
73%if %{?_dist_release}=="vl4"
74%patch11 -p1 -b .cjk-config
75%else
76%patch12 -p1 -b .cjk-config
77%endif
78
79#%patch13 -p1 -b .db43
80#%patch14 -p1 -b .newerdb
81
82
83%build
84touch AUTHORS
85ln -s NEWS ChangeLog
86rm -f README.cjk4.cjk
87
88libtoolize --force
89aclocal -I macros
90automake --add-missing
91autoconf
92autoheader
93CFLAGS="${RPM_OPT_FLAGS} -fomit-frame-pointer -fsigned-char" \
94./configure \
95        --prefix=%{_prefix} \
96        --libdir=%{_libdir} \
97        --libexecdir=%{_libdir}/netatalk \
98        --sysconfdir=%{_sysconfdir} \
99        --mandir=%{_mandir} \
100        --localstatedir=%{_var} \
101        --enable-shared \
102        --enable-afp3 \
103        --with-cnid-dbd-backend \
104        --with-cnid-cdb-backend \
105        --with-cnid-default-backend=dbd \
106        --enable-cups \
107        --with-message-dir=%{_sysconfdir}/netatalk/msg \
108        --with-uams-path=%{_libdir}/netatalk \
109        --with-spooldir=%{_var}/spool/netatalk \
110        --enable-redhat \
111        --with-flock-locksi \
112        --with-cracklib \
113        --with-pam \
114        --with-shadow \
115        --with-tcp-wrappers \
116        --with-ssl \
117        --enable-pgp-uam
118
119make all
120
121
122%install
123### INSTALL (USING "make install") ###
124rm -rf ${RPM_BUILD_ROOT}
125mkdir -p ${RPM_BUILD_ROOT}{%{_prefix},%{_sysconfdir}/netatalk/msg}
126make DESTDIR=$RPM_BUILD_ROOT install
127
128## netatalk/at.h is now provided by glibc
129rm -f $RPM_BUILD_ROOT%{_prefix}/include/netatalk/at.h
130
131## acleandir.rc requires /usr/bin/rc. move it.
132mv $RPM_BUILD_ROOT%{_bindir}/acleandir.rc .
133chmod 644 acleandir.rc
134
135## for Bonjour (requires nss-mdns)
136install -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services
137install -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services/
138
139
140%pre
141### COPY OLD PREFERENCE FILES ###
142
143if [ -d /etc/atalk ] ; then
144    mkdir -p /etc/netatalk/
145    cp -a /etc/atalk /etc/netatalk/00_OLD_VERSION_PREFS
146fi
147exit 0
148
149
150%post
151
152### RUN CHKCONFIG ###
153/sbin/chkconfig --add atalk
154
155/sbin/ldconfig
156
157if test -r /var/lock/atalkd ; then
158        /etc/rc.d/init.d/atalk restart >&2
159fi
160
161
162%preun
163
164### RUN CHKCONFIG ###
165/sbin/chkconfig --del atalk
166
167
168%triggerpostun -- netatalk <= 1.4b2+asun2.1.3-7vl6
169/sbin/chkconfig --add atalk
170
171
172%clean
173rm -rf ${RPM_BUILD_ROOT}
174
175
176%files
177%defattr(-,root,root)
178%doc CONTRIBUTORS COPYING COPYRIGHT
179%doc NEWS README* TODO
180%doc acleandir.rc doc/[A-L,N-Z]*
181%config(noreplace) /etc/netatalk/Apple*
182%config(noreplace) /etc/netatalk/*.conf
183%config /etc/pam.d/netatalk
184%config /etc/rc.d/init.d/atalk
185%dir %{_sysconfdir}/netatalk
186%dir %{_sysconfdir}/netatalk/msg
187%{_sysconfdir}/avahi/services/afpd.service
188%dir %{_var}/spool/netatalk
189%{_bindir}/*
190%{_sbindir}/*
191%{_libdir}/netatalk/*
192%exclude %{_libdir}/netatalk/*.a
193%exclude %{_libdir}/netatalk/*.la
194%{_mandir}/*/*
195%{_datadir}/netatalk/pagecount.ps
196
197
198%files devel
199%defattr(-,root,root)
200%{_libdir}/*.a
201%{_libdir}/*.la
202%{_libdir}/netatalk/*.a
203%{_libdir}/netatalk/*.la
204%dir %{_includedir}/atalk
205%{_includedir}/atalk/*.h
206%dir %{_includedir}/netatalk
207%{_includedir}/netatalk/*.h
208%{_datadir}/aclocal/netatalk.m4
209
210
211%changelog
212* Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
213- new upstream release
214
215* Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
216- new upstream release
217
218* Sun Mar  8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
219- rebuilt both for VineSeed / VinePlus-4.0
220
221* Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
222- updated to the cjk-6 patch
223- Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
224- Patch14 updated for db46
225
226* Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
227- remove openslp dependency
228
229* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
230- add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
231- TODO: remember to revise this fix after VineSeed changes default locale
232        from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
233
234* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
235- revise description (thanks HAT-san for pointing this out)
236- run libtoolize/aclocal/auto{make,conf,header} before doing configure
237  (without this, uams_* modules won't get .so suffix)
238
239* Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
240- Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
241  (Patch10 now includes all the modifications and more fixes)
242
243* Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
244- add patch13 and patch14 for db-4.3.
245- move files in %%_libexecdir to %%libdir.
246
247* Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
248- updated to 2.0.3 release w/ cjk patches (see the above Patch section)
249
250* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
251- security fix: added Patch10 (CAN-2004-0974)
252
253* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
254- configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
255
256* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
257- updated to 2.0 with cjk patch
258  (see the above Patch section for details)
259
260* Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
261- merge the patch repairing bug for System 7.5.5
262- (patch6 netatalk-1.5.3.oldsys.patch)
263- made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
264- patch6 addupted no matter noeuc is, license GPL, URL in comment
265
266* Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
267- euc and kana patch originally by
268- Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
269- applied to netatalk-1.5.2 by me
270- README.vine
271- omit VERSION from doc, omit perl from require
272
273* Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
274- this package is removed because the release number duplicated
275
276* Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
277- move acleandir.rc to the doc directory, remove executable flag.
278
279* Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
280- updated to new upstream release
281
282* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
283- added Japanese Summary for devel and corrected Group
284
285* Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
286- Oops, check /var/lock/atalkd instead of /var/run/atd.pid
287  (say atd.pid doesn't have anything to do with netatalk!!)
288
289* Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
290- updated to new upstream release
291
292* Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
293- install man pages into %%{_mandir}
294- PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
295- let pre script exit 0
296
297* Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
298- spec cleanup
299- backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
300- restart atalk daemons in the %%post section
301
302* Sun Feb 3 2002  k hanai <hanai@koto.kpu-m.ac.jp>
303 - v1.5.1.1-0vl1
304
305* Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
306  - v1.5.0-0vl1
307  - release 1.5.0 for sourceforge
308
309* Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
310  - v1.5pre6-1rh7
311  - pre-release 6 for sourceforge
312
313* Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
314  - v1.5pre5-1
315  - pre-release 5 for sourceforge
316
317* Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
318  - v1.5pre5-0
319  - pre-release 5 for sourceforge (prebuild)
320
321* Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
322  - v1.5pre4-1
323  - pre-release 4 for sourceforge
324  - modified/split mandrake spec for redhat 7 build
325
326* Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
327  - v1.5pre3-1mdk
328  - pre-release 3 for sourceforge
329  - moved away from 1.4.99 ...
330
331* Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
332  - v1.4.99-0.20001108mdk
333  - pre-release 2 for sourceforge
334
335* Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
336  - v1.4.99-0.20000927mdk
337  - pre-release 1 for sourceforge
Note: See TracBrowser for help on using the repository browser.