source: projects/specs/trunk/n/neon/neon-vl.spec @ 521

Revision 521, 7.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: An HTTP and WebDAV client library.
4Summary(ja): HTTP と WebDAV クライアントのライブラリ
5Name: neon
6Version: 0.28.6
7Release: 1%{?_dist_release}
8License: LGPLv2+
9Group: System Environment/Libraries
10URL: http://www.webdav.org/neon/
11Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: expat
14Requires: zlib >= 1.1.4
15Requires: krb5-libs
16BuildRequires: expat-devel
17BuildRequires: openssl-devel
18BuildRequires: libxml2-devel
19BuildRequires: zlib-devel
20BuildRequires: gnutls-devel
21BuildRequires: krb5-devel
22BuildRequires: sed
23
24%description
25neon is an HTTP and WebDAV client library, with a C interface;
26providing a high-level interface to HTTP and WebDAV methods along
27with a low-level interface for HTTP request handling.  neon
28supports persistent connections, proxy servers, basic, digest and
29Kerberos authentication, and has complete SSL support.
30
31%package devel
32Summary: Development libraries and C header files for the neon library
33Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
34Group: Development/Libraries
35Requires: %{name} = %{version}
36Requires: zlib-devel
37Requires: openssl-devel
38Requires: expat-devel
39Requires: gnutls-devel
40
41%description devel
42The development library for the C language HTTP and WebDAV client library.
43
44%description devel -l ja
45C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
46
47## to build compat32 for x86_64 architecture support
48%package -n compat32-%{name}
49Summary: C language HTTP and WebDAV client library.
50Group: System Environment/Libraries
51Requires: expat
52Requires: zlib >= 1.1.4
53
54%description -n compat32-%{name}
55A C language HTTP and WebDAV client library.
56
57%package -n compat32-%{name}-devel
58Summary: A C language HTTP and WebDAV client library.
59Group: Development/Libraries
60Requires: compat32-%{name} = %{version}
61Requires: compat32-zlib-devel
62Requires: compat32-openssl-devel
63Requires: compat32-expat-devel
64
65%description -n compat32-%{name}-devel
66The development library for the C language HTTP and WebDAV client library.
67
68%prep
69%setup -q
70
71%build
72%configure \
73        --with-expat \
74        --with-ssl=gnutls --enable-threadsafe-ssl=posix \
75        --enable-shared \
76        --with-force-ssl
77%__make %{?_smp_mflags}
78
79%install
80%__rm -rf %{buildroot}
81%makeinstall
82
83sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
84      $RPM_BUILD_ROOT%{_libdir}/libneon.la
85
86%find_lang %{name}
87
88## remove unuse files
89rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
90
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%post -p /sbin/ldconfig
96
97%postun -p /sbin/ldconfig
98
99%post -n compat32-%{name} -p /sbin/ldconfig
100
101%postun -n compat32-%{name} -p /sbin/ldconfig
102
103%files -f %{name}.lang
104%defattr(-,root,root)
105%doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README THANKS TODO
106%doc doc/html
107%{_libdir}/*.so.*
108
109%files devel
110%defattr(-,root,root)
111%{_bindir}/*
112%{_includedir}/*
113%{_mandir}/man1/*
114%{_mandir}/man3/*
115%{_libdir}/*.a
116#%{_libdir}/*.la
117%{_libdir}/*.so
118%{_libdir}/pkgconfig/*.pc
119
120%if %{build_compat32}
121%files -n compat32-%{name}
122%defattr(-,root,root)
123%{_libdir}/*.so*
124
125%files -n compat32-%{name}-devel
126%defattr(-,root,root)
127%{_libdir}/*.a
128#%{_libdir}/*.la
129%{_libdir}/pkgconfig/*.pc
130%endif
131
132%changelog
133* Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
134- new upstream release with security fix (CVE-2009-2473, 2474)
135
136* Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
137- rebuild with gnutls-2.6.3
138
139* Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
140- add Requires/BuildRequires krb5-libs/krb5-devel tags
141- add _smp_mflags into make section
142
143* Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
144- new upstream release with security fix (CVE-2008-3746)
145
146* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
147- removed *.la
148- spec in utf-8
149
150* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
151- added --with-ssl=gnutls --enable-threadsafe-ssl
152- added BuildRequires: gnutls-devel
153
154* Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
155- new upstream release
156
157* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
158- removed %%if !%%{build_compat32} case condition
159
160* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
161- rebuild with expat-2.0.1
162
163* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
164- new upstream release
165
166* Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
167- add Requires: zlib-devel, openssl-devel, expat-devel
168
169* Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
170- move %%configure from %%prep to %%build
171- remove unneeded locales.patch (for neon-0.26.x or later)
172
173* Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
174- new upstream release
175- drop doc.patch (patch0)
176- use more macros
177- drop BuildRequires: autoconf, automake
178- add *.pc to -devel (and compat32's) package
179- change group
180- add Requires: %%{name} = %%{version} to -devel (and compat32's) package
181- add doc/html instead of doc/* to %%doc
182- move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
183- run ldconfig in %%post,postun
184- add locales.patch (patch0)
185
186* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
187- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
188
189* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
190- added compat32- packages for x86_64 architecture support
191- added --libdir=%{_libdir} option to configure
192
193* Sun Sep  5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
194- new upstream release
195
196* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
197- upstream release
198- update URL and Source0 tag: valid URL
199
200* Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
201- upstream release
202- add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
203- add Japanese Summary and %%description
204
205* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
206- build VineLinux
207
208* Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
209- Updated to 0.23.5.
210
211* Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
212- Upgraded to 0.23.2.
213
214* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
215- Upgraded to 0.22.0.
216- Fixed compilation from CVS.
217- Took out man pages until I can figure out xmlto program.
218
219* Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
220- Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
221  to RedHat 7.3 versions and fixing bug in spec file.
222- Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
223  work.
224
225* Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
226- Fixed file ownership problems.  Made them owned by root.
227
228* Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
229- Updated to neon 0.21.3.
230
231* Tue Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
232- Updated to neon 0.21.2.
233
234* Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
235- Updated to neon 0.21.1.
236- Now requires zlib >= 1.1.4.
237- Broke into zlib and zlib-devel.
238- Now builds shared library.
239
240* Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
241- Updated to neon 0.19.4.
242
243* Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
244- Updated to neon 0.19.2.
245
246* Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
247- Updated to neon 0.18.2.
248
249* Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
250- Took out dependency on libxml and w3c-libwww packages.
251- Added dependency on expat.
252
253* Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
254- Release 0.17.2-1: Updated neon.
255
256* Thu Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
257- Release 2: Fixed prefix to be /usr instead of /usr/local.
258
259* Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
260- Release 2001-10-20: Initial Version.
261
Note: See TracBrowser for help on using the repository browser.