source: projects/specs/trunk/n/neon/neon-vl.spec @ 12557

Revision 12557, 9.1 KB checked in by tomop, 3 years ago (diff)

updated 2 packages

neon-0.31.2-1

openblas-0.3.13-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: neon
4Summary: An HTTP and WebDAV client library.
5Summary(ja): HTTP と WebDAV クライアントのライブラリ
6Version: 0.31.2
7Release: 1%{?_dist_release}
8Group: system
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: LGPLv2+
13URL: https://notroj.github.io/neon/
14Source0: https://notroj.github.io/neon/%{name}-%{version}.tar.gz
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17Requires: expat
18Requires: zlib >= 1.1.4
19Requires: krb5-libs
20BuildRequires: expat-devel
21BuildRequires: gnutls-devel
22BuildRequires: krb5-devel
23BuildRequires: libxml2-devel
24BuildRequires: sed
25BuildRequires: zlib-devel
26BuildRequires: keyutils-libs-devel
27
28%description
29neon is an HTTP and WebDAV client library, with a C interface;
30providing a high-level interface to HTTP and WebDAV methods along
31with a low-level interface for HTTP request handling.  neon
32supports persistent connections, proxy servers, basic, digest and
33Kerberos authentication, and has complete SSL support.
34
35
36%package devel
37Summary: Development libraries and C header files for the neon library
38Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
39Group: programming
40Requires: %{name} = %{version}
41Requires: zlib-devel
42#Requires: openssl-devel
43Requires: expat-devel
44Requires: gnutls-devel
45Requires: krb5-devel
46Requires: keyutils-libs-devel
47
48%description devel
49The development library for the C language HTTP and WebDAV client library.
50
51%description devel -l ja
52C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
53
54
55## to build compat32 for x86_64 architecture support
56%package -n compat32-%{name}
57Summary: C language HTTP and WebDAV client library.
58Group: system
59Requires: expat
60Requires: zlib >= 1.1.4
61
62%description -n compat32-%{name}
63A C language HTTP and WebDAV client library.
64
65
66%package -n compat32-%{name}-devel
67Summary: A C language HTTP and WebDAV client library.
68Group: programming
69Requires: compat32-%{name} = %{version}
70Requires: compat32-zlib-devel
71#Requires: compat32-openssl-devel
72Requires: compat32-expat-devel
73Requires: compat32-keyutils-libs-devel
74Requires: compat32-krb5-devel
75
76%description -n compat32-%{name}-devel
77The development library for the C language HTTP and WebDAV client library.
78
79
80%debug_package
81
82
83%prep
84%setup -q
85
86# for GnuTLS 3.4
87#sed -e 's/client_set/set/'  \
88#       -e 's/gnutls_retr/&2/'  \
89#       -e 's/type = t/cert_&/' \
90#       -i src/ne_gnutls.c
91
92%build
93%configure \
94        --with-expat \
95        --with-ssl=gnutls \
96        --enable-threadsafe-ssl=posix \
97        --enable-shared \
98        --disable-static \
99        --with-force-ssl
100%__make %{?_smp_mflags}
101
102
103%install
104%__rm -rf %{buildroot}
105%makeinstall
106
107sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
108      $RPM_BUILD_ROOT%{_libdir}/libneon.la
109
110%find_lang %{name}
111
112## remove unuse files
113rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
114
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119
120%ldconfig_scriptlets
121%ldconfig_scriptlets -n compat32-%{name}
122
123
124%files -f %{name}.lang
125%defattr(-,root,root)
126%doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README THANKS TODO
127%doc doc/html
128%{_libdir}/*.so.*
129
130%files devel
131%defattr(-,root,root)
132%{_bindir}/*
133%{_includedir}/*
134%{_mandir}/man1/*
135%{_mandir}/man3/*
136#{_libdir}/*.a
137#{_libdir}/*.la
138%{_libdir}/*.so
139%{_libdir}/pkgconfig/*.pc
140
141%if %{build_compat32}
142%files -n compat32-%{name}
143%defattr(-,root,root)
144%{_libdir}/*.so.*
145
146%files -n compat32-%{name}-devel
147%defattr(-,root,root)
148#{_libdir}/*.a
149#{_libdir}/*.la
150%{_libdir}/pkgconfig/*.pc
151%endif
152
153
154%changelog
155* Sun Feb 28 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.31.2-1
156- new upstream release.
157
158* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.30.2-1
159- new upstream release.
160
161* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.30.1-1
162- new upstream release.
163- built with gnutls-3.4.x.
164
165* Tue Feb 25 2014 NAKAMURA Kenta <kenta@vinelinux.org> 0.30.0-1
166- update to 0.30.0
167
168* Sun Jan 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-2
169- rebuild with VineSeed environment
170
171* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-1
172- update to 0.29.6
173
174* Mon May 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.3-2
175- add BuildRequires: keyutils-libs-devel
176- add Requires: krb5-devel, keyutils-libs-devel (-devel package)
177
178* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 0.29.3-1
179- new upstream release
180
181* Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.6-3
182- rebuilt with krb5-libs-1.8.2
183- removed BR: openssl-devel
184- removed static library from devel package
185
186* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.28.6-2
187- rebuilt with rpm-4.8.1 for pkg-config
188
189* Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
190- new upstream release with security fix (CVE-2009-2473, 2474)
191
192* Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
193- rebuild with gnutls-2.6.3
194
195* Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
196- add Requires/BuildRequires krb5-libs/krb5-devel tags
197- add _smp_mflags into make section
198
199* Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
200- new upstream release with security fix (CVE-2008-3746)
201
202* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
203- removed *.la
204- spec in utf-8
205
206* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
207- added --with-ssl=gnutls --enable-threadsafe-ssl
208- added BuildRequires: gnutls-devel
209
210* Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
211- new upstream release
212
213* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
214- removed %%if !%%{build_compat32} case condition
215
216* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
217- rebuild with expat-2.0.1
218
219* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
220- new upstream release
221
222* Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
223- add Requires: zlib-devel, openssl-devel, expat-devel
224
225* Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
226- move %%configure from %%prep to %%build
227- remove unneeded locales.patch (for neon-0.26.x or later)
228
229* Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
230- new upstream release
231- drop doc.patch (patch0)
232- use more macros
233- drop BuildRequires: autoconf, automake
234- add *.pc to -devel (and compat32's) package
235- change group
236- add Requires: %%{name} = %%{version} to -devel (and compat32's) package
237- add doc/html instead of doc/* to %%doc
238- move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
239- run ldconfig in %%post,postun
240- add locales.patch (patch0)
241
242* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
243- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
244
245* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
246- added compat32- packages for x86_64 architecture support
247- added --libdir=%{_libdir} option to configure
248
249* Sun Sep  5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
250- new upstream release
251
252* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
253- upstream release
254- update URL and Source0 tag: valid URL
255
256* Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
257- upstream release
258- add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
259- add Japanese Summary and %%description
260
261* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
262- build VineLinux
263
264* Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
265- Updated to 0.23.5.
266
267* Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
268- Upgraded to 0.23.2.
269
270* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
271- Upgraded to 0.22.0.
272- Fixed compilation from CVS.
273- Took out man pages until I can figure out xmlto program.
274
275* Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
276- Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
277  to RedHat 7.3 versions and fixing bug in spec file.
278- Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
279  work.
280
281* Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
282- Fixed file ownership problems.  Made them owned by root.
283
284* Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
285- Updated to neon 0.21.3.
286
287* Sun Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
288- Updated to neon 0.21.2.
289
290* Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
291- Updated to neon 0.21.1.
292- Now requires zlib >= 1.1.4.
293- Broke into zlib and zlib-devel.
294- Now builds shared library.
295
296* Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
297- Updated to neon 0.19.4.
298
299* Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
300- Updated to neon 0.19.2.
301
302* Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
303- Updated to neon 0.18.2.
304
305* Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
306- Took out dependency on libxml and w3c-libwww packages.
307- Added dependency on expat.
308
309* Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
310- Release 0.17.2-1: Updated neon.
311
312* Wed Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
313- Release 2: Fixed prefix to be /usr instead of /usr/local.
314
315* Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
316- Release 2001-10-20: Initial Version.
317
Note: See TracBrowser for help on using the repository browser.