source: projects/specs/trunk/n/neon/neon-vl.spec @ 1984

Revision 1984, 7.9 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: An HTTP and WebDAV client library.
4Summary(ja): HTTP と WebDAV クライアントのライブラリ
5Name: neon
6Version: 0.28.6
7Release: 2%{?_dist_release}
8License: LGPLv2+
9Group: System Environment/Libraries
10URL: http://www.webdav.org/neon/
11Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: expat
14Requires: zlib >= 1.1.4
15Requires: krb5-libs
16BuildRequires: expat-devel
17BuildRequires: openssl-devel
18BuildRequires: libxml2-devel
19BuildRequires: zlib-devel
20BuildRequires: gnutls-devel
21BuildRequires: krb5-devel
22BuildRequires: sed
23
24%description
25neon is an HTTP and WebDAV client library, with a C interface;
26providing a high-level interface to HTTP and WebDAV methods along
27with a low-level interface for HTTP request handling.  neon
28supports persistent connections, proxy servers, basic, digest and
29Kerberos authentication, and has complete SSL support.
30
31%package devel
32Summary: Development libraries and C header files for the neon library
33Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
34Group: Development/Libraries
35Requires: %{name} = %{version}
36Requires: zlib-devel
37Requires: openssl-devel
38Requires: expat-devel
39Requires: gnutls-devel
40
41%description devel
42The development library for the C language HTTP and WebDAV client library.
43
44%description devel -l ja
45C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
46
47## to build compat32 for x86_64 architecture support
48%package -n compat32-%{name}
49Summary: C language HTTP and WebDAV client library.
50Group: System Environment/Libraries
51Requires: expat
52Requires: zlib >= 1.1.4
53
54%description -n compat32-%{name}
55A C language HTTP and WebDAV client library.
56
57%package -n compat32-%{name}-devel
58Summary: A C language HTTP and WebDAV client library.
59Group: Development/Libraries
60Requires: compat32-%{name} = %{version}
61Requires: compat32-zlib-devel
62Requires: compat32-openssl-devel
63Requires: compat32-expat-devel
64
65%description -n compat32-%{name}-devel
66The development library for the C language HTTP and WebDAV client library.
67
68%prep
69%setup -q
70
71%build
72%configure \
73        --with-expat \
74        --with-ssl=gnutls --enable-threadsafe-ssl=posix \
75        --enable-shared \
76        --with-force-ssl
77%__make %{?_smp_mflags}
78
79%install
80%__rm -rf %{buildroot}
81%makeinstall
82
83sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
84      $RPM_BUILD_ROOT%{_libdir}/libneon.la
85
86%find_lang %{name}
87
88## remove unuse files
89rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
90
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%post -p /sbin/ldconfig
96
97%postun -p /sbin/ldconfig
98
99%post -n compat32-%{name} -p /sbin/ldconfig
100
101%postun -n compat32-%{name} -p /sbin/ldconfig
102
103%files -f %{name}.lang
104%defattr(-,root,root)
105%doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README THANKS TODO
106%doc doc/html
107%{_libdir}/*.so.*
108
109%files devel
110%defattr(-,root,root)
111%{_bindir}/*
112%{_includedir}/*
113%{_mandir}/man1/*
114%{_mandir}/man3/*
115%{_libdir}/*.a
116#%{_libdir}/*.la
117%{_libdir}/*.so
118%{_libdir}/pkgconfig/*.pc
119
120%if %{build_compat32}
121%files -n compat32-%{name}
122%defattr(-,root,root)
123%{_libdir}/*.so*
124
125%files -n compat32-%{name}-devel
126%defattr(-,root,root)
127%{_libdir}/*.a
128#%{_libdir}/*.la
129%{_libdir}/pkgconfig/*.pc
130%endif
131
132%changelog
133* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.28.6-2
134- rebuilt with rpm-4.8.1 for pkg-config
135
136* Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
137- new upstream release with security fix (CVE-2009-2473, 2474)
138
139* Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
140- rebuild with gnutls-2.6.3
141
142* Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
143- add Requires/BuildRequires krb5-libs/krb5-devel tags
144- add _smp_mflags into make section
145
146* Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
147- new upstream release with security fix (CVE-2008-3746)
148
149* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
150- removed *.la
151- spec in utf-8
152
153* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
154- added --with-ssl=gnutls --enable-threadsafe-ssl
155- added BuildRequires: gnutls-devel
156
157* Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
158- new upstream release
159
160* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
161- removed %%if !%%{build_compat32} case condition
162
163* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
164- rebuild with expat-2.0.1
165
166* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
167- new upstream release
168
169* Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
170- add Requires: zlib-devel, openssl-devel, expat-devel
171
172* Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
173- move %%configure from %%prep to %%build
174- remove unneeded locales.patch (for neon-0.26.x or later)
175
176* Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
177- new upstream release
178- drop doc.patch (patch0)
179- use more macros
180- drop BuildRequires: autoconf, automake
181- add *.pc to -devel (and compat32's) package
182- change group
183- add Requires: %%{name} = %%{version} to -devel (and compat32's) package
184- add doc/html instead of doc/* to %%doc
185- move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
186- run ldconfig in %%post,postun
187- add locales.patch (patch0)
188
189* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
190- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
191
192* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
193- added compat32- packages for x86_64 architecture support
194- added --libdir=%{_libdir} option to configure
195
196* Sun Sep  5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
197- new upstream release
198
199* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
200- upstream release
201- update URL and Source0 tag: valid URL
202
203* Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
204- upstream release
205- add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
206- add Japanese Summary and %%description
207
208* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
209- build VineLinux
210
211* Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
212- Updated to 0.23.5.
213
214* Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
215- Upgraded to 0.23.2.
216
217* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
218- Upgraded to 0.22.0.
219- Fixed compilation from CVS.
220- Took out man pages until I can figure out xmlto program.
221
222* Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
223- Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
224  to RedHat 7.3 versions and fixing bug in spec file.
225- Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
226  work.
227
228* Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
229- Fixed file ownership problems.  Made them owned by root.
230
231* Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
232- Updated to neon 0.21.3.
233
234* Tue Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
235- Updated to neon 0.21.2.
236
237* Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
238- Updated to neon 0.21.1.
239- Now requires zlib >= 1.1.4.
240- Broke into zlib and zlib-devel.
241- Now builds shared library.
242
243* Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
244- Updated to neon 0.19.4.
245
246* Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
247- Updated to neon 0.19.2.
248
249* Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
250- Updated to neon 0.18.2.
251
252* Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
253- Took out dependency on libxml and w3c-libwww packages.
254- Added dependency on expat.
255
256* Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
257- Release 0.17.2-1: Updated neon.
258
259* Thu Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
260- Release 2: Fixed prefix to be /usr instead of /usr/local.
261
262* Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
263- Release 2001-10-20: Initial Version.
264
Note: See TracBrowser for help on using the repository browser.