source: projects/specs/trunk/n/ncurses/ncurses-vl.spec @ 5284

Revision 5284, 19.1 KB checked in by daisuke, 12 years ago (diff)

fix libtinfo linking problem

Line 
1Summary: A CRT screen handling and optimization package.
2Summary(ja): CRT スクリーンの操作と最適化を行うパッケージ
3Name: ncurses
4Version: 5.9
5%define includedirw %{_includedir}/ncursesw
6%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
7Release: 2%{?_dist_release}
8License: distributable
9Group: System Environment/Libraries
10URL: http://dickey.his.com/ncurses/ncurses.html
11
12Source0: ftp://invisible-island.net/ncurses/ncurses-%{version}.tar.gz
13
14Patch1: ncurses-5.9-20110409-20110716.patch.bz2
15Patch8: ncurses-config.patch
16Patch9: ncurses-libs.patch
17Patch11: ncurses-urxvt.patch
18Patch12: ncurses-kbs.patch
19
20Requires(post): /sbin/ldconfig
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: pkgconfig
24
25Vendor: Project Vine
26Distribution: Vine Linux
27Packager: daisuke
28
29%description
30The curses library routines are a terminal-independent method of
31updating character screens with reasonable optimization.  The ncurses
32(new curses) library is a freely distributable replacement for the
33discontinued 4.4 BSD classic curses library.
34
35
36%package devel
37Summary: The development files for applications which use ncurses.
38Summary(ja): ncurses を用いるアプリケーション開発用のファイル
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41Obsoletes: libtermcap-devel <= 2.0.8-46vl1
42Provides: libtermcap-devel = 2.0.8-47
43
44%description devel
45The header files and libraries for developing applications that use
46the ncurses CRT screen handling and optimization package.
47
48Install the ncurses-devel package if you want to develop applications
49which will use ncurses.
50
51Use the following compiler flags to build against the ncurses library:
52                                                                               
53-lncurses
54(compile and link against the regular ncurses library)
55                                                                               
56-I %{includedirw} -lncursesw
57(compile and link against the wide-character, UTF-8, library)
58
59
60%package c++-devel
61Summary: C++ bindings to ncurses
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64Requires: %{name}-devel = %{version}-%{release}
65 
66%description c++-devel
67C++ bindings to ncurses
68
69
70%package -n compat32-%{name}
71Summary: A CRT screen handling and optimization package.
72Summary(ja): CRT スクリーンの操作と最適化を行うパッケージ
73Group: System Environment/Libraries
74Requires: %{name} = %{version}-%{release}
75
76%description -n compat32-%{name}
77The curses library routines are a terminal-independent method of
78updating character screens with reasonable optimization.  The ncurses
79(new curses) library is a freely distributable replacement for the
80discontinued 4.4 BSD classic curses library.
81
82
83%package -n compat32-%{name}-devel
84Summary: The development files for applications which use ncurses.
85Summary(ja): ncurses を用いるアプリケーション開発用のファイル
86Group: Development/Libraries
87Requires: compat32-%{name} = %{version}-%{release}
88Requires: %{name}-devel = %{version}-%{release}
89Obsoletes: compat32-libtermcap-devel <= 2.0.8-46vl1
90Provides: compat32-libtermcap-devel = 2.0.8-47
91
92%description -n compat32-%{name}-devel
93The header files and libraries for developing applications that use
94the ncurses CRT screen handling and optimization package.
95
96Install the ncurses-devel package if you want to develop applications
97which will use ncurses.
98
99Use the following compiler flags to build against the ncurses library:
100                                                                               
101-lncurses
102(compile and link against the regular ncurses library)
103                                                                               
104-I %{includedirw} -lncursesw
105(compile and link against the wide-character, UTF-8, library)
106
107
108%package -n compat32-%{name}-c++-devel
109Summary: C++ bindings to ncurses
110Group: System Environment/Libraries
111Requires: compat32-%{name} = %{version}-%{release}
112Requires: compat32-%{name}-devel = %{version}-%{release}
113Requires: %{name}-c++-devel = %{version}-%{release}
114 
115%description -n compat32-%{name}-c++-devel
116C++ bindings to ncurses
117
118
119%prep
120%setup -q
121%patch1 -p1
122
123%patch8 -p1 -b .config
124%patch9 -p1 -b .libs
125%patch11 -p1 -b .urxvt
126%patch12 -p1 -b .kbs
127
128find . -name "*.orig" -exec rm -f {} \;
129
130
131%build
132%define rootdatadir /lib
133%define ncurses_options \\\
134    --with-shared --without-ada --with-ospeed=unsigned \\\
135    --enable-hard-tabs --enable-xmc-glitch --enable-colorfgbg \\\
136    --with-terminfo-dirs=%{_sysconfdir}/terminfo:%{_datadir}/terminfo:%{rootdatadir}/terminfo \\\
137    --enable-overwrite \\\
138    --enable-pc-files \\\
139    --with-termlib=tinfo \\\
140    --with-chtype=long
141
142mkdir narrowc widec
143cd narrowc
144ln -s ../configure .
145%configure %{ncurses_options} --with-ticlib
146make %{?_smp_mflags} libs
147make %{?_smp_mflags} -C progs
148
149cd ../widec
150ln -s ../configure .
151%configure %{ncurses_options} --enable-widec --without-progs
152make %{?_smp_mflags} libs
153cd ..
154
155
156%install
157rm -rf ${RPM_BUILD_ROOT}
158
159make -C narrowc DESTDIR=$RPM_BUILD_ROOT install.{libs,progs,data}
160rm -f $RPM_BUILD_ROOT%{_libdir}/libtinfo.*
161make -C widec DESTDIR=$RPM_BUILD_ROOT install.{libs,includes,man}
162
163chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/lib*.so.*.*
164chmod 644 ${RPM_BUILD_ROOT}%{_libdir}/lib*.a
165
166# move lib{ncurses{,w},tinfo}.so.* to /lib*
167mkdir $RPM_BUILD_ROOT/%{_lib}
168mv $RPM_BUILD_ROOT%{_libdir}/lib{ncurses{,w},tinfo}.so.* $RPM_BUILD_ROOT/%{_lib}
169for l in $RPM_BUILD_ROOT%{_libdir}/lib{ncurses{,w},tinfo}.so; do
170    ln -sf $(echo %{_libdir} | \
171        sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
172done
173
174mkdir -p $RPM_BUILD_ROOT{%{rootdatadir},%{_sysconfdir}}/terminfo
175
176# move few basic terminfo entries to /lib
177baseterms=
178for termname in \
179        ansi dumb linux vt100 vt100-nav vt102 vt220 vt52
180do
181    for t in $(find $RPM_BUILD_ROOT%{_datadir}/terminfo \
182        -samefile $RPM_BUILD_ROOT%{_datadir}/terminfo/${termname::1}/$termname)
183    do
184        baseterms="$baseterms $(basename $t)"
185    done
186done
187for termname in $baseterms; do
188    termpath=terminfo/${termname::1}/$termname
189    mkdir $RPM_BUILD_ROOT%{rootdatadir}/terminfo/${termname::1} &> /dev/null || :
190    mv $RPM_BUILD_ROOT%{_datadir}/$termpath $RPM_BUILD_ROOT%{rootdatadir}/$termpath
191    ln -s $(dirname %{_datadir}/$termpath | \
192        sed 's,\(^/\|\)[^/][^/]*,..,g')%{rootdatadir}/$termpath \
193        $RPM_BUILD_ROOT%{_datadir}/$termpath
194done
195
196# prepare -base and -term file lists
197for termname in \
198    Eterm cons25 cygwin gnome* hurd jfbterm mach* mlterm mrxvt \
199    nsterm putty* pcansi rxvt rxvt-\* screen screen-\* screen.* \
200    sun teraterm wsvt25* xfce xterm xterm-\*
201do
202    for i in $RPM_BUILD_ROOT%{_datadir}/terminfo/?/$termname; do
203        for t in $(find $RPM_BUILD_ROOT%{_datadir}/terminfo -samefile $i); do
204            baseterms="$baseterms $(basename $t)"
205        done
206    done
207done 2> /dev/null
208for t in $baseterms; do
209    echo "%dir %{_datadir}/terminfo/${t::1}"
210    echo %{_datadir}/terminfo/${t::1}/$t
211done 2> /dev/null | sort -u > terms.base
212find $RPM_BUILD_ROOT%{_datadir}/terminfo \! -type d | \
213    sed "s|^$RPM_BUILD_ROOT||" | while read t
214do
215    echo "%dir $(dirname $t)"
216    echo $t
217done 2> /dev/null | sort -u | comm -2 -3 - terms.base > terms.term
218
219cat terms.base terms.term |sort -u > terms.all
220
221# can't replace directory with symlink (rpm bug), symlink all headers
222mkdir $RPM_BUILD_ROOT%{_includedir}/ncurses{,w}
223for l in $RPM_BUILD_ROOT%{_includedir}/*.h; do
224    ln -s ../$(basename $l) $RPM_BUILD_ROOT%{_includedir}/ncurses
225    ln -s ../$(basename $l) $RPM_BUILD_ROOT%{_includedir}/ncursesw
226done
227
228# don't require -ltinfo when linking with --no-add-needed
229for l in $RPM_BUILD_ROOT%{_libdir}/libncurses{,w}.so; do
230    soname=$(basename $(readlink $l))
231    rm -f $l
232    echo "INPUT($soname -ltinfo)" > $l
233done
234             
235rm -f $RPM_BUILD_ROOT%{_libdir}/libcurses{,w}.so
236echo "INPUT(-lncurses)" > $RPM_BUILD_ROOT%{_libdir}/libcurses.so
237echo "INPUT(-lncursesw)" > $RPM_BUILD_ROOT%{_libdir}/libcursesw.so
238
239echo "INPUT(-ltinfo)" > $RPM_BUILD_ROOT%{_libdir}/libtermcap.so
240
241rm -f ${RPM_BUILD_ROOT}%{_libdir}/terminfo
242#rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/{*_g,ncurses++*}.pc
243
244
245%post -p /sbin/ldconfig
246
247%postun -p /sbin/ldconfig
248
249%post -n compat32-%{name} -p /sbin/ldconfig
250
251%postun -n compat32-%{name} -p /sbin/ldconfig
252
253
254%files -f terms.all
255%defattr(-,root,root)
256%doc ANNOUNCE AUTHORS README TO-DO
257%{_bindir}/[cirt]*
258%{_mandir}/man1/*
259%{_mandir}/man5/*
260%{_mandir}/man7/*
261/%{_lib}/lib*.so.*
262%{_libdir}/lib*.so.*
263%dir %{_sysconfdir}/terminfo
264%{rootdatadir}/terminfo
265%{_datadir}/tabset
266%dir %{_datadir}/terminfo
267
268%files devel
269%defattr(-,root,root)
270%doc test
271%doc doc/html/hackguide.html
272%doc doc/html/ncurses-intro.html
273%doc c++/README*
274%{_bindir}/ncurses*-config
275%{_libdir}/lib*.so
276%{_libdir}/lib*.a
277 %dir %{_includedir}/ncurses
278%dir %{_includedir}/ncursesw
279%{_includedir}/ncurses/*.h
280%{_includedir}/ncursesw/*.h
281%{_includedir}/*.h
282%{_mandir}/man3/*
283%{_libdir}/pkgconfig/*.pc
284%exclude %{_libdir}/pkgconfig/ncurses++*.pc
285
286%files c++-devel
287%defattr(-,root,root)
288%doc c++/NEWS c++/PROBLEMS c++/README*
289%{_includedir}/ncurses/cursesapp.h
290%{_includedir}/ncurses/curses?.h
291%{_includedir}/ncurses/etip.h
292%{_libdir}/libncurses++.a
293%{_libdir}/libncurses++w.a
294%{_libdir}/pkgconfig/ncurses++*.pc
295
296%if %{build_compat32}
297%files -n compat32-%{name}
298%defattr(-,root,root)
299%attr(755,root,root) %{_libdir}/lib*.so.*
300/%{_lib}/lib*.so.*
301%{_libdir}/lib*.so.*
302
303
304%files -n compat32-%{name}-devel
305%defattr(-,root,root)
306%{_libdir}/lib*.so
307%{_libdir}/lib*.a
308%{_libdir}/pkgconfig/*.pc
309%exclude %{_libdir}/pkgconfig/ncurses++*.pc
310 
311
312%files -n compat32-%{name}-c++-devel
313%defattr(-,root,root)
314%{_libdir}/libncurses++.a
315%{_libdir}/libncurses++w.a
316%{_libdir}/pkgconfig/ncurses++*.pc
317%endif
318
319
320%clean
321rm -rf $RPM_BUILD_ROOT
322
323
324%changelog
325* Tue Dec 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9-2
326- don't require -ltinfo when linking with --no-add-needed
327
328* Fri Sep 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9-1
329- update to 5.9 + 20110716
330- update all patches
331- add pkgconfig file
332
333* Sun Mar 27 2011 IWAI, Masaharu <iwai@alib.jp> 5.6-5
334- build with new toolchain
335
336* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.6-4
337- rebuilt with new toolchain
338- add Requires(post,pre): /sbin/ldconfig
339
340* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 5.6-3
341- updated %%files section on compat32-* packages
342
343* Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.6-2
344- changed c++-devel Group to Development/Libraries
345- changelog of 5.6-1 is missing... seemed to be updated on Aug 10 2008
346
347* Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 5.4-0vl3
348- added compat32- packages for x86_64 architecture support
349
350* Mon May 17 2004 Tomoya TAKA <taka@vinelinux.org> 5.4-0vl2
351- add patch10 taken from fedora's 5.4-4
352
353* Sun May  9 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4-0vl1
354- new upstream release
355- remove obsolete patches
356
357* Mon Mar 22 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.3-9vl1
358- synced up with Fedora 5.3-9
359  - Thu Sep 11 2003 Adrian Havill <havill@redhat.com> 5.3-9
360  - remove not-so safe-sprintf configure option because the code does
361    not appear to be stable enough for some apps. (#103790)
362 
363  - Wed Aug 20 2003 Adrian Havill <havill@redhat.com> 5.3-8.1
364  - RHEL bump
365 
366  - Wed Aug 20 2003 Adrian Havill <havill@redhat.com> 5.3-8
367  - multilib patch (#91211)
368 
369  - Mon Aug 11 2003 Adrian Havill <havill@redhat.com> 5.3-7
370  - fixed the safe sprintf code that was enabled in the previous release
371    by the configure parameter. (#101486)
372 
373  - Mon Jun 16 2003 Elliot Lee <sopwith@redhat.com> 5.3-6.1
374  - Fix ac25 patch, make it easy to turn off GPM support
375 
376  - Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
377  - rebuilt
378 
379  - Thu May 22 2003 Adrian Havill <havill@redhat.com> 5.3-5
380  - added latest rollup patch with widec/UTF8 centric weekly (20030517)
381  - added --enable-widec to configure (#86311)
382    original work done by Mr. Sam <sam@email-scan.com>
383  - require sharutils (#86605)
384  - add gpm, xmc support
385  - add debug syms back into package
386  - updated autoconf/configure patch
387
388* Thu Mar 27 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.3-4vl1
389- synced Rawhide 5.3-4
390
391* Fri Feb 08 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-16vl2
392- revert to patch13 from 14 for XF86-4
393
394* Wed Feb 06 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-16vl1
395- synced Rawhide 5.2-16
396
397* Tue Aug 28 2001 Shoji Matsumoto <shom@vinelinux.org> 5.2-12vl2
398- patch 3 (xterm) disabled. this patch is for XF86-4???
399
400* Wed Aug 22 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-12vl1
401- added kon patch for Vine
402
403* Fri Jul 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.2-12
404- Sync terminfo with termcap 11.0.1-10
405
406* Sun Jun 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.2-11
407- Update to patchlevel 20010623, fixes some lynx issues
408 
409* Mon Jun 18 2001 Helge Deller <hdeller@redhat.de>
410- fixed tput -S segfaulting bug (#44669)
411- use _tmppath for BuildRoot:
412- Copyright -> License
413
414* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
415- Update to patchlevel 20010407
416
417* Tue Mar  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
418- Fix up some terminfo entries containing includes to
419  "/var/tmp/ncurses-root/something" (#30771)
420
421* Wed Feb 22 2001 Harald Hoyer <harald@redhat.de>
422- fixed rxvt backspace setting
423
424* Fri Feb  9 2001 Yukihiro Nakai <ynakai@redhat.com>
425- Update Japanese kterm patch
426
427* Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
428- Update
429- Add japanese patch from termcap
430- Fix ospeed handling
431
432* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
433- Add libcurses.a -> libncurses.a symlink (RFE #23023)
434
435* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
436- Use --with-ospeed='unsigned int'
437
438* Fri Nov 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
439- Fix alpha and ia64
440- Rebuild with gcc 2.96-64
441
442* Thu Nov  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
443- 5.2
444- Fix typo in man page (Bug #20205)
445- update the "screen" terminfo entries to the version supplied with
446  screen 3.9.8
447
448* Mon Oct  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
449- Update (fixes the "make menuconfig" bug introduced by the security fix)
450
451* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
452- Fix security problem (possible buffer overrun)
453
454* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
455- Add the bugfix patches from the ncurses maintainer
456
457* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
458- 5.1
459
460* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
461- automatic rebuild
462
463* Mon Jun  5 2000 Matt Wilson <msw@redhat.com>
464- *don't ship symlinks from lib*.so.5 to lib*.so.4!
465- use FHS macros
466
467* Fri Jun  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
468- rebuild for 7.0
469- /usr/share/man
470- update URL for patches
471- misc. fixes to spec file
472
473* Mon Mar 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
474- use the real library version number
475- update to 20000319
476
477* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
478- rebuild for sparc baud rates > 38400.
479
480* Fri Feb 18 2000 Preston Brown <pbrown@redhat.com>
481- xterm terminfo entries from XFree86 3.3.6
482- final round of xterm fixes, follow debian policy.
483
484* Sat Feb  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
485- strip libraries
486
487* Thu Feb  3 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
488- More xterm fixes (Bug #9087)
489
490* Thu Jan 27 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
491- More xterm fixes from Hans de Goede (Bug #8633)
492
493* Sat Jan 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
494- remove some broken symlinks (leftovers from libncurses.so.5)
495- Use %configure (Bug #8484)
496
497* Tue Jan 11 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
498- Add xterm patch from Hans de Goede <hans@highrise.nl>
499- Patch 20000108, this fixes a problem with a header file.
500
501* Wed Jan  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
502- Add 20000101 patch, hopefully finally fixing the xterm description
503
504* Wed Dec 22 1999 Cristian Gafton <gafton@redhat.com>
505- revert to the old major number - because the ABI is not changed (and we
506  should be handling the changes via symbol versioning anyway)
507
508* Fri Nov 12 1999 Bernhard Rosenkraenzer <bero@redhat.com>
509- Fix a typo in spec
510- Add the 19991006 patch, fixing some C++ STL compatibility problems.
511- get rid of profiling and debugging versions - we need to save space...
512
513* Thu Nov  4 1999 Bernhard Rosenkraenzer <bero@redhat.com>
514- 5.0
515- some spec cleanups to make updating easier
516- add links *.so.5 to *.so.4 - they are fully binary compatible.
517  (Why did they change the invocation number???)
518
519* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
520- make clean in the test dir - don't ship any binaries at all.
521
522* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
523- fixed stripping of test programs.
524
525* Sun Aug 29 1999 Preston Brown <pbrown@redhat.com>
526- removed 'flash' capability for xterm; see bug #2820 for details.
527
528* Fri Aug 27 1999 Cristian Gafton <gafton@redhat.com>
529- add the resetall script from Marc Merlin <marc@merlins.org>
530
531* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
532- added iris-ansi-net as alias for iris-ansi (bug #2561)
533
534* Fri Jul 30 1999 Michael K. Johnson <johnsonm@redhat.com>
535- added ncurses-intro.hmtl and hackguide.html to -devel package [bug #3929]
536
537* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
538- make sure ALL binaries are stripped (incl. test binaries)
539
540* Thu Mar 25 1999 Preston Brown <pbrown@redhat.com>
541- made xterm terminfo stuff MUCH better.
542
543* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
544- auto rebuild in the new build environment (release 16)
545
546* Sat Mar 13 1999 Cristian Gafton <gafton@redhat.com>
547- fixed header for C++ compiles
548
549* Fri Mar 12 1999 Jeff Johnson <jbj@redhat.com>
550- add terminfo entries for linux/linux-m on sparc (obsolete termfile_sparc).
551
552* Thu Feb 18 1999 Cristian Gafton <gafton@redhat.com>
553- updated patchset from original site
554
555* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
556- don't build the C++ demo code
557- update patch set to the current as of today (redid all the individual
558  patches in a single one)
559
560* Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
561- make sure to strip the binaries
562
563* Wed Sep 23 1998 Cristian Gafton <gafton@redhat.com>
564- added another zillion of patches. The spec file *is* ugly
565- defattr
566
567* Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
568- added lots of patches. This spec file is starting to look ugly
569
570* Wed Jul 01 1998 Alan Cox <alan@redhat.com>
571- Fix setuid trusting. Open termcap/info files as the real user.
572
573* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
574- added terminfo entry for the poor guys using lat1 and/or lat-2 on their
575  consoles... Enjoy linux-lat ! Thanks, Erik !
576
577* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
578- new patch to get xterm-color and nxterm terminfo entries
579- aliased them to rxvt, as that seems to satisfy everybody
580
581* Sun Apr 12 1998 Cristian Gafton <gafton@redhat.com>
582- added %clean section
583
584* Tue Apr 07 1998 Cristian Gafton <gafton@redhat.com>
585- removed /usr/lib/terminfo symlink - we shouldn't need that
586
587* Mon Apr 06 1998 Cristian Gafton <gafton@redhat.com>
588- updated to 4.2 + patches
589- added BuildRoot
590
591* Sat Apr 04 1998 Cristian Gafton <gafton@redhat.com>
592- rebuilt with egcs on alpha
593
594* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
595- version 7 didn't rebuild properly on the Alpha somehow -- no real changes
596  are in this version
597
598* Tue Dec 09 1997 Erik Troan <ewt@redhat.com>
599- TIOCGWINSZ wasn't used properly
600
601* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
602- built against glibc, linked shared libs against -lc
603
Note: See TracBrowser for help on using the repository browser.