source: projects/specs/trunk/n/ncurses/ncurses-vl.spec @ 12530

Revision 12530, 20.5 KB checked in by tomop, 3 years ago (diff)

updated 2 packages

ncurses-6.2-1

vim-8.2.2517-1

Line 
1%global revision 20210213
2%define includedirw %{_includedir}/ncursesw
3
4%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
5
6Summary: A screen handling and optimization package.
7Summary(ja): スクリーンの操作と最適化を行うパッケージ
8Name: ncurses
9Version: 6.2
10Release: 1%{?_dist_release}
11Group: system
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16License: distributable
17URL: https://invisible-island.net/ncurses/ncurses.html
18Source0: https://invisible-mirror.net/archives/ncurses/current/ncurses-%{version}-%{revision}.tgz
19Patch8: ncurses-config.patch
20Patch9: ncurses-libs.patch
21Patch11: ncurses-urxvt.patch
22Patch12: ncurses-kbs.patch
23
24Requires(post): /sbin/ldconfig
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: pkgconfig
28
29%description
30The curses library routines are a terminal-independent method of
31updating character screens with reasonable optimization.  The ncurses
32(new curses) library is a freely distributable replacement for the
33discontinued 4.4 BSD classic curses library.
34
35
36%package devel
37Summary: The development files for applications which use ncurses.
38Summary(ja): ncurses を用いるアプリケーション開発用のファイル
39Group: programming
40Requires: %{name} = %{version}-%{release}
41Obsoletes: libtermcap-devel <= 2.0.8-46vl1
42Provides: libtermcap-devel = 2.0.8-47
43
44%description devel
45The header files and libraries for developing applications that use
46the ncurses CRT screen handling and optimization package.
47
48Install the ncurses-devel package if you want to develop applications
49which will use ncurses.
50
51Use the following compiler flags to build against the ncurses library:
52                                                                               
53-lncurses
54(compile and link against the regular ncurses library)
55                                                                               
56-I %{includedirw} -lncursesw
57(compile and link against the wide-character, UTF-8, library)
58
59
60%package c++-devel
61Summary: C++ bindings to ncurses
62Group: programming
63Requires: %{name} = %{version}-%{release}
64Requires: %{name}-devel = %{version}-%{release}
65 
66%description c++-devel
67C++ bindings to ncurses
68
69
70%package -n compat32-%{name}
71Summary: A screen handling and optimization package.
72Summary(ja): スクリーンの操作と最適化を行うパッケージ
73Group: system
74Requires: %{name} = %{version}-%{release}
75
76%description -n compat32-%{name}
77The curses library routines are a terminal-independent method of
78updating character screens with reasonable optimization.  The ncurses
79(new curses) library is a freely distributable replacement for the
80discontinued 4.4 BSD classic curses library.
81
82
83%package -n compat32-%{name}-devel
84Summary: The development files for applications which use ncurses.
85Summary(ja): ncurses を用いるアプリケーション開発用のファイル
86Group: programming
87Requires: compat32-%{name} = %{version}-%{release}
88Requires: %{name}-devel = %{version}-%{release}
89Obsoletes: compat32-libtermcap-devel <= 2.0.8-46vl1
90Provides: compat32-libtermcap-devel = 2.0.8-47
91
92%description -n compat32-%{name}-devel
93The header files and libraries for developing applications that use
94the ncurses CRT screen handling and optimization package.
95
96Install the ncurses-devel package if you want to develop applications
97which will use ncurses.
98
99Use the following compiler flags to build against the ncurses library:
100                                                                               
101-lncurses
102(compile and link against the regular ncurses library)
103                                                                               
104-I %{includedirw} -lncursesw
105(compile and link against the wide-character, UTF-8, library)
106
107
108%package -n compat32-%{name}-c++-devel
109Summary: C++ bindings to ncurses
110Group: programming
111Requires: compat32-%{name} = %{version}-%{release}
112Requires: compat32-%{name}-devel = %{version}-%{release}
113Requires: %{name}-c++-devel = %{version}-%{release}
114 
115%description -n compat32-%{name}-c++-devel
116C++ bindings to ncurses
117
118
119%debug_package
120
121
122%prep
123%setup -q -n %{name}-%{version}-%{revision}
124
125#%patch8 -p1 -b .config
126%patch9 -p1 -b .libs
127%patch11 -p1 -b .urxvt
128%patch12 -p1 -b .kbs
129
130for f in ANNOUNCE; do
131    iconv -f iso8859-1 -t utf8 -o ${f}{_,} &&
132        touch -r ${f}{,_} && mv -f ${f}{_,}
133done
134
135
136%build
137%define rootdatadir /lib
138common_options=" \
139    --enable-colorfgbg \
140    --enable-hard-tabs \
141    --enable-overwrite \
142    --enable-pc-files \
143    --enable-xmc-glitch \
144    --disable-stripping \
145    --disable-wattr-macros \
146    --with-ospeed=unsigned \
147    --with-pkg-config-libdir=%{_libdir}/pkgconfig \
148    --with-shared \
149    --with-terminfo-dirs=%{_sysconfdir}/terminfo:%{_datadir}/terminfo:%{rootdatadir}/terminfo \
150    --with-termlib=tinfo \
151    --with-ticlib=tic \
152    --with-xterm-kbs=DEL \
153    --without-ada"
154abi5_options="--with-chtype=long"
155
156for abi in 5 6; do
157    for char in narrowc widec; do
158        mkdir $char$abi
159        pushd $char$abi
160        ln -s ../configure .
161
162        [ $abi = 6 -a $char = widec ] && progs=yes || progs=no
163
164        %configure $(
165            echo $common_options --with-abi-version=$abi
166            [ $abi = 5 ] && echo $abi5_options
167            [ $char = widec ] && echo --enable-widec
168            [ $progs = yes ] || echo --without-progs
169        )
170
171        make %{?_smp_mflags} libs
172        [ $progs = yes ] && make %{?_smp_mflags} -C progs
173
174        popd
175    done
176done
177
178
179%install
180rm -rf ${RPM_BUILD_ROOT}
181
182make -C narrowc5 DESTDIR=$RPM_BUILD_ROOT install.libs
183rm ${RPM_BUILD_ROOT}%{_libdir}/lib{tic,tinfo}.so.5*
184make -C widec5 DESTDIR=$RPM_BUILD_ROOT install.libs
185make -C narrowc6 DESTDIR=$RPM_BUILD_ROOT install.libs
186rm ${RPM_BUILD_ROOT}%{_libdir}/lib{tic,tinfo}.so.6*
187make -C widec6 DESTDIR=$RPM_BUILD_ROOT install.{libs,progs,data,includes,man}
188
189chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/lib*.so.*.*
190chmod 644 ${RPM_BUILD_ROOT}%{_libdir}/lib*.a
191
192# move lib{ncurses{,w},tinfo}.so.* to /lib*
193mkdir $RPM_BUILD_ROOT/%{_lib}
194mv $RPM_BUILD_ROOT%{_libdir}/lib{ncurses{,w},tinfo}.so.* $RPM_BUILD_ROOT/%{_lib}
195for l in $RPM_BUILD_ROOT%{_libdir}/lib{ncurses{,w},tinfo}.so; do
196    ln -sf $(echo %{_libdir} | \
197        sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
198done
199
200mkdir -p $RPM_BUILD_ROOT{%{rootdatadir},%{_sysconfdir}}/terminfo
201
202# move few basic terminfo entries to /lib
203baseterms=
204for termname in \
205        ansi dumb linux vt100 vt100-nav vt102 vt220 vt52
206do
207    for t in $(find $RPM_BUILD_ROOT%{_datadir}/terminfo \
208        -samefile $RPM_BUILD_ROOT%{_datadir}/terminfo/${termname::1}/$termname)
209    do
210        baseterms="$baseterms $(basename $t)"
211    done
212done
213for termname in $baseterms; do
214    termpath=terminfo/${termname::1}/$termname
215    mkdir $RPM_BUILD_ROOT%{rootdatadir}/terminfo/${termname::1} &> /dev/null || :
216    mv $RPM_BUILD_ROOT%{_datadir}/$termpath $RPM_BUILD_ROOT%{rootdatadir}/$termpath
217    ln -s $(dirname %{_datadir}/$termpath | \
218        sed 's,\(^/\|\)[^/][^/]*,..,g')%{rootdatadir}/$termpath \
219        $RPM_BUILD_ROOT%{_datadir}/$termpath
220done
221
222# prepare -base and -term file lists
223for termname in \
224    ansi dumb linux vt100 vt100-nav vt102 vt220 vt52 \
225    Eterm\* aterm bterm cons25 cygwin eterm\* gnome gnome-256color hurd jfbterm \
226    konsole konsole-256color mach\* mlterm mrxvt nsterm putty{,-256color} pcansi \
227    rxvt{,-\*} screen{,-\*color,.[^mlp]\*,.linux,.mlterm\*,.putty{,-256color},.mrxvt} \
228    st{,-\*color} sun teraterm teraterm2.3 tmux{,-\*} vte vte-256color vwmterm \
229    wsvt25\* xfce xterm xterm-\*
230do
231    for i in $RPM_BUILD_ROOT%{_datadir}/terminfo/?/$termname; do
232        for t in $(find $RPM_BUILD_ROOT%{_datadir}/terminfo -samefile $i); do
233            baseterms="$baseterms $(basename $t)"
234        done
235    done
236done 2> /dev/null
237for t in $baseterms; do
238    echo "%dir %{_datadir}/terminfo/${t::1}"
239    echo %{_datadir}/terminfo/${t::1}/$t
240done 2> /dev/null | sort -u > terms.base
241find $RPM_BUILD_ROOT%{_datadir}/terminfo \! -type d | \
242    sed "s|^$RPM_BUILD_ROOT||" | while read t
243do
244    echo "%dir $(dirname $t)"
245    echo $t
246done 2> /dev/null | sort -u | comm -2 -3 - terms.base > terms.term
247
248cat terms.base terms.term |sort -u > terms.all
249
250# can't replace directory with symlink (rpm bug), symlink all headers
251mkdir $RPM_BUILD_ROOT%{_includedir}/ncurses{,w}
252for l in $RPM_BUILD_ROOT%{_includedir}/*.h; do
253    ln -s ../$(basename $l) $RPM_BUILD_ROOT%{_includedir}/ncurses
254    ln -s ../$(basename $l) $RPM_BUILD_ROOT%{_includedir}/ncursesw
255done
256
257# don't require -ltinfo when linking with --no-add-needed
258for l in $RPM_BUILD_ROOT%{_libdir}/libncurses{,w}.so; do
259    soname=$(basename $(readlink $l))
260    rm -f $l
261    echo "INPUT($soname -ltinfo)" > $l
262done
263             
264rm -f $RPM_BUILD_ROOT%{_libdir}/libcurses{,w}.so
265echo "INPUT(-lncurses)" > $RPM_BUILD_ROOT%{_libdir}/libcurses.so
266echo "INPUT(-lncursesw)" > $RPM_BUILD_ROOT%{_libdir}/libcursesw.so
267
268echo "INPUT(-ltinfo)" > $RPM_BUILD_ROOT%{_libdir}/libtermcap.so
269
270rm -f ${RPM_BUILD_ROOT}%{_libdir}/terminfo
271#rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/{*_g,ncurses++*}.pc
272
273
274%post -p /sbin/ldconfig
275%postun -p /sbin/ldconfig
276
277%post -n compat32-%{name} -p /sbin/ldconfig
278%postun -n compat32-%{name} -p /sbin/ldconfig
279
280
281%files -f terms.all
282%defattr(-,root,root)
283%license COPYING
284%doc ANNOUNCE AUTHORS README TO-DO
285%{_bindir}/[cirt]*
286%{_mandir}/man1/*
287%{_mandir}/man5/*
288%{_mandir}/man7/*
289/%{_lib}/lib*.so.*
290%{_libdir}/lib*.so.*
291%dir %{_sysconfdir}/terminfo
292%{rootdatadir}/terminfo
293%{_datadir}/tabset
294%dir %{_datadir}/terminfo
295
296%files devel
297%defattr(-,root,root)
298%doc test
299%doc doc/html/hackguide.html
300%doc doc/html/ncurses-intro.html
301%doc c++/README*
302%{_bindir}/ncurses*-config
303%{_libdir}/lib*.so
304%{_libdir}/lib*.a
305 %dir %{_includedir}/ncurses
306%dir %{_includedir}/ncursesw
307%{_includedir}/ncurses/*.h
308%{_includedir}/ncursesw/*.h
309%{_includedir}/*.h
310%{_mandir}/man3/*
311%{_libdir}/pkgconfig/*.pc
312%exclude %{_libdir}/pkgconfig/ncurses++*.pc
313
314%files c++-devel
315%defattr(-,root,root)
316%doc c++/NEWS c++/PROBLEMS c++/README*
317%{_includedir}/ncurses/cursesapp.h
318%{_includedir}/ncurses/curses?.h
319%{_includedir}/ncurses/etip.h
320%{_libdir}/libncurses++.a
321%{_libdir}/libncurses++w.a
322%{_libdir}/pkgconfig/ncurses++*.pc
323
324%if %{build_compat32}
325%files -n compat32-%{name}
326%defattr(-,root,root)
327%attr(755,root,root) %{_libdir}/lib*.so.*
328/%{_lib}/lib*.so.*
329%{_libdir}/lib*.so.*
330
331%files -n compat32-%{name}-devel
332%defattr(-,root,root)
333%{_libdir}/lib*.so
334%{_libdir}/lib*.a
335%{_libdir}/pkgconfig/*.pc
336%exclude %{_libdir}/pkgconfig/ncurses++*.pc
337 
338%files -n compat32-%{name}-c++-devel
339%defattr(-,root,root)
340%{_libdir}/libncurses++.a
341%{_libdir}/libncurses++w.a
342%{_libdir}/pkgconfig/ncurses++*.pc
343%endif
344
345
346%clean
347rm -rf $RPM_BUILD_ROOT
348
349
350%changelog
351* Mon Feb 15 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.2-1
352- updated to 6.2 + 20210213.
353- updated Patch9 and 12.
354
355* Sun Oct 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.1-3
356- dropped Patch8.
357
358* Fri Oct 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.1-2
359- updated to 6.1 + 20191015.
360- updated Patch8.
361
362* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.1-1
363- updated to 6.1 + 20190824.
364
365* Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.9-3
366- rebuild with VineSeed environment
367
368* Wed Dec 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9-2
369- don't require -ltinfo when linking with --no-add-needed
370
371* Fri Sep 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9-1
372- update to 5.9 + 20110716
373- update all patches
374- add pkgconfig file
375
376* Sun Mar 27 2011 IWAI, Masaharu <iwai@alib.jp> 5.6-5
377- build with new toolchain
378
379* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.6-4
380- rebuilt with new toolchain
381- add Requires(post,pre): /sbin/ldconfig
382
383* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 5.6-3
384- updated %%files section on compat32-* packages
385
386* Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.6-2
387- changed c++-devel Group to Development/Libraries
388- changelog of 5.6-1 is missing... seemed to be updated on Aug 10 2008
389
390* Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 5.4-0vl3
391- added compat32- packages for x86_64 architecture support
392
393* Mon May 17 2004 Tomoya TAKA <taka@vinelinux.org> 5.4-0vl2
394- add patch10 taken from fedora's 5.4-4
395
396* Sun May  9 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4-0vl1
397- new upstream release
398- remove obsolete patches
399
400* Mon Mar 22 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.3-9vl1
401- synced up with Fedora 5.3-9
402  - Thu Sep 11 2003 Adrian Havill <havill@redhat.com> 5.3-9
403  - remove not-so safe-sprintf configure option because the code does
404    not appear to be stable enough for some apps. (#103790)
405 
406  - Wed Aug 20 2003 Adrian Havill <havill@redhat.com> 5.3-8.1
407  - RHEL bump
408 
409  - Wed Aug 20 2003 Adrian Havill <havill@redhat.com> 5.3-8
410  - multilib patch (#91211)
411 
412  - Mon Aug 11 2003 Adrian Havill <havill@redhat.com> 5.3-7
413  - fixed the safe sprintf code that was enabled in the previous release
414    by the configure parameter. (#101486)
415 
416  - Mon Jun 16 2003 Elliot Lee <sopwith@redhat.com> 5.3-6.1
417  - Fix ac25 patch, make it easy to turn off GPM support
418 
419  - Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
420  - rebuilt
421 
422  - Thu May 22 2003 Adrian Havill <havill@redhat.com> 5.3-5
423  - added latest rollup patch with widec/UTF8 centric weekly (20030517)
424  - added --enable-widec to configure (#86311)
425    original work done by Mr. Sam <sam@email-scan.com>
426  - require sharutils (#86605)
427  - add gpm, xmc support
428  - add debug syms back into package
429  - updated autoconf/configure patch
430
431* Thu Mar 27 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.3-4vl1
432- synced Rawhide 5.3-4
433
434* Fri Feb 08 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-16vl2
435- revert to patch13 from 14 for XF86-4
436
437* Wed Feb 06 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-16vl1
438- synced Rawhide 5.2-16
439
440* Tue Aug 28 2001 Shoji Matsumoto <shom@vinelinux.org> 5.2-12vl2
441- patch 3 (xterm) disabled. this patch is for XF86-4???
442
443* Wed Aug 22 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-12vl1
444- added kon patch for Vine
445
446* Fri Jul 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.2-12
447- Sync terminfo with termcap 11.0.1-10
448
449* Sun Jun 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.2-11
450- Update to patchlevel 20010623, fixes some lynx issues
451 
452* Mon Jun 18 2001 Helge Deller <hdeller@redhat.de>
453- fixed tput -S segfaulting bug (#44669)
454- use _tmppath for BuildRoot:
455- Copyright -> License
456
457* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
458- Update to patchlevel 20010407
459
460* Tue Mar  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
461- Fix up some terminfo entries containing includes to
462  "/var/tmp/ncurses-root/something" (#30771)
463
464* Thu Feb 22 2001 Harald Hoyer <harald@redhat.de>
465- fixed rxvt backspace setting
466
467* Fri Feb  9 2001 Yukihiro Nakai <ynakai@redhat.com>
468- Update Japanese kterm patch
469
470* Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
471- Update
472- Add japanese patch from termcap
473- Fix ospeed handling
474
475* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
476- Add libcurses.a -> libncurses.a symlink (RFE #23023)
477
478* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
479- Use --with-ospeed='unsigned int'
480
481* Fri Nov 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
482- Fix alpha and ia64
483- Rebuild with gcc 2.96-64
484
485* Thu Nov  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
486- 5.2
487- Fix typo in man page (Bug #20205)
488- update the "screen" terminfo entries to the version supplied with
489  screen 3.9.8
490
491* Mon Oct  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
492- Update (fixes the "make menuconfig" bug introduced by the security fix)
493
494* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
495- Fix security problem (possible buffer overrun)
496
497* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
498- Add the bugfix patches from the ncurses maintainer
499
500* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
501- 5.1
502
503* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
504- automatic rebuild
505
506* Mon Jun  5 2000 Matt Wilson <msw@redhat.com>
507- *don't ship symlinks from lib*.so.5 to lib*.so.4!
508- use FHS macros
509
510* Fri Jun  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
511- rebuild for 7.0
512- /usr/share/man
513- update URL for patches
514- misc. fixes to spec file
515
516* Mon Mar 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
517- use the real library version number
518- update to 20000319
519
520* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
521- rebuild for sparc baud rates > 38400.
522
523* Fri Feb 18 2000 Preston Brown <pbrown@redhat.com>
524- xterm terminfo entries from XFree86 3.3.6
525- final round of xterm fixes, follow debian policy.
526
527* Sat Feb  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
528- strip libraries
529
530* Thu Feb  3 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
531- More xterm fixes (Bug #9087)
532
533* Thu Jan 27 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
534- More xterm fixes from Hans de Goede (Bug #8633)
535
536* Sat Jan 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
537- remove some broken symlinks (leftovers from libncurses.so.5)
538- Use %configure (Bug #8484)
539
540* Tue Jan 11 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
541- Add xterm patch from Hans de Goede <hans@highrise.nl>
542- Patch 20000108, this fixes a problem with a header file.
543
544* Wed Jan  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
545- Add 20000101 patch, hopefully finally fixing the xterm description
546
547* Wed Dec 22 1999 Cristian Gafton <gafton@redhat.com>
548- revert to the old major number - because the ABI is not changed (and we
549  should be handling the changes via symbol versioning anyway)
550
551* Fri Nov 12 1999 Bernhard Rosenkraenzer <bero@redhat.com>
552- Fix a typo in spec
553- Add the 19991006 patch, fixing some C++ STL compatibility problems.
554- get rid of profiling and debugging versions - we need to save space...
555
556* Thu Nov  4 1999 Bernhard Rosenkraenzer <bero@redhat.com>
557- 5.0
558- some spec cleanups to make updating easier
559- add links *.so.5 to *.so.4 - they are fully binary compatible.
560  (Why did they change the invocation number???)
561
562* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
563- make clean in the test dir - don't ship any binaries at all.
564
565* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
566- fixed stripping of test programs.
567
568* Sun Aug 29 1999 Preston Brown <pbrown@redhat.com>
569- removed 'flash' capability for xterm; see bug #2820 for details.
570
571* Fri Aug 27 1999 Cristian Gafton <gafton@redhat.com>
572- add the resetall script from Marc Merlin <marc@merlins.org>
573
574* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
575- added iris-ansi-net as alias for iris-ansi (bug #2561)
576
577* Fri Jul 30 1999 Michael K. Johnson <johnsonm@redhat.com>
578- added ncurses-intro.hmtl and hackguide.html to -devel package [bug #3929]
579
580* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
581- make sure ALL binaries are stripped (incl. test binaries)
582
583* Thu Mar 25 1999 Preston Brown <pbrown@redhat.com>
584- made xterm terminfo stuff MUCH better.
585
586* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
587- auto rebuild in the new build environment (release 16)
588
589* Sat Mar 13 1999 Cristian Gafton <gafton@redhat.com>
590- fixed header for C++ compiles
591
592* Fri Mar 12 1999 Jeff Johnson <jbj@redhat.com>
593- add terminfo entries for linux/linux-m on sparc (obsolete termfile_sparc).
594
595* Thu Feb 18 1999 Cristian Gafton <gafton@redhat.com>
596- updated patchset from original site
597
598* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
599- don't build the C++ demo code
600- update patch set to the current as of today (redid all the individual
601  patches in a single one)
602
603* Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
604- make sure to strip the binaries
605
606* Wed Sep 23 1998 Cristian Gafton <gafton@redhat.com>
607- added another zillion of patches. The spec file *is* ugly
608- defattr
609
610* Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
611- added lots of patches. This spec file is starting to look ugly
612
613* Wed Jul 01 1998 Alan Cox <alan@redhat.com>
614- Fix setuid trusting. Open termcap/info files as the real user.
615
616* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
617- added terminfo entry for the poor guys using lat1 and/or lat-2 on their
618  consoles... Enjoy linux-lat ! Thanks, Erik !
619
620* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
621- new patch to get xterm-color and nxterm terminfo entries
622- aliased them to rxvt, as that seems to satisfy everybody
623
624* Sun Apr 12 1998 Cristian Gafton <gafton@redhat.com>
625- added %clean section
626
627* Tue Apr 07 1998 Cristian Gafton <gafton@redhat.com>
628- removed /usr/lib/terminfo symlink - we shouldn't need that
629
630* Mon Apr 06 1998 Cristian Gafton <gafton@redhat.com>
631- updated to 4.2 + patches
632- added BuildRoot
633
634* Sat Apr 04 1998 Cristian Gafton <gafton@redhat.com>
635- rebuilt with egcs on alpha
636
637* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
638- version 7 didn't rebuild properly on the Alpha somehow -- no real changes
639  are in this version
640
641* Tue Dec 09 1997 Erik Troan <ewt@redhat.com>
642- TIOCGWINSZ wasn't used properly
643
644* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
645- built against glibc, linked shared libs against -lc
646
Note: See TracBrowser for help on using the repository browser.