source: projects/specs/trunk/n/ncurses/ncurses-vl.spec @ 8173

Revision 8173, 19.2 KB checked in by Takemikaduchi, 10 years ago (diff)

qt4: fix BTS:2677
librsvg2: fix typo
others: rebuild

Line 
1Summary: A CRT screen handling and optimization package.
2Summary(ja): CRT スクリーンの操作と最適化を行うパッケージ
3Name: ncurses
4Version: 5.9
5%define includedirw %{_includedir}/ncursesw
6%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
7Release: 3%{?_dist_release}
8License: distributable
9Group: System Environment/Libraries
10URL: http://dickey.his.com/ncurses/ncurses.html
11
12Source0: ftp://invisible-island.net/ncurses/ncurses-%{version}.tar.gz
13
14Patch1: ncurses-5.9-20110409-20110716.patch.bz2
15Patch8: ncurses-config.patch
16Patch9: ncurses-libs.patch
17Patch11: ncurses-urxvt.patch
18Patch12: ncurses-kbs.patch
19
20Requires(post): /sbin/ldconfig
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: pkgconfig
24
25Vendor: Project Vine
26Distribution: Vine Linux
27Packager: daisuke
28
29%description
30The curses library routines are a terminal-independent method of
31updating character screens with reasonable optimization.  The ncurses
32(new curses) library is a freely distributable replacement for the
33discontinued 4.4 BSD classic curses library.
34
35
36%package devel
37Summary: The development files for applications which use ncurses.
38Summary(ja): ncurses を用いるアプリケーション開発用のファイル
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41Obsoletes: libtermcap-devel <= 2.0.8-46vl1
42Provides: libtermcap-devel = 2.0.8-47
43
44%description devel
45The header files and libraries for developing applications that use
46the ncurses CRT screen handling and optimization package.
47
48Install the ncurses-devel package if you want to develop applications
49which will use ncurses.
50
51Use the following compiler flags to build against the ncurses library:
52                                                                               
53-lncurses
54(compile and link against the regular ncurses library)
55                                                                               
56-I %{includedirw} -lncursesw
57(compile and link against the wide-character, UTF-8, library)
58
59
60%package c++-devel
61Summary: C++ bindings to ncurses
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64Requires: %{name}-devel = %{version}-%{release}
65 
66%description c++-devel
67C++ bindings to ncurses
68
69
70%package -n compat32-%{name}
71Summary: A CRT screen handling and optimization package.
72Summary(ja): CRT スクリーンの操作と最適化を行うパッケージ
73Group: System Environment/Libraries
74Requires: %{name} = %{version}-%{release}
75
76%description -n compat32-%{name}
77The curses library routines are a terminal-independent method of
78updating character screens with reasonable optimization.  The ncurses
79(new curses) library is a freely distributable replacement for the
80discontinued 4.4 BSD classic curses library.
81
82
83%package -n compat32-%{name}-devel
84Summary: The development files for applications which use ncurses.
85Summary(ja): ncurses を用いるアプリケーション開発用のファイル
86Group: Development/Libraries
87Requires: compat32-%{name} = %{version}-%{release}
88Requires: %{name}-devel = %{version}-%{release}
89Obsoletes: compat32-libtermcap-devel <= 2.0.8-46vl1
90Provides: compat32-libtermcap-devel = 2.0.8-47
91
92%description -n compat32-%{name}-devel
93The header files and libraries for developing applications that use
94the ncurses CRT screen handling and optimization package.
95
96Install the ncurses-devel package if you want to develop applications
97which will use ncurses.
98
99Use the following compiler flags to build against the ncurses library:
100                                                                               
101-lncurses
102(compile and link against the regular ncurses library)
103                                                                               
104-I %{includedirw} -lncursesw
105(compile and link against the wide-character, UTF-8, library)
106
107
108%package -n compat32-%{name}-c++-devel
109Summary: C++ bindings to ncurses
110Group: System Environment/Libraries
111Requires: compat32-%{name} = %{version}-%{release}
112Requires: compat32-%{name}-devel = %{version}-%{release}
113Requires: %{name}-c++-devel = %{version}-%{release}
114 
115%description -n compat32-%{name}-c++-devel
116C++ bindings to ncurses
117
118
119%prep
120%setup -q
121%patch1 -p1
122
123%patch8 -p1 -b .config
124%patch9 -p1 -b .libs
125%patch11 -p1 -b .urxvt
126%patch12 -p1 -b .kbs
127
128find . -name "*.orig" -exec rm -f {} \;
129
130
131%build
132%define rootdatadir /lib
133%define ncurses_options \\\
134    --with-shared --without-ada --with-ospeed=unsigned \\\
135    --enable-hard-tabs --enable-xmc-glitch --enable-colorfgbg \\\
136    --with-terminfo-dirs=%{_sysconfdir}/terminfo:%{_datadir}/terminfo:%{rootdatadir}/terminfo \\\
137    --enable-overwrite \\\
138    --enable-pc-files \\\
139    --with-termlib=tinfo \\\
140    --with-chtype=long
141
142mkdir narrowc widec
143cd narrowc
144ln -s ../configure .
145%configure %{ncurses_options} --with-ticlib
146make %{?_smp_mflags} libs
147make %{?_smp_mflags} -C progs
148
149cd ../widec
150ln -s ../configure .
151%configure %{ncurses_options} --enable-widec --without-progs
152make %{?_smp_mflags} libs
153cd ..
154
155
156%install
157rm -rf ${RPM_BUILD_ROOT}
158
159make -C narrowc DESTDIR=$RPM_BUILD_ROOT install.{libs,progs,data}
160rm -f $RPM_BUILD_ROOT%{_libdir}/libtinfo.*
161make -C widec DESTDIR=$RPM_BUILD_ROOT install.{libs,includes,man}
162
163chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/lib*.so.*.*
164chmod 644 ${RPM_BUILD_ROOT}%{_libdir}/lib*.a
165
166# move lib{ncurses{,w},tinfo}.so.* to /lib*
167mkdir $RPM_BUILD_ROOT/%{_lib}
168mv $RPM_BUILD_ROOT%{_libdir}/lib{ncurses{,w},tinfo}.so.* $RPM_BUILD_ROOT/%{_lib}
169for l in $RPM_BUILD_ROOT%{_libdir}/lib{ncurses{,w},tinfo}.so; do
170    ln -sf $(echo %{_libdir} | \
171        sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
172done
173
174mkdir -p $RPM_BUILD_ROOT{%{rootdatadir},%{_sysconfdir}}/terminfo
175
176# move few basic terminfo entries to /lib
177baseterms=
178for termname in \
179        ansi dumb linux vt100 vt100-nav vt102 vt220 vt52
180do
181    for t in $(find $RPM_BUILD_ROOT%{_datadir}/terminfo \
182        -samefile $RPM_BUILD_ROOT%{_datadir}/terminfo/${termname::1}/$termname)
183    do
184        baseterms="$baseterms $(basename $t)"
185    done
186done
187for termname in $baseterms; do
188    termpath=terminfo/${termname::1}/$termname
189    mkdir $RPM_BUILD_ROOT%{rootdatadir}/terminfo/${termname::1} &> /dev/null || :
190    mv $RPM_BUILD_ROOT%{_datadir}/$termpath $RPM_BUILD_ROOT%{rootdatadir}/$termpath
191    ln -s $(dirname %{_datadir}/$termpath | \
192        sed 's,\(^/\|\)[^/][^/]*,..,g')%{rootdatadir}/$termpath \
193        $RPM_BUILD_ROOT%{_datadir}/$termpath
194done
195
196# prepare -base and -term file lists
197for termname in \
198    Eterm cons25 cygwin gnome* hurd jfbterm mach* mlterm mrxvt \
199    nsterm putty* pcansi rxvt rxvt-\* screen screen-\* screen.* \
200    sun teraterm wsvt25* xfce xterm xterm-\*
201do
202    for i in $RPM_BUILD_ROOT%{_datadir}/terminfo/?/$termname; do
203        for t in $(find $RPM_BUILD_ROOT%{_datadir}/terminfo -samefile $i); do
204            baseterms="$baseterms $(basename $t)"
205        done
206    done
207done 2> /dev/null
208for t in $baseterms; do
209    echo "%dir %{_datadir}/terminfo/${t::1}"
210    echo %{_datadir}/terminfo/${t::1}/$t
211done 2> /dev/null | sort -u > terms.base
212find $RPM_BUILD_ROOT%{_datadir}/terminfo \! -type d | \
213    sed "s|^$RPM_BUILD_ROOT||" | while read t
214do
215    echo "%dir $(dirname $t)"
216    echo $t
217done 2> /dev/null | sort -u | comm -2 -3 - terms.base > terms.term
218
219cat terms.base terms.term |sort -u > terms.all
220
221# can't replace directory with symlink (rpm bug), symlink all headers
222mkdir $RPM_BUILD_ROOT%{_includedir}/ncurses{,w}
223for l in $RPM_BUILD_ROOT%{_includedir}/*.h; do
224    ln -s ../$(basename $l) $RPM_BUILD_ROOT%{_includedir}/ncurses
225    ln -s ../$(basename $l) $RPM_BUILD_ROOT%{_includedir}/ncursesw
226done
227
228# don't require -ltinfo when linking with --no-add-needed
229for l in $RPM_BUILD_ROOT%{_libdir}/libncurses{,w}.so; do
230    soname=$(basename $(readlink $l))
231    rm -f $l
232    echo "INPUT($soname -ltinfo)" > $l
233done
234             
235rm -f $RPM_BUILD_ROOT%{_libdir}/libcurses{,w}.so
236echo "INPUT(-lncurses)" > $RPM_BUILD_ROOT%{_libdir}/libcurses.so
237echo "INPUT(-lncursesw)" > $RPM_BUILD_ROOT%{_libdir}/libcursesw.so
238
239echo "INPUT(-ltinfo)" > $RPM_BUILD_ROOT%{_libdir}/libtermcap.so
240
241rm -f ${RPM_BUILD_ROOT}%{_libdir}/terminfo
242#rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/{*_g,ncurses++*}.pc
243
244
245%post -p /sbin/ldconfig
246
247%postun -p /sbin/ldconfig
248
249%post -n compat32-%{name} -p /sbin/ldconfig
250
251%postun -n compat32-%{name} -p /sbin/ldconfig
252
253
254%files -f terms.all
255%defattr(-,root,root)
256%doc ANNOUNCE AUTHORS README TO-DO
257%{_bindir}/[cirt]*
258%{_mandir}/man1/*
259%{_mandir}/man5/*
260%{_mandir}/man7/*
261/%{_lib}/lib*.so.*
262%{_libdir}/lib*.so.*
263%dir %{_sysconfdir}/terminfo
264%{rootdatadir}/terminfo
265%{_datadir}/tabset
266%dir %{_datadir}/terminfo
267
268%files devel
269%defattr(-,root,root)
270%doc test
271%doc doc/html/hackguide.html
272%doc doc/html/ncurses-intro.html
273%doc c++/README*
274%{_bindir}/ncurses*-config
275%{_libdir}/lib*.so
276%{_libdir}/lib*.a
277 %dir %{_includedir}/ncurses
278%dir %{_includedir}/ncursesw
279%{_includedir}/ncurses/*.h
280%{_includedir}/ncursesw/*.h
281%{_includedir}/*.h
282%{_mandir}/man3/*
283%{_libdir}/pkgconfig/*.pc
284%exclude %{_libdir}/pkgconfig/ncurses++*.pc
285
286%files c++-devel
287%defattr(-,root,root)
288%doc c++/NEWS c++/PROBLEMS c++/README*
289%{_includedir}/ncurses/cursesapp.h
290%{_includedir}/ncurses/curses?.h
291%{_includedir}/ncurses/etip.h
292%{_libdir}/libncurses++.a
293%{_libdir}/libncurses++w.a
294%{_libdir}/pkgconfig/ncurses++*.pc
295
296%if %{build_compat32}
297%files -n compat32-%{name}
298%defattr(-,root,root)
299%attr(755,root,root) %{_libdir}/lib*.so.*
300/%{_lib}/lib*.so.*
301%{_libdir}/lib*.so.*
302
303
304%files -n compat32-%{name}-devel
305%defattr(-,root,root)
306%{_libdir}/lib*.so
307%{_libdir}/lib*.a
308%{_libdir}/pkgconfig/*.pc
309%exclude %{_libdir}/pkgconfig/ncurses++*.pc
310 
311
312%files -n compat32-%{name}-c++-devel
313%defattr(-,root,root)
314%{_libdir}/libncurses++.a
315%{_libdir}/libncurses++w.a
316%{_libdir}/pkgconfig/ncurses++*.pc
317%endif
318
319
320%clean
321rm -rf $RPM_BUILD_ROOT
322
323
324%changelog
325* Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.9-3
326- rebuild with VineSeed environment
327
328* Wed Dec 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9-2
329- don't require -ltinfo when linking with --no-add-needed
330
331* Fri Sep 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9-1
332- update to 5.9 + 20110716
333- update all patches
334- add pkgconfig file
335
336* Sun Mar 27 2011 IWAI, Masaharu <iwai@alib.jp> 5.6-5
337- build with new toolchain
338
339* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.6-4
340- rebuilt with new toolchain
341- add Requires(post,pre): /sbin/ldconfig
342
343* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 5.6-3
344- updated %%files section on compat32-* packages
345
346* Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.6-2
347- changed c++-devel Group to Development/Libraries
348- changelog of 5.6-1 is missing... seemed to be updated on Aug 10 2008
349
350* Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 5.4-0vl3
351- added compat32- packages for x86_64 architecture support
352
353* Mon May 17 2004 Tomoya TAKA <taka@vinelinux.org> 5.4-0vl2
354- add patch10 taken from fedora's 5.4-4
355
356* Sun May  9 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4-0vl1
357- new upstream release
358- remove obsolete patches
359
360* Mon Mar 22 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.3-9vl1
361- synced up with Fedora 5.3-9
362  - Thu Sep 11 2003 Adrian Havill <havill@redhat.com> 5.3-9
363  - remove not-so safe-sprintf configure option because the code does
364    not appear to be stable enough for some apps. (#103790)
365 
366  - Wed Aug 20 2003 Adrian Havill <havill@redhat.com> 5.3-8.1
367  - RHEL bump
368 
369  - Wed Aug 20 2003 Adrian Havill <havill@redhat.com> 5.3-8
370  - multilib patch (#91211)
371 
372  - Mon Aug 11 2003 Adrian Havill <havill@redhat.com> 5.3-7
373  - fixed the safe sprintf code that was enabled in the previous release
374    by the configure parameter. (#101486)
375 
376  - Mon Jun 16 2003 Elliot Lee <sopwith@redhat.com> 5.3-6.1
377  - Fix ac25 patch, make it easy to turn off GPM support
378 
379  - Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
380  - rebuilt
381 
382  - Thu May 22 2003 Adrian Havill <havill@redhat.com> 5.3-5
383  - added latest rollup patch with widec/UTF8 centric weekly (20030517)
384  - added --enable-widec to configure (#86311)
385    original work done by Mr. Sam <sam@email-scan.com>
386  - require sharutils (#86605)
387  - add gpm, xmc support
388  - add debug syms back into package
389  - updated autoconf/configure patch
390
391* Thu Mar 27 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.3-4vl1
392- synced Rawhide 5.3-4
393
394* Fri Feb 08 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-16vl2
395- revert to patch13 from 14 for XF86-4
396
397* Wed Feb 06 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-16vl1
398- synced Rawhide 5.2-16
399
400* Tue Aug 28 2001 Shoji Matsumoto <shom@vinelinux.org> 5.2-12vl2
401- patch 3 (xterm) disabled. this patch is for XF86-4???
402
403* Wed Aug 22 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-12vl1
404- added kon patch for Vine
405
406* Fri Jul 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.2-12
407- Sync terminfo with termcap 11.0.1-10
408
409* Sun Jun 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.2-11
410- Update to patchlevel 20010623, fixes some lynx issues
411 
412* Mon Jun 18 2001 Helge Deller <hdeller@redhat.de>
413- fixed tput -S segfaulting bug (#44669)
414- use _tmppath for BuildRoot:
415- Copyright -> License
416
417* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
418- Update to patchlevel 20010407
419
420* Tue Mar  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
421- Fix up some terminfo entries containing includes to
422  "/var/tmp/ncurses-root/something" (#30771)
423
424* Thu Feb 22 2001 Harald Hoyer <harald@redhat.de>
425- fixed rxvt backspace setting
426
427* Fri Feb  9 2001 Yukihiro Nakai <ynakai@redhat.com>
428- Update Japanese kterm patch
429
430* Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
431- Update
432- Add japanese patch from termcap
433- Fix ospeed handling
434
435* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
436- Add libcurses.a -> libncurses.a symlink (RFE #23023)
437
438* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
439- Use --with-ospeed='unsigned int'
440
441* Fri Nov 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
442- Fix alpha and ia64
443- Rebuild with gcc 2.96-64
444
445* Thu Nov  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
446- 5.2
447- Fix typo in man page (Bug #20205)
448- update the "screen" terminfo entries to the version supplied with
449  screen 3.9.8
450
451* Mon Oct  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
452- Update (fixes the "make menuconfig" bug introduced by the security fix)
453
454* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
455- Fix security problem (possible buffer overrun)
456
457* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
458- Add the bugfix patches from the ncurses maintainer
459
460* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
461- 5.1
462
463* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
464- automatic rebuild
465
466* Mon Jun  5 2000 Matt Wilson <msw@redhat.com>
467- *don't ship symlinks from lib*.so.5 to lib*.so.4!
468- use FHS macros
469
470* Fri Jun  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
471- rebuild for 7.0
472- /usr/share/man
473- update URL for patches
474- misc. fixes to spec file
475
476* Mon Mar 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
477- use the real library version number
478- update to 20000319
479
480* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
481- rebuild for sparc baud rates > 38400.
482
483* Fri Feb 18 2000 Preston Brown <pbrown@redhat.com>
484- xterm terminfo entries from XFree86 3.3.6
485- final round of xterm fixes, follow debian policy.
486
487* Sat Feb  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
488- strip libraries
489
490* Thu Feb  3 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
491- More xterm fixes (Bug #9087)
492
493* Thu Jan 27 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
494- More xterm fixes from Hans de Goede (Bug #8633)
495
496* Sat Jan 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
497- remove some broken symlinks (leftovers from libncurses.so.5)
498- Use %configure (Bug #8484)
499
500* Tue Jan 11 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
501- Add xterm patch from Hans de Goede <hans@highrise.nl>
502- Patch 20000108, this fixes a problem with a header file.
503
504* Wed Jan  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
505- Add 20000101 patch, hopefully finally fixing the xterm description
506
507* Wed Dec 22 1999 Cristian Gafton <gafton@redhat.com>
508- revert to the old major number - because the ABI is not changed (and we
509  should be handling the changes via symbol versioning anyway)
510
511* Fri Nov 12 1999 Bernhard Rosenkraenzer <bero@redhat.com>
512- Fix a typo in spec
513- Add the 19991006 patch, fixing some C++ STL compatibility problems.
514- get rid of profiling and debugging versions - we need to save space...
515
516* Thu Nov  4 1999 Bernhard Rosenkraenzer <bero@redhat.com>
517- 5.0
518- some spec cleanups to make updating easier
519- add links *.so.5 to *.so.4 - they are fully binary compatible.
520  (Why did they change the invocation number???)
521
522* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
523- make clean in the test dir - don't ship any binaries at all.
524
525* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
526- fixed stripping of test programs.
527
528* Sun Aug 29 1999 Preston Brown <pbrown@redhat.com>
529- removed 'flash' capability for xterm; see bug #2820 for details.
530
531* Fri Aug 27 1999 Cristian Gafton <gafton@redhat.com>
532- add the resetall script from Marc Merlin <marc@merlins.org>
533
534* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
535- added iris-ansi-net as alias for iris-ansi (bug #2561)
536
537* Fri Jul 30 1999 Michael K. Johnson <johnsonm@redhat.com>
538- added ncurses-intro.hmtl and hackguide.html to -devel package [bug #3929]
539
540* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
541- make sure ALL binaries are stripped (incl. test binaries)
542
543* Thu Mar 25 1999 Preston Brown <pbrown@redhat.com>
544- made xterm terminfo stuff MUCH better.
545
546* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
547- auto rebuild in the new build environment (release 16)
548
549* Sat Mar 13 1999 Cristian Gafton <gafton@redhat.com>
550- fixed header for C++ compiles
551
552* Fri Mar 12 1999 Jeff Johnson <jbj@redhat.com>
553- add terminfo entries for linux/linux-m on sparc (obsolete termfile_sparc).
554
555* Thu Feb 18 1999 Cristian Gafton <gafton@redhat.com>
556- updated patchset from original site
557
558* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
559- don't build the C++ demo code
560- update patch set to the current as of today (redid all the individual
561  patches in a single one)
562
563* Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
564- make sure to strip the binaries
565
566* Wed Sep 23 1998 Cristian Gafton <gafton@redhat.com>
567- added another zillion of patches. The spec file *is* ugly
568- defattr
569
570* Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
571- added lots of patches. This spec file is starting to look ugly
572
573* Wed Jul 01 1998 Alan Cox <alan@redhat.com>
574- Fix setuid trusting. Open termcap/info files as the real user.
575
576* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
577- added terminfo entry for the poor guys using lat1 and/or lat-2 on their
578  consoles... Enjoy linux-lat ! Thanks, Erik !
579
580* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
581- new patch to get xterm-color and nxterm terminfo entries
582- aliased them to rxvt, as that seems to satisfy everybody
583
584* Sun Apr 12 1998 Cristian Gafton <gafton@redhat.com>
585- added %clean section
586
587* Tue Apr 07 1998 Cristian Gafton <gafton@redhat.com>
588- removed /usr/lib/terminfo symlink - we shouldn't need that
589
590* Mon Apr 06 1998 Cristian Gafton <gafton@redhat.com>
591- updated to 4.2 + patches
592- added BuildRoot
593
594* Sat Apr 04 1998 Cristian Gafton <gafton@redhat.com>
595- rebuilt with egcs on alpha
596
597* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
598- version 7 didn't rebuild properly on the Alpha somehow -- no real changes
599  are in this version
600
601* Tue Dec 09 1997 Erik Troan <ewt@redhat.com>
602- TIOCGWINSZ wasn't used properly
603
604* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
605- built against glibc, linked shared libs against -lc
606
Note: See TracBrowser for help on using the repository browser.