source: projects/specs/trunk/m/mono/mono-vl.spec @ 3559

Revision 3559, 27.1 KB checked in by shaolin, 13 years ago (diff)
  • mono: some fix for ppc
Line 
1Summary: .NET runtime environment
2Summary(ja): .NET ランタイム環境
3Name: mono
4Version: 2.10.1
5Release: 2%{?_dist_release}
6Group: Development/Languages
7License: GPL, LGPL, MIT X11
8URL: http://www.mono-project.com/
9Source0: http://ftp.novell.com/pub/mono/sources/mono/%{name}-%{version}.tar.bz2
10Source1: monodir.c
11
12Patch1: mono-2.10.1-ppc-len.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: bison
16BuildRequires: glib2-devel
17BuildRequires: pkgconfig
18BuildRequires: libicu-devel
19BuildRequires: libgdiplus-devel >= 2.0
20BuildRequires: zlib-devel
21# JIT only availible on these:
22ExclusiveArch: %{ix86} x86_64 ppc ia64 s390 s390x armv4l sparc
23Obsoletes: %{name}-jscript < 2.8
24Obsoletes: %{name}-data-sybase < 2.8
25Obsoletes: %{name}-data-firebird < 2.8
26Obsoletes: bytefx-data-mysql < 2.8
27
28%description
29The Mono runtime implements a JIT engine for the ECMA CLI
30virtual machine (as well as a byte code interpreter, the
31class loader, the garbage collector, threading system and
32metadata access libraries.
33
34%description -l ja
35Mono ランタイムは ECMA CLI 仮想機械用 JIT エンジンの実装です。バイト
36コードインタプリタ、クラスローダ、ガベージコレクタ、スレッドシステム
37およびメタデータアクセスライブラリの機能を持ちます。
38
39%package core
40Summary: The Mono CIL runtime, suitable for running .NET code
41Summary(ja): .NET の実行に適した Mono CIL ランタイム
42Group: Development/Languages
43Requires: libgdiplus
44
45%description core
46This package contains the core of the Mono runtime including its
47Virtual Machine, Just-in-time compiler, C# compiler, security
48tools and libraries (corlib, XML, System.Security, ZipLib,
49I18N, Cairo and Mono.*).
50
51%package devel
52Summary:        Development tools for Mono
53Summary(ja):    Mono 開発ツール
54Group:          Development/Languages
55Requires:       mono-core = %{version}-%{release}
56Requires:       glib2-devel
57
58%description devel
59This package completes the Mono developer toolchain with the mono profiler,
60assembler and other various tools.
61
62%package nunit
63Summary:        NUnit Testing Framework
64Summary(ja):    NUnit テストフレームワーク
65Group:          Development/Languages
66Requires:       mono-core = %{version}-%{release}
67Requires:       glib2-devel
68
69%description nunit
70NUnit is a unit-testing framework for all .NET languages. Initially
71ported from JUnit, the current release, version 2.2, is the fourth
72major release of this Unit based unit testing tool for Microsoft .NET.
73It is written entirely in C# and  has been completely redesigned to
74take advantage of many .NET language features, for example
75custom attributes and other reflection related capabilities. NUnit
76brings xUnit to all .NET languages.
77
78%package locale-extras
79Summary:        Extra locale information for Mono
80Summary(ja):    Mono 用追加ロケール情報
81Group:          Development/Languages
82Requires:       mono-core = %{version}-%{release}
83
84%description locale-extras
85This package contains assemblies to support I18N applications for
86non-latin alphabets.
87
88%package extras
89Summary:        Provides the infrastructure for running and building daemons and services with Mono as well as various stub assemblies
90Group:          Development/Languages
91Requires:       mono-core = %{version}-%{release}
92
93%description extras
94This package provides the libary and application to run services
95and daemons with Mono. It also includes stubs for the following
96.NET 1.1 and 2.0 assemblies: Microsoft.Vsa,
97System.Configuration.Install, System.Management, System.Messaging.
98
99%package winforms
100Summary:        Windows Forms implementation for Mono
101Group:          Development/Languages
102Requires:       mono-core = %{version}-%{release}
103
104%description winforms
105This package provides a fully managed implementation of
106System.Windows.Forms, the default graphical toolkit for .NET
107applications.
108
109%package web
110Summary:        ASP.NET, Remoting, and Web Services for Mono
111Group:          Development/Languages
112Requires:       mono-core = %{version}-%{release}
113
114%description web
115This package provides the ASP.NET libraries and runtime for
116development of web application, web services and remoting support.
117
118%package data
119Summary:        Database connectivity for Mono
120Group:          Development/Languages
121Requires:       mono-core = %{version}-%{release}
122
123%description data
124This package provides a Mono assembly to facilitate data access
125and manipulation with databases, LDAP compatible directory servers
126and/or XML data exchange. Beyond the ADO.NET, Novell.LDAP and
127System.DirectoryServices assemblies, it also includes a command
128line sql application as well as the Microsoft SQL Server and ODBC
129data providers.
130
131%package data-sqlite
132Summary:        sqlite database connectivity for Mono
133Group:          Development/Languages
134Requires:       mono-core = %{version}-%{release}
135Requires:       sqlite
136
137%description data-sqlite
138This package contains the ADO.NET Data provider for the sqlite
139database.
140
141%package data-oracle
142Summary:        Oracle database connectivity for Mono
143Group:          Development/Languages
144Requires:       mono-core = %{version}-%{release}
145
146%description data-oracle
147This package contains the ADO.NET Data provider for the Oracle
148database.
149
150%package data-postgresql
151Summary:        Postgresql database connectivity for Mono
152Group:          Development/Languages
153Requires:       mono-core = %{version}-%{release}
154
155%description data-postgresql
156This package contains the ADO.NET Data provider for the PostgreSQL
157database.
158
159%package -n ibm-data-db2
160Summary:        IBM DB2 database connectivity for Mono
161Group:          Development/Languages
162Requires:       mono-core = %{version}-%{release}
163
164%description -n ibm-data-db2
165This package contains the ADO.NET Data provider for the IBM DB2
166Universal database.
167
168%package -n monodoc
169Summary:        The Mono documentation system
170Group:          Development/Tools
171Requires:       mono-core = %{version}-%{release}
172Requires:       libgluezilla >= 2.4
173Obsoletes:      monodoc-core <= 2.0-1vl5
174
175%description -n monodoc
176monodoc is the documentation package for the mono .NET environment
177
178## macros
179%define mono_dir %{_prefix}/lib/mono
180%define mono_doc %{_prefix}/lib/monodoc
181%define bin_and_exe(bin, exe) %{_bindir}/%{1} \
182        %{mono_dir}/%{2}.exe \
183        %{mono_dir}/%{2}.exe.* \
184        %{nil}
185%define gac_and_1dll(dll)  %{mono_dir}/gac/%{1} \
186        %{mono_dir}/%{2}/%{1}.dll \
187        %{nil}
188%define gac_and_2dll(dll)  %{mono_dir}/gac/%{1} \
189        %{mono_dir}/%{2}/%{1}.dll \
190        %{mono_dir}/%{3}/%{1}.dll \
191        %{nil}
192%define gac_and_3dll(dll)  %{mono_dir}/gac/%{1} \
193        %{mono_dir}/%{2}/%{1}.dll \
194        %{mono_dir}/%{3}/%{1}.dll \
195        %{mono_dir}/%{4}/%{1}.dll \
196        %{nil}
197
198
199%prep
200%setup -q
201%patch1 -p1
202
203## These are only needed if there are patches to the runtime
204#rm -f libgc/libtool.m4
205#autoreconf --force --install
206#autoreconf --force --install libgc
207
208## Remove prebuilt binaries
209#rm -rf mcs/class/lib/monolite/*
210
211%build
212gcc -o monodir %{SOURCE1} -DMONODIR=\"%{mono_dir}\"
213
214export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
215%configure \
216        --with-jit=yes \
217        --with-ikvm=yes \
218        --with-sigaltstack=no \
219%ifarch ppc
220        --with-sgen=no \
221        --disable-system-aot \
222%endif
223        ;
224
225# don't use parallel builds
226# make %{?_smp_mflags}
227make
228
229
230%install
231[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
232make install DESTDIR=%{buildroot}
233
234install monodir %{buildroot}%{_bindir}
235
236## Remove unused files
237%{__rm} -f %{buildroot}%{_libdir}/*.la
238%{__rm} -f %{buildroot}%{_libdir}/*.a
239%{__rm} -f %{buildroot}%{_bindir}/mono-find-provides
240%{__rm} -f %{buildroot}%{_bindir}/mono-find-requires
241
242## This was removed upstream:
243%{__rm} -rf %{buildroot}%{mono_dir}/gac/Mono.Security.Win32/2*
244%{__rm} -rf %{buildroot}%{mono_dir}/2.0/Mono.Security.Win32.dll
245%{__rm} -rf %{buildroot}%{_datadir}/libgc-mono
246%{__rm} -rf %{buildroot}%{_datadir}/mono-2.0/mono/cil
247%{__rm} -f %{buildroot}%{_bindir}/prj2make
248%{__rm} -f %{buildroot}%{_mandir}/man1/prj2make.*
249%{__rm} -f %{buildroot}%{_mandir}/man1/cilc.*
250
251%find_lang mcs
252
253
254%clean
255[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
256
257%post core -p /sbin/ldconfig
258%postun core -p /sbin/ldconfig
259%post devel -p /sbin/ldconfig
260%postun devel -p /sbin/ldconfig
261
262
263%files core -f mcs.lang
264%defattr(-,root,root,-)
265%doc AUTHORS COPYING.LIB ChangeLog NEWS README
266##{_bindir}/mcs
267%{_bindir}/mono
268%{_bindir}/monodir
269%{_bindir}/mono-api-*
270%{_bindir}/mono-configuration-crypto
271%{_bindir}/mono-heapviz
272%ifnarch ppc
273%{_bindir}/mono-sgen
274%endif
275%{_bindir}/peverify
276%{_bindir}/mprof-report
277%{_bindir}/mono-test-install
278%{_libdir}/libMonoPosixHelper.so
279%{_libdir}/libmono-2.0.so.*
280%ifnarch ppc
281%{_libdir}/libmonosgen-2.0.so.*
282%endif
283%{_libdir}/libmono-profiler-aot.so.*
284%{_libdir}/libmono-profiler-cov.so.*
285%{_libdir}/libmono-profiler-iomap.so.*
286%{_libdir}/libmono-profiler-log.so*
287%dir %{mono_dir}
288%dir %{mono_dir}/4.0
289%dir %{mono_dir}/3.5
290%dir %{mono_dir}/2.0
291%dir %{mono_dir}/gac
292%dir %{mono_dir}/compat-2.0
293%bin_and_exe ccrewrite 4.0/ccrewrite
294%bin_and_exe csharp 4.0/csharp
295%bin_and_exe csharp2 2.0/csharp
296%bin_and_exe certmgr 4.0/certmgr
297%bin_and_exe chktrust 4.0/chktrust
298%bin_and_exe dmcs 4.0/dmcs
299%bin_and_exe lc 4.0/lc
300%bin_and_exe gacutil 4.0/gacutil
301%bin_and_exe gacutil2 2.0/gacutil
302%bin_and_exe gmcs 2.0/gmcs
303%bin_and_exe installvst 4.0/installvst
304%bin_and_exe mconfig 4.0/mconfig
305%ifarch ppc
306%{mono_dir}/2.0/mcs.exe
307%else
308%bin_and_exe mcs 2.0/mcs
309%endif
310%bin_and_exe mod 4.0/mod
311%bin_and_exe mono-cil-strip 4.0/mono-cil-strip
312%bin_and_exe monolinker 2.0/monolinker
313%bin_and_exe mozroots 4.0/mozroots
314%bin_and_exe setreg 4.0/setreg
315%bin_and_exe sn 4.0/sn
316%bin_and_exe sqlmetal 4.0/sqlmetal
317%bin_and_exe svcutil 4.0/svcutil
318%{mono_dir}/4.0/browsercaps-updater.exe*
319%{mono_dir}/4.0/monolinker.exe*
320%{mono_dir}/4.0/ictool.exe*
321%{mono_dir}/4.0/installutil.exe*
322%{mono_dir}/4.0/mono-api-info.exe
323%{mono_dir}/4.0/mscorlib.dll*
324%{mono_dir}/2.0/mscorlib.dll*
325%{mono_dir}/3.5/Microsoft.Build.*
326%{mono_dir}/4.0/Microsoft.CSharp.targets
327%{mono_dir}/3.5/Microsoft.CSharp.targets
328%{mono_dir}/2.0/Microsoft.CSharp.targets
329%{mono_dir}/4.0/Microsoft.Common.targets
330%{mono_dir}/3.5/Microsoft.Common.targets
331%{mono_dir}/2.0/Microsoft.Common.targets
332%{mono_dir}/4.0/Microsoft.VisualBasic.targets
333%{mono_dir}/3.5/Microsoft.VisualBasic.targets
334%{mono_dir}/2.0/Microsoft.VisualBasic.targets
335%{mono_dir}/compat-*/ICSharpCode.SharpZipLib.dll
336%{mono_dir}/gac/Mono.Cecil
337%{mono_dir}/gac/Mono.Cecil.Mdb
338%{mono_dir}/mono-configuration-crypto/4.0/Mono.Configuration.Crypto.dll*
339%{mono_dir}/mono-configuration-crypto/4.0/mono-configuration-crypto.exe*
340%gac_and_2dll cscompmgd 4.0 2.0
341%gac_and_2dll Commons.Xml.Relaxng 4.0 2.0
342%gac_and_2dll CustomMarshalers 4.0 2.0
343%gac_and_2dll I18N 4.0 2.0
344%gac_and_2dll I18N.West 4.0 2.0
345%gac_and_2dll ICSharpCode.SharpZipLib 4.0 2.0
346%gac_and_1dll Microsoft.CSharp 4.0
347%gac_and_2dll Mono.C5 4.0 2.0
348%gac_and_2dll Mono.Cairo 4.0 2.0
349%gac_and_2dll Mono.CompilerServices.SymbolWriter 4.0 2.0
350%gac_and_2dll Mono.Posix 4.0 2.0
351%gac_and_2dll Mono.Security 4.0 2.0
352%gac_and_1dll Mono.Security.Win32 4.0
353%gac_and_2dll Mono.CSharp 4.0 2.0
354%gac_and_1dll Mono.CodeContracts 4.0
355%gac_and_2dll Mono.Debugger.Soft 4.0 2.0
356%gac_and_2dll Mono.Management 4.0 2.0
357%gac_and_2dll Mono.Simd 4.0 2.0
358%gac_and_2dll Mono.Tasklets 4.0 2.0
359%gac_and_2dll System 4.0 2.0
360%gac_and_2dll System.Configuration 4.0 2.0
361%gac_and_1dll System.Dynamic 4.0
362%gac_and_2dll System.Drawing 4.0 2.0
363%gac_and_2dll System.Core 4.0 2.0
364%gac_and_1dll System.ComponentModel.Composition 4.0
365%gac_and_2dll System.ComponentModel.DataAnnotations 4.0 2.0
366%gac_and_2dll System.IdentityModel 4.0 2.0
367%gac_and_2dll System.IdentityModel.Selectors 4.0 2.0
368%gac_and_2dll System.Net 4.0 2.0
369%gac_and_1dll System.Numerics 4.0
370%gac_and_1dll System.Runtime.Caching 4.0
371%gac_and_1dll System.Runtime.DurableInstancing 4.0
372%gac_and_2dll System.Runtime.Serialization 4.0 2.0
373%gac_and_2dll System.Runtime.Serialization.Formatters.Soap 4.0 2.0
374%gac_and_2dll System.Security 4.0 2.0
375%gac_and_1dll System.Xaml 4.0
376%gac_and_2dll System.Xml 4.0 2.0
377%gac_and_2dll System.Xml.Linq 4.0 2.0
378%gac_and_2dll OpenSystem.C 4.0 2.0
379%gac_and_2dll WindowsBase 4.0 2.0
380%dir %{_sysconfdir}/mono
381%dir %{_sysconfdir}/mono/4.0
382%dir %{_sysconfdir}/mono/2.0
383%dir %{_sysconfdir}/mono/mconfig
384%config (noreplace) %{_sysconfdir}/mono/config
385%config (noreplace) %{_sysconfdir}/mono/2.0/machine.config
386%config (noreplace) %{_sysconfdir}/mono/4.0/machine.config
387%config (noreplace) %{_sysconfdir}/mono/mconfig/config.xml
388%config (noreplace) %{_sysconfdir}/mono/2.0/settings.map
389%config (noreplace) %{_sysconfdir}/mono/4.0/settings.map
390%{_prefix}/lib/mono-source-libs/
391%{_mandir}/man1/ccrewrite.1.gz
392%{_mandir}/man1/certmgr.1.gz
393%{_mandir}/man1/chktrust.1.gz
394%{_mandir}/man1/csharp.1.gz
395%{_mandir}/man1/gacutil.1.gz
396%{_mandir}/man1/lc.1.gz
397%{_mandir}/man1/mconfig.1.gz
398%{_mandir}/man1/mcs.1.gz
399%{_mandir}/man1/mono.1.gz
400%{_mandir}/man1/monolinker.1.gz
401%{_mandir}/man1/mozroots.1.gz
402%{_mandir}/man1/mprof-report.1.gz
403%{_mandir}/man1/setreg.1.gz
404%{_mandir}/man1/sn.1.gz
405%{_mandir}/man1/resgen.1.gz
406%{_mandir}/man1/mono-api-info.1.gz
407%{_mandir}/man1/mono-cil-strip.1.gz
408%{_mandir}/man1/mono-configuration-crypto.1.gz
409%{_mandir}/man5/mono-config.5.gz
410
411%files devel
412%defattr(-,root,root,-)
413%{_bindir}/genxs
414%{_bindir}/mkbundle
415%{_bindir}/mono-gdb.py
416%{_bindir}/monodis
417%{_bindir}/monograph
418%{_bindir}/pedump
419%{_bindir}/xbuild
420%{_libdir}/libmono-2.0.so
421%{_libdir}/libmono-profiler-aot.so
422%{_libdir}/libmono-profiler-cov.so
423%{_libdir}/libmono-profiler-iomap.so
424%ifnarch ppc
425%{_libdir}/libmonosgen-2.0.so
426%endif
427%{_libdir}/libMonoSupportW.so
428%{_libdir}/libikvm-native.so
429%{mono_dir}/4.0/mkbundle.exe*
430%{mono_dir}/2.0/mkbundle.exe*
431%{mono_dir}/4.0/genxs.exe*
432%{mono_dir}/2.0/genxs.exe*
433%{mono_dir}/2.0/ilasm.exe*
434%bin_and_exe al 4.0/al
435%bin_and_exe al2 2.0/al
436%bin_and_exe caspol 4.0/caspol
437%bin_and_exe cert2spc 4.0/cert2spc
438%bin_and_exe dtd2xsd 4.0/dtd2xsd
439%bin_and_exe dtd2rng 4.0/dtd2rng
440%bin_and_exe sgen 4.0/sgen
441%bin_and_exe ilasm 4.0/ilasm
442%bin_and_exe macpack 4.0/macpack
443%bin_and_exe makecert 4.0/makecert
444%bin_and_exe monop 4.0/monop
445%bin_and_exe monop2 2.0/monop
446%bin_and_exe mono-shlib-cop 4.0/mono-shlib-cop
447%bin_and_exe mono-xmltool 4.0/mono-xmltool
448%bin_and_exe pdb2mdb 4.0/pdb2mdb
449%bin_and_exe permview 4.0/permview
450%bin_and_exe resgen 4.0/resgen
451%bin_and_exe resgen2 2.0/resgen
452%bin_and_exe secutil 4.0/secutil
453%bin_and_exe signcode 4.0/signcode
454%{mono_dir}/xbuild
455%{mono_dir}/4.0/xbuild.*
456%{mono_dir}/3.5/xbuild.*
457%{mono_dir}/2.0/xbuild.*
458%{mono_dir}/4.0/culevel.exe*
459%{mono_dir}/2.0/culevel.exe*
460%{mono_dir}/4.0/MSBuild/*.xsd
461%{mono_dir}/3.5/MSBuild/*.xsd
462%{mono_dir}/2.0/MSBuild/*.xsd
463%{mono_dir}/4.0/Microsoft.Build.xsd
464%{mono_dir}/3.5/Microsoft.Build.xsd
465%{mono_dir}/2.0/Microsoft.Build.xsd
466%{mono_dir}/4.0/Microsoft.*.targets
467%{mono_dir}/3.5/Microsoft.*.targets
468%{mono_dir}/2.0/Microsoft.*.targets
469%{mono_dir}/4.0/Microsoft.Common.tasks
470%{mono_dir}/3.5/Microsoft.Common.tasks
471%{mono_dir}/2.0/Microsoft.Common.tasks
472%gac_and_2dll PEAPI 4.0 2.0
473%gac_and_3dll Microsoft.Build.Engine 4.0 3.5 2.0
474%gac_and_3dll Microsoft.Build.Framework 4.0 3.5 2.0
475%gac_and_1dll Microsoft.Build.Tasks 2.0
476%gac_and_1dll Microsoft.Build.Tasks.v4.0 4.0
477%gac_and_1dll Microsoft.Build.Tasks.v3.5 3.5
478%gac_and_1dll Microsoft.Build.Utilities 2.0
479%gac_and_1dll Microsoft.Build.Utilities.v4.0 4.0
480%gac_and_1dll Microsoft.Build.Utilities.v3.5 3.5
481%gac_and_2dll Microsoft.VisualC 4.0 2.0
482%{_libdir}/pkgconfig/cecil.pc
483%{_libdir}/pkgconfig/dotnet.pc
484%{_libdir}/pkgconfig/dotnet35.pc
485%{_libdir}/pkgconfig/mono-cairo.pc
486%{_libdir}/pkgconfig/mono.pc
487%{_libdir}/pkgconfig/mono-2.pc
488%{_libdir}/pkgconfig/mono-lineeditor.pc
489%{_libdir}/pkgconfig/mono-options.pc
490%ifnarch ppc
491%{_libdir}/pkgconfig/monosgen-2.pc
492%endif
493%{_libdir}/pkgconfig/wcf.pc
494%{_includedir}/mono-2.0
495%{_mandir}/man1/al.1.gz
496%{_mandir}/man1/cert2spc.1.gz
497%{_mandir}/man1/dtd2xsd.1.gz
498%{_mandir}/man1/genxs.1.gz
499%{_mandir}/man1/ilasm.1.gz
500%{_mandir}/man1/macpack.1.gz
501%{_mandir}/man1/makecert.1.gz
502%{_mandir}/man1/mkbundle.1.gz
503%{_mandir}/man1/mono-shlib-cop.1.gz
504%{_mandir}/man1/mono-xmltool.1.gz
505%{_mandir}/man1/monodis.1.gz
506%{_mandir}/man1/monop.1.gz
507%{_mandir}/man1/pdb2mdb.1.gz
508%{_mandir}/man1/permview.1.gz
509%{_mandir}/man1/secutil.1.gz
510%{_mandir}/man1/sgen.1.gz
511%{_mandir}/man1/signcode.1.gz
512%{_mandir}/man1/xbuild.1.gz
513
514%files nunit
515%defattr(-,root,root,-)
516%bin_and_exe nunit-console 4.0/nunit-console
517%bin_and_exe nunit-console2 2.0/nunit-console
518%gac_and_2dll nunit.core 4.0 2.0
519%gac_and_2dll nunit.framework 4.0 2.0
520%gac_and_2dll nunit.util 4.0 2.0
521%gac_and_2dll nunit.mocks 4.0 2.0
522%gac_and_2dll nunit-console-runner 4.0 2.0
523%gac_and_2dll nunit.core.extensions 4.0 2.0
524%gac_and_2dll nunit.core.interfaces 4.0 2.0
525%gac_and_2dll nunit.framework.extensions 4.0 2.0
526%{_libdir}/pkgconfig/mono-nunit.pc
527
528%files locale-extras
529%defattr(-,root,root,-)
530%gac_and_2dll I18N.MidEast 4.0 2.0
531%gac_and_2dll I18N.Rare 4.0 2.0
532%gac_and_2dll I18N.CJK 4.0 2.0
533%gac_and_2dll I18N.Other 4.0 2.0
534
535%files extras
536%defattr(-,root,root,-)
537%{_mandir}/man1/mono-service.1.gz
538%bin_and_exe mono-service 4.0/mono-service
539%bin_and_exe mono-service2 2.0/mono-service
540%{mono_dir}/gac/mono-service
541%gac_and_2dll System.Configuration.Install 4.0 2.0
542%gac_and_2dll System.Management 4.0 2.0
543%gac_and_2dll System.Messaging 4.0 2.0
544%gac_and_2dll System.ServiceProcess 4.0 2.0
545%gac_and_2dll System.ServiceModel 4.0 2.0
546%gac_and_1dll System.ServiceModel.Discovery 4.0
547%gac_and_1dll System.ServiceModel.Routing 4.0
548%gac_and_2dll Mono.Messaging.RabbitMQ 4.0 2.0
549%gac_and_2dll Mono.Messaging 4.0 2.0
550%gac_and_2dll RabbitMQ.Client 4.0 2.0
551%{mono_dir}/4.0/RabbitMQ.Client.Apigen.exe*
552%{mono_dir}/2.0/RabbitMQ.Client.Apigen.exe*
553
554%files winforms
555%defattr(-,root,root,-)
556%gac_and_2dll Accessibility 4.0 2.0
557%gac_and_2dll System.Design 4.0 2.0
558%gac_and_2dll System.Drawing.Design 4.0 2.0
559%gac_and_2dll System.Windows.Forms 4.0 2.0
560%gac_and_1dll System.Windows.Forms.DataVisualization 4.0
561
562%files web
563%defattr(-,root,root,-)
564%{mono_dir}/2.0/xsd.exe*
565%{mono_dir}/compat-2.0/System.Web.Extensions*dll
566%{mono_dir}/compat-2.0/System.Web.Mvc.dll
567%bin_and_exe disco 4.0/disco
568%bin_and_exe soapsuds 4.0/soapsuds
569%bin_and_exe xsd 4.0/xsd
570%bin_and_exe wsdl 4.0/wsdl
571%bin_and_exe wsdl2 2.0/wsdl
572%bin_and_exe httpcfg 4.0/httpcfg
573%gac_and_2dll Mono.Http 4.0 2.0
574%gac_and_2dll Mono.Web 4.0 2.0
575%gac_and_2dll Mono.WebBrowser 4.0 2.0
576%gac_and_2dll System.Runtime.Remoting 4.0 2.0
577%gac_and_2dll System.Runtime.Serialization.Formatters.Soap 4.0 2.0
578%gac_and_2dll System.ServiceModel.Web 4.0 2.0
579%gac_and_2dll System.Web 4.0 2.0
580%gac_and_1dll System.Web.ApplicationServices 4.0
581%gac_and_2dll System.Web.Abstractions 4.0 2.0
582%gac_and_2dll System.Web.DynamicData 4.0 2.0
583%gac_and_1dll System.Web.Mvc 2.0
584%gac_and_2dll System.Web.Routing 4.0 2.0
585%gac_and_2dll System.Web.Services 4.0 2.0
586%gac_and_2dll System.Web.Extensions.Design 4.0 2.0
587%gac_and_2dll System.Web.Extensions 4.0 2.0
588%gac_and_1dll Microsoft.Web.Infrastructure 4.0
589%gac_and_1dll WebMatrix.Data 4.0
590%{_mandir}/man1/disco.1.gz
591%{_mandir}/man1/soapsuds.1.gz
592%{_mandir}/man1/wsdl.1.gz
593%{_mandir}/man1/xsd.1.gz
594%config (noreplace) %{_sysconfdir}/mono/browscap.ini
595%config (noreplace) %{_sysconfdir}/mono/2.0/Browsers/Compat.browser
596%config (noreplace) %{_sysconfdir}/mono/4.0/DefaultWsdlHelpGenerator.aspx
597%config (noreplace) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
598%config (noreplace) %{_sysconfdir}/mono/4.0/web.config
599%config (noreplace) %{_sysconfdir}/mono/2.0/web.config
600%{_mandir}/man1/httpcfg.1.gz
601%{_libdir}/pkgconfig/mono.web.pc
602%{_libdir}/pkgconfig/system.web.extensions_1.0.pc
603%{_libdir}/pkgconfig/system.web.extensions.design_1.0.pc
604%{_libdir}/pkgconfig/system.web.mvc.pc
605%{_libdir}/pkgconfig/system.web.mvc2.pc
606
607%files data
608%defattr(-,root,root,-)
609%bin_and_exe sqlsharp 4.0/sqlsharp
610%gac_and_2dll Mono.Data.Tds 4.0 2.0
611%gac_and_2dll Novell.Directory.Ldap 4.0 2.0
612%gac_and_2dll System.Data 4.0 2.0
613%gac_and_2dll System.Data.DataSetExtensions 4.0 2.0
614%gac_and_2dll System.Data.Linq 4.0 2.0
615%gac_and_2dll System.Data.Services 4.0 2.0
616%gac_and_2dll System.Data.Services.Client 4.0 2.0
617%gac_and_2dll System.DirectoryServices 4.0 2.0
618%gac_and_2dll System.EnterpriseServices 4.0 2.0
619%gac_and_2dll System.Transactions 4.0 2.0
620%{mono_dir}/gac/System.Data.Services.Client
621%{_mandir}/man1/sqlsharp.1.gz
622
623%files data-sqlite
624%defattr(-,root,root,-)
625%gac_and_2dll Mono.Data.Sqlite 4.0 2.0
626
627%files data-oracle
628%defattr(-,root,root,-)
629%gac_and_2dll System.Data.OracleClient 4.0 2.0
630
631%files data-postgresql
632%defattr(-,root,root,-)
633%gac_and_2dll Npgsql 4.0 2.0
634
635%files -n ibm-data-db2
636%defattr(-,root,root,-)
637%gac_and_2dll IBM.Data.DB2 4.0 2.0
638
639%files -n monodoc
640%defattr(-, root, root)
641%bin_and_exe mdoc 2.0/mdoc
642%{_bindir}/mdoc-*
643%{_bindir}/mdass*
644%{_bindir}/mdval*
645%{_bindir}/mod
646%{_bindir}/monodoc*
647%{mono_dir}/gac/monodoc
648%{mono_dir}/monodoc/monodoc.dll
649%{mono_doc}/*
650%{_mandir}/man1/md*
651%{_mandir}/man1/monodoc*
652%{_mandir}/man5/mdoc*
653%{_libdir}/pkgconfig/monodoc.pc
654
655
656%changelog
657* Sat Apr 16 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.10.1-2
658- remove the old ppc patch (similar codes already in the upstream)
659- add Patch1 (from Gentoo)
660- mono/2.0/mcs.exe.so not available on ppc - remove from the filelist
661  (TODO: see the Fedora's srpm - removing mono/2.0/{mcs,gmcs}.exe.so etc.)
662
663* Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.1-1
664- updated mono to 2.10.1
665
666* Sat Jan 08 2011 Shu KONNO <owa@bg.wakwak.com> 2.8.2-1
667- updated mono to 2.8.2
668
669* Tue Dec 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-2
670- add Patch0 (mono-2.8.1-ppc.patch)
671- add configure option "--with-sgen=no" and "--disable-system-aot" (ppc only)
672- fix %%files (add %%ifnarch ppc)
673
674* Sun Nov 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-1
675- updated mono to 2.8.1
676
677* Sat Nov 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-2
678- comment out script that removes prebuilt binaries, because gmcs.exe require
679
680* Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
681- updated mono to 2.8
682- modified macros used in %%files
683- removed below:
684  - packages:
685    %{name}-jscript, %{name}-data-sybase, %{name}-data-firebird, bytefx-data-mysql
686  - libraries:
687    ByteFX.Data, FirebirdSql.Data.Firebird
688    Mono.Data Mono.Data.TdsClient, Mono.Data.SybaseClient, Mono.Data.SqliteClient
689    Microsoft.JScript, Microsoft.Vsa
690  - commands:
691    cilc, mjs, prj2make (replaced by xbuild)
692
693* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.6.7-2
694- build with rpm-4.8.1-1 for pkg-config file
695
696* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.7-1
697- updated mono to 2.6.7
698
699* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
700- updated mono to 2.6.4
701
702* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
703- updated mono to 2.6.3
704  added RabbitMQ.Client.Apigen.exe
705
706* Thu Dec 31 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-2
707- unuse _smp_mflags
708
709* Sat Dec 26 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-1
710- updated mono to 2.6.1
711- simplified macros
712
713* Mon Dec 14 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-1
714- updated mono to 2.4.3
715  added %%{mono_dir}/2.0/lc.exe*
716  added %%gac_dll System.Web.Mvc
717  added %%{mono_dir}/xbuild/*
718  added %%{_mandir}/man1/lc.1.gz
719  added %%{_mandir}/man1/xbuild.1.gz
720
721* Wed Jul 29 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.3-1
722- updated mono to 2.4.2.3
723
724* Fri Jul 24 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.2-1
725- updated mono to 2.4.2.2
726
727* Tue Jul 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.2.1-1
728- new upstream release
729- build with latest rpm to update mono-dependencies
730
731* Thu Jul 02 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
732- updated mono to 2.4.2
733
734* Mon Apr 27 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4-3
735- fix temporary workaround against build failure on ppc,
736  from RH bugzilla #494026
737  - statically link mono to libmono: remove "--disable-static" from configure
738  - ensure removing *.a files in the install section
739- remove prebuilt binaries under mcs/class/lib/monolite/ before building
740
741* Sun Apr  5 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
742- fixed paths using %%mono_dir, %%mono_doc macros
743- added Requires:libgluezilla >= 2.4 in monodoc
744
745* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
746- new upstream release
747- added monodoc package (Obsoletes: monodoc-core <= 2.0-1vl5)
748
749* Mon Nov 03 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1
750- new upstream release
751- dropt %%{_bindir}/mono-find-{provides,requires}
752- added --with-libgdiplus=installed
753
754* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-3
755- update to mono-2.0 released source
756- BR: libgdiplus-devel >= 2.0
757
758* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-2vl5
759- removed *.la
760
761* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1vl5
762- updated mono to 2.0
763- updated url
764- changed macro %%monodir to %%mono_dir
765- dropt mono-1.1.13.4-selinux-ia64.patch
766- dropt mono-1.1.13.4-ppc-threading.patch
767- dropt mono-1.2.3-use-monodir.patch
768
769* Tue Aug 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-1vl5
770- applied new versioning policy, spec in utf-8
771- dropt mono-1.2.5-libdir.patch
772- reverted monodir macro to using %%{_prefix}/lib/mono
773
774* Sat Dec 29 2007 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-0vl2
775- updated monodir to %%{_libdir}/mono
776
777* Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5.1-0vl1
778- new upstream release
779- splited mono-basic package
780
781* Sat Oct 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.8.1-0vl1
782- new upstream release
783
784* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.6-0vl1
785- new upstream release
786
787* Thu Apr 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.13.4-2vl2
788- disabled Patch2 on Vine/ppc environment
789
790* Wed Mar 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.4-2vl1
791- updated source and sub-packages based on Fedora packages
792  * Tue Feb 22 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.6-0vl1
793  - new upstream version(mono-1.0.6)
794  * Sun Jan 16 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.5-0vl1
795  - new upstream version(mono-1.0.5)
796  * Sat Nov 06 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.4-0vl1
797  - new upstream version(mono-1.0.4)
798        -- changed to use configure
799  * Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
800  - rebuild for Vine Linux (based on mono.spec inside src archive)
801  - Fixed BuildRequires: gc-devel, libicu-devel
802  - add Japanese translation
803
804* Fri Mar 10 2006 Bill Nottingham <notting@redhat.com> - 1.1.13.4-2
805- rebuild for ppc TLS issue (#184446)
806
807* Fri Mar  3 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.4-1
808- Update to 1.1.13.4
809- Add patch so mono doesn't segfault on PPC SMP machines
810- Minor spec cleanup
811
812* Thu Mar  2 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-5
813- Updated patch from Jakub (1.1.13.2-3 to 1.1.13.2-5 are
814  for bug 182965)
815
816* Tue Feb 28 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-4
817- Updated patch from Paolo Molaro <lupus@ximian.com>
818
819* Mon Feb 27 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-3
820- Patch from Jakub to make work with SELinux better
821
822* Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-2
823- Rebuild
824
825* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.1.13.2-1.1
826- rebuilt for new gcc4.1 snapshot and glibc changes
827
828* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-1
829- Update to 1.1.13.2
830
831* Fri Jan 13 2006 Alexander Larsson <alexl@redhat.com> - 1.1.13-1
832- Update to 1.13
833- Add libgdiplus dep to mono-core
834- Add s390x to build
835
836* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.12.1-1
837- Update to 1.1.12.1
838
839* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.10-4
840- rebuild
841
842* Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-3
843- Disable s390 due to some build failure
844
845* Thu Nov 17 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-2
846- Build on s390 and x86-64 now
847
848* Tue Nov 15 2005 Alexander Larsson <alexl@redhat.com> - 1.1.10-1
849- Initial version
Note: See TracBrowser for help on using the repository browser.