source: projects/specs/trunk/m/mono/mono-vl.spec @ 3689

Revision 3689, 27.8 KB checked in by owa, 13 years ago (diff)

update:mono

Line 
1Summary: .NET runtime environment
2Summary(ja): .NET ランタイム環境
3Name: mono
4Version: 2.10.1
5Release: 3%{?_dist_release}
6Group: Development/Languages
7License: GPL, LGPL, MIT X11
8URL: http://www.mono-project.com/
9Source0: http://ftp.novell.com/pub/mono/sources/mono/%{name}-%{version}.tar.bz2
10Source1: monodir.c
11Patch1: mono-2.10.1-ppc-len.patch
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: bison
14BuildRequires: glib2-devel
15BuildRequires: pkgconfig
16BuildRequires: libicu-devel
17BuildRequires: libgdiplus-devel >= 2.0
18BuildRequires: zlib-devel
19# JIT only availible on these:
20ExclusiveArch: %{ix86} x86_64 ppc ia64 s390 s390x armv4l sparc
21Obsoletes: %{name}-jscript < 2.8
22Obsoletes: %{name}-data-sybase < 2.8
23Obsoletes: %{name}-data-firebird < 2.8
24Obsoletes: bytefx-data-mysql < 2.8
25
26%description
27The Mono runtime implements a JIT engine for the ECMA CLI
28virtual machine (as well as a byte code interpreter, the
29class loader, the garbage collector, threading system and
30metadata access libraries.
31
32%description -l ja
33Mono ランタイムは ECMA CLI 仮想機械用 JIT エンジンの実装です。バイト
34コードインタプリタ、クラスローダ、ガベージコレクタ、スレッドシステム
35およびメタデータアクセスライブラリの機能を持ちます。
36
37%package core
38Summary: The Mono CIL runtime, suitable for running .NET code
39Summary(ja): .NET の実行に適した Mono CIL ランタイム
40Group: Development/Languages
41Requires: libgdiplus
42
43%description core
44This package contains the core of the Mono runtime including its
45Virtual Machine, Just-in-time compiler, C# compiler, security
46tools and libraries (corlib, XML, System.Security, ZipLib,
47I18N, Cairo and Mono.*).
48
49%package devel
50Summary:        Development tools for Mono
51Summary(ja):    Mono 開発ツール
52Group:          Development/Languages
53Requires:       mono-core = %{version}-%{release}
54Requires:       glib2-devel
55
56%description devel
57This package completes the Mono developer toolchain with the mono profiler,
58assembler and other various tools.
59
60%package nunit
61Summary:        NUnit Testing Framework
62Summary(ja):    NUnit テストフレームワーク
63Group:          Development/Languages
64Requires:       mono-core = %{version}-%{release}
65Requires:       glib2-devel
66
67%description nunit
68NUnit is a unit-testing framework for all .NET languages. Initially
69ported from JUnit, the current release, version 2.2, is the fourth
70major release of this Unit based unit testing tool for Microsoft .NET.
71It is written entirely in C# and  has been completely redesigned to
72take advantage of many .NET language features, for example
73custom attributes and other reflection related capabilities. NUnit
74brings xUnit to all .NET languages.
75
76%package locale-extras
77Summary:        Extra locale information for Mono
78Summary(ja):    Mono 用追加ロケール情報
79Group:          Development/Languages
80Requires:       mono-core = %{version}-%{release}
81
82%description locale-extras
83This package contains assemblies to support I18N applications for
84non-latin alphabets.
85
86%package extras
87Summary:        Provides the infrastructure for running and building daemons and services with Mono as well as various stub assemblies
88Group:          Development/Languages
89Requires:       mono-core = %{version}-%{release}
90
91%description extras
92This package provides the libary and application to run services
93and daemons with Mono. It also includes stubs for the following
94.NET 1.1 and 2.0 assemblies: Microsoft.Vsa,
95System.Configuration.Install, System.Management, System.Messaging.
96
97%package winforms
98Summary:        Windows Forms implementation for Mono
99Group:          Development/Languages
100Requires:       mono-core = %{version}-%{release}
101
102%description winforms
103This package provides a fully managed implementation of
104System.Windows.Forms, the default graphical toolkit for .NET
105applications.
106
107%package web
108Summary:        ASP.NET, Remoting, and Web Services for Mono
109Group:          Development/Languages
110Requires:       mono-core = %{version}-%{release}
111
112%description web
113This package provides the ASP.NET libraries and runtime for
114development of web application, web services and remoting support.
115
116%package data
117Summary:        Database connectivity for Mono
118Group:          Development/Languages
119Requires:       mono-core = %{version}-%{release}
120
121%description data
122This package provides a Mono assembly to facilitate data access
123and manipulation with databases, LDAP compatible directory servers
124and/or XML data exchange. Beyond the ADO.NET, Novell.LDAP and
125System.DirectoryServices assemblies, it also includes a command
126line sql application as well as the Microsoft SQL Server and ODBC
127data providers.
128
129%package data-sqlite
130Summary:        sqlite database connectivity for Mono
131Group:          Development/Languages
132Requires:       mono-core = %{version}-%{release}
133Requires:       sqlite
134
135%description data-sqlite
136This package contains the ADO.NET Data provider for the sqlite
137database.
138
139%package data-oracle
140Summary:        Oracle database connectivity for Mono
141Group:          Development/Languages
142Requires:       mono-core = %{version}-%{release}
143
144%description data-oracle
145This package contains the ADO.NET Data provider for the Oracle
146database.
147
148%package data-postgresql
149Summary:        Postgresql database connectivity for Mono
150Group:          Development/Languages
151Requires:       mono-core = %{version}-%{release}
152
153%description data-postgresql
154This package contains the ADO.NET Data provider for the PostgreSQL
155database.
156
157%package -n ibm-data-db2
158Summary:        IBM DB2 database connectivity for Mono
159Group:          Development/Languages
160Requires:       mono-core = %{version}-%{release}
161
162%description -n ibm-data-db2
163This package contains the ADO.NET Data provider for the IBM DB2
164Universal database.
165
166%package -n monodoc
167Summary:        The Mono documentation system
168Group:          Development/Tools
169Requires:       mono-core = %{version}-%{release}
170Requires:       libgluezilla >= 2.4
171Obsoletes:      monodoc-core <= 2.0-1vl5
172
173%description -n monodoc
174monodoc is the documentation package for the mono .NET environment
175
176## macros
177%define mono_dir %{_prefix}/lib/mono
178%define mono_doc %{_prefix}/lib/monodoc
179%define bin_and_exe(bin, exe) %{_bindir}/%{1} \
180        %{mono_dir}/%{2}.exe \
181        %{mono_dir}/%{2}.exe.* \
182        %{nil}
183%define gac_and_1dll(dll)  %{mono_dir}/gac/%{1} \
184        %{mono_dir}/%{2}/%{1}.dll \
185        %{nil}
186%define gac_and_2dll(dll)  %{mono_dir}/gac/%{1} \
187        %{mono_dir}/%{2}/%{1}.dll \
188        %{mono_dir}/%{3}/%{1}.dll \
189        %{nil}
190%define gac_and_3dll(dll)  %{mono_dir}/gac/%{1} \
191        %{mono_dir}/%{2}/%{1}.dll \
192        %{mono_dir}/%{3}/%{1}.dll \
193        %{mono_dir}/%{4}/%{1}.dll \
194        %{nil}
195
196
197%prep
198%setup -q
199%patch1 -p1
200
201## These are only needed if there are patches to the runtime
202#rm -f libgc/libtool.m4
203#autoreconf --force --install
204#autoreconf --force --install libgc
205
206## Remove prebuilt binaries
207#rm -rf mcs/class/lib/monolite/*
208
209%build
210gcc -o monodir %{SOURCE1} -DMONODIR=\"%{mono_dir}\"
211
212export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
213%configure \
214        --with-jit=yes \
215        --with-ikvm-native=yes \
216        --with-sigaltstack=no \
217        --with-sgen=no \
218%ifarch ppc
219        --disable-system-aot \
220%endif
221        ;
222
223# don't use parallel builds
224# make %{?_smp_mflags}
225make
226
227
228%install
229[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
230make install DESTDIR=%{buildroot}
231
232install monodir %{buildroot}%{_bindir}
233
234## Remove unused files
235%{__rm} -f %{buildroot}%{_libdir}/*.la
236%{__rm} -f %{buildroot}%{_libdir}/*.a
237%{__rm} -f %{buildroot}%{_bindir}/mono-find-provides
238%{__rm} -f %{buildroot}%{_bindir}/mono-find-requires
239
240## This was removed upstream:
241%{__rm} -rf %{buildroot}%{_datadir}/mono-2.0/mono/cil
242%{__rm} -f %{buildroot}%{_bindir}/prj2make
243%{__rm} -f %{buildroot}%{_mandir}/man1/prj2make.*
244%{__rm} -f %{buildroot}%{_mandir}/man1/cilc.*
245## This was referring to fedora:
246%{__rm} -rf %{buildroot}%{mono_dir}/gac/Mono.Security.Win32
247%{__rm} -rf %{buildroot}%{mono_dir}/2.0/Mono.Security.Win32.dll
248%{__rm} -rf %{buildroot}%{mono_dir}/4.0/Mono.Security.Win32.dll
249%{__rm} -rf %{buildroot}%{mono_dir}/xbuild/Microsoft
250%{__rm} -f %{buildroot}%{mono_dir}/2.0/mcs.exe.so
251%{__rm} -f %{buildroot}%{mono_dir}/2.0/mscorlib.dll.so
252%{__rm} -f %{buildroot}%{_datadir}/libgc-mono/README*
253%{__rm} -f %{buildroot}%{_datadir}/libgc-mono/barrett_diagram
254%{__rm} -f %{buildroot}%{_datadir}/libgc-mono/*.html
255%{__rm} -f %{buildroot}%{_datadir}/libgc-mono/gc.man
256%{__rm} -rf %{buildroot}%{_bindir}/mono-configuration-crypto
257%{__rm} -rf %{buildroot}%{_mandir}/man?/mono-configuration-crypto*
258
259
260%find_lang mcs
261
262
263%clean
264[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
265
266%post core -p /sbin/ldconfig
267%postun core -p /sbin/ldconfig
268%post devel -p /sbin/ldconfig
269%postun devel -p /sbin/ldconfig
270
271
272%files core -f mcs.lang
273%defattr(-,root,root,-)
274%doc AUTHORS COPYING.LIB ChangeLog NEWS README
275%{_bindir}/mcs
276%{_bindir}/mono
277%{_bindir}/monodir
278%{_bindir}/mono-api-*
279##{_bindir}/mono-configuration-crypto
280%{_bindir}/mono-heapviz
281##ifnarch ppc
282##{_bindir}/mono-sgen
283##endif
284%{_bindir}/peverify
285%{_bindir}/mprof-report
286%{_bindir}/mono-test-install
287%{_libdir}/libMonoPosixHelper.so
288%{_libdir}/libmono-2.0.so.*
289##ifnarch ppc
290##{_libdir}/libmonosgen-2.0.so.*
291##endif
292%{_libdir}/libmono-profiler-aot.so.*
293%{_libdir}/libmono-profiler-cov.so.*
294%{_libdir}/libmono-profiler-iomap.so.*
295%{_libdir}/libmono-profiler-log.so*
296%dir %{mono_dir}
297%dir %{mono_dir}/4.0
298%dir %{mono_dir}/3.5
299%dir %{mono_dir}/2.0
300%dir %{mono_dir}/gac
301%dir %{mono_dir}/compat-2.0
302%bin_and_exe ccrewrite 4.0/ccrewrite
303%bin_and_exe csharp 4.0/csharp
304%bin_and_exe csharp2 2.0/csharp
305%bin_and_exe certmgr 4.0/certmgr
306%bin_and_exe chktrust 4.0/chktrust
307%bin_and_exe dmcs 4.0/dmcs
308%bin_and_exe lc 4.0/lc
309%bin_and_exe gacutil 4.0/gacutil
310%bin_and_exe gacutil2 2.0/gacutil
311%bin_and_exe gmcs 2.0/gmcs
312%bin_and_exe installvst 4.0/installvst
313%bin_and_exe mconfig 4.0/mconfig
314%ifarch ppc
315%{mono_dir}/2.0/mcs.exe
316%else
317%{mono_dir}/2.0/mcs.exe
318%endif
319%bin_and_exe mod 4.0/mod
320%bin_and_exe mono-cil-strip 4.0/mono-cil-strip
321%bin_and_exe monolinker 2.0/monolinker
322%bin_and_exe mozroots 4.0/mozroots
323%bin_and_exe setreg 4.0/setreg
324%bin_and_exe sn 4.0/sn
325%bin_and_exe sqlmetal 4.0/sqlmetal
326%bin_and_exe svcutil 4.0/svcutil
327%{mono_dir}/4.0/browsercaps-updater.exe*
328%{mono_dir}/4.0/monolinker.exe*
329%{mono_dir}/4.0/ictool.exe*
330%{mono_dir}/4.0/installutil.exe*
331%{mono_dir}/4.0/mono-api-info.exe
332%{mono_dir}/4.0/mscorlib.dll*
333%{mono_dir}/2.0/mscorlib.dll*
334%{mono_dir}/3.5/Microsoft.Build.*
335%{mono_dir}/4.0/Microsoft.CSharp.targets
336%{mono_dir}/3.5/Microsoft.CSharp.targets
337%{mono_dir}/2.0/Microsoft.CSharp.targets
338%{mono_dir}/4.0/Microsoft.Common.targets
339%{mono_dir}/3.5/Microsoft.Common.targets
340%{mono_dir}/2.0/Microsoft.Common.targets
341%{mono_dir}/4.0/Microsoft.VisualBasic.targets
342%{mono_dir}/3.5/Microsoft.VisualBasic.targets
343%{mono_dir}/2.0/Microsoft.VisualBasic.targets
344%{mono_dir}/compat-*/ICSharpCode.SharpZipLib.dll
345%{mono_dir}/gac/Mono.Cecil
346%{mono_dir}/gac/Mono.Cecil.Mdb
347%{mono_dir}/mono-configuration-crypto/4.0/Mono.Configuration.Crypto.dll*
348%{mono_dir}/mono-configuration-crypto/4.0/mono-configuration-crypto.exe*
349%gac_and_2dll cscompmgd 4.0 2.0
350%gac_and_2dll Commons.Xml.Relaxng 4.0 2.0
351%gac_and_2dll CustomMarshalers 4.0 2.0
352%gac_and_2dll I18N 4.0 2.0
353%gac_and_2dll I18N.West 4.0 2.0
354%gac_and_2dll ICSharpCode.SharpZipLib 4.0 2.0
355%gac_and_1dll Microsoft.CSharp 4.0
356%gac_and_2dll Mono.C5 4.0 2.0
357%gac_and_2dll Mono.Cairo 4.0 2.0
358%gac_and_2dll Mono.CompilerServices.SymbolWriter 4.0 2.0
359%gac_and_2dll Mono.Posix 4.0 2.0
360%gac_and_2dll Mono.Security 4.0 2.0
361##gac_and_1dll Mono.Security.Win32 4.0
362%gac_and_2dll Mono.CSharp 4.0 2.0
363%gac_and_1dll Mono.CodeContracts 4.0
364%gac_and_2dll Mono.Debugger.Soft 4.0 2.0
365%gac_and_2dll Mono.Management 4.0 2.0
366%gac_and_2dll Mono.Simd 4.0 2.0
367%gac_and_2dll Mono.Tasklets 4.0 2.0
368%gac_and_2dll System 4.0 2.0
369%gac_and_2dll System.Configuration 4.0 2.0
370%gac_and_1dll System.Dynamic 4.0
371%gac_and_2dll System.Drawing 4.0 2.0
372%gac_and_2dll System.Core 4.0 2.0
373%gac_and_1dll System.ComponentModel.Composition 4.0
374%gac_and_2dll System.ComponentModel.DataAnnotations 4.0 2.0
375%gac_and_2dll System.IdentityModel 4.0 2.0
376%gac_and_2dll System.IdentityModel.Selectors 4.0 2.0
377%gac_and_2dll System.Net 4.0 2.0
378%gac_and_1dll System.Numerics 4.0
379%gac_and_1dll System.Runtime.Caching 4.0
380%gac_and_1dll System.Runtime.DurableInstancing 4.0
381%gac_and_2dll System.Runtime.Serialization 4.0 2.0
382%gac_and_2dll System.Runtime.Serialization.Formatters.Soap 4.0 2.0
383%gac_and_2dll System.Security 4.0 2.0
384%gac_and_1dll System.Xaml 4.0
385%gac_and_2dll System.Xml 4.0 2.0
386%gac_and_2dll System.Xml.Linq 4.0 2.0
387%gac_and_2dll OpenSystem.C 4.0 2.0
388%gac_and_2dll WindowsBase 4.0 2.0
389%dir %{_sysconfdir}/mono
390%dir %{_sysconfdir}/mono/4.0
391%dir %{_sysconfdir}/mono/2.0
392%dir %{_sysconfdir}/mono/mconfig
393%config (noreplace) %{_sysconfdir}/mono/config
394%config (noreplace) %{_sysconfdir}/mono/2.0/machine.config
395%config (noreplace) %{_sysconfdir}/mono/4.0/machine.config
396%config (noreplace) %{_sysconfdir}/mono/mconfig/config.xml
397%config (noreplace) %{_sysconfdir}/mono/2.0/settings.map
398%config (noreplace) %{_sysconfdir}/mono/4.0/settings.map
399%{_prefix}/lib/mono-source-libs/
400%{_mandir}/man1/ccrewrite.1.gz
401%{_mandir}/man1/certmgr.1.gz
402%{_mandir}/man1/chktrust.1.gz
403%{_mandir}/man1/csharp.1.gz
404%{_mandir}/man1/gacutil.1.gz
405%{_mandir}/man1/lc.1.gz
406%{_mandir}/man1/mconfig.1.gz
407%{_mandir}/man1/mcs.1.gz
408%{_mandir}/man1/mono.1.gz
409%{_mandir}/man1/monolinker.1.gz
410%{_mandir}/man1/mozroots.1.gz
411%{_mandir}/man1/mprof-report.1.gz
412%{_mandir}/man1/setreg.1.gz
413%{_mandir}/man1/sn.1.gz
414%{_mandir}/man1/resgen.1.gz
415%{_mandir}/man1/mono-api-info.1.gz
416%{_mandir}/man1/mono-cil-strip.1.gz
417##{_mandir}/man1/mono-configuration-crypto.1.gz
418%{_mandir}/man5/mono-config.5.gz
419
420%files devel
421%defattr(-,root,root,-)
422%{_bindir}/genxs
423%{_bindir}/mkbundle
424%{_bindir}/mono-gdb.py
425%{_bindir}/monodis
426%{_bindir}/monograph
427%{_bindir}/pedump
428%{_bindir}/xbuild
429%{_libdir}/libmono-2.0.so
430%{_libdir}/libmono-profiler-aot.so
431%{_libdir}/libmono-profiler-cov.so
432%{_libdir}/libmono-profiler-iomap.so
433##ifnarch ppc
434##{_libdir}/libmonosgen-2.0.so
435##endif
436%{_libdir}/libMonoSupportW.so
437%{_libdir}/libikvm-native.so
438%{mono_dir}/4.0/mkbundle.exe*
439%{mono_dir}/2.0/mkbundle.exe*
440%{mono_dir}/4.0/genxs.exe*
441%{mono_dir}/2.0/genxs.exe*
442%{mono_dir}/2.0/ilasm.exe*
443%bin_and_exe al 4.0/al
444%bin_and_exe al2 2.0/al
445%bin_and_exe caspol 4.0/caspol
446%bin_and_exe cert2spc 4.0/cert2spc
447%bin_and_exe dtd2xsd 4.0/dtd2xsd
448%bin_and_exe dtd2rng 4.0/dtd2rng
449%bin_and_exe sgen 4.0/sgen
450%bin_and_exe ilasm 4.0/ilasm
451%bin_and_exe macpack 4.0/macpack
452%bin_and_exe makecert 4.0/makecert
453%bin_and_exe monop 4.0/monop
454%bin_and_exe monop2 2.0/monop
455%bin_and_exe mono-shlib-cop 4.0/mono-shlib-cop
456%bin_and_exe mono-xmltool 4.0/mono-xmltool
457%bin_and_exe pdb2mdb 4.0/pdb2mdb
458%bin_and_exe permview 4.0/permview
459%bin_and_exe resgen 4.0/resgen
460%bin_and_exe resgen2 2.0/resgen
461%bin_and_exe secutil 4.0/secutil
462%bin_and_exe signcode 4.0/signcode
463%{mono_dir}/xbuild
464%{mono_dir}/4.0/xbuild.*
465%{mono_dir}/3.5/xbuild.*
466%{mono_dir}/2.0/xbuild.*
467%{mono_dir}/4.0/culevel.exe*
468%{mono_dir}/2.0/culevel.exe*
469%{mono_dir}/4.0/MSBuild/*.xsd
470%{mono_dir}/3.5/MSBuild/*.xsd
471%{mono_dir}/2.0/MSBuild/*.xsd
472%{mono_dir}/4.0/Microsoft.Build.xsd
473%{mono_dir}/3.5/Microsoft.Build.xsd
474%{mono_dir}/2.0/Microsoft.Build.xsd
475%{mono_dir}/4.0/Microsoft.*.targets
476%{mono_dir}/3.5/Microsoft.*.targets
477%{mono_dir}/2.0/Microsoft.*.targets
478%{mono_dir}/4.0/Microsoft.Common.tasks
479%{mono_dir}/3.5/Microsoft.Common.tasks
480%{mono_dir}/2.0/Microsoft.Common.tasks
481%gac_and_2dll PEAPI 4.0 2.0
482%gac_and_3dll Microsoft.Build.Engine 4.0 3.5 2.0
483%gac_and_3dll Microsoft.Build.Framework 4.0 3.5 2.0
484%gac_and_1dll Microsoft.Build.Tasks 2.0
485%gac_and_1dll Microsoft.Build.Tasks.v4.0 4.0
486%gac_and_1dll Microsoft.Build.Tasks.v3.5 3.5
487%gac_and_1dll Microsoft.Build.Utilities 2.0
488%gac_and_1dll Microsoft.Build.Utilities.v4.0 4.0
489%gac_and_1dll Microsoft.Build.Utilities.v3.5 3.5
490%gac_and_2dll Microsoft.VisualC 4.0 2.0
491%{_libdir}/pkgconfig/cecil.pc
492%{_libdir}/pkgconfig/dotnet.pc
493%{_libdir}/pkgconfig/dotnet35.pc
494%{_libdir}/pkgconfig/mono-cairo.pc
495%{_libdir}/pkgconfig/mono.pc
496%{_libdir}/pkgconfig/mono-2.pc
497%{_libdir}/pkgconfig/mono-lineeditor.pc
498%{_libdir}/pkgconfig/mono-options.pc
499##ifnarch ppc
500##{_libdir}/pkgconfig/monosgen-2.pc
501##endif
502%{_libdir}/pkgconfig/wcf.pc
503%{_includedir}/mono-2.0
504%{_mandir}/man1/al.1.gz
505%{_mandir}/man1/cert2spc.1.gz
506%{_mandir}/man1/dtd2xsd.1.gz
507%{_mandir}/man1/genxs.1.gz
508%{_mandir}/man1/ilasm.1.gz
509%{_mandir}/man1/macpack.1.gz
510%{_mandir}/man1/makecert.1.gz
511%{_mandir}/man1/mkbundle.1.gz
512%{_mandir}/man1/mono-shlib-cop.1.gz
513%{_mandir}/man1/mono-xmltool.1.gz
514%{_mandir}/man1/monodis.1.gz
515%{_mandir}/man1/monop.1.gz
516%{_mandir}/man1/pdb2mdb.1.gz
517%{_mandir}/man1/permview.1.gz
518%{_mandir}/man1/secutil.1.gz
519%{_mandir}/man1/sgen.1.gz
520%{_mandir}/man1/signcode.1.gz
521%{_mandir}/man1/xbuild.1.gz
522
523%files nunit
524%defattr(-,root,root,-)
525%bin_and_exe nunit-console 4.0/nunit-console
526%bin_and_exe nunit-console2 2.0/nunit-console
527%gac_and_2dll nunit.core 4.0 2.0
528%gac_and_2dll nunit.framework 4.0 2.0
529%gac_and_2dll nunit.util 4.0 2.0
530%gac_and_2dll nunit.mocks 4.0 2.0
531%gac_and_2dll nunit-console-runner 4.0 2.0
532%gac_and_2dll nunit.core.extensions 4.0 2.0
533%gac_and_2dll nunit.core.interfaces 4.0 2.0
534%gac_and_2dll nunit.framework.extensions 4.0 2.0
535%{_libdir}/pkgconfig/mono-nunit.pc
536
537%files locale-extras
538%defattr(-,root,root,-)
539%gac_and_2dll I18N.MidEast 4.0 2.0
540%gac_and_2dll I18N.Rare 4.0 2.0
541%gac_and_2dll I18N.CJK 4.0 2.0
542%gac_and_2dll I18N.Other 4.0 2.0
543
544%files extras
545%defattr(-,root,root,-)
546%{_mandir}/man1/mono-service.1.gz
547%bin_and_exe mono-service 4.0/mono-service
548%bin_and_exe mono-service2 2.0/mono-service
549%{mono_dir}/gac/mono-service
550%gac_and_2dll System.Configuration.Install 4.0 2.0
551%gac_and_2dll System.Management 4.0 2.0
552%gac_and_2dll System.Messaging 4.0 2.0
553%gac_and_2dll System.ServiceProcess 4.0 2.0
554%gac_and_2dll System.ServiceModel 4.0 2.0
555%gac_and_1dll System.ServiceModel.Discovery 4.0
556%gac_and_1dll System.ServiceModel.Routing 4.0
557%gac_and_2dll Mono.Messaging.RabbitMQ 4.0 2.0
558%gac_and_2dll Mono.Messaging 4.0 2.0
559%gac_and_2dll RabbitMQ.Client 4.0 2.0
560%{mono_dir}/4.0/RabbitMQ.Client.Apigen.exe*
561%{mono_dir}/2.0/RabbitMQ.Client.Apigen.exe*
562
563%files winforms
564%defattr(-,root,root,-)
565%gac_and_2dll Accessibility 4.0 2.0
566%gac_and_2dll System.Design 4.0 2.0
567%gac_and_2dll System.Drawing.Design 4.0 2.0
568%gac_and_2dll System.Windows.Forms 4.0 2.0
569%gac_and_1dll System.Windows.Forms.DataVisualization 4.0
570
571%files web
572%defattr(-,root,root,-)
573%{mono_dir}/2.0/xsd.exe*
574%{mono_dir}/compat-2.0/System.Web.Extensions*dll
575%{mono_dir}/compat-2.0/System.Web.Mvc.dll
576%bin_and_exe disco 4.0/disco
577%bin_and_exe soapsuds 4.0/soapsuds
578%bin_and_exe xsd 4.0/xsd
579%bin_and_exe wsdl 4.0/wsdl
580%bin_and_exe wsdl2 2.0/wsdl
581%bin_and_exe httpcfg 4.0/httpcfg
582%gac_and_2dll Mono.Http 4.0 2.0
583%gac_and_2dll Mono.Web 4.0 2.0
584%gac_and_2dll Mono.WebBrowser 4.0 2.0
585%gac_and_2dll System.Runtime.Remoting 4.0 2.0
586%gac_and_2dll System.Runtime.Serialization.Formatters.Soap 4.0 2.0
587%gac_and_2dll System.ServiceModel.Web 4.0 2.0
588%gac_and_2dll System.Web 4.0 2.0
589%gac_and_1dll System.Web.ApplicationServices 4.0
590%gac_and_2dll System.Web.Abstractions 4.0 2.0
591%gac_and_2dll System.Web.DynamicData 4.0 2.0
592%gac_and_1dll System.Web.Mvc 2.0
593%gac_and_2dll System.Web.Routing 4.0 2.0
594%gac_and_2dll System.Web.Services 4.0 2.0
595%gac_and_2dll System.Web.Extensions.Design 4.0 2.0
596%gac_and_2dll System.Web.Extensions 4.0 2.0
597%gac_and_1dll Microsoft.Web.Infrastructure 4.0
598%gac_and_1dll WebMatrix.Data 4.0
599%{_mandir}/man1/disco.1.gz
600%{_mandir}/man1/soapsuds.1.gz
601%{_mandir}/man1/wsdl.1.gz
602%{_mandir}/man1/xsd.1.gz
603%config (noreplace) %{_sysconfdir}/mono/browscap.ini
604%config (noreplace) %{_sysconfdir}/mono/2.0/Browsers/Compat.browser
605%config (noreplace) %{_sysconfdir}/mono/4.0/DefaultWsdlHelpGenerator.aspx
606%config (noreplace) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
607%config (noreplace) %{_sysconfdir}/mono/4.0/web.config
608%config (noreplace) %{_sysconfdir}/mono/2.0/web.config
609%{_mandir}/man1/httpcfg.1.gz
610%{_libdir}/pkgconfig/mono.web.pc
611%{_libdir}/pkgconfig/system.web.extensions_1.0.pc
612%{_libdir}/pkgconfig/system.web.extensions.design_1.0.pc
613%{_libdir}/pkgconfig/system.web.mvc.pc
614%{_libdir}/pkgconfig/system.web.mvc2.pc
615
616%files data
617%defattr(-,root,root,-)
618%bin_and_exe sqlsharp 4.0/sqlsharp
619%gac_and_2dll Mono.Data.Tds 4.0 2.0
620%gac_and_2dll Novell.Directory.Ldap 4.0 2.0
621%gac_and_2dll System.Data 4.0 2.0
622%gac_and_2dll System.Data.DataSetExtensions 4.0 2.0
623%gac_and_2dll System.Data.Linq 4.0 2.0
624%gac_and_2dll System.Data.Services 4.0 2.0
625%gac_and_2dll System.Data.Services.Client 4.0 2.0
626%gac_and_2dll System.DirectoryServices 4.0 2.0
627%gac_and_2dll System.EnterpriseServices 4.0 2.0
628%gac_and_2dll System.Transactions 4.0 2.0
629##{mono_dir}/gac/System.Data.Services.Client
630%{_mandir}/man1/sqlsharp.1.gz
631
632%files data-sqlite
633%defattr(-,root,root,-)
634%gac_and_2dll Mono.Data.Sqlite 4.0 2.0
635
636%files data-oracle
637%defattr(-,root,root,-)
638%gac_and_2dll System.Data.OracleClient 4.0 2.0
639
640%files data-postgresql
641%defattr(-,root,root,-)
642%gac_and_2dll Npgsql 4.0 2.0
643
644%files -n ibm-data-db2
645%defattr(-,root,root,-)
646%gac_and_2dll IBM.Data.DB2 4.0 2.0
647
648%files -n monodoc
649%defattr(-, root, root)
650%bin_and_exe mdoc 2.0/mdoc
651%{_bindir}/mdoc-*
652%{_bindir}/mdass*
653%{_bindir}/mdval*
654%{_bindir}/mod
655%{_bindir}/monodoc*
656%{mono_dir}/gac/monodoc
657%{mono_dir}/monodoc/monodoc.dll
658%{mono_doc}/*
659%{_mandir}/man1/md*
660%{_mandir}/man1/monodoc*
661%{_mandir}/man5/mdoc*
662%{_libdir}/pkgconfig/monodoc.pc
663
664
665%changelog
666* Sun Apr 24 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.1-3
667- added '--with-sgen=no' to all arch
668- dropt %%{mono_dir}/2.0/{mcs.exe,mscorlib.dll}.so
669
670* Sat Apr 16 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.10.1-2
671- remove the old ppc patch (similar codes already in the upstream)
672- add Patch1 (from Gentoo)
673- mono/2.0/mcs.exe.so not available on ppc - remove from the filelist
674  (TODO: see the Fedora's srpm - removing mono/2.0/{mcs,gmcs}.exe.so etc.)
675
676* Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.1-1
677- updated mono to 2.10.1
678
679* Sat Jan 08 2011 Shu KONNO <owa@bg.wakwak.com> 2.8.2-1
680- updated mono to 2.8.2
681
682* Tue Dec 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-2
683- add Patch0 (mono-2.8.1-ppc.patch)
684- add configure option "--with-sgen=no" and "--disable-system-aot" (ppc only)
685- fix %%files (add %%ifnarch ppc)
686
687* Sun Nov 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-1
688- updated mono to 2.8.1
689
690* Sat Nov 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-2
691- comment out script that removes prebuilt binaries, because gmcs.exe require
692
693* Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
694- updated mono to 2.8
695- modified macros used in %%files
696- removed below:
697  - packages:
698    %{name}-jscript, %{name}-data-sybase, %{name}-data-firebird, bytefx-data-mysql
699  - libraries:
700    ByteFX.Data, FirebirdSql.Data.Firebird
701    Mono.Data Mono.Data.TdsClient, Mono.Data.SybaseClient, Mono.Data.SqliteClient
702    Microsoft.JScript, Microsoft.Vsa
703  - commands:
704    cilc, mjs, prj2make (replaced by xbuild)
705
706* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.6.7-2
707- build with rpm-4.8.1-1 for pkg-config file
708
709* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.7-1
710- updated mono to 2.6.7
711
712* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
713- updated mono to 2.6.4
714
715* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
716- updated mono to 2.6.3
717  added RabbitMQ.Client.Apigen.exe
718
719* Thu Dec 31 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-2
720- unuse _smp_mflags
721
722* Sat Dec 26 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-1
723- updated mono to 2.6.1
724- simplified macros
725
726* Mon Dec 14 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-1
727- updated mono to 2.4.3
728  added %%{mono_dir}/2.0/lc.exe*
729  added %%gac_dll System.Web.Mvc
730  added %%{mono_dir}/xbuild/*
731  added %%{_mandir}/man1/lc.1.gz
732  added %%{_mandir}/man1/xbuild.1.gz
733
734* Wed Jul 29 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.3-1
735- updated mono to 2.4.2.3
736
737* Fri Jul 24 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.2-1
738- updated mono to 2.4.2.2
739
740* Tue Jul 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.2.1-1
741- new upstream release
742- build with latest rpm to update mono-dependencies
743
744* Thu Jul 02 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
745- updated mono to 2.4.2
746
747* Mon Apr 27 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4-3
748- fix temporary workaround against build failure on ppc,
749  from RH bugzilla #494026
750  - statically link mono to libmono: remove "--disable-static" from configure
751  - ensure removing *.a files in the install section
752- remove prebuilt binaries under mcs/class/lib/monolite/ before building
753
754* Sun Apr  5 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
755- fixed paths using %%mono_dir, %%mono_doc macros
756- added Requires:libgluezilla >= 2.4 in monodoc
757
758* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
759- new upstream release
760- added monodoc package (Obsoletes: monodoc-core <= 2.0-1vl5)
761
762* Mon Nov 03 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1
763- new upstream release
764- dropt %%{_bindir}/mono-find-{provides,requires}
765- added --with-libgdiplus=installed
766
767* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-3
768- update to mono-2.0 released source
769- BR: libgdiplus-devel >= 2.0
770
771* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-2vl5
772- removed *.la
773
774* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1vl5
775- updated mono to 2.0
776- updated url
777- changed macro %%monodir to %%mono_dir
778- dropt mono-1.1.13.4-selinux-ia64.patch
779- dropt mono-1.1.13.4-ppc-threading.patch
780- dropt mono-1.2.3-use-monodir.patch
781
782* Tue Aug 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-1vl5
783- applied new versioning policy, spec in utf-8
784- dropt mono-1.2.5-libdir.patch
785- reverted monodir macro to using %%{_prefix}/lib/mono
786
787* Sat Dec 29 2007 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-0vl2
788- updated monodir to %%{_libdir}/mono
789
790* Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5.1-0vl1
791- new upstream release
792- splited mono-basic package
793
794* Sat Oct 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.8.1-0vl1
795- new upstream release
796
797* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.6-0vl1
798- new upstream release
799
800* Thu Apr 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.13.4-2vl2
801- disabled Patch2 on Vine/ppc environment
802
803* Wed Mar 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.4-2vl1
804- updated source and sub-packages based on Fedora packages
805  * Tue Feb 22 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.6-0vl1
806  - new upstream version(mono-1.0.6)
807  * Sun Jan 16 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.5-0vl1
808  - new upstream version(mono-1.0.5)
809  * Sat Nov 06 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.4-0vl1
810  - new upstream version(mono-1.0.4)
811        -- changed to use configure
812  * Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
813  - rebuild for Vine Linux (based on mono.spec inside src archive)
814  - Fixed BuildRequires: gc-devel, libicu-devel
815  - add Japanese translation
816
817* Fri Mar 10 2006 Bill Nottingham <notting@redhat.com> - 1.1.13.4-2
818- rebuild for ppc TLS issue (#184446)
819
820* Fri Mar  3 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.4-1
821- Update to 1.1.13.4
822- Add patch so mono doesn't segfault on PPC SMP machines
823- Minor spec cleanup
824
825* Thu Mar  2 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-5
826- Updated patch from Jakub (1.1.13.2-3 to 1.1.13.2-5 are
827  for bug 182965)
828
829* Tue Feb 28 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-4
830- Updated patch from Paolo Molaro <lupus@ximian.com>
831
832* Mon Feb 27 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-3
833- Patch from Jakub to make work with SELinux better
834
835* Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-2
836- Rebuild
837
838* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.1.13.2-1.1
839- rebuilt for new gcc4.1 snapshot and glibc changes
840
841* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-1
842- Update to 1.1.13.2
843
844* Fri Jan 13 2006 Alexander Larsson <alexl@redhat.com> - 1.1.13-1
845- Update to 1.13
846- Add libgdiplus dep to mono-core
847- Add s390x to build
848
849* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.12.1-1
850- Update to 1.1.12.1
851
852* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.10-4
853- rebuild
854
855* Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-3
856- Disable s390 due to some build failure
857
858* Thu Nov 17 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-2
859- Build on s390 and x86-64 now
860
861* Tue Nov 15 2005 Alexander Larsson <alexl@redhat.com> - 1.1.10-1
862- Initial version
Note: See TracBrowser for help on using the repository browser.