source: projects/specs/trunk/m/mono/mono-vl.spec @ 9472

Revision 9472, 31.5 KB checked in by inagaki, 9 years ago (diff)

2015-03-28 Ryoichi INAGAKI <ryo1@…>

  • dbus-sharp, dbus-sharp-glib, gecko-sharp2, gio-sharp, gnome-desktop-sharp2, kimono, libgpod, mono-debugger, mono-zeroconf, webkit-sharp: rebuilt
  • gnome-sharp2, libgdiplus, mono, mono-addins, mono-basic, nant: updated


Line 
1%define bootstrap 1
2
3Name:           mono
4Version:        3.12.1
5Release:        1%{?_dist_release}
6Summary:        A .NET runtime environment
7Summary(ja):    .NET ランタイム環境
8
9Group:          Development/Languages
10License:        LGPLv2.1 and MIT and MS-PL
11URL:            http://www.mono-project.com/
12
13Source0:        http://download.mono-project.com/sources/mono/mono-%{version}.tar.bz2
14#Source1: monodir.c
15
16Patch0:         0001-Workaround-for-X509Certificate.RSA-throwing-an-unhan.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  bison
20BuildRequires:  gettext-devel
21BuildRequires:  glib2-devel
22BuildRequires:  pkgconfig
23BuildRequires:  libicu-devel
24BuildRequires:  libgdiplus-devel >= 2.10
25BuildRequires:  libX11-devel
26BuildRequires:  valgrind-devel
27BuildRequires:  zlib-devel
28
29# Yes, mono actually depends on itself, because
30# we deleted the bootstrapping binaries. If you
31# need to bootstrap mono, comment out this BuildRequires
32# and don't delete the binaries in %%prep.
33%if !%{bootstrap}
34BuildRequires:  mono-core
35%endif
36                         
37# JIT only availible on these:
38ExclusiveArch: %{ix86} x86_64 %{arm} sparcv9 alpha s390x ppc ppc64
39
40Distribution:   Vine Linux
41Vendor:         Project Vine
42Packager:       owa
43
44%description
45The Mono runtime implements a JIT engine for the ECMA CLI
46virtual machine (as well as a byte code interpreter, the
47class loader, the garbage collector, threading system and
48metadata access libraries.
49
50%description -l ja
51Mono ランタイムは ECMA CLI 仮想機械用 JIT エンジンの実装です。バイト
52コードインタプリタ、クラスローダ、ガベージコレクタ、スレッドシステム
53およびメタデータアクセスライブラリの機能を持ちます。
54
55%package core
56Summary:        The Mono CIL runtime, suitable for running .NET code
57Summary(ja):    .NET コードの実行に適した Mono CIL ランタイム
58License:        LGPLv2.1 and MIT and MS-PL
59Group:          Development/Languages
60Requires:       libgdiplus
61
62%description core
63This package contains the core of the Mono runtime including its
64Virtual Machine, Just-in-time compiler, C# compiler, security
65tools and libraries (corlib, XML, System.Security, ZipLib,
66I18N, Cairo and Mono.*).
67
68%description -l ja core
69このパッケージには、仮想マシン、Just-In-Time コンパイラ、C# コンパイラ、セキュリティツール及びライブラリ (corlib, XML, System.Security, ZipLib, I18N, Cairo and Mono.*) を含む Mono ランタイムが含まれています。
70
71%package devel
72Summary:        Development tools for Mono
73Summary(ja):    Mono 開発ツール
74License:        LGPLv2
75Group:          Development/Tools
76Requires:       mono-core = %{version}-%{release}
77# Required because they are referenced by .pc files
78Requires:       mono-data = %{version}
79Requires:       mono-extras = %{version}
80Requires:       mono-web = %{version}
81Requires:       mono-winforms = %{version}
82Requires:       libgdiplus-devel
83Requires:       pkgconfig
84
85%description devel
86This package completes the Mono developer toolchain with the mono profiler,
87assembler and other various tools.
88
89%package nunit
90Summary:        NUnit Testing Framework
91Summary(ja):    NUnit テストフレームワーク
92License:        LGPLv2
93Group:          Development/Languages
94Requires:       mono-core = %{version}-%{release}
95Provides:       mono-nunit-devel = %{version}-%{release}
96
97%description nunit
98NUnit is a unit-testing framework for all .NET languages. Initially
99ported from JUnit, the current release, version 2.2, is the fourth
100major release of this Unit based unit testing tool for Microsoft .NET.
101It is written entirely in C# and  has been completely redesigned to
102take advantage of many .NET language features, for example
103custom attributes and other reflection related capabilities. NUnit
104brings xUnit to all .NET languages.
105
106%package locale-extras
107Summary:        Extra locale information for Mono
108Summary(ja):    Mono 用追加ロケール情報
109License:        LGPLv2
110Group:          Development/Languages
111Requires:       mono-core = %{version}-%{release}
112
113%description locale-extras
114This package contains assemblies to support I18N applications for non-latin alphabets.
115
116%package extras
117Summary:        Provides the infrastructure for running and building daemons and services with Mono as well as various stub assemblies
118License:        LGPLv2
119Group:          Development/Languages
120Requires:       mono-core = %{version}-%{release}
121
122%description extras
123This package provides the libary and application to run services
124and daemons with Mono. It also includes stubs for the following
125.NET 1.1 and 2.0 assemblies: Microsoft.Vsa,
126System.Configuration.Install, System.Management, System.Messaging.
127
128%package winforms
129Summary:        Windows Forms implementation for Mono
130Summary(ja):    Windows フォームの Mono による実装
131License:        LGPLv2
132Group:          Development/Languages
133Requires:       mono-core = %{version}-%{release}
134
135%description winforms
136This package provides a fully managed implementation of
137System.Windows.Forms, the default graphical toolkit for .NET
138applications.
139
140%package wcf
141Summary:        Mono implementation of Windows Communication Foundation
142Summary(ja):    Windows Communication Foundation の Mono による実装
143License:        MIT and MS-PL
144Group:          Development/Languages
145Requires:       mono-core = %{version}-%{release}
146Provides:       mono-wcf-devel = %{version}-%{release}
147
148%description wcf
149This package provides an implementation of WCF, the Windows Communication
150Foundation.
151
152%package winfx
153Summary:        Mono implementation of core WinFX APIs
154Summary(ja):    コア WinFX API の Mono による実装
155License:        MIT and MS-PL
156Group:          Development/Languages
157Requires:       mono-core = %{version}-%{release}
158
159%description winfx
160Open source implementation of core WinFX APIs
161
162%package web
163Summary:        ASP.NET, Remoting, and Web Services for Mono
164Summary(ja):    Mono 用の ASP.NET, リモート,Web サービス
165License:        MIT and MS-PL
166Group:          Development/Languages
167Requires:       mono-core = %{version}-%{release}
168
169%description web
170This package provides the ASP.NET libraries and runtime for
171development of web application, web services and remoting support.
172
173%package mvc
174Summary:        Mono implementation of ASP.NET MVC
175Summary(ja):    ASP.NET MVC の Mono による実装
176License:        MIT and MS-PL
177Group:          Development/Languages
178Requires:       mono-core = %{version}-%{release}
179Provides:       mono-mvc-devel = %{version}-%{release}
180
181%description mvc
182This is the Mono implementation of ASP.NET MVC
183
184%package entityframework
185Summary:        Entity Framework (EF) is an object-relational mapper
186License:        Apache
187Group:          Development/Languages
188Requires:       mono-core = %{version}-%{release}
189
190%description entityframework
191Entity Framework (EF) is an object-relational mapper that enables .NET
192developers to work with relational data using domain-specific objects.
193It eliminates the need for most of the data-access code that developers
194usually need to write
195
196%package reactive
197Summary:        Reactive Extensions
198License:        Apache
199Group:          Development/Languages
200Requires:       mono-core = %{version}-%{release}
201Provides:       mono-reactive-devel = %{version}-%{release}
202
203%description reactive
204This is the Mono implementation of Microsoft's Reactive Extensions.
205
206#'
207
208%package data
209Summary:        Database connectivity for Mono
210License:        LGPLv2
211Group:          Development/Languages
212Requires:       mono-core = %{version}-%{release}
213
214%description data
215This package provides a Mono assembly to facilitate data access
216and manipulation with databases, LDAP compatible directory servers
217and/or XML data exchange. Beyond the ADO.NET, Novell.LDAP and
218System.DirectoryServices assemblies, it also includes a command
219line sql application as well as the Microsoft SQL Server and ODBC
220data providers.
221
222%package data-sqlite
223Summary:        sqlite database connectivity for Mono
224License:        LGPLv2
225Group:          Development/Languages
226Requires:       mono-core = %{version}-%{release}
227Requires:       mono-data = %{version}-%{release}
228
229%description data-sqlite
230This package contains the ADO.NET Data provider for the sqlite
231database.
232
233%package data-oracle
234Summary:        Oracle database connectivity for Mono
235License:        LGPLv2
236Group:          Development/Languages
237Requires:       mono-core = %{version}-%{release}
238Requires:       mono-data = %{version}-%{release}
239
240%description data-oracle
241This package contains the ADO.NET Data provider for the Oracle
242database.
243
244%package data-postgresql
245Summary:        Postgresql database connectivity for Mono
246License:        LGPLv2
247Group:          Development/Languages
248Requires:       mono-core = %{version}-%{release}
249Requires:       mono-data = %{version}-%{release}
250
251%description data-postgresql
252This package contains the ADO.NET Data provider for the PostgreSQL
253database.
254
255%package -n ibm-data-db2
256Summary:        IBM DB2 database connectivity for Mono
257License:        LGPLv2
258Group:          Development/Languages
259Requires:       mono-core = %{version}-%{release}
260Requires:       mono-data = %{version}-%{release}
261
262%description -n ibm-data-db2
263This package contains the ADO.NET Data provider for the IBM DB2
264Universal database.
265
266%package -n monodoc
267Summary:        The Mono documentation system
268Summary(ja):    Mono ドキュメントシステム
269License:        LGPLv2
270Group:          Development/Tools
271Requires:       mono-core = %{version}-%{release}
272# Added to uncompress and compare documentation used by build-compare
273Requires:       unzip
274Provides:       monodoc-devel = %{version}-%{release}
275Obsoletes:      monodoc-core <= 2.0-1vl5
276
277%description -n monodoc
278monodoc is the documentation package for the mono .NET environment
279
280
281## macros
282%define mono_dir %{_prefix}/lib/mono
283%define mono_doc %{_prefix}/lib/monodoc
284%define gac_dll(dll) %{mono_dir}/gac/%{1} \
285        %{mono_dir}/?.?/%{1}.dll \
286        %{nil}
287%define mono_bin(bin) %{_bindir}/%{1} \
288        %{mono_dir}/?.?/%{1}.exe \
289        %{mono_dir}/?.?/%{1}.exe.* \
290        %{nil}
291
292%prep
293%setup -q -n mono-%{version}
294%patch0 -p1
295
296%build
297export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
298
299%configure \
300    --with-ikvm-native=yes \
301    --with-jit=yes \
302    --with-xen_opt=yes \
303    --with-sgen=no \
304%ifnarch %ix86 x86_64
305    --disable-system-aot \
306%endif
307%ifarch ppc
308    --with-mcs-docs=no \
309    --with-sigaltstack=no \
310%endif
311    --with-moonlight=no \
312    --with-monotouch=no \
313    --with-libgdiplus=installed
314                   
315make %{?_smp_mflags}
316
317
318%install
319[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
320make install DESTDIR=%{buildroot}
321
322## Remove unused files
323rm -f %{buildroot}%{_libdir}/*.la
324rm -f %{buildroot}%{_libdir}/*.a
325
326# We put these inside rpm
327rm -f %{buildroot}%{_bindir}/mono-find-provides
328rm -f %{buildroot}%{_bindir}/mono-find-requires
329
330# This was removed upstream:
331rm -rf %{buildroot}%{mono_dir}/*/Mono.Security.Win32*
332rm -f %{buildroot}%{_libdir}/libMonoSupportW.*
333rm %{buildroot}%{_datadir}/libgc-mono/README*
334rm %{buildroot}%{_datadir}/libgc-mono/barrett_diagram
335rm %{buildroot}%{_datadir}/libgc-mono/*.html
336rm %{buildroot}%{_datadir}/libgc-mono/gc.man
337rm -f %{buildroot}%{mono_dir}/2.0/mscorlib.dll.so
338rm -f %{buildroot}%{mono_dir}/2.0/mcs.exe.so
339rm -f %{buildroot}%{mono_dir}/2.0/gmcs.exe.so
340rm -rf %{buildroot}%{mono_dir}/xbuild/Microsoft
341rm -f %{buildroot}%{mono_dir}/4.0/mscorlib.dll.so
342rm -f %{buildroot}%{mono_dir}/4.5/mscorlib.dll.so
343#rm -rf %{buildroot}%{_bindir}/mono-configuration-crypto
344#rm -rf %{buildroot}%{_mandir}/man?/mono-configuration-crypto*
345
346# remove stuff that we don't package
347rm -f %{buildroot}%{_bindir}/cilc
348rm -f %{buildroot}%{_mandir}/man1/cilc.1*
349rm -f %{buildroot}%{_prefix}/lib/mono/*/browsercaps-updater.exe*
350rm -f %{buildroot}%{_prefix}/lib/mono/*/culevel.exe*
351rm -f %{buildroot}%{_prefix}/lib/mono/2.0/cilc.exe*
352
353# Fix non-executable-in-bin
354chmod +x %{buildroot}%{_bindir}/mono-gdb.py
355rm -f %{buildroot}%{_bindir}/mono-sgen-gdb.py
356
357#ERROR: link target doesn't exist (neither in build root nor in installed system):
358rm -rf %{buildroot}%{_prefix}/lib/mono/xbuild/12.0/bin/Microsoft.Build.dll
359rm -rf %{buildroot}%{_prefix}/lib/mono/xbuild/12.0/bin/Microsoft.Build.Engine.dll
360rm -rf %{buildroot}%{_prefix}/lib/mono/xbuild/12.0/bin/Mono.XBuild.Tasks.dll
361rm -rf %{buildroot}%{_prefix}/lib/mono/xbuild/12.0/bin/Microsoft.Build.Framework.dll
362rm -rf %{buildroot}%{_prefix}/lib/mono/xbuild/12.0/bin/Microsoft.Build.Tasks.v12.0.dll
363rm -rf %{buildroot}%{_prefix}/lib/mono/xbuild/12.0/bin/Microsoft.Build.Utilities.v12.0.dll
364
365%find_lang mcs
366
367
368%clean
369[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
370
371%post core -p /sbin/ldconfig
372%postun core -p /sbin/ldconfig
373
374%files core -f mcs.lang
375%defattr(-,root,root,-)
376%doc AUTHORS COPYING.LIB LICENSE ChangeLog NEWS README.md
377%dir %{mono_dir}
378%dir %{mono_dir}/2.0
379%dir %{mono_dir}/3.5
380%dir %{mono_dir}/4.0
381%dir %{mono_dir}/4.5
382%dir %{mono_dir}/4.5/Facades
383%dir %{mono_dir}/compat-2.0
384%dir %{mono_dir}/gac
385%dir %{_sysconfdir}/mono
386%dir %{_sysconfdir}/mono/2.0
387%dir %{_sysconfdir}/mono/4.0
388%dir %{_sysconfdir}/mono/4.5
389%config %{_sysconfdir}/mono/2.0/machine.config
390%config %{_sysconfdir}/mono/2.0/settings.map
391%config %{_sysconfdir}/mono/4.0/machine.config
392%config %{_sysconfdir}/mono/4.0/settings.map
393%config %{_sysconfdir}/mono/4.5/machine.config
394%config %{_sysconfdir}/mono/4.5/settings.map
395%config %{_sysconfdir}/mono/config
396
397%mono_bin al
398%{_bindir}/al2
399%mono_bin certmgr
400%mono_bin chktrust
401%mono_bin crlupdate
402%mono_bin csharp
403%{_bindir}/dmcs
404%mono_bin gacutil
405%{_bindir}/gacutil2
406%{_bindir}/gmcs
407%mono_bin ikdasm
408%mono_bin mcs
409%{_bindir}/mono
410%{_bindir}/mono-boehm
411%{_bindir}/mono-configuration-crypto
412%{_bindir}/mono-test-install
413%mono_bin mozroots
414%{_bindir}/peverify
415%mono_bin setreg
416%mono_bin sn
417
418%{_mandir}/man1/al.1.gz
419%{_mandir}/man1/certmgr.1.gz
420%{_mandir}/man1/chktrust.1.gz
421%{_mandir}/man1/crlupdate.1.gz
422%{_mandir}/man1/csharp.1.gz
423%{_mandir}/man1/gacutil.1.gz
424%{_mandir}/man1/mcs.1.gz
425%{_mandir}/man1/mono.1.gz
426%{_mandir}/man1/mono-configuration-crypto.1.gz
427%{_mandir}/man1/mozroots.1.gz
428%{_mandir}/man1/setreg.1.gz
429%{_mandir}/man1/sn.1.gz
430%{_mandir}/man5/mono-config.5.gz
431
432%{_libdir}/libMonoPosixHelper.so
433%{_libdir}/libikvm-native.so
434%{_libdir}/libmono*-2.0.so.*
435%{_libdir}/libmono-profiler-*.so.*
436
437%gac_dll Commons.Xml.Relaxng
438%gac_dll CustomMarshalers
439%gac_dll I18N
440%gac_dll I18N.CJK
441%gac_dll I18N.West
442%gac_dll ICSharpCode.SharpZipLib
443%gac_dll Microsoft.CSharp
444%gac_dll Microsoft.VisualC
445%gac_dll Mono.C5
446%gac_dll Mono.CSharp
447%gac_dll Mono.Cairo
448%gac_dll Mono.CompilerServices.SymbolWriter
449%gac_dll Mono.Management
450%gac_dll Mono.Parallel
451%gac_dll Mono.Posix
452%gac_dll Mono.Security
453%gac_dll Mono.Simd
454%gac_dll Mono.Tasklets
455%gac_dll System
456%gac_dll System.Configuration
457%gac_dll System.Core
458%gac_dll System.Drawing
459%gac_dll System.Dynamic
460%gac_dll System.IO.Compression
461%gac_dll System.IO.Compression.FileSystem
462%gac_dll System.Json
463%gac_dll System.Json.Microsoft
464%gac_dll System.Net
465%gac_dll System.Net.Http
466%gac_dll System.Net.Http.Formatting
467%gac_dll System.Net.Http.WebRequest
468%gac_dll System.Numerics
469%gac_dll System.Security
470%gac_dll System.Threading.Tasks.Dataflow
471%gac_dll System.Windows
472%gac_dll System.Xml
473%gac_dll System.Xml.Linq
474%gac_dll System.Xml.Serialization
475%gac_dll cscompmgd
476
477%{mono_dir}/2.0/mscorlib.dll
478%{mono_dir}/2.0/mscorlib.dll.mdb
479%{mono_dir}/4.0/mscorlib.dll
480%{mono_dir}/4.5/Facades/System*
481%{mono_dir}/4.5/mscorlib.dll
482%{mono_dir}/4.5/mscorlib.dll.mdb
483%{mono_dir}/compat-2.0/ICSharpCode.SharpZipLib.dll
484%{mono_dir}/gac/Mono.Cecil
485%{mono_dir}/gac/Mono.Cecil.Mdb
486%{mono_dir}/mono-configuration-crypto/4.5/mono-config*
487%{mono_dir}/mono-configuration-crypto/4.5/Mono.Configuration.Crypto.dll*
488
489
490%files devel
491%defattr(-,root,root,-)
492%mono_bin caspol
493%mono_bin cccheck
494%mono_bin ccrewrite
495%mono_bin cert-sync
496%mono_bin cert2spc
497%mono_bin dtd2rng
498%mono_bin dtd2xsd
499%mono_bin genxs
500%mono_bin httpcfg
501%mono_bin ilasm
502%mono_bin installvst
503%mono_bin lc
504%mono_bin macpack
505%mono_bin makecert
506%mono_bin mdbrebase
507%mono_bin mkbundle
508%{_bindir}/mono-api-info
509%mono_bin mono-cil-strip
510%{_bindir}/mono-gdb.py
511%{_bindir}/mono-heapviz
512%mono_bin mono-shlib-cop
513%mono_bin mono-xmltool
514%{_bindir}/monodis
515%{_bindir}/monograph
516%mono_bin monolinker
517%mono_bin monop
518%{_bindir}/monop2
519%{_bindir}/mprof-report
520%mono_bin pdb2mdb
521%{_bindir}/pedump
522%mono_bin permview
523%{_bindir}/prj2make
524%mono_bin resgen
525%{_bindir}/resgen2
526%mono_bin secutil
527%mono_bin sgen
528%mono_bin signcode
529%mono_bin xbuild
530%{_prefix}/lib/mono-source-libs/
531
532%{_mandir}/man1/cccheck.1.gz
533%{_mandir}/man1/ccrewrite.1.gz
534%{_mandir}/man1/cert2spc.1.gz
535%{_mandir}/man1/resgen.1.gz
536%{_mandir}/man1/dtd2xsd.1.gz
537%{_mandir}/man1/genxs.1.gz
538%{_mandir}/man1/httpcfg.1.gz
539%{_mandir}/man1/ilasm.1.gz
540%{_mandir}/man1/lc.1.gz
541%{_mandir}/man1/macpack.1.gz
542%{_mandir}/man1/makecert.1.gz
543%{_mandir}/man1/mkbundle.1.gz
544%{_mandir}/man1/mono-api-info.1.gz
545%{_mandir}/man1/mono-cil-strip.1.gz
546%{_mandir}/man1/mono-shlib-cop.1.gz
547%{_mandir}/man1/mono-xmltool.1.gz
548%{_mandir}/man1/monodis.1.gz
549%{_mandir}/man1/monolinker.1.gz
550%{_mandir}/man1/monop.1.gz
551%{_mandir}/man1/mprof-report.1.gz
552%{_mandir}/man1/pdb2mdb.1.gz
553%{_mandir}/man1/permview.1.gz
554%{_mandir}/man1/prj2make.1.gz
555%{_mandir}/man1/secutil.1.gz
556%{_mandir}/man1/sgen.1.gz
557%{_mandir}/man1/signcode.1.gz
558%{_mandir}/man1/xbuild.1.gz
559%{_datadir}/mono-2.0/mono/cil/cil-opcodes.xml
560
561%gac_dll Mono.CodeContracts
562%gac_dll Mono.Debugger.Soft
563%gac_dll Mono.XBuild.Tasks
564%gac_dll PEAPI
565%gac_dll Microsoft.Build
566%gac_dll Microsoft.Build.Engine
567%gac_dll Microsoft.Build.Framework
568%gac_dll Microsoft.Build.Tasks
569%gac_dll Microsoft.Build.Utilities
570%gac_dll Microsoft.Build.Tasks.v3.5
571%gac_dll Microsoft.Build.Utilities.v3.5
572%gac_dll Microsoft.Build.Tasks.v4.0
573%gac_dll Microsoft.Build.Utilities.v4.0
574%{mono_dir}/2.0/MSBuild
575%{mono_dir}/2.0/Microsoft.Build.xsd
576%{mono_dir}/2.0/Microsoft.*.targets
577%{mono_dir}/?.0/Microsoft.Common.tasks
578%{mono_dir}/3.5/MSBuild/Microsoft.Build*
579%{mono_dir}/3.5/Microsoft.Build.xsd
580%{mono_dir}/3.5/Microsoft.CSharp.targets
581%{mono_dir}/3.5/Microsoft.Common.ta*
582%{mono_dir}/3.5/Microsoft.VisualBasic.targets
583%{mono_dir}/4.5/Microsoft.Build.xsd
584%{mono_dir}/4.5/MSBuild/Microsoft*
585%{mono_dir}/4.5/Microsoft.CSharp.targets
586%{mono_dir}/4.5/Microsoft.Common.ta*
587%{mono_dir}/4.5/Microsoft.VisualBasic.targets
588%{mono_dir}/4.5/mono-api-info.exe
589%{mono_dir}/4.5/installutil*
590%{mono_dir}/4.5/ictool*
591%{mono_dir}/?.?/xbuild.rsp
592%{mono_dir}/gac/Microsoft.Build.Tasks.v12.0/
593%{mono_dir}/gac/Microsoft.Build.Utilities.v12.0/
594%{_libdir}/libmono*-2.0.so
595%{_libdir}/libmono-profiler-*.so
596%{_libdir}/pkgconfig/aspnetwebstack.pc
597%{_libdir}/pkgconfig/cecil.pc
598%{_libdir}/pkgconfig/dotnet.pc
599%{_libdir}/pkgconfig/dotnet35.pc
600%{_libdir}/pkgconfig/mono.pc
601%{_libdir}/pkgconfig/mono-cairo.pc
602%{_libdir}/pkgconfig/mono-lineeditor.pc
603%{_libdir}/pkgconfig/mono-options.pc
604%{_libdir}/pkgconfig/mono-2.pc
605%{_libdir}/pkgconfig/xbuild12.pc
606%{_includedir}/mono-2.0/mono/jit/jit.h
607%{_includedir}/mono-2.0/mono/metadata/*.h
608%{_includedir}/mono-2.0/mono/utils/*.h
609%{_includedir}/mono-2.0/mono/cil/opcode.def
610%{mono_dir}/xbuild
611%{mono_dir}/xbuild-frameworks
612
613%files nunit
614%defattr(-,root,root,-)
615%mono_bin nunit-console
616%{_bindir}/nunit-console2
617%{_bindir}/nunit-console4
618%gac_dll nunit-console-runner
619%gac_dll nunit.core
620%gac_dll nunit.core.extensions
621%gac_dll nunit.core.interfaces
622%gac_dll nunit.framework
623%gac_dll nunit.framework.extensions
624%gac_dll nunit.mocks
625%gac_dll nunit.util
626# devel
627%{_libdir}/pkgconfig/mono-nunit.pc
628
629%files locale-extras
630%defattr(-,root,root,-)
631%gac_dll I18N.MidEast
632%gac_dll I18N.Rare
633%gac_dll I18N.Other
634
635%files extras
636%defattr(-,root,root,-)
637%mono_bin mono-service
638%{_bindir}/mono-service2
639%{_mandir}/man1/mono-service.1.gz
640%gac_dll Mono.Messaging
641%gac_dll Mono.Messaging.RabbitMQ
642%gac_dll RabbitMQ.Client
643%gac_dll System.Configuration.Install
644%gac_dll System.Management
645%gac_dll System.Messaging
646%gac_dll System.Runtime.Caching
647%gac_dll System.ServiceProcess
648%gac_dll System.Xaml
649%{mono_dir}/?.?/RabbitMQ.Client.Apigen*
650%{mono_dir}/gac/mono-service
651
652%files winforms
653%defattr(-,root,root,-)
654%gac_dll Accessibility
655%gac_dll Mono.WebBrowser
656%gac_dll System.Design
657%gac_dll System.Drawing.Design
658%gac_dll System.Windows.Forms
659%gac_dll System.Windows.Forms.DataVisualization
660
661%files wcf
662%defattr(-, root, root, -)
663%mono_bin svcutil
664%gac_dll System.Data.Services
665%gac_dll System.IdentityModel
666%gac_dll System.IdentityModel.Selectors
667%gac_dll System.Runtime.DurableInstancing
668%gac_dll System.ServiceModel
669%gac_dll System.ServiceModel.Activation
670%gac_dll System.ServiceModel.Discovery
671%gac_dll System.ServiceModel.Routing
672%gac_dll System.ServiceModel.Web
673# wcf-devel
674%{_libdir}/pkgconfig/wcf.pc
675
676%files winfx
677%defattr(-, root, root)
678%gac_dll System.Data.Services.Client
679%gac_dll WindowsBase
680
681%files web
682%defattr(-,root,root,-)
683%dir %{_sysconfdir}/mono/mconfig
684%config (noreplace) %{_sysconfdir}/mono/browscap.ini
685%config (noreplace) %{_sysconfdir}/mono/mconfig/config.xml
686%config (noreplace) %{_sysconfdir}/mono/2.0/Browsers
687%config (noreplace) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
688%config (noreplace) %{_sysconfdir}/mono/2.0/web.config
689%config (noreplace) %{_sysconfdir}/mono/4.0/Browsers
690%config (noreplace) %{_sysconfdir}/mono/4.0/DefaultWsdlHelpGenerator.aspx
691%config (noreplace) %{_sysconfdir}/mono/4.0/web.config
692%config (noreplace) %{_sysconfdir}/mono/4.5/Browsers
693%config (noreplace) %{_sysconfdir}/mono/4.5/DefaultWsdlHelpGenerator.aspx
694%config (noreplace) %{_sysconfdir}/mono/4.5/web.config
695%mono_bin disco
696%mono_bin mconfig
697%mono_bin soapsuds
698%mono_bin wsdl
699%{_bindir}/wsdl2
700%mono_bin xsd
701%{_mandir}/man1/disco.1.gz
702%{_mandir}/man1/mconfig.1.gz
703%{_mandir}/man1/soapsuds.1.gz
704%{_mandir}/man1/wsdl.1.gz
705%{_mandir}/man1/xsd.1.gz
706%gac_dll Microsoft.Web.Infrastructure
707%gac_dll Mono.Http
708%gac_dll System.ComponentModel.Composition
709%gac_dll System.ComponentModel.DataAnnotations
710%gac_dll System.Runtime.Remoting
711%gac_dll System.Runtime.Serialization.Formatters.Soap
712%gac_dll System.Web
713%gac_dll System.Web.Abstractions
714%gac_dll System.Web.ApplicationServices
715%gac_dll System.Web.Http
716%gac_dll System.Web.Http.SelfHost
717%gac_dll System.Web.Http.WebHost
718%gac_dll System.Web.Razor
719%gac_dll System.Web.Routing
720%gac_dll System.Web.Services
721%gac_dll System.Web.WebPages
722%gac_dll System.Web.WebPages.Deployment
723%gac_dll System.Web.WebPages.Razor
724
725%files mvc
726%defattr(-, root, root,-)
727%gac_dll System.Web.DynamicData
728%gac_dll System.Web.Extensions
729%gac_dll System.Web.Extensions.Design
730%gac_dll System.Web.Mvc
731%{mono_dir}/compat-2.0/System.Web.Extensions.Design.dll
732%{mono_dir}/compat-2.0/System.Web.Extensions.dll
733%{mono_dir}/compat-2.0/System.Web.Mvc.dll
734# mvc-devel
735%{_libdir}/pkgconfig/system.web.extensions.design_1.0.pc
736%{_libdir}/pkgconfig/system.web.extensions_1.0.pc
737%{_libdir}/pkgconfig/system.web.mvc.pc
738%{_libdir}/pkgconfig/system.web.mvc2.pc
739%{_libdir}/pkgconfig/system.web.mvc3.pc
740
741%files entityframework
742%defattr(-, root, root)
743%gac_dll EntityFramework
744%gac_dll EntityFramework.SqlServer
745
746%files reactive
747%defattr(-, root, root)
748%gac_dll System.Reactive.Core
749%gac_dll System.Reactive.Debugger
750%gac_dll System.Reactive.Experimental
751%gac_dll System.Reactive.Interfaces
752%gac_dll System.Reactive.Linq
753%gac_dll System.Reactive.Observable.Aliases
754%gac_dll System.Reactive.PlatformServices
755%gac_dll System.Reactive.Providers
756%gac_dll System.Reactive.Runtime.Remoting
757%gac_dll System.Reactive.Windows.Forms
758%gac_dll System.Reactive.Windows.Threading
759# reactive-devel
760%{_libdir}/pkgconfig/reactive.pc
761
762%files data
763%defattr(-,root,root,-)
764%mono_bin sqlsharp
765%mono_bin sqlmetal
766%{_mandir}/man1/sqlsharp.1.gz
767%gac_dll Mono.Data.Tds
768%gac_dll Novell.Directory.Ldap
769%gac_dll System.Data
770%gac_dll System.Data.DataSetExtensions
771%gac_dll System.Data.Linq
772%gac_dll System.DirectoryServices
773%gac_dll System.DirectoryServices.Protocols
774%gac_dll System.EnterpriseServices
775%gac_dll System.Runtime.Serialization
776%gac_dll System.Transactions
777%gac_dll WebMatrix.Data
778
779%files data-sqlite
780%defattr(-,root,root,-)
781%gac_dll Mono.Data.Sqlite
782
783%files data-oracle
784%defattr(-,root,root,-)
785%gac_dll System.Data.OracleClient
786
787%files data-postgresql
788%defattr(-,root,root,-)
789%gac_dll Npgsql
790
791%files -n ibm-data-db2
792%defattr(-,root,root,-)
793%gac_dll IBM.Data.DB2
794
795%files -n monodoc
796%defattr(-, root, root)
797%{_bindir}/mdass*
798%mono_bin mdoc
799%{_bindir}/mdoc-*
800%{_bindir}/mdval*
801%mono_bin mod
802%{_bindir}/monodoc*
803%{_mandir}/man1/md*
804%{_mandir}/man1/monodoc*
805%{_mandir}/man5/mdoc*
806%{mono_dir}/4.0/monodoc.dll
807%{mono_dir}/gac/monodoc
808%{mono_dir}/monodoc/*
809%ifnarch  ppc
810%{_prefix}/lib/monodoc
811%endif
812# monodoc-devel
813%{_libdir}/pkgconfig/monodoc.pc
814
815%changelog
816* Thu Mar 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.12.1-1
817- updated to 3.12.1
818
819* Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.8-2
820- rebuild with VineSeed environment
821- remove Requires:libgluezilla in monodoc
822
823* Sun Jan 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.8-1
824- updated mono to 2.10.8
825
826* Sun Jan 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.8-1
827- updated mono to 2.10.8
828
829* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.6-1
830- updated mono to 2.10.6
831
832* Sat May 07 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.2-1
833- updated mono to 2.10.2
834- dropt Patch1: mono-2.10.1-ppc-len.patch (fixed in the upstream)
835
836* Sun Apr 24 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.1-3
837- added '--with-sgen=no' to all arch
838- dropt %%{mono_dir}/2.0/{mcs.exe,mscorlib.dll}.so
839
840* Sat Apr 16 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.10.1-2
841- remove the old ppc patch (similar codes already in the upstream)
842- add Patch1 (from Gentoo)
843- mono/2.0/mcs.exe.so not available on ppc - remove from the filelist
844  (TODO: see the Fedora's srpm - removing mono/2.0/{mcs,gmcs}.exe.so etc.)
845
846* Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.1-1
847- updated mono to 2.10.1
848
849* Sat Jan 08 2011 Shu KONNO <owa@bg.wakwak.com> 2.8.2-1
850- updated mono to 2.8.2
851
852* Tue Dec 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-2
853- add Patch0 (mono-2.8.1-ppc.patch)
854- add configure option "--with-sgen=no" and "--disable-system-aot" (ppc only)
855- fix %%files (add %%ifnarch ppc)
856
857* Sun Nov 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-1
858- updated mono to 2.8.1
859
860* Sat Nov 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-2
861- comment out script that removes prebuilt binaries, because gmcs.exe require
862
863* Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
864- updated mono to 2.8
865- modified macros used in %%files
866- removed below:
867  - packages:
868    %{name}-jscript, %{name}-data-sybase, %{name}-data-firebird, bytefx-data-mysql
869  - libraries:
870    ByteFX.Data, FirebirdSql.Data.Firebird
871    Mono.Data Mono.Data.TdsClient, Mono.Data.SybaseClient, Mono.Data.SqliteClient
872    Microsoft.JScript, Microsoft.Vsa
873  - commands:
874    cilc, mjs, prj2make (replaced by xbuild)
875
876* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.6.7-2
877- build with rpm-4.8.1-1 for pkg-config file
878
879* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.7-1
880- updated mono to 2.6.7
881
882* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
883- updated mono to 2.6.4
884
885* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
886- updated mono to 2.6.3
887  added RabbitMQ.Client.Apigen.exe
888
889* Thu Dec 31 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-2
890- unuse _smp_mflags
891
892* Sat Dec 26 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-1
893- updated mono to 2.6.1
894- simplified macros
895
896* Mon Dec 14 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-1
897- updated mono to 2.4.3
898  added %%{mono_dir}/2.0/lc.exe*
899  added %%gac_dll System.Web.Mvc
900  added %%{mono_dir}/xbuild/*
901  added %%{_mandir}/man1/lc.1.gz
902  added %%{_mandir}/man1/xbuild.1.gz
903
904* Wed Jul 29 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.3-1
905- updated mono to 2.4.2.3
906
907* Fri Jul 24 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.2-1
908- updated mono to 2.4.2.2
909
910* Tue Jul 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.2.1-1
911- new upstream release
912- build with latest rpm to update mono-dependencies
913
914* Thu Jul 02 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
915- updated mono to 2.4.2
916
917* Mon Apr 27 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4-3
918- fix temporary workaround against build failure on ppc,
919  from RH bugzilla #494026
920  - statically link mono to libmono: remove "--disable-static" from configure
921  - ensure removing *.a files in the install section
922- remove prebuilt binaries under mcs/class/lib/monolite/ before building
923
924* Sun Apr  5 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
925- fixed paths using %%mono_dir, %%mono_doc macros
926- added Requires:libgluezilla >= 2.4 in monodoc
927
928* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
929- new upstream release
930- added monodoc package (Obsoletes: monodoc-core <= 2.0-1vl5)
931
932* Mon Nov 03 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1
933- new upstream release
934- dropt %%{_bindir}/mono-find-{provides,requires}
935- added --with-libgdiplus=installed
936
937* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-3
938- update to mono-2.0 released source
939- BR: libgdiplus-devel >= 2.0
940
941* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-2vl5
942- removed *.la
943
944* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1vl5
945- updated mono to 2.0
946- updated url
947- changed macro %%monodir to %%mono_dir
948- dropt mono-1.1.13.4-selinux-ia64.patch
949- dropt mono-1.1.13.4-ppc-threading.patch
950- dropt mono-1.2.3-use-monodir.patch
951
952* Tue Aug 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-1vl5
953- applied new versioning policy, spec in utf-8
954- dropt mono-1.2.5-libdir.patch
955- reverted monodir macro to using %%{_prefix}/lib/mono
956
957* Sat Dec 29 2007 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-0vl2
958- updated monodir to %%{_libdir}/mono
959
960* Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5.1-0vl1
961- new upstream release
962- splited mono-basic package
963
964* Sat Oct 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.8.1-0vl1
965- new upstream release
966
967* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.6-0vl1
968- new upstream release
969
970* Thu Apr 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.13.4-2vl2
971- disabled Patch2 on Vine/ppc environment
972
973* Wed Mar 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.4-2vl1
974- updated source and sub-packages based on Fedora packages
975  * Tue Feb 22 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.6-0vl1
976  - new upstream version(mono-1.0.6)
977  * Sun Jan 16 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.5-0vl1
978  - new upstream version(mono-1.0.5)
979  * Sat Nov 06 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.4-0vl1
980  - new upstream version(mono-1.0.4)
981        -- changed to use configure
982  * Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
983  - rebuild for Vine Linux (based on mono.spec inside src archive)
984  - Fixed BuildRequires: gc-devel, libicu-devel
985  - add Japanese translation
986
987* Fri Mar 10 2006 Bill Nottingham <notting@redhat.com> - 1.1.13.4-2
988- rebuild for ppc TLS issue (#184446)
989
990* Fri Mar  3 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.4-1
991- Update to 1.1.13.4
992- Add patch so mono doesn't segfault on PPC SMP machines
993- Minor spec cleanup
994
995* Thu Mar  2 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-5
996- Updated patch from Jakub (1.1.13.2-3 to 1.1.13.2-5 are
997  for bug 182965)
998
999* Tue Feb 28 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-4
1000- Updated patch from Paolo Molaro <lupus@ximian.com>
1001
1002* Mon Feb 27 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-3
1003- Patch from Jakub to make work with SELinux better
1004
1005* Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-2
1006- Rebuild
1007
1008* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.1.13.2-1.1
1009- rebuilt for new gcc4.1 snapshot and glibc changes
1010
1011* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-1
1012- Update to 1.1.13.2
1013
1014* Fri Jan 13 2006 Alexander Larsson <alexl@redhat.com> - 1.1.13-1
1015- Update to 1.13
1016- Add libgdiplus dep to mono-core
1017- Add s390x to build
1018
1019* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.12.1-1
1020- Update to 1.1.12.1
1021
1022* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.10-4
1023- rebuild
1024
1025* Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-3
1026- Disable s390 due to some build failure
1027
1028* Thu Nov 17 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-2
1029- Build on s390 and x86-64 now
1030
1031* Tue Nov 15 2005 Alexander Larsson <alexl@redhat.com> - 1.1.10-1
1032- Initial version
Note: See TracBrowser for help on using the repository browser.