source: projects/specs/trunk/m/meson/meson-vl.spec @ 12383

Revision 12383, 9.9 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

OpenEXR-2.4.1-1

ipset-7.6-1

meson-0.54.0-1

ninja-1.10.0-1

postsrsd-1.6-2

stunnel-5.56-1

ulogd-2.0.7-2

Line 
1%{!?rpmmacrodir:%global rpmmacrodir %{_sysconfdir}/rpm}
2
3%global libname mesonbuild
4
5Name:           meson
6Summary:        High productivity build system
7Summary(ja):    高生産性ビルドシステム
8Version:        0.54.0
9Release:        1%{?_dist_release}
10Group:          Development/Tools
11Vendor:         Project Vine
12Distribution:   Vine Linux
13BuildArch:      noarch
14
15License:        ASL 2.0
16URL:            https://mesonbuild.com/
17Source0:        https://github.com/mesonbuild/meson/archive/%{version}/%{name}-%{version}.tar.gz
18Source1:        macros.meson
19
20Obsoletes:      %{name}-gui < 0.31.0-3
21BuildRequires:  python3-devel
22BuildRequires:  python3-setuptools
23BuildRequires:  python-rpm-macros
24BuildRequires:  python3-rpm-macros
25BuildRequires:  ninja
26# Various languages
27BuildRequires:  gcc
28BuildRequires:  libasan
29BuildRequires:  gcc-c++
30BuildRequires:  gcc-objc
31BuildRequires:  gcc-objc++
32BuildRequires:  rust
33
34# Various libs support
35BuildRequires:  libboost-devel
36BuildRequires:  vala
37BuildRequires:  flex
38BuildRequires:  bison
39BuildRequires:  gettext
40BuildRequires:  git-core
41#BuildRequires:  pkgconfig(glib-2.0)
42#BuildRequires:  pkgconfig(gobject-introspection-1.0)
43#BuildRequires:  itstool
44BuildRequires:  zlib-devel
45BuildRequires:  llvm-devel
46BuildRequires:  cups-devel
47Requires:       ninja
48Requires:       python3-setuptools
49
50%description
51Meson is a build system designed to optimize programmer
52productivity. It aims to do this by providing simple, out-of-the-box
53support for modern software development tools and practices, such as
54unit tests, coverage reports, Valgrind, CCache and the like.
55
56%prep
57%autosetup -p1
58find -type f -name '*.py' -executable -exec sed -i -e '1s|.*|#!%{__python3}|' {} ';'
59# Remove MPI tests for now because it is complicated to run
60rm -rf "test cases/frameworks/17 mpi"
61
62%build
63%py3_build
64#python3 setup.py build
65
66%install
67%py3_install
68#python3 setup.py install --root %{buildroot}
69
70install -Dpm0644 %{SOURCE1} %{buildroot}%{rpmmacrodir}/macros.%{name}
71
72%check
73export MESON_PRINT_TEST_OUTPUT=1
74python3 ./run_tests.py ||:
75
76%files
77%license COPYING
78%{_bindir}/%{name}
79%{python3_sitelib}/%{libname}/
80%{python3_sitelib}/%{name}-*.egg-info/
81%{_datadir}/polkit-1/actions/com.mesonbuild.install.policy
82%{_mandir}/man1/%{name}.1*
83%{rpmmacrodir}/macros.*
84
85%changelog
86* Sun Apr 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.54.0-1
87- new upstream release.
88
89* Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.51.2-1
90- updated to 0.51.2.
91
92* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.49.0-1
93- updated to 0.49.0.
94- updated macros.meson.
95
96* Sun Jan 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.44.0-1
97- updated to 0.44.0.
98
99* Wed Sep 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.42.0-1
100- initial build for Vine Linux.
101
102* Fri Aug 18 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.42.0-1
103- Update to 0.42.0
104
105* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.41.2-2
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
107
108* Wed Jul 19 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.41.2-1
109- Update to 0.41.2
110
111* Tue Jul 18 2017 Kalev Lember <klember@redhat.com> - 0.41.1-3
112- Backport various gtk-doc fixes from upstream
113
114* Thu Jul 13 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.41.1-2
115- Strip trailing slash from pkg-config files
116
117* Mon Jun 19 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.41.1-1
118- Update to 0.41.1
119
120* Tue Jun 13 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.41.0-1
121- Update to 0.41.0
122
123* Wed May 31 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.1-2
124- Don't run ldc tests
125
126* Fri Apr 28 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.1-1
127- Update to 0.40.1
128
129* Sun Apr 23 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.0-1
130- Update to 0.40.0
131
132* Thu Apr 13 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.39.1-2
133- Exclude ldc for module builds
134
135* Thu Mar 16 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.39.1-1
136- Update to 0.39.1
137
138* Mon Mar 06 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.39.0-1
139- Update to 0.39.0
140
141* Tue Feb 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.38.1-1
142- Update to 0.38.1
143
144* Sun Jan 29 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.38.0-1
145- Update to 0.38.0
146
147* Thu Dec 22 2016 Miro Hrončok <mhroncok@redhat.com> - 0.37.1-2
148- Rebuild for Python 3.6
149
150* Tue Dec 20 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.37.1-1
151- Update to 0.37.1
152
153* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 0.37.0-2
154- Rebuild for Python 3.6
155
156* Sun Dec 18 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.37.0-1
157- Update to 0.37.0
158
159* Thu Dec 15 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-4
160- Backport more RPM macro fixes (FPC ticket #655)
161
162* Tue Dec 13 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-3
163- Backport fixes to RPM macros
164
165* Sat Dec 03 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-2
166- Print test output during build
167
168* Mon Nov 14 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-1
169- Update to 0.36.0
170
171* Tue Oct 18 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.1-1
172- Update to 0.35.1 (RHBZ #1385986)
173
174* Tue Oct 11 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-3
175- Backport couple of fixes
176
177* Wed Oct 05 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-2
178- Apply patch to fix FTBFS
179
180* Mon Oct 03 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-1
181- Update to 0.35.0
182
183* Wed Sep 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.34.0-2
184- Run D test suite
185
186* Wed Sep 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.34.0-1
187- Update to 0.34.0
188
189* Tue Aug 09 2016 Jon Ciesla <limburgher@gmail.com> - 0.33.0-2
190- Obsoletes fix.
191
192* Tue Aug 09 2016 Jon Ciesla <limburgher@gmail.com> - 0.33.0-1
193- 0.33.0
194- GUI dropped upstream.
195
196* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31.0-2
197- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
198
199* Thu Apr 14 2016 Igor Gnatenko <ignatenko@redhat.com> - 0.31.0-1
200- Update to 0.31.0
201
202* Sun Mar 20 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.30.0-1
203- Update to 0.30.0
204
205* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.29.0-2
206- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
207
208* Sun Jan 24 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.29.0-1
209- Update to 0.29.0
210
211* Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 0.28.0-2
212- Rebuilt for Boost 1.60
213
214* Mon Dec 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.28.0-1
215- 0.28.0
216
217* Wed Nov 25 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.27.0-1
218- 0.27.0
219
220* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.26.0-3
221- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
222
223* Fri Oct 30 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.26.0-2
224- Fix rpm macros for using optflags
225
226* Sun Sep 13 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.26.0-1
227- 0.26.0
228
229* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 0.25.0-4
230- Rebuilt for Boost 1.59
231
232* Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25.0-3
233- Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
234
235* Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 0.25.0-2
236- rebuild for Boost 1.58
237
238* Sun Jul 12 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.25.0-1
239- 0.25.0
240
241* Sat Jul 11 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.24.0-3
242- Update URLs
243- drop unneded hacks in install section
244- enable print test output for tests
245
246* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24.0-2
247- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
248
249* Mon May 25 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.24.0-1
250- Update to 0.24.0
251
252* Thu May 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-3.20150328git0ba1d54
253- Update to latest git
254
255* Thu May 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-3
256- Add patch to accept .S files
257
258* Wed Apr 29 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-2
259- Add python3 to Requires (Thanks to Ilya Kyznetsov)
260
261* Tue Mar 31 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-1
262- 0.23.0
263
264* Sat Mar 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150328git3b49b71
265- Update to latest git
266
267* Mon Mar 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150325git18550fe
268- Update to latest git
269- Include mesonintrospect
270
271* Mon Mar 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150322git78d31ca
272- Fix filelists for mesongui (python-bytecode-without-source)
273
274* Sun Mar 22 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-8.20150322git78d31ca
275- Enable C# tests
276
277* Sun Mar 22 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150322git78d31ca
278- update to latest git
279- fix tests on arm
280
281* Sat Mar 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150321gita084a8e
282- update to latest git
283
284* Mon Mar 16 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150316gitfa2c659
285- update to latest git
286
287* Tue Mar 10 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150310gitf9f51b1
288- today's git snapshot with support for cool GNOME features
289- re-enable wxGTK3 tests, package fixed in rawhide
290
291* Thu Feb 26 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-6.git7581895
292- split gui to subpkg
293- update to latest snapshot
294- enable tests
295
296* Thu Feb 26 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-5.gitc6dbf98
297- Fix packaging style
298- Make package noarch
299
300* Mon Feb 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-4.git.c6dbf98
301- Use development version
302
303* Sat Feb 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-3
304- Add ninja-build to requires
305
306* Thu Jan 22 2015 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.22.0-2
307- fix shebang in python files
308
309* Wed Jan 21 2015 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.22.0-1
310- Initial package
Note: See TracBrowser for help on using the repository browser.