source: projects/specs/trunk/m/meson/meson-vl.spec @ 12469

Revision 12469, 9.9 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%{!?rpmmacrodir:%global rpmmacrodir %{_sysconfdir}/rpm}
2
3%global libname mesonbuild
4
5Name:           meson
6Summary:        High productivity build system
7Summary(ja):    高生産性ビルドシステム
8Version:        0.55.0
9Release:        1%{?_dist_release}
10Group:          programming
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14License:        ASL 2.0
15URL:            https://mesonbuild.com/
16Source0:        https://github.com/mesonbuild/meson/archive/%{version}/%{name}-%{version}.tar.gz
17Source1:        macros.meson
18
19BuildArch:      noarch
20Obsoletes:      %{name}-gui < 0.31.0-3
21BuildRequires:  python3-devel
22BuildRequires:  python3-setuptools
23BuildRequires:  python-rpm-macros
24BuildRequires:  python3-rpm-macros
25BuildRequires:  ninja
26# Various languages
27BuildRequires:  gcc
28BuildRequires:  libasan
29BuildRequires:  gcc-c++
30BuildRequires:  gcc-objc
31BuildRequires:  gcc-objc++
32BuildRequires:  rust
33
34# Various libs support
35BuildRequires:  libboost-devel
36BuildRequires:  vala
37BuildRequires:  flex
38BuildRequires:  bison
39BuildRequires:  gettext
40BuildRequires:  git-core
41#BuildRequires:  pkgconfig(glib-2.0)
42#BuildRequires:  pkgconfig(gobject-introspection-1.0)
43#BuildRequires:  itstool
44BuildRequires:  zlib-devel
45BuildRequires:  llvm-devel
46BuildRequires:  cups-devel
47Requires:       ninja
48Requires:       python3-setuptools
49
50%description
51Meson is a build system designed to optimize programmer
52productivity. It aims to do this by providing simple, out-of-the-box
53support for modern software development tools and practices, such as
54unit tests, coverage reports, Valgrind, CCache and the like.
55
56%prep
57%autosetup -p1
58find -type f -name '*.py' -executable -exec sed -i -e '1s|.*|#!%{__python3}|' {} ';'
59# Remove MPI tests for now because it is complicated to run
60rm -rf "test cases/frameworks/17 mpi"
61
62%build
63%py3_build
64
65%install
66%py3_install
67
68install -Dpm0644 %{SOURCE1} %{buildroot}%{rpmmacrodir}/macros.%{name}
69
70%check
71export MESON_PRINT_TEST_OUTPUT=1
72python3 ./run_tests.py ||:
73
74%files
75%license COPYING
76%{_bindir}/%{name}
77%{python3_sitelib}/%{libname}/
78%{python3_sitelib}/%{name}-*.egg-info/
79%{_datadir}/polkit-1/actions/com.mesonbuild.install.policy
80%{_mandir}/man1/%{name}.1*
81%{rpmmacrodir}/macros.*
82
83%changelog
84* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.55.0-1
85- new upstream release.
86
87* Sun Apr 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.54.0-1
88- new upstream release.
89
90* Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.51.2-1
91- updated to 0.51.2.
92
93* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.49.0-1
94- updated to 0.49.0.
95- updated macros.meson.
96
97* Sun Jan 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.44.0-1
98- updated to 0.44.0.
99
100* Wed Sep 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.42.0-1
101- initial build for Vine Linux.
102
103* Fri Aug 18 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.42.0-1
104- Update to 0.42.0
105
106* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.41.2-2
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
108
109* Wed Jul 19 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.41.2-1
110- Update to 0.41.2
111
112* Tue Jul 18 2017 Kalev Lember <klember@redhat.com> - 0.41.1-3
113- Backport various gtk-doc fixes from upstream
114
115* Thu Jul 13 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.41.1-2
116- Strip trailing slash from pkg-config files
117
118* Mon Jun 19 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.41.1-1
119- Update to 0.41.1
120
121* Tue Jun 13 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.41.0-1
122- Update to 0.41.0
123
124* Wed May 31 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.1-2
125- Don't run ldc tests
126
127* Fri Apr 28 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.1-1
128- Update to 0.40.1
129
130* Sun Apr 23 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.0-1
131- Update to 0.40.0
132
133* Thu Apr 13 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.39.1-2
134- Exclude ldc for module builds
135
136* Thu Mar 16 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.39.1-1
137- Update to 0.39.1
138
139* Mon Mar 06 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.39.0-1
140- Update to 0.39.0
141
142* Tue Feb 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.38.1-1
143- Update to 0.38.1
144
145* Sun Jan 29 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.38.0-1
146- Update to 0.38.0
147
148* Thu Dec 22 2016 Miro Hrončok <mhroncok@redhat.com> - 0.37.1-2
149- Rebuild for Python 3.6
150
151* Tue Dec 20 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.37.1-1
152- Update to 0.37.1
153
154* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 0.37.0-2
155- Rebuild for Python 3.6
156
157* Sun Dec 18 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.37.0-1
158- Update to 0.37.0
159
160* Thu Dec 15 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-4
161- Backport more RPM macro fixes (FPC ticket #655)
162
163* Tue Dec 13 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-3
164- Backport fixes to RPM macros
165
166* Sat Dec 03 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-2
167- Print test output during build
168
169* Mon Nov 14 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-1
170- Update to 0.36.0
171
172* Tue Oct 18 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.1-1
173- Update to 0.35.1 (RHBZ #1385986)
174
175* Tue Oct 11 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-3
176- Backport couple of fixes
177
178* Wed Oct 05 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-2
179- Apply patch to fix FTBFS
180
181* Mon Oct 03 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-1
182- Update to 0.35.0
183
184* Wed Sep 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.34.0-2
185- Run D test suite
186
187* Wed Sep 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.34.0-1
188- Update to 0.34.0
189
190* Tue Aug 09 2016 Jon Ciesla <limburgher@gmail.com> - 0.33.0-2
191- Obsoletes fix.
192
193* Tue Aug 09 2016 Jon Ciesla <limburgher@gmail.com> - 0.33.0-1
194- 0.33.0
195- GUI dropped upstream.
196
197* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31.0-2
198- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
199
200* Thu Apr 14 2016 Igor Gnatenko <ignatenko@redhat.com> - 0.31.0-1
201- Update to 0.31.0
202
203* Sun Mar 20 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.30.0-1
204- Update to 0.30.0
205
206* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.29.0-2
207- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
208
209* Sun Jan 24 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.29.0-1
210- Update to 0.29.0
211
212* Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 0.28.0-2
213- Rebuilt for Boost 1.60
214
215* Mon Dec 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.28.0-1
216- 0.28.0
217
218* Wed Nov 25 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.27.0-1
219- 0.27.0
220
221* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.26.0-3
222- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
223
224* Fri Oct 30 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.26.0-2
225- Fix rpm macros for using optflags
226
227* Sun Sep 13 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.26.0-1
228- 0.26.0
229
230* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 0.25.0-4
231- Rebuilt for Boost 1.59
232
233* Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25.0-3
234- Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
235
236* Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 0.25.0-2
237- rebuild for Boost 1.58
238
239* Sun Jul 12 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.25.0-1
240- 0.25.0
241
242* Sat Jul 11 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.24.0-3
243- Update URLs
244- drop unneded hacks in install section
245- enable print test output for tests
246
247* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24.0-2
248- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
249
250* Mon May 25 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.24.0-1
251- Update to 0.24.0
252
253* Thu May 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-3.20150328git0ba1d54
254- Update to latest git
255
256* Thu May 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-3
257- Add patch to accept .S files
258
259* Wed Apr 29 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-2
260- Add python3 to Requires (Thanks to Ilya Kyznetsov)
261
262* Tue Mar 31 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-1
263- 0.23.0
264
265* Sat Mar 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150328git3b49b71
266- Update to latest git
267
268* Mon Mar 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150325git18550fe
269- Update to latest git
270- Include mesonintrospect
271
272* Mon Mar 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150322git78d31ca
273- Fix filelists for mesongui (python-bytecode-without-source)
274
275* Sun Mar 22 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-8.20150322git78d31ca
276- Enable C# tests
277
278* Sun Mar 22 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150322git78d31ca
279- update to latest git
280- fix tests on arm
281
282* Sat Mar 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150321gita084a8e
283- update to latest git
284
285* Mon Mar 16 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150316gitfa2c659
286- update to latest git
287
288* Tue Mar 10 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150310gitf9f51b1
289- today's git snapshot with support for cool GNOME features
290- re-enable wxGTK3 tests, package fixed in rawhide
291
292* Thu Feb 26 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-6.git7581895
293- split gui to subpkg
294- update to latest snapshot
295- enable tests
296
297* Thu Feb 26 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-5.gitc6dbf98
298- Fix packaging style
299- Make package noarch
300
301* Mon Feb 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-4.git.c6dbf98
302- Use development version
303
304* Sat Feb 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-3
305- Add ninja-build to requires
306
307* Thu Jan 22 2015 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.22.0-2
308- fix shebang in python files
309
310* Wed Jan 21 2015 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.22.0-1
311- Initial package
Note: See TracBrowser for help on using the repository browser.