source: projects/specs/trunk/m/meson/meson-vl.spec @ 12559

Revision 12559, 9.9 KB checked in by tomop, 3 years ago (diff)

updated 5 packages

git-2.30.1-1

imake-1.0.8-1

irqbalance-1.7.0-1

meson-0.57.1-1

vine-rpm-macros-4-1

Line 
1%{!?rpmmacrodir:%global rpmmacrodir %{_sysconfdir}/rpm}
2
3%global libname mesonbuild
4
5Name:           meson
6Summary:        High productivity build system
7Summary(ja):    高生産性ビルドシステム
8Version:        0.57.1
9Release:        1%{?_dist_release}
10Group:          programming
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14License:        ASL 2.0
15URL:            https://mesonbuild.com/
16Source0:        https://github.com/mesonbuild/meson/archive/%{version}/%{name}-%{version}.tar.gz
17
18BuildArch:      noarch
19Obsoletes:      %{name}-gui < 0.31.0-3
20BuildRequires:  python3-devel
21BuildRequires:  python3-setuptools
22BuildRequires:  ninja
23# Various languages
24BuildRequires:  gcc
25BuildRequires:  libasan
26BuildRequires:  gcc-c++
27BuildRequires:  gcc-objc
28BuildRequires:  gcc-objc++
29BuildRequires:  rust
30
31# Various libs support
32BuildRequires:  libboost-devel
33BuildRequires:  vala
34BuildRequires:  flex
35BuildRequires:  bison
36BuildRequires:  gettext
37BuildRequires:  git-core
38#BuildRequires:  pkgconfig(glib-2.0)
39#BuildRequires:  pkgconfig(gobject-introspection-1.0)
40#BuildRequires:  itstool
41BuildRequires:  zlib-devel
42BuildRequires:  llvm-devel
43BuildRequires:  cups-devel
44Requires:       ninja
45Requires:       python3-setuptools
46
47%description
48Meson is a build system designed to optimize programmer
49productivity. It aims to do this by providing simple, out-of-the-box
50support for modern software development tools and practices, such as
51unit tests, coverage reports, Valgrind, CCache and the like.
52
53
54%prep
55%autosetup -p1
56find -type f -name '*.py' -executable -exec sed -i -e '1s|.*|#!%{__python3}|' {} ';'
57# Remove MPI tests for now because it is complicated to run
58rm -rf "test cases/frameworks/17 mpi"
59
60
61%build
62%py3_build
63
64
65%install
66%py3_install
67
68install -Dpm0644 data/macros.meson %{buildroot}%{rpmmacrodir}/macros.%{name}
69
70
71%check
72export MESON_PRINT_TEST_OUTPUT=1
73python3 ./run_tests.py ||:
74
75
76%files
77%license COPYING
78%{_bindir}/%{name}
79%{python3_sitelib}/%{libname}/
80%{python3_sitelib}/%{name}-*.egg-info/
81%{_datadir}/polkit-1/actions/com.mesonbuild.install.policy
82%{_mandir}/man1/%{name}.1*
83%{rpmmacrodir}/macros.*
84
85
86%changelog
87* Mon Mar 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.57.1-1
88- new upstream release.
89- dropped Source1: use macros in tarball.
90
91* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.55.0-1
92- new upstream release.
93
94* Sun Apr 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.54.0-1
95- new upstream release.
96
97* Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.51.2-1
98- updated to 0.51.2.
99
100* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.49.0-1
101- updated to 0.49.0.
102- updated macros.meson.
103
104* Sun Jan 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.44.0-1
105- updated to 0.44.0.
106
107* Wed Sep 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.42.0-1
108- initial build for Vine Linux.
109
110* Fri Aug 18 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.42.0-1
111- Update to 0.42.0
112
113* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.41.2-2
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
115
116* Wed Jul 19 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.41.2-1
117- Update to 0.41.2
118
119* Tue Jul 18 2017 Kalev Lember <klember@redhat.com> - 0.41.1-3
120- Backport various gtk-doc fixes from upstream
121
122* Thu Jul 13 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.41.1-2
123- Strip trailing slash from pkg-config files
124
125* Mon Jun 19 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.41.1-1
126- Update to 0.41.1
127
128* Tue Jun 13 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.41.0-1
129- Update to 0.41.0
130
131* Wed May 31 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.1-2
132- Don't run ldc tests
133
134* Fri Apr 28 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.1-1
135- Update to 0.40.1
136
137* Sun Apr 23 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.0-1
138- Update to 0.40.0
139
140* Thu Apr 13 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.39.1-2
141- Exclude ldc for module builds
142
143* Thu Mar 16 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.39.1-1
144- Update to 0.39.1
145
146* Mon Mar 06 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.39.0-1
147- Update to 0.39.0
148
149* Tue Feb 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.38.1-1
150- Update to 0.38.1
151
152* Sun Jan 29 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.38.0-1
153- Update to 0.38.0
154
155* Thu Dec 22 2016 Miro Hrončok <mhroncok@redhat.com> - 0.37.1-2
156- Rebuild for Python 3.6
157
158* Tue Dec 20 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.37.1-1
159- Update to 0.37.1
160
161* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 0.37.0-2
162- Rebuild for Python 3.6
163
164* Sun Dec 18 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.37.0-1
165- Update to 0.37.0
166
167* Thu Dec 15 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-4
168- Backport more RPM macro fixes (FPC ticket #655)
169
170* Tue Dec 13 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-3
171- Backport fixes to RPM macros
172
173* Sat Dec 03 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-2
174- Print test output during build
175
176* Mon Nov 14 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-1
177- Update to 0.36.0
178
179* Tue Oct 18 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.1-1
180- Update to 0.35.1 (RHBZ #1385986)
181
182* Tue Oct 11 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-3
183- Backport couple of fixes
184
185* Wed Oct 05 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-2
186- Apply patch to fix FTBFS
187
188* Mon Oct 03 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-1
189- Update to 0.35.0
190
191* Wed Sep 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.34.0-2
192- Run D test suite
193
194* Wed Sep 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.34.0-1
195- Update to 0.34.0
196
197* Tue Aug 09 2016 Jon Ciesla <limburgher@gmail.com> - 0.33.0-2
198- Obsoletes fix.
199
200* Tue Aug 09 2016 Jon Ciesla <limburgher@gmail.com> - 0.33.0-1
201- 0.33.0
202- GUI dropped upstream.
203
204* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31.0-2
205- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
206
207* Thu Apr 14 2016 Igor Gnatenko <ignatenko@redhat.com> - 0.31.0-1
208- Update to 0.31.0
209
210* Sun Mar 20 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.30.0-1
211- Update to 0.30.0
212
213* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.29.0-2
214- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
215
216* Sun Jan 24 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.29.0-1
217- Update to 0.29.0
218
219* Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 0.28.0-2
220- Rebuilt for Boost 1.60
221
222* Mon Dec 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.28.0-1
223- 0.28.0
224
225* Wed Nov 25 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.27.0-1
226- 0.27.0
227
228* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.26.0-3
229- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
230
231* Fri Oct 30 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.26.0-2
232- Fix rpm macros for using optflags
233
234* Sun Sep 13 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.26.0-1
235- 0.26.0
236
237* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 0.25.0-4
238- Rebuilt for Boost 1.59
239
240* Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25.0-3
241- Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
242
243* Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 0.25.0-2
244- rebuild for Boost 1.58
245
246* Sun Jul 12 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.25.0-1
247- 0.25.0
248
249* Sat Jul 11 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.24.0-3
250- Update URLs
251- drop unneded hacks in install section
252- enable print test output for tests
253
254* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24.0-2
255- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
256
257* Mon May 25 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.24.0-1
258- Update to 0.24.0
259
260* Thu May 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-3.20150328git0ba1d54
261- Update to latest git
262
263* Thu May 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-3
264- Add patch to accept .S files
265
266* Wed Apr 29 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-2
267- Add python3 to Requires (Thanks to Ilya Kyznetsov)
268
269* Tue Mar 31 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-1
270- 0.23.0
271
272* Sat Mar 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150328git3b49b71
273- Update to latest git
274
275* Mon Mar 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150325git18550fe
276- Update to latest git
277- Include mesonintrospect
278
279* Mon Mar 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150322git78d31ca
280- Fix filelists for mesongui (python-bytecode-without-source)
281
282* Sun Mar 22 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-8.20150322git78d31ca
283- Enable C# tests
284
285* Sun Mar 22 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150322git78d31ca
286- update to latest git
287- fix tests on arm
288
289* Sat Mar 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150321gita084a8e
290- update to latest git
291
292* Mon Mar 16 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150316gitfa2c659
293- update to latest git
294
295* Tue Mar 10 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150310gitf9f51b1
296- today's git snapshot with support for cool GNOME features
297- re-enable wxGTK3 tests, package fixed in rawhide
298
299* Thu Feb 26 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-6.git7581895
300- split gui to subpkg
301- update to latest snapshot
302- enable tests
303
304* Thu Feb 26 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-5.gitc6dbf98
305- Fix packaging style
306- Make package noarch
307
308* Mon Feb 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-4.git.c6dbf98
309- Use development version
310
311* Sat Feb 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-3
312- Add ninja-build to requires
313
314* Thu Jan 22 2015 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.22.0-2
315- fix shebang in python files
316
317* Wed Jan 21 2015 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.22.0-1
318- Initial package
Note: See TracBrowser for help on using the repository browser.