source: projects/specs/trunk/m/medit/medit-vl.spec @ 8488

Revision 8488, 6.2 KB checked in by kudoh, 10 years ago (diff)
Line 
1%define name     medit
2%define version  1.2.0
3
4Name:        %{name}
5Version:     %{version}
6Release:     1%{?_dist_release}
7Summary:     Multiplatform GTK+2 text editor
8Summary(ja): マルチプラットフォームな GTK+2 テキストエディタ
9Group:       Applications/Editors
10License:     GPLv2+
11URL:         http://mooedit.sourceforge.net/
12Source0:     http://prdownloads.sourceforge.net/mooedit/%{name}-%{version}.tar.bz2
13#Source1:     medit_new_ja.po
14
15BuildRoot:   %{_tmppath}/%{name}-%{version}-root
16
17Buildrequires:   cairo-devel
18BuildRequires:   desktop-file-utils
19BuildRequires:   gettext
20BuildRequires:   gtk2-devel glib2-devel
21BuildRequires:   intltool
22BuildRequires:   libxml2-devel
23BuildRequires:   libX11-devel libXext-devel libICE-devel
24BuildRequires:   libSM-devel
25Buildrequires:   perl-XML-Parser pango-devel
26BuildRequires:   pcre-devel
27BuildRequires:   python-devel
28BuildRequires:   pygtk2-devel
29
30%description
31Medit is a multiplatform GTK+2 text editor.
32
33Features:
34 * Configurable syntax highlighting.
35 * Configurable keyboard accelerators.
36 * Multiplatform - works both on unix and windows.
37 * Plugins: can be written in C or Python.
38 * Configurable tools available from the main and context menus.
39   They can be written in Python or Lua, or it can be a shell script.
40 * Regular expression search/replace, grep and find frontends, builtin file selector, etc.
41
42%description -l ja
43Medit はマルチプラットフォームな GTK+2 テキストエディタです。
44
45機能一覧:
46 * 設定可能な構文強調機能。
47 * 設定可能なキーボードアクセラレータ。
48 * マルチプラットフォーム - unix と windows の両者で動作。
49 * プラグイン: C あるいは Python で作成可能。
50 * メインメニューおよびコンテキストメニューから設定可能なツールを利用可能。
51   Python あるいは lua 、シェルスクリプトで作成可能。
52 * 正規表現による検索/置換、grep と find のフロントエンド、組み込みファイルセレクタなどなど。
53
54
55%prep
56%setup -q
57#sed -i 's|fr|fr\nja|g' po/LINGUAS
58
59#%__cp -f %{SOURCE1} po/ja.po
60
61%build
62%configure
63make %{?_smp_mflags}
64
65%install
66rm -rf %{buildroot}
67make install DESTDIR=$RPM_BUILD_ROOT
68
69desktop-file-install --vendor=""                          \
70        --dir=${RPM_BUILD_ROOT}%{_datadir}/applications   \
71        --mode 0644                                       \
72        $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
73
74%post
75update-desktop-database %{_datadir}/applications
76touch --no-create %{_datadir}/icons/hicolor
77if [ -x /usr/bin/gtk-update-icon-cache ]; then
78  gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
79fi
80
81%postun
82update-desktop-database %{_datadir}/applications
83touch --no-create %{_datadir}/icons/hicolor
84if [ -x /usr/bin/gtk-update-icon-cache ]; then
85  gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
86fi
87
88%clean
89rm -rf %{buildroot}
90
91%files
92%defattr(-,root,root)
93%doc COPYING README
94%{_bindir}/*
95%{_datadir}/applications/%{name}.desktop
96%{_datadir}/%{name}-1/*
97%{_datadir}/icons/hicolor/48x48/
98%exclude %{_datadir}/icons/hicolor/icon-theme.cache
99%{_datadir}/locale/*
100%{_docdir}/%{name}-1/*
101%{_mandir}/man?/
102
103%changelog
104* Sat May 31 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.2.0-1
105- new upstream release
106- dropt Source1 to merge upstream
107
108* Sat Mar 15 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.1-2
109- rebuilt with new toolchain
110
111* Sun Aug 05 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.1-1
112- new upstream release
113- added Source1
114
115* Sat Mar 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.0-1
116- new upstream release
117- dropt Source1 to merge upstream
118
119* Tue Feb 21 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.5-2
120- rebuilt with python-2.7
121
122* Sat Oct 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.5-1
123- new upstream release
124
125* Sun Sep 18 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.4-1
126- new upstream release
127
128* Sat Apr 30 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.3-1
129- new upstream release
130
131* Mon Feb 28 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1-1
132- new upstream release
133
134* Sat Feb 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.0-1
135- new upstream release
136- updated Source1
137- dropt BuildRequires: cmake
138- added BuildRequires: libSM-devel
139- fixed %%files
140
141* Sun Oct 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-2
142- updated Source1
143
144* Fri Oct 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-1
145- new upstream release
146- cleaned up spec
147
148* Sat Jul 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-2
149- updated Source1
150- added BuildRequires: cairo-devel, gettext, libX11-devel, perl-XML-Parser, pango-devel
151- changed BuildRequires: cmake >= 2.6
152
153* Wed May 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-1
154- new upstream release
155- added Japanese language file
156- added man directory in %files
157
158* Sun Mar 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
159- new upstream release
160- applied new naming policy to spec
161
162* Fri Mar 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.0-1
163- initial build for VineSeed
164
165* Mon Jan 21 2008 Funda Wang <fundawang@mandriva.org> 0.9.2-1mdv2008.1
166+ Revision: 155675
167- New version 0.9.2
168- rediff patch0
169
170  + Olivier Blin <oblin@mandriva.com>
171    - restore BuildRoot
172
173  + Thierry Vignaud <tvignaud@mandriva.com>
174    - kill re-definition of %%buildroot on Pixel's request
175
176* Sat Dec 01 2007 Funda Wang <fundawang@mandriva.org> 0.9.0-1mdv2008.1
177+ Revision: 114221
178- New version 0.9.0
179
180* Sat Nov 17 2007 Jérôme Soyer <saispo@mandriva.org> 0.8.11-1mdv2008.1
181+ Revision: 109208
182- New release 0.8.11
183
184* Tue Aug 07 2007 Funda Wang <fundawang@mandriva.org> 0.8.10-1mdv2008.0
185+ Revision: 59667
186- New version 0.8.10
187
188* Wed Aug 01 2007 Funda Wang <fundawang@mandriva.org> 0.8.9-1mdv2008.0
189+ Revision: 57568
190- New version 0.8.9
191
192* Thu Jul 12 2007 Funda Wang <fundawang@mandriva.org> 0.8.8-1mdv2008.0
193+ Revision: 51500
194- Fix file list
195- New version
196
197* Thu Jun 14 2007 Funda Wang <fundawang@mandriva.org> 0.8.6-1mdv2008.0
198+ Revision: 39539
199- SILent renew tarball
200- New version
201- New version
202  add dirty patch that skips update-icon-cache and mime database when building
203
204  + Jérôme Soyer <saispo@mandriva.org>
205    - Import medit
206
207
208
209
210* Tue May 09 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.98-1mdk
211- new release
212
213* Mon May 08 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.97-1mdk
214- first spec for Mandriva
Note: See TracBrowser for help on using the repository browser.