source: projects/specs/trunk/m/medit/medit-vl.spec @ 10766

Revision 10766, 6.3 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%define name     medit
2%define version  1.2.0
3
4Name:        %{name}
5Version:     %{version}
6Release:     2%{?_dist_release}
7Summary:     Multiplatform GTK+2 text editor
8Summary(ja): マルチプラットフォームな GTK+2 テキストエディタ
9Group:       Applications/Editors
10License:     GPLv2+
11URL:         http://mooedit.sourceforge.net/
12Source0:     http://prdownloads.sourceforge.net/mooedit/%{name}-%{version}.tar.bz2
13#Source1:     medit_new_ja.po
14
15BuildRoot:   %{_tmppath}/%{name}-%{version}-root
16
17Buildrequires:   cairo-devel
18BuildRequires:   desktop-file-utils
19BuildRequires:   gettext
20BuildRequires:   gtk2-devel glib2-devel
21BuildRequires:   intltool
22BuildRequires:   libxml2-devel
23BuildRequires:   libX11-devel libXext-devel libICE-devel
24BuildRequires:   libSM-devel
25Buildrequires:   perl-XML-Parser pango-devel
26BuildRequires:   pcre-devel
27BuildRequires:   python-devel
28BuildRequires:   pygtk2-devel
29
30%description
31Medit is a multiplatform GTK+2 text editor.
32
33Features:
34 * Configurable syntax highlighting.
35 * Configurable keyboard accelerators.
36 * Multiplatform - works both on unix and windows.
37 * Plugins: can be written in C or Python.
38 * Configurable tools available from the main and context menus.
39   They can be written in Python or Lua, or it can be a shell script.
40 * Regular expression search/replace, grep and find frontends, builtin file selector, etc.
41
42%description -l ja
43Medit はマルチプラットフォームな GTK+2 テキストエディタです。
44
45機能一覧:
46 * 設定可能な構文強調機能。
47 * 設定可能なキーボードアクセラレータ。
48 * マルチプラットフォーム - unix と windows の両者で動作。
49 * プラグイン: C あるいは Python で作成可能。
50 * メインメニューおよびコンテキストメニューから設定可能なツールを利用可能。
51   Python あるいは lua 、シェルスクリプトで作成可能。
52 * 正規表現による検索/置換、grep と find のフロントエンド、組み込みファイルセレクタなどなど。
53
54
55%prep
56%setup -q
57#sed -i 's|fr|fr\nja|g' po/LINGUAS
58
59#%__cp -f %{SOURCE1} po/ja.po
60
61%build
62%configure
63make %{?_smp_mflags}
64
65%install
66rm -rf %{buildroot}
67make install DESTDIR=$RPM_BUILD_ROOT
68
69desktop-file-install --vendor=""                          \
70        --dir=${RPM_BUILD_ROOT}%{_datadir}/applications   \
71        --mode 0644                                       \
72        $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
73
74%post
75update-desktop-database %{_datadir}/applications
76touch --no-create %{_datadir}/icons/hicolor
77if [ -x /usr/bin/gtk-update-icon-cache ]; then
78  gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
79fi
80
81%postun
82update-desktop-database %{_datadir}/applications
83touch --no-create %{_datadir}/icons/hicolor
84if [ -x /usr/bin/gtk-update-icon-cache ]; then
85  gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
86fi
87
88%clean
89rm -rf %{buildroot}
90
91%files
92%defattr(-,root,root)
93%doc COPYING README
94%{_bindir}/*
95%{_datadir}/applications/%{name}.desktop
96%{_datadir}/%{name}-1/*
97%{_datadir}/icons/hicolor/48x48/
98%exclude %{_datadir}/icons/hicolor/icon-theme.cache
99%{_datadir}/locale/*
100%{_docdir}/%{name}-1/*
101%{_mandir}/man?/
102
103%changelog
104* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.2.0-2
105- rebuild with gcc-5.4.0
106
107* Sat May 31 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.2.0-1
108- new upstream release
109- dropt Source1 to merge upstream
110
111* Sat Mar 15 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.1-2
112- rebuilt with new toolchain
113
114* Sun Aug 05 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.1-1
115- new upstream release
116- added Source1
117
118* Sat Mar 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.0-1
119- new upstream release
120- dropt Source1 to merge upstream
121
122* Tue Feb 21 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.5-2
123- rebuilt with python-2.7
124
125* Sat Oct 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.5-1
126- new upstream release
127
128* Sun Sep 18 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.4-1
129- new upstream release
130
131* Sat Apr 30 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.3-1
132- new upstream release
133
134* Mon Feb 28 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1-1
135- new upstream release
136
137* Sat Feb 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.0-1
138- new upstream release
139- updated Source1
140- dropt BuildRequires: cmake
141- added BuildRequires: libSM-devel
142- fixed %%files
143
144* Sun Oct 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-2
145- updated Source1
146
147* Fri Oct 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-1
148- new upstream release
149- cleaned up spec
150
151* Sat Jul 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-2
152- updated Source1
153- added BuildRequires: cairo-devel, gettext, libX11-devel, perl-XML-Parser, pango-devel
154- changed BuildRequires: cmake >= 2.6
155
156* Wed May 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-1
157- new upstream release
158- added Japanese language file
159- added man directory in %files
160
161* Sun Mar 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
162- new upstream release
163- applied new naming policy to spec
164
165* Fri Mar 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.0-1
166- initial build for VineSeed
167
168* Mon Jan 21 2008 Funda Wang <fundawang@mandriva.org> 0.9.2-1mdv2008.1
169+ Revision: 155675
170- New version 0.9.2
171- rediff patch0
172
173  + Olivier Blin <oblin@mandriva.com>
174    - restore BuildRoot
175
176  + Thierry Vignaud <tvignaud@mandriva.com>
177    - kill re-definition of %%buildroot on Pixel's request
178
179* Sat Dec 01 2007 Funda Wang <fundawang@mandriva.org> 0.9.0-1mdv2008.1
180+ Revision: 114221
181- New version 0.9.0
182
183* Sat Nov 17 2007 Jérôme Soyer <saispo@mandriva.org> 0.8.11-1mdv2008.1
184+ Revision: 109208
185- New release 0.8.11
186
187* Tue Aug 07 2007 Funda Wang <fundawang@mandriva.org> 0.8.10-1mdv2008.0
188+ Revision: 59667
189- New version 0.8.10
190
191* Wed Aug 01 2007 Funda Wang <fundawang@mandriva.org> 0.8.9-1mdv2008.0
192+ Revision: 57568
193- New version 0.8.9
194
195* Thu Jul 12 2007 Funda Wang <fundawang@mandriva.org> 0.8.8-1mdv2008.0
196+ Revision: 51500
197- Fix file list
198- New version
199
200* Thu Jun 14 2007 Funda Wang <fundawang@mandriva.org> 0.8.6-1mdv2008.0
201+ Revision: 39539
202- SILent renew tarball
203- New version
204- New version
205  add dirty patch that skips update-icon-cache and mime database when building
206
207  + Jérôme Soyer <saispo@mandriva.org>
208    - Import medit
209
210
211
212
213* Tue May 09 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.98-1mdk
214- new release
215
216* Mon May 08 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.97-1mdk
217- first spec for Mandriva
Note: See TracBrowser for help on using the repository browser.