source: projects/specs/trunk/m/medit/medit-vl.spec @ 8307

Revision 8307, 6.1 KB checked in by kudoh, 10 years ago (diff)

rebuilt and new upstream release

Line 
1%define name     medit
2%define version  1.1.1
3
4Name:        %{name}
5Version:     %{version}
6Release:     2%{?_dist_release}
7Summary:     Multiplatform GTK+2 text editor
8Summary(ja): マルチプラットフォームな GTK+2 テキストエディタ
9Group:       Applications/Editors
10License:     GPLv2+
11URL:         http://mooedit.sourceforge.net/
12Source0:     http://prdownloads.sourceforge.net/mooedit/%{name}-%{version}.tar.bz2
13Source1:     medit_new_ja.po
14
15BuildRoot:   %{_tmppath}/%{name}-%{version}-root
16
17Buildrequires:   cairo-devel
18BuildRequires:   desktop-file-utils
19BuildRequires:   gettext
20BuildRequires:   gtk2-devel glib2-devel
21BuildRequires:   intltool
22BuildRequires:   libxml2-devel
23BuildRequires:   libX11-devel libXext-devel libICE-devel
24BuildRequires:   libSM-devel
25Buildrequires:   perl-XML-Parser pango-devel
26BuildRequires:   pcre-devel
27BuildRequires:   python-devel
28BuildRequires:   pygtk2-devel
29
30%description
31Medit is a multiplatform GTK+2 text editor.
32
33Features:
34 * Configurable syntax highlighting.
35 * Configurable keyboard accelerators.
36 * Multiplatform - works both on unix and windows.
37 * Plugins: can be written in C or Python.
38 * Configurable tools available from the main and context menus.
39   They can be written in Python or Lua, or it can be a shell script.
40 * Regular expression search/replace, grep and find frontends, builtin file selector, etc.
41
42%description -l ja
43Medit はマルチプラットフォームな GTK+2 テキストエディタです。
44
45機能一覧:
46 * 設定可能な構文強調機能。
47 * 設定可能なキーボードアクセラレータ。
48 * マルチプラットフォーム - unix と windows の両者で動作。
49 * プラグイン: C あるいは Python で作成可能。
50 * メインメニューおよびコンテキストメニューから設定可能なツールを利用可能。
51   Python あるいは lua 、シェルスクリプトで作成可能。
52 * 正規表現による検索/置換、grep と find のフロントエンド、組み込みファイルセレクタなどなど。
53
54
55%prep
56%setup -q
57#sed -i 's|fr|fr\nja|g' po/LINGUAS
58
59%__cp -f %{SOURCE1} po/ja.po
60
61%build
62%configure
63make %{?_smp_mflags}
64
65%install
66rm -rf %{buildroot}
67make install DESTDIR=$RPM_BUILD_ROOT
68
69desktop-file-install --vendor=""                          \
70        --dir=${RPM_BUILD_ROOT}%{_datadir}/applications   \
71        --mode 0644                                       \
72        $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
73
74%post
75update-desktop-database %{_datadir}/applications
76touch --no-create %{_datadir}/icons/hicolor
77if [ -x /usr/bin/gtk-update-icon-cache ]; then
78  gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
79fi
80
81%postun
82update-desktop-database %{_datadir}/applications
83touch --no-create %{_datadir}/icons/hicolor
84if [ -x /usr/bin/gtk-update-icon-cache ]; then
85  gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
86fi
87
88%clean
89rm -rf %{buildroot}
90
91%files
92%defattr(-,root,root)
93%doc COPYING README
94%{_bindir}/*
95%{_datadir}/applications/%{name}.desktop
96%{_datadir}/%{name}-1/*
97%{_datadir}/icons/hicolor/48x48/
98%exclude %{_datadir}/icons/hicolor/icon-theme.cache
99%{_datadir}/locale/*
100%{_docdir}/%{name}-1/*
101%{_mandir}/man?/
102
103%changelog
104* Sat Mar 15 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.1-2
105- rebuilt with new toolchain
106
107* Sun Aug 05 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.1-1
108- new upstream release
109- added Source1
110
111* Sat Mar 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.0-1
112- new upstream release
113- dropt Source1 to merge upstream
114
115* Tue Feb 21 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.5-2
116- rebuilt with python-2.7
117
118* Sat Oct 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.5-1
119- new upstream release
120
121* Sun Sep 18 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.4-1
122- new upstream release
123
124* Sat Apr 30 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.3-1
125- new upstream release
126
127* Mon Feb 28 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1-1
128- new upstream release
129
130* Sat Feb 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.0-1
131- new upstream release
132- updated Source1
133- dropt BuildRequires: cmake
134- added BuildRequires: libSM-devel
135- fixed %%files
136
137* Sun Oct 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-2
138- updated Source1
139
140* Fri Oct 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-1
141- new upstream release
142- cleaned up spec
143
144* Sat Jul 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-2
145- updated Source1
146- added BuildRequires: cairo-devel, gettext, libX11-devel, perl-XML-Parser, pango-devel
147- changed BuildRequires: cmake >= 2.6
148
149* Wed May 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-1
150- new upstream release
151- added Japanese language file
152- added man directory in %files
153
154* Sun Mar 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
155- new upstream release
156- applied new naming policy to spec
157
158* Fri Mar 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.0-1
159- initial build for VineSeed
160
161* Mon Jan 21 2008 Funda Wang <fundawang@mandriva.org> 0.9.2-1mdv2008.1
162+ Revision: 155675
163- New version 0.9.2
164- rediff patch0
165
166  + Olivier Blin <oblin@mandriva.com>
167    - restore BuildRoot
168
169  + Thierry Vignaud <tvignaud@mandriva.com>
170    - kill re-definition of %%buildroot on Pixel's request
171
172* Sat Dec 01 2007 Funda Wang <fundawang@mandriva.org> 0.9.0-1mdv2008.1
173+ Revision: 114221
174- New version 0.9.0
175
176* Sat Nov 17 2007 Jérôme Soyer <saispo@mandriva.org> 0.8.11-1mdv2008.1
177+ Revision: 109208
178- New release 0.8.11
179
180* Tue Aug 07 2007 Funda Wang <fundawang@mandriva.org> 0.8.10-1mdv2008.0
181+ Revision: 59667
182- New version 0.8.10
183
184* Wed Aug 01 2007 Funda Wang <fundawang@mandriva.org> 0.8.9-1mdv2008.0
185+ Revision: 57568
186- New version 0.8.9
187
188* Thu Jul 12 2007 Funda Wang <fundawang@mandriva.org> 0.8.8-1mdv2008.0
189+ Revision: 51500
190- Fix file list
191- New version
192
193* Thu Jun 14 2007 Funda Wang <fundawang@mandriva.org> 0.8.6-1mdv2008.0
194+ Revision: 39539
195- SILent renew tarball
196- New version
197- New version
198  add dirty patch that skips update-icon-cache and mime database when building
199
200  + Jérôme Soyer <saispo@mandriva.org>
201    - Import medit
202
203
204
205
206* Tue May 09 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.98-1mdk
207- new release
208
209* Mon May 08 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.97-1mdk
210- first spec for Mandriva
Note: See TracBrowser for help on using the repository browser.