source: projects/specs/trunk/m/mdadm/mdadm-vl.spec @ 8346

Revision 8346, 10.4 KB checked in by tomop, 10 years ago (diff)

mdadm-3.3-1

Line 
1%define _tmpfilesdir %{_sysconfdir}/tmpfiles.d
2%define _udevrulesdir /lib/udev/rules.d
3
4Summary:     Utilities for Linux md devices (software RAID arrays)
5Summary(ja): Linux の MD デバイス(ソフトウエアRAIDアレイ)用のユーティリティ
6Name:        mdadm
7Version:     3.3
8Release:     1%{?_dist_release}
9Source:      http://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.xz
10Source1:     mdmonitor.init
11Source2:     raid-check
12Source3:     mdadm.rules
13Source4:     mdadm-raid-check-sysconfig
14Source5:     mdadm-cron
15Source6:     mdmonitor.service
16Source7:     mdadm.conf
17Source8:     mdadm_event.conf
18Patch1:      mdadm-3.3-Be-consistent-in-return-types-from-byteswap-macros.patch
19Patch93:     mdadm-3.2.6-Remove-offroot-argument-and-default-to-always-settin.patch
20Patch94:     mdadm-3.2.6-Add-support-for-launching-mdmon-via-systemctl-instea.patch
21Patch95:     mdadm-3.2.6-In-case-launching-mdmon-fails-print-an-error-message.patch
22Patch96:     mdadm-3.2.6-mdmon-add-foreground-option.patch
23# Fedora customization patches
24Patch97:     mdadm-3.3-udev.patch
25Patch98:     mdadm-2.5.2-static.patch
26URL:         http://www.kernel.org/pub/linux/utils/raid/mdadm/
27License:     GPL
28Group:       System Environment/Base
29BuildRoot:   %{_tmppath}/%{name}-%{version}-root
30Obsoletes:   mdctl,raidtools
31Requires:    smtpdaemon
32BuildRequires: glibc-static
33
34Vendor: Project Vine
35Distribution: Vine Linux
36
37%description
38mdadm is used to create, manage, and monitor Linux MD (software RAID)
39devices.  As such, it provides similar functionality to the raidtools
40package.  However, mdadm is a single program, and it can perform
41almost all functions without a configuration file, though a configuration
42file can be used to help with some common tasks.
43
44%prep
45%setup -q
46
47%patch1 -p1 -b .types
48# Fedora customization patches
49%patch97 -p1 -b .udev
50%patch98 -p1 -b .static
51
52%build
53make %{?_smp_mflags} CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}" mdadm mdmon
54
55%install
56rm -rf %{buildroot}
57
58#make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=%{_sbindir} SYSTEMD_DIR=%{_unitdir} install install-systemd
59make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=/sbin install
60install -Dp -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/raid-check
61install -Dp -m 644 %{SOURCE3} %{buildroot}%{_udevrulesdir}/65-md-incremental.rules
62install -Dp -m 644 %{SOURCE4} %{buildroot}%{_sysconfdir}/sysconfig/raid-check
63install -Dp -m 644 %{SOURCE5} %{buildroot}%{_sysconfdir}/cron.d/raid-check
64
65# tmpfile
66mkdir -p %{buildroot}%{_tmpfilesdir}
67install -m 0644 %{SOURCE7} %{buildroot}%{_tmpfilesdir}/%{name}.conf
68mkdir -p %{buildroot}%{_localstatedir}/run/
69install -d -m 0710 %{buildroot}%{_localstatedir}/run/%{name}/
70
71# initscript
72mkdir -p %{buildroot}%{_initdir}
73install -m755 %{SOURCE1} %{buildroot}%{_initdir}/mdmonitor
74
75# systemd
76#mkdir -p %{buildroot}%{_unitdir}
77#install -m644 %{SOURCE6} %{buildroot}%{_unitdir}
78
79# abrt
80#mkdir -p %{buildroot}/etc/libreport/events.d
81#install -m644 %{SOURCE8} %{buildroot}/etc/libreport/events.d
82
83
84%clean
85rm -rf %{buildroot}
86
87%post
88/sbin/chkconfig --add mdmonitor
89
90%preun
91if [ "$1" = 0 ]; then
92        service mdmonitor stop > /dev/null 2>&1 ||:
93        /sbin/chkconfig --del mdmonitor
94fi
95if [ -e %{_initrddir}/mdmpd ]; then
96        service mdmpd stop > /dev/null 2>&1 ||:
97        /sbin/chkconfig --del mdmpd
98fi
99
100%postun
101if [ "$1" -ge "1" ]; then
102        service mdmonitor condrestart > /dev/null 2>&1
103fi
104
105%files
106%defattr(-,root,root)
107%doc TODO ChangeLog mdadm.conf-example COPYING misc/*
108/sbin/*
109%{_sbindir}/*
110%{_initdir}/*
111%{_mandir}/man*/md*
112%{_udevrulesdir}/*
113%config(noreplace) %{_sysconfdir}/sysconfig/*
114%config(noreplace) %{_sysconfdir}/cron.d/*
115%dir %{_localstatedir}/run/%{name}/
116%config(noreplace) %{_tmpfilesdir}/%{name}.conf
117
118%changelog
119* Fri Jan 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3-1
120- new upstream release.
121
122* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.9-4
123- rebuild with VineSeed environment
124
125* Mon Apr 18 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.9-3
126- added BR: glibc-static
127
128* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.9-2
129- rebuilt with rpm-4.8.1-3
130
131* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.9-1
132- new upstream release
133
134* Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1vl5
135- applied new versioning policy, spec in utf-8
136
137* Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
138- new upstream release
139
140* Wed Aug 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.3-0vl1
141- initial build for Vine Linux
142
143* Mon Aug  7 2006 Doug Ledford <dledford@redhat.com> - 2.5.3-1
144- Update to 2.5.3 which upstream calls a "bug fix" release
145
146* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.2-1.1
147- rebuild
148
149* Fri Jul  7 2006 Doug Ledford <dledford@redhat.com> - 2.5.2-1
150- Update to 2.5.2
151- Remove auto default patch as upstream now has a preferred default auto method
152
153* Wed Mar  8 2006 Peter Jones <pjones@redhat.com> - 2.3.1-3
154- fix build on ppc64
155
156* Wed Mar  8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-2
157- fix build on ppc
158
159* Wed Mar  8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-1
160- update to 2.3.1 to fix raid5 (#184284)
161
162* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2.1
163- bump again for double-long bug on ppc(64)
164
165* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2
166- rebuilt for new gcc4.1 snapshot and glibc changes
167
168* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
169- rebuilt
170
171* Mon Dec 05 2005 Warren Togami <wtogami@redhat.com> 2.2-1
172- 2.2 upgrade (#167897)
173- disable diet because we don't ship it anymore
174  and we don't actually use mdassemble now
175
176* Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-4.fc4
177- Make the mdmonitor init script use the pid-file option, major cleanup
178  of the script now possible (#134459)
179
180* Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-3.fc4
181- Put back the obsoletes: raidtools that was present in 1.11.0-1.fc4
182
183* Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-2.fc4
184- Change the default auto= mode so it need not be on the command line to
185  work with udev, however it is still supported on the command line (#132706)
186- Add a man page (from Luca Berra) for mdassemble
187
188* Wed May 11 2005 Doug Ledford <dledford@redhat.com> - 1.11.0-1.fc4
189- Upgrade to 1.11.0
190
191* Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 1.9.0-3.fc4
192- fix mdmonitor initscript (#144717)
193
194* Mon Mar 21 2005 Doug Ledford <dledford@redhat.com> 1.9.0-2
195- Build mdadm.static and mdassemble (static as well) to be used in initrd
196  images
197
198* Wed Mar 09 2005 Doug Ledford <dledford@redhat.com> 1.9.0-1
199- Initial upgrade to 1.9.0 and update of doc files
200- Fix an s390 build error
201
202* Mon Oct 04 2004 Doug Ledford <dledford@redhat.com> 1.6.0-2
203- Remove /etc/mdadm.conf from the file list.  Anaconda will write one out
204  if it's needed.
205
206* Fri Oct 01 2004 Doug Ledford <dledford@redhat.com> 1.6.0-1
207- Update to newer upstream version
208- Make mdmpd work on kernels that don't have the event interface patch
209
210* Fri Jul 30 2004 Dan Walsh <dwalsh@redhat.com> 1.5.0-11
211- Create a directory /var/run/mdadm to contain mdadm.pid
212- This cleans up SELinux problem
213
214* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
215- rebuilt
216
217* Sat May 22 2004 Doug Ledford <dledford@redhat.com> - 1.5.0-9
218- Fix Makefile and build method to satisfy bz #123769
219- Add mdmpd man page, update mdmpd version to 0.3 - bz #117160
220- Make sure mdadm --monitor closes all md device files so that md devices
221  can be stopped while mdadm is still running - bz #119532
222
223* Thu May 20 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-8
224- remove unneeded patch, can use --run instead
225
226* Wed May 19 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-7
227- add patch with reallyforce mode on creation to be used by anaconda
228
229* Wed May 12 2004 Doug Ledford <dledford@redhat.com> 2.5.0-6
230- Fix a bug in the %postun scriptlet related to downgrading to a version
231  of mdadm that doesn't include the mdmpd daemon.
232
233* Fri May 07 2004 Doug Ledford <dledford@redhat.com> 1.5.0-5
234- Disable service mdmpd by default to avoid [Failed] messages on
235  current 2.6 kernels.  Possibly re-enable it by default once the
236  2.6 kernels have the md event interface.
237
238* Thu Apr 22 2004 Doug Ledford <dledford@redhat.com> 1.5.0-4
239- Update mdmonitor script to start daemon more cleanly
240- Repackage mdmpd tarball to include gcc-3.4 changes and to make
241  mdmpd properly daemonize at startup instead of forking and leaving
242  the child attached to the terminal.
243
244* Thu Mar  4 2004 Bill Nottingham <notting@redhat.com> 1.5.0-3
245- ship /var/run/mpmpd (#117497)
246
247* Thu Feb 26 2004 Doug Ledford <dledford@redhat.com> 1.5.0-2
248- Add a default MAILADDR line to the mdadm.conf file installed by default
249  (Bugzilla #92447)
250- Make it build with gcc-3.4
251
252* Mon Feb 23 2004 Doug Ledford <dledford@redhat.com> 1.5.0-1
253- Update to 1.5.0 (from Matthew J. Galgoci <mgalgoci@redhat.com>)
254
255* Sun Nov 16 2003 Doug Ledford <dledford@redhat.com> 1.4.0-1
256- fix problem with recovery thread sleeping in mdmpd
257
258* Fri Nov 14 2003 Doug Ledford <dledford@redhat.com>
259- sync upstream
260- add mdmpd package into mdadm package
261
262* Wed Sep 10 2003 Michael K. Johnson <johnsonm@redhat.com> 1.3.0-1
263- sync upstream
264
265* Tue Mar 11 2003 Michael K. Johnson <johnsonm@redhat.com> 1.1.0-1
266- sync upstream
267
268* Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 1.0.1-1
269- update for rebuild
270
271* Wed Dec 25 2002 Tim Powers <timp@redhat.com> 1.0.0-8
272- fix references to %%install in the changelog so that it will build
273
274* Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.0.0-7
275- Rebuild
276
277* Fri Jul 12 2002 Michael K. Johnson <johnsonm@redhat.com>
278- Changed RPM Group to System Environment/Base
279
280* Wed May 15 2002 Michael K. Johnson <johnsonm@redhat.com>
281- minor cleanups to the text, conditionalize rm -rf
282- added mdmonitor init script
283
284* Fri May 10 2002  <neilb@cse.unsw.edu.au>
285- update to 1.0.0
286- Set CXFLAGS instead of CFLAGS
287
288* Sat Apr  6 2002  <neilb@cse.unsw.edu.au>
289- change %%install to use "make install"
290
291* Fri Mar 15 2002  <gleblanc@localhost.localdomain>
292- beautification
293- made mdadm.conf non-replaceable config
294- renamed Copyright to License in the header
295- added missing license file
296- used macros for file paths
297
298* Fri Mar 15 2002 Luca Berra <bluca@comedia.it>
299- Added Obsoletes: mdctl
300- missingok for configfile
301
302* Tue Mar 12 2002 NeilBrown <neilb@cse.unsw.edu.au>
303- Add md.4 and mdadm.conf.5 man pages
304
305* Fri Mar 08 2002               Chris Siebenmann <cks@cquest.utoronto.ca>
306- builds properly as non-root.
307
308* Fri Mar 08 2002 Derek Vadala <derek@cynicism.com>
309- updated for 0.7, fixed /usr/share/doc and added manpage
310
311* Tue Aug 07 2001 Danilo Godec <danci@agenda.si>
312- initial RPM build
Note: See TracBrowser for help on using the repository browser.