source: projects/specs/trunk/m/mdadm/mdadm-vl.spec @ 11538

Revision 11538, 10.4 KB checked in by tomop, 6 years ago (diff)

mdadm-4.0-1

Line 
1%define _tmpfilesdir %{_sysconfdir}/tmpfiles.d
2%define _udevrulesdir /lib/udev/rules.d
3
4Summary:     Utilities for Linux md devices (software RAID arrays)
5Summary(ja): Linux の MD デバイス(ソフトウエアRAIDアレイ)用のユーティリティ
6Name:        mdadm
7Version:     4.0
8Release:     1%{?_dist_release}
9Source:      https://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.xz
10Source1:     mdmonitor.init
11Source2:     raid-check
12Source3:     mdadm.rules
13Source4:     mdadm-raid-check-sysconfig
14Source5:     mdadm-cron
15Source6:     mdmonitor.service
16Source7:     mdadm.conf
17Source8:     mdadm_event.conf
18Patch93:     add-Wimplicit-fallthrough-0-in-Makefile.patch
19Patch94:     forced-type-conversion-to-avoid-truncation.patch
20Patch95:     replace-snprintf-with-strncpy-at-some-places.patch
21Patch96:     specify-enough-length-when-write-to-buffer.patch
22Patch97:     mdadm-3.3-udev.patch
23Patch98:     mdadm-2.5.2-static.patch
24URL:         http://www.kernel.org/pub/linux/utils/raid/mdadm/
25License:     GPL
26Group:       System Environment/Base
27BuildRoot:   %{_tmppath}/%{name}-%{version}-root
28Obsoletes:   mdctl,raidtools
29Requires:    smtpdaemon
30BuildRequires: glibc-static
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36mdadm is used to create, manage, and monitor Linux MD (software RAID)
37devices.  As such, it provides similar functionality to the raidtools
38package.  However, mdadm is a single program, and it can perform
39almost all functions without a configuration file, though a configuration
40file can be used to help with some common tasks.
41
42%prep
43%setup -q
44
45# Fedora customization patches
46%patch93 -p1 -b .fallthrough
47%patch94 -p1 -b .forced
48%patch95 -p1 -b .replace
49%patch96 -p1 -b .buffer
50%patch97 -p1 -b .udev
51%patch98 -p1 -b .static
52
53%build
54make %{?_smp_mflags} CXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS" SYSCONFDIR="%{_sysconfdir}" mdadm mdmon
55
56%install
57rm -rf %{buildroot}
58
59#make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=%{_sbindir} SYSTEMD_DIR=%{_unitdir} install install-systemd
60make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=/sbin install
61install -Dp -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/raid-check
62install -Dp -m 644 %{SOURCE3} %{buildroot}%{_udevrulesdir}/65-md-incremental.rules
63install -Dp -m 644 %{SOURCE4} %{buildroot}%{_sysconfdir}/sysconfig/raid-check
64install -Dp -m 644 %{SOURCE5} %{buildroot}%{_sysconfdir}/cron.d/raid-check
65
66# tmpfile
67mkdir -p %{buildroot}%{_tmpfilesdir}
68install -m 0644 %{SOURCE7} %{buildroot}%{_tmpfilesdir}/%{name}.conf
69
70mkdir -p %{buildroot}%{_localstatedir}/run/
71install -d -m 0710 %{buildroot}%{_localstatedir}/run/%{name}/
72
73# initscript
74mkdir -p %{buildroot}%{_initdir}
75install -m755 %{SOURCE1} %{buildroot}%{_initdir}/mdmonitor
76
77# systemd
78#mkdir -p %{buildroot}%{_unitdir}
79#install -m644 %{SOURCE6} %{buildroot}%{_unitdir}
80
81# abrt
82#mkdir -p %{buildroot}/etc/libreport/events.d
83#install -m644 %{SOURCE8} %{buildroot}/etc/libreport/events.d
84
85
86%clean
87rm -rf %{buildroot}
88
89%post
90/sbin/chkconfig --add mdmonitor
91
92%preun
93if [ "$1" = 0 ]; then
94        service mdmonitor stop > /dev/null 2>&1 ||:
95        /sbin/chkconfig --del mdmonitor
96fi
97if [ -e %{_initrddir}/mdmpd ]; then
98        service mdmpd stop > /dev/null 2>&1 ||:
99        /sbin/chkconfig --del mdmpd
100fi
101
102%postun
103if [ "$1" -ge "1" ]; then
104        service mdmonitor condrestart > /dev/null 2>&1
105fi
106
107%files
108%defattr(-,root,root)
109%doc TODO ChangeLog mdadm.conf-example COPYING misc/*
110/sbin/*
111%{_sbindir}/*
112%{_initdir}/*
113%{_mandir}/man*/md*
114%{_udevrulesdir}/*
115%config(noreplace) %{_sysconfdir}/sysconfig/*
116%config(noreplace) %{_sysconfdir}/cron.d/*
117%dir %{_localstatedir}/run/%{name}/
118%config(noreplace) %{_tmpfilesdir}/%{name}.conf
119
120%changelog
121* Sat Feb 24 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0-1
122- new upstream release.
123
124* Fri Jan 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3-1
125- new upstream release.
126
127* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.9-4
128- rebuild with VineSeed environment
129
130* Mon Apr 18 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.9-3
131- added BR: glibc-static
132
133* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.9-2
134- rebuilt with rpm-4.8.1-3
135
136* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.9-1
137- new upstream release
138
139* Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1vl5
140- applied new versioning policy, spec in utf-8
141
142* Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
143- new upstream release
144
145* Wed Aug 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.3-0vl1
146- initial build for Vine Linux
147
148* Mon Aug  7 2006 Doug Ledford <dledford@redhat.com> - 2.5.3-1
149- Update to 2.5.3 which upstream calls a "bug fix" release
150
151* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.2-1.1
152- rebuild
153
154* Fri Jul  7 2006 Doug Ledford <dledford@redhat.com> - 2.5.2-1
155- Update to 2.5.2
156- Remove auto default patch as upstream now has a preferred default auto method
157
158* Wed Mar  8 2006 Peter Jones <pjones@redhat.com> - 2.3.1-3
159- fix build on ppc64
160
161* Wed Mar  8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-2
162- fix build on ppc
163
164* Wed Mar  8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-1
165- update to 2.3.1 to fix raid5 (#184284)
166
167* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2.1
168- bump again for double-long bug on ppc(64)
169
170* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2
171- rebuilt for new gcc4.1 snapshot and glibc changes
172
173* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
174- rebuilt
175
176* Mon Dec 05 2005 Warren Togami <wtogami@redhat.com> 2.2-1
177- 2.2 upgrade (#167897)
178- disable diet because we don't ship it anymore
179  and we don't actually use mdassemble now
180
181* Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-4.fc4
182- Make the mdmonitor init script use the pid-file option, major cleanup
183  of the script now possible (#134459)
184
185* Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-3.fc4
186- Put back the obsoletes: raidtools that was present in 1.11.0-1.fc4
187
188* Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-2.fc4
189- Change the default auto= mode so it need not be on the command line to
190  work with udev, however it is still supported on the command line (#132706)
191- Add a man page (from Luca Berra) for mdassemble
192
193* Wed May 11 2005 Doug Ledford <dledford@redhat.com> - 1.11.0-1.fc4
194- Upgrade to 1.11.0
195
196* Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 1.9.0-3.fc4
197- fix mdmonitor initscript (#144717)
198
199* Mon Mar 21 2005 Doug Ledford <dledford@redhat.com> 1.9.0-2
200- Build mdadm.static and mdassemble (static as well) to be used in initrd
201  images
202
203* Wed Mar 09 2005 Doug Ledford <dledford@redhat.com> 1.9.0-1
204- Initial upgrade to 1.9.0 and update of doc files
205- Fix an s390 build error
206
207* Mon Oct 04 2004 Doug Ledford <dledford@redhat.com> 1.6.0-2
208- Remove /etc/mdadm.conf from the file list.  Anaconda will write one out
209  if it's needed.
210
211* Fri Oct 01 2004 Doug Ledford <dledford@redhat.com> 1.6.0-1
212- Update to newer upstream version
213- Make mdmpd work on kernels that don't have the event interface patch
214
215* Fri Jul 30 2004 Dan Walsh <dwalsh@redhat.com> 1.5.0-11
216- Create a directory /var/run/mdadm to contain mdadm.pid
217- This cleans up SELinux problem
218
219* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
220- rebuilt
221
222* Sat May 22 2004 Doug Ledford <dledford@redhat.com> - 1.5.0-9
223- Fix Makefile and build method to satisfy bz #123769
224- Add mdmpd man page, update mdmpd version to 0.3 - bz #117160
225- Make sure mdadm --monitor closes all md device files so that md devices
226  can be stopped while mdadm is still running - bz #119532
227
228* Thu May 20 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-8
229- remove unneeded patch, can use --run instead
230
231* Wed May 19 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-7
232- add patch with reallyforce mode on creation to be used by anaconda
233
234* Wed May 12 2004 Doug Ledford <dledford@redhat.com> 2.5.0-6
235- Fix a bug in the %postun scriptlet related to downgrading to a version
236  of mdadm that doesn't include the mdmpd daemon.
237
238* Fri May 07 2004 Doug Ledford <dledford@redhat.com> 1.5.0-5
239- Disable service mdmpd by default to avoid [Failed] messages on
240  current 2.6 kernels.  Possibly re-enable it by default once the
241  2.6 kernels have the md event interface.
242
243* Thu Apr 22 2004 Doug Ledford <dledford@redhat.com> 1.5.0-4
244- Update mdmonitor script to start daemon more cleanly
245- Repackage mdmpd tarball to include gcc-3.4 changes and to make
246  mdmpd properly daemonize at startup instead of forking and leaving
247  the child attached to the terminal.
248
249* Thu Mar  4 2004 Bill Nottingham <notting@redhat.com> 1.5.0-3
250- ship /var/run/mpmpd (#117497)
251
252* Thu Feb 26 2004 Doug Ledford <dledford@redhat.com> 1.5.0-2
253- Add a default MAILADDR line to the mdadm.conf file installed by default
254  (Bugzilla #92447)
255- Make it build with gcc-3.4
256
257* Mon Feb 23 2004 Doug Ledford <dledford@redhat.com> 1.5.0-1
258- Update to 1.5.0 (from Matthew J. Galgoci <mgalgoci@redhat.com>)
259
260* Sun Nov 16 2003 Doug Ledford <dledford@redhat.com> 1.4.0-1
261- fix problem with recovery thread sleeping in mdmpd
262
263* Fri Nov 14 2003 Doug Ledford <dledford@redhat.com>
264- sync upstream
265- add mdmpd package into mdadm package
266
267* Wed Sep 10 2003 Michael K. Johnson <johnsonm@redhat.com> 1.3.0-1
268- sync upstream
269
270* Tue Mar 11 2003 Michael K. Johnson <johnsonm@redhat.com> 1.1.0-1
271- sync upstream
272
273* Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 1.0.1-1
274- update for rebuild
275
276* Wed Dec 25 2002 Tim Powers <timp@redhat.com> 1.0.0-8
277- fix references to %%install in the changelog so that it will build
278
279* Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.0.0-7
280- Rebuild
281
282* Fri Jul 12 2002 Michael K. Johnson <johnsonm@redhat.com>
283- Changed RPM Group to System Environment/Base
284
285* Wed May 15 2002 Michael K. Johnson <johnsonm@redhat.com>
286- minor cleanups to the text, conditionalize rm -rf
287- added mdmonitor init script
288
289* Fri May 10 2002  <neilb@cse.unsw.edu.au>
290- update to 1.0.0
291- Set CXFLAGS instead of CFLAGS
292
293* Sat Apr  6 2002  <neilb@cse.unsw.edu.au>
294- change %%install to use "make install"
295
296* Fri Mar 15 2002  <gleblanc@localhost.localdomain>
297- beautification
298- made mdadm.conf non-replaceable config
299- renamed Copyright to License in the header
300- added missing license file
301- used macros for file paths
302
303* Fri Mar 15 2002 Luca Berra <bluca@comedia.it>
304- Added Obsoletes: mdctl
305- missingok for configfile
306
307* Tue Mar 12 2002 NeilBrown <neilb@cse.unsw.edu.au>
308- Add md.4 and mdadm.conf.5 man pages
309
310* Fri Mar 08 2002               Chris Siebenmann <cks@cquest.utoronto.ca>
311- builds properly as non-root.
312
313* Fri Mar 08 2002 Derek Vadala <derek@cynicism.com>
314- updated for 0.7, fixed /usr/share/doc and added manpage
315
316* Tue Aug 07 2001 Danilo Godec <danci@agenda.si>
317- initial RPM build
Note: See TracBrowser for help on using the repository browser.