source: projects/specs/trunk/m/mdadm/mdadm-vl.spec @ 12372

Revision 12372, 11.2 KB checked in by tomop, 4 years ago (diff)

updated 14 packages

acpica-tools-20190509-1

ethtool-5.4-1

flac-1.3.3-1

iproute-5.6.0-1

libcap-ng-0.7.10-1

libestr-0.1.11-2

libfastjson-0.99.8-4

libproxy-0.4.15-2

libpwquality-1.4.2-1

libunistring-0.9.10-2

mdadm-4.1-1

python-six-1.14.0-1

rsyslog-8.2002.0-1

speexdsp-1.2-0.16.rc3

Line 
1%bcond_with systemd
2%define _udevrulesdir /lib/udev/rules.d
3
4Summary:        Utilities for Linux md devices (software RAID arrays)
5Summary(ja):    Linux の MD デバイス(ソフトウエアRAIDアレイ)用のユーティリティ
6Name:           mdadm
7Version:        4.1
8Release:        1%{?_dist_release}%{?with_systemd:.systemd}
9Group:          System Environment/Base
10Vendor:         Project Vine
11Distribution:   Vine Linux
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14License:        GPL
15URL:            http://www.kernel.org/pub/linux/utils/raid/mdadm/
16Source:         https://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.xz
17Source1:        mdmonitor.init
18Source2:        raid-check
19Source3:        mdadm.rules
20Source4:        mdadm-raid-check-sysconfig
21Source5:        mdadm-cron
22
23Source103:      mdadm.rules.systemd
24Source104:      mdmonitor.service
25Source105:      mdadm.conf
26Source106:      mdadm_event.conf
27Source107:      raid-check.timer
28Source108:      raid-check.service
29
30Patch97:        mdadm-3.3-udev.patch
31Patch98:        mdadm-2.5.2-static.patch
32
33Obsoletes:      mdctl,raidtools
34Requires:       postfix
35BuildRequires:  glibc-static
36
37%if %{with systemd}
38Requires(post): systemd coreutils
39Requires(preun): systemd
40Requires(postun): systemd coreutils
41%else
42Requires(post): /sbin/chkconfig
43Requires(preun): /sbin/chkconfig
44Requires(preun): /sbin/service
45Requires(postun): /sbin/service
46%endif
47
48%description
49mdadm is used to create, manage, and monitor Linux MD (software RAID)
50devices.  As such, it provides similar functionality to the raidtools
51package.  However, mdadm is a single program, and it can perform
52almost all functions without a configuration file, though a configuration
53file can be used to help with some common tasks.
54
55
56%prep
57%setup -q
58%autopatch -p1
59
60sed -i -e 's/ -Werror / /' Makefile
61
62%build
63make %{?_smp_mflags} CXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS" SYSCONFDIR="%{_sysconfdir}" mdadm mdmon
64
65
66%install
67rm -rf %{buildroot}
68
69%if %{with systemd}
70make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=/sbin SYSTEMD_DIR=%{_unitdir} install install-systemd
71%else
72make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=/sbin install
73%endif
74install -Dp -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/raid-check
75install -Dp -m 644 %{SOURCE4} %{buildroot}%{_sysconfdir}/sysconfig/raid-check
76
77%if %{with systemd}
78install -Dp -m 644 %{SOURCE103} %{buildroot}%{_udevrulesdir}/65-md-incremental.rules
79# systemd
80mkdir -p %{buildroot}%{_unitdir}
81install -m644 %{SOURCE104} %{buildroot}%{_unitdir}
82install -m644 %{SOURCE107} %{buildroot}%{_unitdir}
83install -m644 %{SOURCE108} %{buildroot}%{_unitdir}
84
85# tmpfile
86mkdir -p %{buildroot}%{_tmpfilesdir}
87install -m 0644 %{SOURCE105} %{buildroot}%{_tmpfilesdir}/%{name}.conf
88install -d -m 0710 %{buildroot}/run/%{name}/
89
90# abrt
91#mkdir -p %{buildroot}/etc/libreport/events.d
92#install -m644 %{SOURCE6} %{buildroot}/etc/libreport/events.d
93%else
94# initscript
95mkdir -p %{buildroot}%{_initdir}
96install -m755 %{SOURCE1} %{buildroot}%{_initdir}/mdmonitor
97install -Dp -m 644 %{SOURCE5} %{buildroot}%{_sysconfdir}/cron.d/raid-check
98install -Dp -m 644 %{SOURCE3} %{buildroot}%{_udevrulesdir}/65-md-incremental.rules
99mkdir -p %{buildroot}%{_localstatedir}/run/mdadm
100%endif
101
102
103%clean
104rm -rf %{buildroot}
105
106
107%post
108%if %{with systemd}
109%systemd_post mdmonitor.service raid-check.{service,timer}
110%else
111/sbin/chkconfig --add mdmonitor
112%endif
113
114%preun
115%if %{with systemd}
116%systemd_preun mdmonitor.service raid-check.timer
117%else
118if [ "$1" = 0 -o -x /bin/systemctl ]; then
119        service mdmonitor stop > /dev/null 2>&1 ||:
120        /sbin/chkconfig --del mdmonitor
121fi
122if [ -e %{_initrddir}/mdmpd ]; then
123        service mdmpd stop > /dev/null 2>&1 ||:
124        /sbin/chkconfig --del mdmpd
125fi
126%endif
127
128%postun
129%if %{with systemd}
130%systemd_postun_with_restart mdmonitor.service
131%else
132if [ "$1" -ge "1" ]; then
133        service mdmonitor condrestart > /dev/null 2>&1
134fi
135%endif
136
137
138%files
139%defattr(-,root,root)
140%license COPYING
141%doc mdadm.conf-example misc/*
142/sbin/*
143%{_sbindir}/*
144%if %{with systemd}
145%{_unitdir}/*
146/lib/systemd/system-shutdown/*
147%config(noreplace) %{_tmpfilesdir}/%{name}.conf
148%else
149%{_initdir}/*
150%config(noreplace) %{_sysconfdir}/cron.d/*
151%dir %{_localstatedir}/run/%{name}/
152%endif
153%{_mandir}/man*/md*
154%{_udevrulesdir}/*
155%config(noreplace) %{_sysconfdir}/sysconfig/*
156
157
158%changelog
159* Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1-1
160- new upstream release.
161- added systemd support (disabled as default).
162- dropped Patch93-96.
163
164* Sat Feb 24 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0-1
165- new upstream release.
166
167* Fri Jan 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3-1
168- new upstream release.
169
170* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.9-4
171- rebuild with VineSeed environment
172
173* Mon Apr 18 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.9-3
174- added BR: glibc-static
175
176* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.9-2
177- rebuilt with rpm-4.8.1-3
178
179* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.9-1
180- new upstream release
181
182* Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1vl5
183- applied new versioning policy, spec in utf-8
184
185* Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
186- new upstream release
187
188* Wed Aug 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.3-0vl1
189- initial build for Vine Linux
190
191* Mon Aug  7 2006 Doug Ledford <dledford@redhat.com> - 2.5.3-1
192- Update to 2.5.3 which upstream calls a "bug fix" release
193
194* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.2-1.1
195- rebuild
196
197* Fri Jul  7 2006 Doug Ledford <dledford@redhat.com> - 2.5.2-1
198- Update to 2.5.2
199- Remove auto default patch as upstream now has a preferred default auto method
200
201* Wed Mar  8 2006 Peter Jones <pjones@redhat.com> - 2.3.1-3
202- fix build on ppc64
203
204* Wed Mar  8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-2
205- fix build on ppc
206
207* Wed Mar  8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-1
208- update to 2.3.1 to fix raid5 (#184284)
209
210* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2.1
211- bump again for double-long bug on ppc(64)
212
213* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2
214- rebuilt for new gcc4.1 snapshot and glibc changes
215
216* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
217- rebuilt
218
219* Mon Dec 05 2005 Warren Togami <wtogami@redhat.com> 2.2-1
220- 2.2 upgrade (#167897)
221- disable diet because we don't ship it anymore
222  and we don't actually use mdassemble now
223
224* Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-4.fc4
225- Make the mdmonitor init script use the pid-file option, major cleanup
226  of the script now possible (#134459)
227
228* Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-3.fc4
229- Put back the obsoletes: raidtools that was present in 1.11.0-1.fc4
230
231* Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-2.fc4
232- Change the default auto= mode so it need not be on the command line to
233  work with udev, however it is still supported on the command line (#132706)
234- Add a man page (from Luca Berra) for mdassemble
235
236* Wed May 11 2005 Doug Ledford <dledford@redhat.com> - 1.11.0-1.fc4
237- Upgrade to 1.11.0
238
239* Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 1.9.0-3.fc4
240- fix mdmonitor initscript (#144717)
241
242* Mon Mar 21 2005 Doug Ledford <dledford@redhat.com> 1.9.0-2
243- Build mdadm.static and mdassemble (static as well) to be used in initrd
244  images
245
246* Wed Mar 09 2005 Doug Ledford <dledford@redhat.com> 1.9.0-1
247- Initial upgrade to 1.9.0 and update of doc files
248- Fix an s390 build error
249
250* Mon Oct 04 2004 Doug Ledford <dledford@redhat.com> 1.6.0-2
251- Remove /etc/mdadm.conf from the file list.  Anaconda will write one out
252  if it's needed.
253
254* Fri Oct 01 2004 Doug Ledford <dledford@redhat.com> 1.6.0-1
255- Update to newer upstream version
256- Make mdmpd work on kernels that don't have the event interface patch
257
258* Fri Jul 30 2004 Dan Walsh <dwalsh@redhat.com> 1.5.0-11
259- Create a directory /var/run/mdadm to contain mdadm.pid
260- This cleans up SELinux problem
261
262* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
263- rebuilt
264
265* Sat May 22 2004 Doug Ledford <dledford@redhat.com> - 1.5.0-9
266- Fix Makefile and build method to satisfy bz #123769
267- Add mdmpd man page, update mdmpd version to 0.3 - bz #117160
268- Make sure mdadm --monitor closes all md device files so that md devices
269  can be stopped while mdadm is still running - bz #119532
270
271* Thu May 20 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-8
272- remove unneeded patch, can use --run instead
273
274* Wed May 19 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-7
275- add patch with reallyforce mode on creation to be used by anaconda
276
277* Wed May 12 2004 Doug Ledford <dledford@redhat.com> 2.5.0-6
278- Fix a bug in the %postun scriptlet related to downgrading to a version
279  of mdadm that doesn't include the mdmpd daemon.
280
281* Fri May 07 2004 Doug Ledford <dledford@redhat.com> 1.5.0-5
282- Disable service mdmpd by default to avoid [Failed] messages on
283  current 2.6 kernels.  Possibly re-enable it by default once the
284  2.6 kernels have the md event interface.
285
286* Thu Apr 22 2004 Doug Ledford <dledford@redhat.com> 1.5.0-4
287- Update mdmonitor script to start daemon more cleanly
288- Repackage mdmpd tarball to include gcc-3.4 changes and to make
289  mdmpd properly daemonize at startup instead of forking and leaving
290  the child attached to the terminal.
291
292* Thu Mar  4 2004 Bill Nottingham <notting@redhat.com> 1.5.0-3
293- ship /var/run/mpmpd (#117497)
294
295* Thu Feb 26 2004 Doug Ledford <dledford@redhat.com> 1.5.0-2
296- Add a default MAILADDR line to the mdadm.conf file installed by default
297  (Bugzilla #92447)
298- Make it build with gcc-3.4
299
300* Mon Feb 23 2004 Doug Ledford <dledford@redhat.com> 1.5.0-1
301- Update to 1.5.0 (from Matthew J. Galgoci <mgalgoci@redhat.com>)
302
303* Sun Nov 16 2003 Doug Ledford <dledford@redhat.com> 1.4.0-1
304- fix problem with recovery thread sleeping in mdmpd
305
306* Fri Nov 14 2003 Doug Ledford <dledford@redhat.com>
307- sync upstream
308- add mdmpd package into mdadm package
309
310* Wed Sep 10 2003 Michael K. Johnson <johnsonm@redhat.com> 1.3.0-1
311- sync upstream
312
313* Tue Mar 11 2003 Michael K. Johnson <johnsonm@redhat.com> 1.1.0-1
314- sync upstream
315
316* Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 1.0.1-1
317- update for rebuild
318
319* Wed Dec 25 2002 Tim Powers <timp@redhat.com> 1.0.0-8
320- fix references to %%install in the changelog so that it will build
321
322* Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.0.0-7
323- Rebuild
324
325* Fri Jul 12 2002 Michael K. Johnson <johnsonm@redhat.com>
326- Changed RPM Group to System Environment/Base
327
328* Wed May 15 2002 Michael K. Johnson <johnsonm@redhat.com>
329- minor cleanups to the text, conditionalize rm -rf
330- added mdmonitor init script
331
332* Fri May 10 2002  <neilb@cse.unsw.edu.au>
333- update to 1.0.0
334- Set CXFLAGS instead of CFLAGS
335
336* Sat Apr  6 2002  <neilb@cse.unsw.edu.au>
337- change %%install to use "make install"
338
339* Fri Mar 15 2002  <gleblanc@localhost.localdomain>
340- beautification
341- made mdadm.conf non-replaceable config
342- renamed Copyright to License in the header
343- added missing license file
344- used macros for file paths
345
346* Fri Mar 15 2002 Luca Berra <bluca@comedia.it>
347- Added Obsoletes: mdctl
348- missingok for configfile
349
350* Tue Mar 12 2002 NeilBrown <neilb@cse.unsw.edu.au>
351- Add md.4 and mdadm.conf.5 man pages
352
353* Fri Mar 08 2002               Chris Siebenmann <cks@cquest.utoronto.ca>
354- builds properly as non-root.
355
356* Fri Mar 08 2002 Derek Vadala <derek@cynicism.com>
357- updated for 0.7, fixed /usr/share/doc and added manpage
358
359* Tue Aug 07 2001 Danilo Godec <danci@agenda.si>
360- initial RPM build
Note: See TracBrowser for help on using the repository browser.