source: projects/specs/trunk/lib/libs/libsoup/libsoup-vl.spec @ 11333

Revision 11333, 11.7 KB checked in by tomop, 6 years ago (diff)

libsoup-2.61.1-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4Summary: Soup, an HTTP library implementation
5Summary(ja): Soup - HTTP ライブラリ実装
6Name: libsoup
7Version: 2.61.1
8Release: 1%{?_dist_release}
9License: LGPL
10Group: System Environment/Libraries
11Source0: ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.54/%{name}-%{version}.tar.xz
12URL: ftp://ftp.gnome.org/pub/gnome/sources/libsoup/
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: glib2-devel >= 2.26.0
15BuildRequires: gnutls-devel, libxml2-devel, pkgconfig
16BuildRequires: libproxy-devel >= 0.2.3
17BuildRequires: libgnome-keyring-devel
18BuildRequires: sqlite3-devel
19BuildRequires: gobject-introspection-devel
20BuildRequires: vala-devel
21BuildRequires: vala-tools
22BuildRequires: python3
23
24BuildRequires: mod_ssl-apache2
25BuildRequires: curl
26BuildRequires: glib-networking
27
28Requires: glib-networking
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34Libsoup is an HTTP library implementation in C. It was originally part
35of a SOAP (Simple Object Access Protocol) implementation called Soup, but
36the SOAP and non-SOAP parts have now been split into separate packages.
37 
38libsoup uses the Glib main loop and is designed to work well with GTK
39applications. This enables GNOME applications to access HTTP servers
40on the network in a completely asynchronous fashion, very similar to
41the Gtk+ programming model (a synchronous operation mode is also
42supported for those who want it).
43
44
45%package devel
46Summary: Header files for the Soup library
47Summary(ja): Soup ライブラリのヘッダファイル
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50Requires: glib2-devel >= 2.26.0
51Requires: gnutls-devel, libxml2-devel, libgpg-error-devel
52 
53%description devel
54Libsoup is an HTTP library implementation in C. This package allows
55you to develop applications that use the libsoup library.
56
57
58%package vala
59Summary: Vala bindings for %{name}
60Summary(ja): %{name} の Vala バインディング
61Group: Development/Libraries
62Requires: %{name} = %{version}-%{release}
63Requires: vala
64
65%description vala
66Vala bindings for %{name}.
67
68
69# compat32
70%package -n compat32-%{name}
71Summary: Soup, an HTTP library implementation
72Summary(ja): Soup - HTTP ライブラリ実装
73Group: System Environment/Libraries
74
75%description -n compat32-%{name}
76Libsoup is an HTTP library implementation in C. It was originally part
77of a SOAP (Simple Object Access Protocol) implementation called Soup, but
78the SOAP and non-SOAP parts have now been split into separate packages.
79 
80libsoup uses the Glib main loop and is designed to work well with GTK
81applications. This enables GNOME applications to access HTTP servers
82on the network in a completely asynchronous fashion, very similar to
83the Gtk+ programming model (a synchronous operation mode is also
84supported for those who want it).
85
86
87%prep
88%setup -q
89
90%build
91%configure \
92        --disable-static \
93        --enable-introspection=yes
94make %{?_smp_mflags}
95
96%install
97rm -rf $RPM_BUILD_ROOT
98make install DESTDIR=$RPM_BUILD_ROOT
99
100find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
101
102%find_lang %{name}
103
104%post -p /sbin/ldconfig
105
106%postun -p /sbin/ldconfig
107
108%post -n compat32-%{name} -p /sbin/ldconfig
109
110%postun -n compat32-%{name} -p /sbin/ldconfig
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%files -f %{name}.lang
116%defattr(-, root, root)
117%doc README COPYING NEWS AUTHORS
118%{_libdir}/lib*.so.*
119%{_libdir}/girepository-1.0
120
121%files devel
122%defattr(-, root, root)
123%{_includedir}/libsoup-2.4
124%{_includedir}/libsoup-gnome-2.4
125%{_libdir}/*.so
126%{_libdir}/pkgconfig/*.pc
127%{_datadir}/gtk-doc/html/libsoup-2.4
128%{_datadir}/gir-1.0
129
130%files vala
131%defattr(-, root, root)
132%{_datadir}/vala/vapi/libsoup-2.4.vapi
133%{_datadir}/vala/vapi/libsoup-2.4.deps
134
135%if %{build_compat32}
136%files -n compat32-%{name}
137%defattr(-, root, root)
138%{_libdir}/lib*.so.*
139%endif
140
141
142%changelog
143* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.61.1-1
144- new upstream release.
145
146* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.54.1-1
147- new upstream release
148
149* Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.52.2-2
150- create compat32-libsoup subpackage
151
152* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.52.2-1
153- new upstream release
154
155* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.52.1-1
156- new upstream release
157- add BuildRequires: vala-devel, vala-tools
158- create %%{name}-vala subpackage
159
160* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.50.0-1
161- new upstream release
162
163* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.1-1
164- new upstream release
165
166* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.0-1
167- new upstream release
168
169* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.0-1
170- new upstream release
171
172* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.2-1
173- new upstream release
174
175* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.1-1
176- new upstream release
177
178* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.2-1
179- new upstream release
180
181* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.1-1
182- new upstream release
183
184* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.3-1
185- new upstream release
186
187* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-1
188- new upstream release
189
190* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-1
191- new upstream release
192
193* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-1
194- new upstream release
195
196* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
197- new upstream release
198
199* Thu Oct 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
200- new upstream release
201
202* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.0-1
203- new upstream release
204
205* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.92-1
206- new upstream release
207
208* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.90-1
209- new upstream release
210
211* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.5-1
212- new upstream release
213
214* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.4-1
215- new upstream release
216- add BuildRequires: glib-networking
217- add Requires: glib-networking
218- change BuildRequires: mod_ssl-apache2 instead of apache2
219
220* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
221- new upstream release
222
223* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
224- new upstream release
225- add BuildRequires: apache2, curl
226
227* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
228- new upstream release
229- add configure option (--enable-introspection=yes)
230
231* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.2-2
232- build with rpm-4.8.1-1 for pkg-config file
233
234* Mon Jun 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
235- new upstream release
236
237* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
238- new upstream release
239
240* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
241- new upstream release
242- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
243
244* Sat Jan  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
245- new upstream release
246- added BR: gnome-keyring-devel, GConf2-devel, sqlite3-devel
247
248* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
249- new upstream release
250
251* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
252- new upstream release
253
254* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
255- new upstream release
256
257* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
258- new upstream release
259
260* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
261- new upstream release
262- add BR: libproxy-devel >= 0.2.3
263
264* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
265- new upstream release
266
267* Sat Jan 17 2009 Toshiharu kudoh <toshi.kd2@gmail.com> 2.24.2.1-2
268- rebuild with gnutls-2.6.3
269
270* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2.1-1
271- new upstream release
272
273* Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.1-1
274- new upstream release
275
276* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
277- new upstream release
278
279* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
280- new upstream release
281
282* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.23.91-1
283- new upstream release
284
285* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-1vl5
286- new upstream release
287
288* Thu Mar 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.0-1vl5
289- new upstream release
290
291* Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.104-0vl1
292- new upstream release
293
294* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.100-0vl1
295- new upstream release
296
297* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.99-0vl1
298- new upstream release
299  (includes security fix CVE-2006-5876 <BTS:462>)
300
301* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.2.96-0vl2
302- rebuild with gnutls-1.4.1
303
304* Thu Sep 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.96-0vl1
305- new upstream release
306
307* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.93-0vl1
308- new upstream release
309
310* Wed Nov 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.7-0vl1
311- new upstream release
312
313* Fri Sep 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6.1-0vl1
314- new upstream release
315- added BuildRequires: gnutls-devel instead of openssl-devel
316
317* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
318- new upstream release
319
320* Sat Mar 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.28-0vl1
321- new upstream release
322
323* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.26-0vl1
324- new upstream release
325
326* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.23-0vl1
327- new upstream release
328
329* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.22-0vl1
330- new upstream release
331
332* Sun May 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.20-1vl1
333- build for Vine Linux
334
335* Tue May  6 2003 Jeremy Katz <katzj@redhat.com> 1.99.20-1
336- 1.99.20
337
338* Sun May  4 2003 Jeremy Katz <katzj@redhat.com> 1.99.17-3
339- include ssl proxy so that ssl urls work properly (#90165, #90166)
340
341* Wed Apr 16 2003 Jeremy Katz <katzj@redhat.com> 1.99.17-2
342- forward port patch to use a union initializer to fix build on x86_64
343
344* Wed Apr 16 2003 Jeremy Katz <katzj@redhat.com> 1.99.17-1
345- rename package to libsoup
346- update to 1.99.17
347- don't obsolete soup for now, it's parallel installable
348
349* Sun Apr  6 2003 Jeremy Katz <katzj@redhat.com> 0.7.11-1
350- update to 0.7.11
351
352* Wed Apr  2 2003 Matt Wilson <msw@redhat.com> 0.7.10-5
353- added soup-0.7.10-64bit.patch to fix 64 bit platforms (#86347)
354
355* Sat Feb 01 2003 Florian La Roche <Florian.LaRoche@redhat.de>
356- only runtime libs in normal rpm
357
358* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
359- rebuilt
360
361* Tue Jan 21 2003 Jeremy Katz <katzj@redhat.com>
362- update url (#82347)
363
364* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 0.7.10-2
365- use pkgconfig's openssl configuration information, if it exists
366
367* Fri Dec 13 2002 Jeremy Katz <katzj@redhat.com> 0.7.10-1
368- update to 0.7.10
369
370* Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-4
371- fix fpic patch
372- soup-devel should require soup
373
374* Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-3
375- better lib64 patch
376- fix building of libwsdl-build to use libtool so that it gets built
377  with -fPIC as needed
378
379* Tue Dec 10 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-2
380- change popt handling in configure slightly so that it will work on
381  multilib arches
382
383* Tue Dec 10 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-1
384- update to 0.7.9, pulling the tarball out of Ximian packages
385
386* Wed Oct 23 2002 Jeremy Katz <katzj@redhat.com> 0.7.4-3
387- fix to not try to include non-existent doc files and remove all
388  unwanted files from the build
389- include api docs
390- don't build the apache module
391
392* Wed Sep 25 2002 Jeremy Katz <katzj@redhat.com> 0.7.4-2
393- various specfile tweaks to include in Red Hat Linux
394- include all the files
395
396* Tue Jan 23 2001 Alex Graveley <alex@ximian.com>
397- Inital RPM config.
Note: See TracBrowser for help on using the repository browser.