source: projects/specs/trunk/lib/libs/libsoup/libsoup-vl.spec @ 12398

Revision 12398, 11.9 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

glibc-2.31-2

gnome-terminal-3.30.3-1

libsoup-2.70.0-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4Summary: Soup, an HTTP library implementation
5Summary(ja): Soup - HTTP ライブラリ実装
6Name: libsoup
7Version: 2.70.0
8Release: 1%{?_dist_release}
9Group: System Environment/Libraries
10Vendor: Project Vine
11Distribution: Vine Linux
12
13License: LGPL
14%global shortver %(echo %{version} | cut -d . -f 1,2)
15URL: ftp://ftp.gnome.org/pub/gnome/sources/libsoup/
16Source: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: glib2-devel >= 2.26.0
20BuildRequires: gnutls-devel, libxml2-devel, pkgconfig
21BuildRequires: libproxy-devel >= 0.2.3
22BuildRequires: libgnome-keyring-devel
23BuildRequires: sqlite3-devel
24BuildRequires: gobject-introspection-devel
25BuildRequires: vala-devel
26BuildRequires: vala-tools
27BuildRequires: python3
28BuildRequires: meson
29BuildRequires: brotli-devel
30BuildRequires: libpsl-devel
31
32#BuildRequires: mod_ssl-apache2
33BuildRequires: curl
34BuildRequires: glib-networking
35
36Requires: glib-networking
37
38%description
39Libsoup is an HTTP library implementation in C. It was originally part
40of a SOAP (Simple Object Access Protocol) implementation called Soup, but
41the SOAP and non-SOAP parts have now been split into separate packages.
42 
43libsoup uses the Glib main loop and is designed to work well with GTK
44applications. This enables GNOME applications to access HTTP servers
45on the network in a completely asynchronous fashion, very similar to
46the Gtk+ programming model (a synchronous operation mode is also
47supported for those who want it).
48
49
50%package devel
51Summary: Header files for the Soup library
52Summary(ja): Soup ライブラリのヘッダファイル
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
55Requires: glib2-devel >= 2.26.0
56Requires: gnutls-devel, libxml2-devel, libgpg-error-devel
57 
58%description devel
59Libsoup is an HTTP library implementation in C. This package allows
60you to develop applications that use the libsoup library.
61
62
63%package vala
64Summary: Vala bindings for %{name}
65Summary(ja): %{name} の Vala バインディング
66Group: Development/Libraries
67Requires: %{name} = %{version}-%{release}
68Requires: vala
69
70%description vala
71Vala bindings for %{name}.
72
73
74# compat32
75%package -n compat32-%{name}
76Summary: Soup, an HTTP library implementation
77Summary(ja): Soup - HTTP ライブラリ実装
78Group: System Environment/Libraries
79
80%description -n compat32-%{name}
81Libsoup is an HTTP library implementation in C. It was originally part
82of a SOAP (Simple Object Access Protocol) implementation called Soup, but
83the SOAP and non-SOAP parts have now been split into separate packages.
84 
85libsoup uses the Glib main loop and is designed to work well with GTK
86applications. This enables GNOME applications to access HTTP servers
87on the network in a completely asynchronous fashion, very similar to
88the Gtk+ programming model (a synchronous operation mode is also
89supported for those who want it).
90
91
92%prep
93%setup -q
94
95
96%build
97%meson \
98  -Dgssapi=disabled \
99  -Dntlm=disabled
100%meson_build
101
102
103%install
104rm -rf $RPM_BUILD_ROOT
105%meson_install
106
107%find_lang %{name}
108
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113
114%post -p /sbin/ldconfig
115
116%postun -p /sbin/ldconfig
117
118%post -n compat32-%{name} -p /sbin/ldconfig
119
120%postun -n compat32-%{name} -p /sbin/ldconfig
121
122
123%files -f %{name}.lang
124%defattr(-, root, root)
125%license COPYING
126%doc README NEWS AUTHORS
127%{_libdir}/lib*.so.*
128%{_libdir}/girepository-1.0
129
130%files devel
131%defattr(-, root, root)
132%{_includedir}/libsoup-2.4
133%{_includedir}/libsoup-gnome-2.4
134%{_libdir}/*.so
135%{_libdir}/pkgconfig/*.pc
136#%{_datadir}/gtk-doc/html/libsoup-2.4
137%{_datadir}/gir-1.0
138
139%files vala
140%defattr(-, root, root)
141%{_datadir}/vala/vapi/libsoup-2.4.vapi
142%{_datadir}/vala/vapi/libsoup-2.4.deps
143
144%if %{build_compat32}
145%files -n compat32-%{name}
146%defattr(-, root, root)
147%{_libdir}/lib*.so.*
148%endif
149
150
151%changelog
152* Sat May 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.70.0-1
153- new upstream release.
154
155* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.61.1-1
156- new upstream release.
157
158* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.54.1-1
159- new upstream release
160
161* Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.52.2-2
162- create compat32-libsoup subpackage
163
164* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.52.2-1
165- new upstream release
166
167* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.52.1-1
168- new upstream release
169- add BuildRequires: vala-devel, vala-tools
170- create %%{name}-vala subpackage
171
172* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.50.0-1
173- new upstream release
174
175* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.1-1
176- new upstream release
177
178* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.0-1
179- new upstream release
180
181* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.0-1
182- new upstream release
183
184* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.2-1
185- new upstream release
186
187* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.1-1
188- new upstream release
189
190* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.2-1
191- new upstream release
192
193* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.1-1
194- new upstream release
195
196* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.3-1
197- new upstream release
198
199* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-1
200- new upstream release
201
202* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-1
203- new upstream release
204
205* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-1
206- new upstream release
207
208* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
209- new upstream release
210
211* Thu Oct 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
212- new upstream release
213
214* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.0-1
215- new upstream release
216
217* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.92-1
218- new upstream release
219
220* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.90-1
221- new upstream release
222
223* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.5-1
224- new upstream release
225
226* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.4-1
227- new upstream release
228- add BuildRequires: glib-networking
229- add Requires: glib-networking
230- change BuildRequires: mod_ssl-apache2 instead of apache2
231
232* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
233- new upstream release
234
235* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
236- new upstream release
237- add BuildRequires: apache2, curl
238
239* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
240- new upstream release
241- add configure option (--enable-introspection=yes)
242
243* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.2-2
244- build with rpm-4.8.1-1 for pkg-config file
245
246* Mon Jun 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
247- new upstream release
248
249* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
250- new upstream release
251
252* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
253- new upstream release
254- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
255
256* Sat Jan  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
257- new upstream release
258- added BR: gnome-keyring-devel, GConf2-devel, sqlite3-devel
259
260* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
261- new upstream release
262
263* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
264- new upstream release
265
266* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
267- new upstream release
268
269* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
270- new upstream release
271
272* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
273- new upstream release
274- add BR: libproxy-devel >= 0.2.3
275
276* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
277- new upstream release
278
279* Sat Jan 17 2009 Toshiharu kudoh <toshi.kd2@gmail.com> 2.24.2.1-2
280- rebuild with gnutls-2.6.3
281
282* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2.1-1
283- new upstream release
284
285* Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.1-1
286- new upstream release
287
288* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
289- new upstream release
290
291* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
292- new upstream release
293
294* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.23.91-1
295- new upstream release
296
297* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-1vl5
298- new upstream release
299
300* Thu Mar 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.0-1vl5
301- new upstream release
302
303* Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.104-0vl1
304- new upstream release
305
306* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.100-0vl1
307- new upstream release
308
309* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.99-0vl1
310- new upstream release
311  (includes security fix CVE-2006-5876 <BTS:462>)
312
313* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.2.96-0vl2
314- rebuild with gnutls-1.4.1
315
316* Thu Sep 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.96-0vl1
317- new upstream release
318
319* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.93-0vl1
320- new upstream release
321
322* Wed Nov 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.7-0vl1
323- new upstream release
324
325* Fri Sep 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6.1-0vl1
326- new upstream release
327- added BuildRequires: gnutls-devel instead of openssl-devel
328
329* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
330- new upstream release
331
332* Sat Mar 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.28-0vl1
333- new upstream release
334
335* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.26-0vl1
336- new upstream release
337
338* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.23-0vl1
339- new upstream release
340
341* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.22-0vl1
342- new upstream release
343
344* Sun May 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.20-1vl1
345- build for Vine Linux
346
347* Tue May  6 2003 Jeremy Katz <katzj@redhat.com> 1.99.20-1
348- 1.99.20
349
350* Sun May  4 2003 Jeremy Katz <katzj@redhat.com> 1.99.17-3
351- include ssl proxy so that ssl urls work properly (#90165, #90166)
352
353* Wed Apr 16 2003 Jeremy Katz <katzj@redhat.com> 1.99.17-2
354- forward port patch to use a union initializer to fix build on x86_64
355
356* Wed Apr 16 2003 Jeremy Katz <katzj@redhat.com> 1.99.17-1
357- rename package to libsoup
358- update to 1.99.17
359- don't obsolete soup for now, it's parallel installable
360
361* Sun Apr  6 2003 Jeremy Katz <katzj@redhat.com> 0.7.11-1
362- update to 0.7.11
363
364* Wed Apr  2 2003 Matt Wilson <msw@redhat.com> 0.7.10-5
365- added soup-0.7.10-64bit.patch to fix 64 bit platforms (#86347)
366
367* Sat Feb 01 2003 Florian La Roche <Florian.LaRoche@redhat.de>
368- only runtime libs in normal rpm
369
370* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
371- rebuilt
372
373* Tue Jan 21 2003 Jeremy Katz <katzj@redhat.com>
374- update url (#82347)
375
376* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 0.7.10-2
377- use pkgconfig's openssl configuration information, if it exists
378
379* Fri Dec 13 2002 Jeremy Katz <katzj@redhat.com> 0.7.10-1
380- update to 0.7.10
381
382* Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-4
383- fix fpic patch
384- soup-devel should require soup
385
386* Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-3
387- better lib64 patch
388- fix building of libwsdl-build to use libtool so that it gets built
389  with -fPIC as needed
390
391* Tue Dec 10 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-2
392- change popt handling in configure slightly so that it will work on
393  multilib arches
394
395* Tue Dec 10 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-1
396- update to 0.7.9, pulling the tarball out of Ximian packages
397
398* Wed Oct 23 2002 Jeremy Katz <katzj@redhat.com> 0.7.4-3
399- fix to not try to include non-existent doc files and remove all
400  unwanted files from the build
401- include api docs
402- don't build the apache module
403
404* Wed Sep 25 2002 Jeremy Katz <katzj@redhat.com> 0.7.4-2
405- various specfile tweaks to include in Red Hat Linux
406- include all the files
407
408* Tue Jan 23 2001 Alex Graveley <alex@ximian.com>
409- Inital RPM config.
Note: See TracBrowser for help on using the repository browser.