source: projects/specs/trunk/lib/libs/libsoup/libsoup-vl.spec @ 10716

Revision 10716, 11.6 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME-3.20

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Soup, an HTTP library implementation
4Summary(ja): Soup - HTTP ライブラリ実装
5Name: libsoup
6Version: 2.54.1
7Release: 1%{?_dist_release}
8License: LGPL
9Group: System Environment/Libraries
10Source0: ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.54/%{name}-%{version}.tar.xz
11URL: ftp://ftp.gnome.org/pub/gnome/sources/libsoup/
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: glib2-devel >= 2.26.0
14BuildRequires: gnutls-devel, libxml2-devel, pkgconfig
15BuildRequires: libproxy-devel >= 0.2.3
16BuildRequires: libgnome-keyring-devel
17BuildRequires: sqlite3-devel
18BuildRequires: gobject-introspection-devel
19BuildRequires: vala-devel
20BuildRequires: vala-tools
21
22BuildRequires: mod_ssl-apache2
23BuildRequires: curl
24BuildRequires: glib-networking
25
26Requires: glib-networking
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31%description
32Libsoup is an HTTP library implementation in C. It was originally part
33of a SOAP (Simple Object Access Protocol) implementation called Soup, but
34the SOAP and non-SOAP parts have now been split into separate packages.
35 
36libsoup uses the Glib main loop and is designed to work well with GTK
37applications. This enables GNOME applications to access HTTP servers
38on the network in a completely asynchronous fashion, very similar to
39the Gtk+ programming model (a synchronous operation mode is also
40supported for those who want it).
41
42
43%package devel
44Summary: Header files for the Soup library
45Summary(ja): Soup ライブラリのヘッダファイル
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Requires: glib2-devel >= 2.26.0
49Requires: gnutls-devel, libxml2-devel, libgpg-error-devel
50 
51%description devel
52Libsoup is an HTTP library implementation in C. This package allows
53you to develop applications that use the libsoup library.
54
55
56%package vala
57Summary: Vala bindings for %{name}
58Summary(ja): %{name} の Vala バインディング
59Group: Development/Libraries
60Requires: %{name} = %{version}-%{release}
61Requires: vala
62
63%description vala
64Vala bindings for %{name}.
65
66
67# compat32
68%package -n compat32-%{name}
69Summary: Soup, an HTTP library implementation
70Summary(ja): Soup - HTTP ライブラリ実装
71Group: System Environment/Libraries
72
73%description -n compat32-%{name}
74Libsoup is an HTTP library implementation in C. It was originally part
75of a SOAP (Simple Object Access Protocol) implementation called Soup, but
76the SOAP and non-SOAP parts have now been split into separate packages.
77 
78libsoup uses the Glib main loop and is designed to work well with GTK
79applications. This enables GNOME applications to access HTTP servers
80on the network in a completely asynchronous fashion, very similar to
81the Gtk+ programming model (a synchronous operation mode is also
82supported for those who want it).
83
84
85%prep
86%setup -q
87
88%build
89%configure \
90        --disable-static \
91        --enable-introspection=yes
92make %{?_smp_mflags}
93
94%install
95rm -rf $RPM_BUILD_ROOT
96make install DESTDIR=$RPM_BUILD_ROOT
97
98find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
99
100%find_lang %{name}
101
102%post -p /sbin/ldconfig
103
104%postun -p /sbin/ldconfig
105
106%post -n compat32-%{name} -p /sbin/ldconfig
107
108%postun -n compat32-%{name} -p /sbin/ldconfig
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files -f %{name}.lang
114%defattr(-, root, root)
115%doc README COPYING NEWS AUTHORS
116%{_libdir}/lib*.so.*
117%{_libdir}/girepository-1.0
118
119%files devel
120%defattr(-, root, root)
121%{_includedir}/libsoup-2.4
122%{_includedir}/libsoup-gnome-2.4
123%{_libdir}/*.so
124%{_libdir}/pkgconfig/*.pc
125%{_datadir}/gtk-doc/html/libsoup-2.4
126%{_datadir}/gir-1.0
127
128%files vala
129%defattr(-, root, root)
130%{_datadir}/vala/vapi/libsoup-2.4.vapi
131%{_datadir}/vala/vapi/libsoup-2.4.deps
132
133%if %{build_compat32}
134%files -n compat32-%{name}
135%defattr(-, root, root)
136%{_libdir}/lib*.so.*
137%endif
138
139
140%changelog
141* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.54.1-1
142- new upstream release
143
144* Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.52.2-2
145- create compat32-libsoup subpackage
146
147* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.52.2-1
148- new upstream release
149
150* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.52.1-1
151- new upstream release
152- add BuildRequires: vala-devel, vala-tools
153- create %%{name}-vala subpackage
154
155* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.50.0-1
156- new upstream release
157
158* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.1-1
159- new upstream release
160
161* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.0-1
162- new upstream release
163
164* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.0-1
165- new upstream release
166
167* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.2-1
168- new upstream release
169
170* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.1-1
171- new upstream release
172
173* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.2-1
174- new upstream release
175
176* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.1-1
177- new upstream release
178
179* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.3-1
180- new upstream release
181
182* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-1
183- new upstream release
184
185* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-1
186- new upstream release
187
188* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-1
189- new upstream release
190
191* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
192- new upstream release
193
194* Thu Oct 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
195- new upstream release
196
197* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.0-1
198- new upstream release
199
200* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.92-1
201- new upstream release
202
203* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.90-1
204- new upstream release
205
206* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.5-1
207- new upstream release
208
209* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.4-1
210- new upstream release
211- add BuildRequires: glib-networking
212- add Requires: glib-networking
213- change BuildRequires: mod_ssl-apache2 instead of apache2
214
215* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
216- new upstream release
217
218* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
219- new upstream release
220- add BuildRequires: apache2, curl
221
222* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
223- new upstream release
224- add configure option (--enable-introspection=yes)
225
226* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.2-2
227- build with rpm-4.8.1-1 for pkg-config file
228
229* Mon Jun 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
230- new upstream release
231
232* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
233- new upstream release
234
235* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
236- new upstream release
237- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
238
239* Sat Jan  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
240- new upstream release
241- added BR: gnome-keyring-devel, GConf2-devel, sqlite3-devel
242
243* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
244- new upstream release
245
246* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
247- new upstream release
248
249* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
250- new upstream release
251
252* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
253- new upstream release
254
255* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
256- new upstream release
257- add BR: libproxy-devel >= 0.2.3
258
259* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
260- new upstream release
261
262* Sat Jan 17 2009 Toshiharu kudoh <toshi.kd2@gmail.com> 2.24.2.1-2
263- rebuild with gnutls-2.6.3
264
265* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2.1-1
266- new upstream release
267
268* Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.1-1
269- new upstream release
270
271* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
272- new upstream release
273
274* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
275- new upstream release
276
277* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.23.91-1
278- new upstream release
279
280* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-1vl5
281- new upstream release
282
283* Thu Mar 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.0-1vl5
284- new upstream release
285
286* Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.104-0vl1
287- new upstream release
288
289* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.100-0vl1
290- new upstream release
291
292* Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.99-0vl1
293- new upstream release
294  (includes security fix CVE-2006-5876 <BTS:462>)
295
296* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.2.96-0vl2
297- rebuild with gnutls-1.4.1
298
299* Thu Sep 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.96-0vl1
300- new upstream release
301
302* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.93-0vl1
303- new upstream release
304
305* Wed Nov 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.7-0vl1
306- new upstream release
307
308* Fri Sep 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6.1-0vl1
309- new upstream release
310- added BuildRequires: gnutls-devel instead of openssl-devel
311
312* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
313- new upstream release
314
315* Sat Mar 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.28-0vl1
316- new upstream release
317
318* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.26-0vl1
319- new upstream release
320
321* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.23-0vl1
322- new upstream release
323
324* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.22-0vl1
325- new upstream release
326
327* Sun May 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.20-1vl1
328- build for Vine Linux
329
330* Tue May  6 2003 Jeremy Katz <katzj@redhat.com> 1.99.20-1
331- 1.99.20
332
333* Sun May  4 2003 Jeremy Katz <katzj@redhat.com> 1.99.17-3
334- include ssl proxy so that ssl urls work properly (#90165, #90166)
335
336* Wed Apr 16 2003 Jeremy Katz <katzj@redhat.com> 1.99.17-2
337- forward port patch to use a union initializer to fix build on x86_64
338
339* Wed Apr 16 2003 Jeremy Katz <katzj@redhat.com> 1.99.17-1
340- rename package to libsoup
341- update to 1.99.17
342- don't obsolete soup for now, it's parallel installable
343
344* Sun Apr  6 2003 Jeremy Katz <katzj@redhat.com> 0.7.11-1
345- update to 0.7.11
346
347* Wed Apr  2 2003 Matt Wilson <msw@redhat.com> 0.7.10-5
348- added soup-0.7.10-64bit.patch to fix 64 bit platforms (#86347)
349
350* Sat Feb 01 2003 Florian La Roche <Florian.LaRoche@redhat.de>
351- only runtime libs in normal rpm
352
353* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
354- rebuilt
355
356* Tue Jan 21 2003 Jeremy Katz <katzj@redhat.com>
357- update url (#82347)
358
359* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 0.7.10-2
360- use pkgconfig's openssl configuration information, if it exists
361
362* Fri Dec 13 2002 Jeremy Katz <katzj@redhat.com> 0.7.10-1
363- update to 0.7.10
364
365* Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-4
366- fix fpic patch
367- soup-devel should require soup
368
369* Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-3
370- better lib64 patch
371- fix building of libwsdl-build to use libtool so that it gets built
372  with -fPIC as needed
373
374* Tue Dec 10 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-2
375- change popt handling in configure slightly so that it will work on
376  multilib arches
377
378* Tue Dec 10 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-1
379- update to 0.7.9, pulling the tarball out of Ximian packages
380
381* Wed Oct 23 2002 Jeremy Katz <katzj@redhat.com> 0.7.4-3
382- fix to not try to include non-existent doc files and remove all
383  unwanted files from the build
384- include api docs
385- don't build the apache module
386
387* Wed Sep 25 2002 Jeremy Katz <katzj@redhat.com> 0.7.4-2
388- various specfile tweaks to include in Red Hat Linux
389- include all the files
390
391* Tue Jan 23 2001 Alex Graveley <alex@ximian.com>
392- Inital RPM config.
Note: See TracBrowser for help on using the repository browser.